DEXTUploadX

DEXT Products

DEXT製品紹介

■ DEXTUpload Pro Extension

DEXTUpload Pro Extensionは DEXTUpload Proと DEXTUploadX 製品を統合して、力強いファイルアップロード機能共にウェブハード概念のサービスを具現できるようにしています。

この製品はブラウザーとウェブサーバー間のアップロード容量制限及び送信を画期的に改善してシステムが処理可能な容量無制限のファイルアップロードが できるようになりました。 その上、ファイル送信方式を統合送信方式から個別送信方式に切り替えて一般的なファイルアップロードサービス以外にもウェブハード概念のサービスに確張するようにしています。

- 同一サーバーに既存のDEXTUpload Pro共にDEXTUploadXを設置及び配布ができます。DEXTUpload Pro Extension製品は DEXTUpload Pro Extensionバージョンと DEXTUploadX Extensionバージョンで構成され、既存製品とは ProgID、ClassIDが違います。

- 既存 DEXTUpload Pro または DEXTUploadXからアップグレードするための既存コードの修正は最小化されます。詳しい事項はマニュアルとサンプルを参考してください。(http://www.dextsolution.comの‘DEXTUpload Pro Extension’ メニュ－中 [コードサンプル] 参照)

■ DEXTUpload Pro

DEXTUpload Professionalはウェブブラウザーからウェブサーバーへのファイルアップロード機能を支援する HTTPプロトコル基盤のサーバー側のコンポーネントでウィンドウプラットホームで IIS(Internet Information Server)にホスティングされ、ASPで開発されたすべてのウェブサイトで使用できます。

国内外アップロードコンポーネントの中で最高の性能と安全性で世界10,000余個以上のサイトでサービスされているし、持続的に多様な付加機能支援を通じて開発生産性と便宜性を向上しています。

■ DEXTUpload.NET Pro

DEXTUpload.NET Professionalはウェブブラウザーからウェブサーバーへのファイルアップロード機能を支援する HTTPプロトコル基盤のサーバー側 Componentでウィンドウプラットホームで IIS(Internet Information Server)にホスティングされ、ASP.NETで開発されたすべてのウェブサイトで使用できます。

韓国最初 .NET 基盤アップロードコンポネントで、持続的に多様な付加機能の支援を通じて開発生産性と便宜性を向上しています。

DEXTUpload.NET Professionalは ASP.NETと完全統合の特徴を持って、 NET Frameworkファイルアップロードクラスとの相互運用性を提供し、ファイルアップロード側でASP.NETの限界(大容量ファイルアップロードに不向き、サーバー負荷問題及び安全性、単純なアップロード機能だけ提供)を完全に越せます。

C#言語を使って100%管理されたコードで作成され、DEXTUpload Professional製品のコアエンジンを .NETに最適化されたコードで完全に再作成することでDEXTUploadを含んだ既存の ASP ファイルアップロードコンポーネントに比べてめっきり向上したアップロード速度と安全性を提供します。

■ DEXTUploadJ

DEXTUploadJはウェブブラウザからウェブサーバーへファイル・アップロード機能を支援する HTTPプロトコル基盤のサーバー側Componentとしてリナクス/ユニックスプラットフォームのウェブサーバーへホスティングされる全てのサーブレット (Servlet)環境で使用できます。

国内外のComponent製品の中で最高の性能と安定性で10,000余個以上のサイトでサービスされているDEXTUpload製品のJAVAバージョンです。

JSPなどでサービスされている様々なウェーブビジネス環境に適用し、優れた性能のファイル・アップロードやダウンロードサービスを提供してください。

■ DEXTUploadX

DEXTUploadXはウェブブラウザーからウェブサーバーへのファイルアップロード機能を支援する RFC1867 標準の client-side ActiveX コンポーネントです。

HTTP 基盤の環境でウェブブラウザーが支援し難い多様な機能及び UIを支援し、RFC1867 を支援する server-side コンポーネントとの連動を通じて HTTPの制約を越す力強いアップロード及びダウンロード機能を支援します。

また DEXTUploadX コンポーネントは顧客のウェブサイトに最適化になるように開発者のための多様なAPIを提供して、もっと柔軟だし、直観的なUIを製作できるようにします。

■ DEXTWebEditor

DEXTWebEditorは、掲示板などのような対話型ウェブサイトの構築時に必要なコンポーネント型ウェブエディターです。様々な形態の文書作成やワードレベルの表作成機能 、オフィス製品を含む全てのHTML文書との互換性及び多国語対応することで、よりよい業務システムの開発ができるようにします。

特に、DEXTUpload製品群と共に貴社のソルーションやサービスに使用する場合、最適な Interactive System の構築を通じて顧客満足を最大限にするHTMLウェブエディターとして、ウェブブラウザから自動的にダウンロードして使用する形で提供され、活用したいウェブ運営プログラムに自動的に配布して使用します。

■ DEXTVideo

DEXTVideoは、動画を登録し、照会でき動画ソリューションです。動画情報を簡単にウェブ上で共有可能にすることで、社内や外部で簡単にウェブ2.0サービスの構築ができます。

DEXTVideoは、ファイル変換及びアップロード機能の ActiveX Controlと、動画プレイヤーで構成されています。

既存に構築されているウェブシステム（全社グループウェア、ポータルなど）に動画パートを簡単に追加でき、外部顧客の為に安定的な動画サービスができます。世界の最大動画ポータルであるgoogleのYOUTUBE及び、韓国有数のポータル業者で使用しているオープンソース基盤のFFMPEG技術で具現され、後、持続的な機能改善と言うメリットがあります。

DEXTVideoは、多様なビデオフォーマトを一つの標準ファイルフォーマトであるFLVファイルで変換することによって、クライアントで追加ソフトウェア（コーデック）を設置する必要が無く、Viewingが可能であり、またファイル変換がクライアントPCから実行され、サーバーの負荷を減らすことによって、ソリューション構築及び、運営費用を最小化できます。

DEXT 製品のもっと詳しい情報はhttp://www.dextsolution.com/jpの ‘製品’メニューで各製品別の詳細情報及びライブデモなどを参考してください。

Copyright ⓒ DEVPIA Corporation. All rights reserved


DEXTUpload Professional 란?

DEXTUpload Pro Extension

DEXTUpload Pro Extension について

■ DEXTUpload Pro Extensionとは

DEXTUpload Pro Extensionは DEXTUpload Proと DEXTUploadX 製品を統合して、力強いファイルアップロード機能とともにウェブハード概念のサービスを具現 できるようにしています。

この 製品はブラウザーとウェブサーバー間の アップロード容量制限及び送信を画期的に改善してシステムが処理可能な容量無制限の ファイルのアップロードができるようになりました。　その上、ファイル送信方式を統合送信方式から 個別送信方式に切り替えて 一般的なファイルアップロードサービス以外にもウェブハード概念のサービスに確張するようにしています。

-同一サーバーに既存のDEXTUpload Pro共にDEXTUploadXを設置及び配布ができます。DEXTUpload Pro Extension製品はDEXTUpload Pro Extensionバージョンと DEXTUploadX Extensionバージョンで構成され、既存製品とは ProgID、ClassIDが違います。

-既存 DEXTUpload Pro または DEXTUploadXからアップグレードするための既存コードの 修正は最小化されます。詳しい事項はマニュアルとサンプルを参考してください。

(http://www.dextsolution.com/jpの ‘DEXTUpload Pro Extension’ メニュ－中 [コードサンプル] 参照)

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Professional 특징

DEXTUpload Pro Extension

DEXTUpload Pro Extension について

■ DEXTUpload Pro Extension の 特徴

1. 2GB 以上の大容量ファイル送信

-ほとんど無限大のファイル容量安定的に送信できます。

2. 続けてアップロード機能支援

-インターネットが切断され、 ユーザーによる一時停止などによってアップロードが中断されても 安定的な続けてアップロードができます。

3. 伝送速度制限支援

-支援される帯域幅の中でクライアント側で伝送速度の制限ができます。

4. 送信中、ファイル追加/削除支援

-送信中、ファイル追加/削除を支援します。

5. 送信中、一時停止機能支援

-ファイルのアップロードまたはダウンロード中、送信の一時停止ができます。

6. 送信ファイル個数制限除去

-送信方式の変更で 512個の最大ファイル送信個数制限を無くしました。ただ、ファイル個数の増加による UIの表現問題はありえます。

7. DEXTUpoad ProとDEXTUploadXのすべての機能を支援

-既存DEXTUpoad ProとDEXTUploadXのすべての機能を支援します。ただ、支援機能間の特性によって同時に支援できない場合がありえます。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Pro Extensionリリース情報

DEXTUpload Pro Extension

DEXTUpload Pro Extension について

■ DEXTUpload Pro Extension リリース情報
  • DEXTUpload Pro Extension v1.5.1.0
    [バグパッチ]
    # 0バイトのファイルをダウンロードする時、エラー修正(DEXTUpload Pro Extension v1.5.0.0のみ)
    # 画質が低下される現象修正(DEXTUpload Pro Extension v1.5.0.0のみ)

    [機能改善]
    # Internet Explorer 8ポリシーの変更によって HTML inputタッグのファイルは転送されないように変更
  • DEXTUpload Pro Extension v1.5.0.0
    [バグパッチ]
    # 特定環境の PCで IEのセキュリティ設定画面(Internet Exploreのツール⇒インターネットオプション⇒セキュリティ) 不思議な現象修正
    # ファイルダウンロードの時に2個以上のクギを維持することができない問題修正
    # FileDownloadManager    でファイル実行の時デスクトップに臨時のファイルが生成される問題修正
    # DEXTEx.ImageProc    オブジェクトの FontStyleプロパティ適用問題修正
    # BLOB    ファイルダウンロードの時取り消しする場合、ブラウザが止める現状修正

    [機能改善]
    # ActiveXの動的サイズ変更支援
    # ListViewのバックグラウンドイメージ設定支援
    # ListViewのコラム名を通じる整列支援
    # Push方式ダウンロードの時にサーバー側で要求に応答したHTTPステータス コード修身支援
    # Push     方式ダウンロードの時 2GB 以上のファイルダウンロード支援
    #     伝送速度制限の時画面進行状態安定化
    #     １pixelイメージのサムネイル 処理の場合エラーが発生しないように修正
    #     サムネイル 処理の場合右側及び、下側に黒い色のラインできる問題修正
    #     不分的な内部例外の処理とエラーメッセージ改選
  • DEXTUpload Pro Extension v1.0.4.0
    [バグパッチ]
    # DEXTUploadX 連動なくDEXTUpload Proだけを使用した場合ファイル受け継ぐ及ファイルダウンロード時送信進行状態の表示エラー修正
  • DEXTUpload Pro Extension v1.0.3.0
    [バグパッチ]
    # ファイルアップロードプログレスウィンドウを使う時、IE以外のブラウザで実行する場合に生じる問題点を修正
    # ファイルダウンロード時にエラーが発生することによりユーザーとの接続が切れた状態で例外処理トラブルを修正

    [機能改善]
    # 該当のブラウザのクッキーが有効でない場合、ファイルのアップロードは進行するがアップロードプログレスウィンドウは直ちに終了されるように修正
    # [FileUploadMonitor][Progress]オブジェクトに[SetProgressWindowType]のメソッド追加
    - 様々なブラウザにおけるアップロードプログレスウィンドウの対応性をアップ
    # 複数のDEXT製品をインストール後、プログラムを削除する時、他のDEXT製品のレジストリ情報も削除するトラブル修正
    # プログラムを削除する時、レジストリに登録されたDEXTUploadEx.dllを解除
  • DEXTUpload Pro Extension v1.0.3.0

Copyright © DEVPIA Corporation. All rights reserved.


시스템 요구사항

DEXTUpload Pro Extension

DEXTUpload Pro Extensionのインストール

■ 必要なシステムの動作環境

1. 必須サーバー環境

- Microsoft Windows 2000/2003/2008 Family

2. 必須クライアント環境

- Microsoft Windows 2000/XP/2003/Vista/2008

- ActiveXコントロールをサポートできる全てのブラウザ

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Pro Extension

DEXTUpload Pro Extensionのインストール

■ インストール方法

1. インストールの開始

1. DEXTUpload Pro Extensionインストーラー

2. 最終使用者の使用許諾契約

3. インストールする作業を選ぶ。 - "DEXTUpload Pro Extensionをインストールします。"欄にチェック

[参照]
インターネットが接続された環境以外では、製品の認証は正常に行われません。
オフラインでインストールを行う場合、"3.正規品の登録及び認証"を参照して下さい。

4. 製品登録情報を正確に入力します。

- 評価版で登録した場合

- 正規品で登録した場合

5. 設置類型及び設置する位置選択

6. 既にIISがDEXTUploadEx.dllを使用している場合、上書きすることができません。IISを再起動してください。

7. インストールの終了－完了ボタンを押すと、プログラムが自動的にサンプルを実行します。

2. 正規品プログラムインストール制限

正規品を設置する過程で下記のようにもう設置された製品キーという画面が表示されて設置が進めないこともあります。

製品キーを入力して設置する場合には一つのサーバーにだけ設置することができるし, 他サーバーに再設置をするためには以前に設置されたサーバーで製品を削除(Uninstall)しなければなりません。

正規品を設置して削除する場合認証サーバーとの通信が可能な状態で進行されると円滑な製品設置が可能です。

既に設置されている正規品を削除しないで再設置ができる方法は下のような方法があります。

1) 提供される “評価版転換プログラム(ConvertToFree.exe)”で正規品を評価版で強制に切り替える。

- この場合は認証サーバーとの通信が可能なオンライン状態ではなければならないし, 転換が完了すれば認証サーバーで正規品の設置情報を削除します。
- このファイルは製品設置経路の “Bin” フォルダに存在します。

2) 販売サイト(http://www.dextsolution.com/jp)の “MY PAGE-設置情報変更”で正規品設置情報を受動で削除できます。

※ ただ,正規品の設置情報と実際サービスされる製品の情報を故意的に変更する場合正常なサービスに差し支えがありえます。

3. 正規品の登録及び認証

次に該当する場合、製品の登録及び認証をマニュアルで行ってください。

1. インターネットに接続されていない環境でインストールを行った場合
2. インターネットに接続されているが、何らかの障害により正常に認証が行われなかった場合
3. 評価版から正式版へと切り替える場合

正規品の登録及び認証は、次の手順に従って行って下さい。

1. http://www.dextsolution.com/jp に接続してください。

2. "マイページ -> 認証キーの生成(DEXTUpload Pro Extension)"メニューを選びます。("マイページ"にログインするには、"顧客登録"で登録を行う必要があります。)

3. コンピュータ名、製品キー、シリアル番号を入力してから確認ボタンを押すと、"認証番号"が発給されます。

4. DEXTUpload Pro ExtensionがインストールされたPCよりインストールプログラムを実行します。

5. .[インストール方法の選択]スクリーンにて、[正規品の登録及び認証をします]を選択します。

6. 認証番号の欄にウェブサイトで発給された認証番号を入力して認証ボタンを押すと、認証が完了します。
終了ボタンをクリックして実行を完了してください。

4. 評価版の有効期限

評価版をインストールした場合の有効期間は30日です。
30日経過後は、プログラムを実行する際に再インストールを促すメッセージが表示されます。

5. サーバーのコンピューター名の変更する場合、再認証方法案内

アップロード コンポーネント中サーバーコンポーネント製品(DEXTUploadX除外)は正規品の設置後該当サーバーのコンピューター名(Hostname)を変更する場合、
正規品の登録をまた進行しなければなりません。
そうではない場合、認証のエラーによってプログラムを正常にご使用になることができません。

正規品の登録をまたする方法は下のような方法があります。

*認証番号を手動で生成する方法- http://www.dextsolution.comの「認証番号生成」メニュで変更されたコンピューター名で新しい認証番号を手動で生成

方法1:　再認証 - 製品が設置された状態で設置ファイルを実行して「作業選択」画面で「正規品登録および認証をします。」を選択して手動で生成した認証番号を入力

方法2:　再インストールする - IIS中止後「プログラム追加/除去」で設置された製品を削除して再インストールする (認証サーバーと通信ができない場合、評価版設置後「方法1」で再認証)

Copyright © DEVPIA Corporation. All rights reserved.


설치 제거

DEXTUpload Pro Extension

DEXTUpload Pro Extensionのインストール

■ プログラムの削除

プログラムを削除する場合、コントロールパネルにあるプログラムの追加／除去機能や、インストール時ウィンドウズのスタートアップメニューに登録された"UnInstall DEXTUpload Pro Extension"メニューから削除してください。万一、この時IISがDEXTUpload.dllファイルを使用中の場合にはこのファイルを正常に削除できません。
システムを再起動するか、IISを再起動した後で削除してください。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Pro Extensionの プログラミング

DEXTUpload Pro Extension

DEXTUpload Pro Extensionの プログラミング

■ DEXTUpload Pro Extension の プログラミング

DEXTUpload Pro Extensionプログラミング項目はDEXTUpload Proプログラミング項目とDEXTUploadXプログラミング項目を参考してください。

DEXTUpload Pro Extension 製品は DEXTUpload Pro Ex 製品と DEXTUploadX Ex 製品が統合された製品です。

[DEXTUpload Pro Ex 製品と DEXTUpload Pro 製品とのコード互換性]

DEXTUpload Pro Ex 製品は ASP コードで客体を生成する時使う "ProgID"を除いて既存の DEXTUpload Pro 製品と完璧なコード互換性を維持します。

(ただ、もっと向上したサービスのために既存のDEXTUpload Proで支援しない多様なAPIを DEXTUpload Pro Exで支援します。)

[DEXTUploadX Ex 製品と DEXTUploadX 製品とのコード互換性]

DEXTUploadX Ex 製品は HTML コードで客体を宣言する時、使う "CLASSID"と "CODEBASE"の CAB ファイル名を除いて既存の DEXTUploadX 製品と完璧なコード互換性を維持します。

(ただ、もっと向上したサービスのために既存のDEXTUploadXで支援しない多様な APIを DEXTUploadX Exで支援します。)

[DEXTUpload Pro Ex 製品と DEXTUpload Pro 製品とのコード互換性例題]

<%

' DEXTUpload Pro Extension 製品を使う時の客体生成方法
Set FileUpload = Server.CreateObject("DEXTEx.FileUpload")

Set FileUploadMonitor = Server.CreateObject("DEXTEx.FileUploadMonitor")

Set Progress = Server.CreateObject("DEXTEx.Progress")

Set FileDownload = Server.CreateObject("DEXTEx.FileDownload")

Set ImageProc = Server.CreateObject("DEXTEx.ImageProc")

Set BLOBManager = Server.CreateObject("DEXTEx.BLOBManager")

Set BLOBManager = Server.CreateObject("DEXTEx.Manager")

%>

<%

' DEXTUpload Pro 製品を使う時の客体生成方法
Set FileUpload = Server.CreateObject("DEXT.FileUpload")

Set FileUploadMonitor = Server.CreateObject("DEXT.FileUploadMonitor")

Set Progress = Server.CreateObject("DEXT.Progress")

Set FileDownload = Server.CreateObject("DEXT.FileDownload")

Set ImageProc = Server.CreateObject("DEXT.ImageProc")

Set BLOBManager = Server.CreateObject("DEXT.BLOBManager")

Set BLOBManager = Server.CreateObject("DEXT.Manager")

%>

[DEXTUploadX Ex 製品と DEXTUploadX 製品とのコード互換性例題]

<HTML>

<BODY>

<!-- DEXTUploadX Ex 製品を使う時の客体宣言方法 -->

<OBJECT ID="FileUploadManagerEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:4FCFCDC8-346B-4d35-A001-C92AA3775BBB"></OBJECT>

<OBJECT ID="FileUploadMonitorEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988"></OBJECT>

<OBJECT ID="FileDownloadManagerEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:B0250CBD-2F67-45b1-9AC1-E846CF0A12C5"></OBJECT>

<OBJECT ID="FileDownloadMonitorEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:64F53B6B-C2A8-4e46-89E0-8ADD2F2AA861"></OBJECT>

<OBJECT ID="ProgressEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:A7DF7B2A-4537-4e30-9BF1-910E1F9BBF12"></OBJECT>

</BODY>

</HTML>

<HTML>

<BODY>

<!-- DEXTUploadX 製品を使う時の客体宣言方法 -->

<OBJECT ID="FileUploadManager" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316"></OBJECT>

<OBJECT ID="FileUploadMonitor" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5"></OBJECT>

<OBJECT ID="FileDownloadManager" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:535AE497-8E85-45F8-AF36-2DFCBCA8B68A"></OBJECT>

<OBJECT ID="FileDownloadMonitor" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619"></OBJECT>

<OBJECT ID="Progress" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:253B8695-AFE6-4918-AE1C-003FCF070D08"></OBJECT>

</BODY>

</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Pro Extension客体リファレンス

DEXTUpload Pro Extension

DEXTUpload Pro Extension客体リファレンス

■ DEXTUpload Pro Extension 客体リファレンス

DEXTUpload Pro Extension客体リファレンス項目はDEXTUpload Pro客体リファレンス項目とDEXTUploadX客体リファレンス項目を参考してください。

DEXTUpload Pro Extension 製品は DEXTUpload Pro Ex 製品と DEXTUploadX Ex 製品が統合された製品です。

[DEXTUpload Pro Ex 製品と DEXTUpload Pro 製品とのコード互換性]

DEXTUpload Pro Ex 製品は ASP コードで客体を生成する時に使う "ProgID"を除いて既存の DEXTUpload Pro 製品と完璧なコード互換性を維持します。

(ただ、もっと向上したサービスのために既存のDEXTUpload Proで支援しない多様なAPIを DEXTUpload Pro Exで支援します。)

[DEXTUploadX Ex 製品と DEXTUploadX 製品とのコード互換性]

DEXTUploadX Ex 製品は HTML コードで客体を宣言する時、使う "CLASSID"と "CODEBASE"の CAB ファイル名を除いて既存の DEXTUploadX 製品と完璧なコード互換性を維持します。

(ただ、もっと向上したサービスのために既存のDEXTUploadXで支援しない多様な APIを DEXTUploadX Exで支援します。)

[DEXTUpload Pro Ex 製品と DEXTUpload Pro 製品とのコード互換性例題]

<%

' DEXTUpload Pro Extension 製品を使う時の客体生成方法
Set FileUpload = Server.CreateObject("DEXTEx.FileUpload")

Set FileUploadMonitor = Server.CreateObject("DEXTEx.FileUploadMonitor")

Set Progress = Server.CreateObject("DEXTEx.Progress")

Set FileDownload = Server.CreateObject("DEXTEx.FileDownload")

Set ImageProc = Server.CreateObject("DEXTEx.ImageProc")

Set BLOBManager = Server.CreateObject("DEXTEx.BLOBManager")

Set BLOBManager = Server.CreateObject("DEXTEx.Manager")

%>

<%

' DEXTUpload Pro 製品を使う時の客体生成方法
Set FileUpload = Server.CreateObject("DEXT.FileUpload")

Set FileUploadMonitor = Server.CreateObject("DEXT.FileUploadMonitor")

Set Progress = Server.CreateObject("DEXT.Progress")

Set FileDownload = Server.CreateObject("DEXT.FileDownload")

Set ImageProc = Server.CreateObject("DEXT.ImageProc")

Set BLOBManager = Server.CreateObject("DEXT.BLOBManager")

Set BLOBManager = Server.CreateObject("DEXT.Manager")

%>

[DEXTUploadX Ex 製品と DEXTUploadX 製品とのコード互換性例題]

<HTML>

<BODY>

<!-- DEXTUploadX Ex 製品を使う時の客体宣言方法 -->

<OBJECT ID="FileUploadManagerEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:4FCFCDC8-346B-4d35-A001-C92AA3775BBB"></OBJECT>

<OBJECT ID="FileUploadMonitorEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988"></OBJECT>

<OBJECT ID="FileDownloadManagerEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:B0250CBD-2F67-45b1-9AC1-E846CF0A12C5"></OBJECT>

<OBJECT ID="FileDownloadMonitorEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:64F53B6B-C2A8-4e46-89E0-8ADD2F2AA861"></OBJECT>

<OBJECT ID="ProgressEx" CODEBASE=" サーバー URL/DEXTUploadXEx.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:A7DF7B2A-4537-4e30-9BF1-910E1F9BBF12"></OBJECT>

</BODY>

</HTML>

<HTML>

<BODY>

<!-- DEXTUploadX 製品を使う時の客体宣言方法 -->

<OBJECT ID="FileUploadManager" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316"></OBJECT>

<OBJECT ID="FileUploadMonitor" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5"></OBJECT>

<OBJECT ID="FileDownloadManager" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:535AE497-8E85-45F8-AF36-2DFCBCA8B68A"></OBJECT>

<OBJECT ID="FileDownloadMonitor" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619"></OBJECT>

<OBJECT ID="Progress" CODEBASE=" サーバー URL/DEXTUploadX.cab#version= 現在バージョン " HEIGHT="200" WIDTH="450" CLASSID="CLSID:253B8695-AFE6-4918-AE1C-003FCF070D08"></OBJECT>

</BODY>

</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


에러 처리 방법

DEXTFileCleaner

DEXTFileCleanerサービス

■ DEXTFileCleanerサービスとは

 DEXTUpload Pro Extension 製品の機能の中に“無制限大容量アップロード”,“続けてアップロード” などの 機能を使うようになればウェブサーバーの 一時フォルダ (DEXTUpload Pro 使用時に設定した DefaultPath)に ユーザー の一時ファイルが 積むようになります。 このファイルは ユーザー によって一定期間内に最終 アップロードされ、自動に削除ができますが、そうではない場合 (ユーザーがアップロードを完了したくない場合) 不必要な ユーザー の一時ファイルを定期的に削除してくれるとウェブサーバーの 不必要なディスク空間を減らせます。

このような一時ファイル整理作業のために DEXTFileCleanerと言うウィンドウサービスプログラムをウェブサーバーのサービスに登録して, ウェブサーバー管理規約の通りに定期的に一時ファイルを削除できます。

この製品の機能は単純ですので、必要によっては任意に作って使えます。

■ DEXTFileCleaner サービス登録/削除及び使用方法

1. サービス登録方法

 : 命令プロンプトを実行後、実行ファイルがあるフォルダに移動

(Ex_ C:Program FilesDEVPIADEXTUpload Pro ExtensionBin)

: DEXTFileCleaner.exe -i 実行

: “ コントロールパネル-サービス ” メニューで “ サービス手始め “

2. サービス使用方法

: DEXTFileCleaner.ini ファイル内容を修正して一時ファイル削除政策を決めます。

[[ DEXTFileCleaner Configuration ]]

DEXTUpload_DefaultPath=C:\TEMP
=> DEXTUpload Proで一時ファイル経路で設定した DefaultPath 経路を指定する。

DEXTFileCleaner_FileMaintainTerm=60
=> 分単位の数字値で一時ファイルの最終修正時間が 60分が過ぎたファイルは削除対象にします。

DEXTFileCleaner_ExecuteTerm=120
=> 分単位の数字値で一時フォルダを検索して、削除対象ファイルの整理作業を120分基準で繰り返します。

DEXTFileCleaner_BeginTime=20080905142500
=> “年月日時分秒” 値で該当の時点から ExecuteTerm期間ごとに削除対象ファイルを整理します。

3. サービス削除方法

 : “ コントロールパネル-サービス ” メニューで “ サービス中止 “をした後, 命令プロンプトを実行後、実行ファイルがあるフォルダに移動

(Ex_ C:Program FilesDEVPIADEXTUpload Pro ExtensionBin )

: DEXTFileCleaner.exe -u 実行

Copyright © DEVPIA Corporation. All rights reserved.


에러 처리 방법

ConvertToFree

ConvertToFree 評価版転換プログラム

■ ConvertToFree 評価版転換プログラムとは？

ConvertToFree　評価版転換プログラムは、DEXTUpload Pro v3,3,0以上、DEXTUpload Pro Extension v1,0,0以上の製品を対象にする評価版転換プログラムです。

DEXTUpload Pro v3,3,0以上、 DEXTUpload Pro Extension v1,0,0以上の製品は正規品設置作業の回数制限があるので、反復される正規品設置のためには既存に設置された製品を、削除または評価版に転換する必要があります。

評価版転換プログラムは DEXTUpload製品の再設置をしなくて、簡単に正規品として設置された DEXTUpload製品を評価版に転換できるプログラムです。

評価版転換プログラムを正常に使用するためには、インタ－ネットが可能可能の環境が必要です。

(http://www.dextsolution.com/jp)との通信が可能な環境)

■ 使用方法

[ConvertToFree評価版転換プログラム]

1. ConvertToFree評価版転換プログラム実行

DEXTUpload製品に設置されたBinデｲレクトリ－で“ConvertToFree.exe”を実行します。

(Ex_ C:\Program Files\DEVPIA\DEXTUpload Pro Extension\Bin)

2. 評価版に転換する製品選択及び適用

DEXTUpload Pro v3,3,0以上、 DEXTUpload Pro Extension v1,0,0以上の製品の中で正規品として設置された製品が[評価版に転換する設置情報]のリストに見られます。

[DEXTUpload Pro Extension追加入力情報]

PID – 評価版の PID

SN – 評価版の　SN

IP – 評価版製品に設置するサ－バ－の IP

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Professionalとは

DEXTUpload Professional

DEXTUpload Professionalの概要

■ DEXTUpload Professionalとは。

DEXTUpload Professionalは、ウェブブラウザからMicrosoft Internet Information Serverにファイルをアップロードする機能を持つ、インターネット標準であるRFC1867に準拠したActive Server Componentです。
本製品は、Microsoft Active Server Pagesでも使用できます。 大容量ファイルのアップロード時にも早い速度と低いリソース占有率を発揮します。
また、ユーザーがアップロードの進行状態を簡単に確認できるようデザインしました。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Professionalの特長

DEXTUpload Professional

DEXTUpload Professionalの概要

■ DEXTUpload Professionalの特長

1. Windows NT/2000/XP/2003 IIS 4.0以上のサーバ側ASP Scriptで利用可能なサーバ側Active Server Component

2. HTML 3.2及びインターネット標準であるRFC 1867に準拠

3. Microsoft Internet Explorer 4.0以上、Netscape 3.0以上、MacOS XのSafari, Netscapeブラウザでのテスト完了

4.大容量ファイルのアップロードに対応(2GBのファイルアップロードのテスト完了) 及び早いアップロード速度と低いリソース占有率
(CPUの低利用率、一つのアップロード作業あたりの瞬間メモリ使用量: 16 ∼ 70KB)

5. 様々なイメージフォーマット(JPG, BMP, GIF, PNG, TIFF, ICON, WMF, EMFなど)に対応

6. イメージファイルに対する多機能支援 (サムネイル、透かし、フォーマット変換、メタデータの支援など)

7. キャッシュファイル機能の支援により、状況によってより効率的なファイル伝送可能

8. エラーメッセージの詳細出力により開発及びメンテナンスが容易です。

9. 高いユーザ便宜性の提供(フォルダの自動生成、 仮想経路の自動変換など)

10. 外国語及びユニコードに完璧対応

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Professional における変更事項

DEXTUpload Professional

DEXTUpload Professionalの概要

■ DEXTUpload Professionalの変更事項

既存のDEXTUploadからの変更事項

1.FolderExists()によりフォルダが存在するかをチェック
今まではファイル及びフォルダが存在するかをFileExists()を使ってチェックしていましたが、新バージョンではFolderExists()でフォルダを確認します。

2.BLOB関連メソッドはBinary型にのみ対応
新バージョンでは、BLOB関連メソッドがTextフィールド型に対応していません。Binary型でない場合には警告が発生します。

3.Save()、SaveAs()、Download()の仮想経路に対応
新バージョンでは、SaveVirtual()、SaveAsVirtual()、DownloadVirtual()などを使う必要がありません。 ただし、互換性のために、既存のメソッドの使用も可能なままにしてあります。

4.仮想経路の支援
DefaultPath, Save()メッソドなどの経路が必要なメッソドは仮想経路ができるように支援しました。
(これまでは指定がない場合には“C:\”を使用してきましたが、DEXTUpload Professionalでは指定がない場合にはエラーとして処理されます。)

5.DEXT.FileDownloadオブジェクトの簡潔性
ユーザーがそれぞれファイルのサイズなどをヘッダに追加する面倒がありません。Download()を実行するとDEXT.FileDownloadオブジェクトが自動的に処理します。

6.新規なプログレスバー

DEXT.FileUploadMonitorの代わりにDEXT.Progressオブジェクトを新たに生成されました。

DEXT.Progressを使えば、ユーザーが好きなタイプのプログレスバーを作るできます。DEXT.Progressの使用を推奨します。

7.メッソドにパラメータがある間合い、必ず括弧を指定

これまでは括弧無しで使用できましたが、DEXTUpload　Professionalは括弧を指定しなければエラーメッセジーが発生します。

DEXTUpload Professional の新たな特長

1.Visual C++とATL7.1を使って再作成
既存のコードをすべて廃棄し、ATLを使って効率性を極大化させました。

2.速度及び安定性アップ
内部データ処理アルゴリズムを改善することにより、低容量のメモリで効率的に構文解析します。

３.ユーザーの便宜性
コーディングが一層手軽に行えるよう、最大限の部分をコンポーネントで処理しました。(Ex. 既存のSaveVirtualやDownloadVirutalなどの関数はもう必要ありません。)

4.画像処理オブジェクトの追加
サムネイル、透かし、EXIF情報、イメージフォーマット変換など、画像ファイルをより多様に処理できます。

5. マネーザーオブジェクトの追加
キャッシュ機能に対応しており、頻繁にダウンロードされるファイルをメモリから直接転送できます。

6.詳細なエラーメッセージ
不正なコードを事前に知らせ、できるだけ詳しく説明します。予想されうる論理的なエラーをより簡単に確認できます。

DEXTUpload Professionalの変更及び追加されたメソッド＆プロパティ

[DEXT.FileUpload]
プロパティ
 1.DefaultPath - 仮想経路の支援
2.CodePage - アップロードが行われる前に設定しなければなりません。
アップロードの進行中にパースを行いますので、アップロード 後のCodePageの指定は効果がありません。
3.ImageFormat - 様々なイメージフォーマット(JPG, BMP, GIF, PNG, TIFF, ICON, WMF, EMFなど)に対応しています。
4.UseIE5BugFix - このプロパティは、過去にInternet Explorer 5.0の特殊な環境下で起こるバグを修正するために設定されていましたが、新バージョンはこれに対応していません。
5.ExpirationDate - 評価版の有効期間を表示するプロパティ。新バージョンでは対応していません。
6.TotalLen - アップロードするデータの全体のサイズを表示します。サーバーにオーバーロードを起こす可能性がある転送を遮断する目的のプロパティです。
TotalLenの制限を超えたブラウザは、構造上、正常に動作しなくなり、ブラウザの再起動を促します。
7.AutoMakeFolder - Save、SaveAs、DefaultPathなどの、フォルダが必須なメソッドの使用時、フォルダが存在しない場合に自動的にフォルダを作成します。
8.TempFilePath - Saveメソッドなどによりファイルが保存される前の一時的なファイル置き場を表示します。
9.FileNameWithoutExt - 拡張子を除くファイル名を表示します。
10.FileExtension - ファイルの拡張子を表示します。

メソッド
 1.Save, SaveAs - ユーザーはFilePath値により仮想経路を使用できます。
2.SaveVirtual, SaveAsVirtual - Save、SaveAsメソッドと機能は同様です。
3.SaveAsBlob - Binary型のフィールド型にのみ対応しています。これ以外のフィールド型についてはエラーを発します。
4.FileExists - ファイルが存在するかをチェック。フォルダの確認をしたい場合にはFolderExistsをお使い下さい。これは、ファイルとフォルダが同じ名前である場合に発生する誤動作を防止するためです。
5.FolderExists - フォルダが存在するかをチェックします。
6.IsImageItem - 選択したファイルが画像ファイルであるかどうかを表示します。
7.SetProgress - 新しいプログレスバーを設定するためのメソッドです。詳しくはサンプルを参照下さい。

[DEXT.FileDownload]
メソッド
 1.Download - これまではダウンロード前にユーザーがそれぞれ作成していたヘッダ情報を、これからはDEXTUpload Professionalが代わりに作成します。そのためコードが極めて簡潔になりました。
2.DownloadVirtual - SaveVirtualなどと同様、Downloadに置き換えられます。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload Professional のリリースノート

DEXTUpload Professional

DEXTUpload Professionalの概要

■ DEXTUpload Professional のリリースノート

DEXTUpload Professional v3.5.1

[バグパッチ]

# 0バイトのファイルをダウンロードする時、エラー修正(DEXTUpload Pro v3.5.0のみ)

# 画質が低下される現象修正(DEXTUpload Pro v3.5.0のみ)

DEXTUpload Professional v3.5

[バグパッチ]

# DEXT.ImageProcオブジェクトの FontStyleプロパティ適用問題修正

# BLOBファイルダウンロードの時取り消しする場合、ブラウザが止める現状修正

[機能改善]

# １pixelイメージのサムネイル 処理の場合エラーが発生しないように修正

# サムネイル 処理の場合右側及び、下側に黒い色のラインできる問題修正

# 不分的な内部例外の処理とエラーメッセージ改選

DEXTUpload Professional v3.3.4

[バグパッチ]

# ファイルダウンロードの時正常にファイル受け継ぐ及送信進行状態が表示されるように修正 (DEXTUpload Pro v3.3.0 以上にだけ該当 )

DEXTUpload Professional v3.3.3

[バグパッチ]

# ファイルアップロードプログレスウィンドウを使う時、IE以外のブラウザで実行する場合に生じる問題点を修正

# ファイルダウンロード時にエラーが発生することによりユーザーとの接続が切れた状態で例外処理トラブルを修正

[機能改善]

# 該当のブラウザのクッキーが有効でない場合、ファイルのアップロードは進行するがアップロードプログレスウィンドウは直ちに終了されるように修正

# [FileUploadMonitor][Progress]オブジェクトに[SetProgressWindowType]のメソッド追加

- 様々なブラウザにおけるアップロードプログレスウィンドウの対応性をアップ

# 複数のDEXT製品をインストール後、プログラムを削除する時、他のDEXT製品のレジストリ情報も削除するトラブル修正

# プログラムを削除する時、レジストリに登録されたDEXTUpload.dllを解除

DEXTUploadProfessional v3.3.2

[バグパッチ]
# ファイルアップロードの時、ファイルが保存されない場合、一時フォルダが削除できないエラーの修正 (v3.3.0, v3.3.1 バージョンだけ)

DEXTUploadProfessional v3.3.1

[バグパッチ]
# 一部のWindows Server 2008で発生する "IIS Worker Process" 作動中止間違いの修正

DEXTUploadProfessional v3.3.0

[機能改善]
# Windows 2008 支援

- 空のForm 客体アップロード時、構文分析の間違い修正

- 製品設置時、正常に設置されないで止める現象の修正(予定)

[参考] 以前バージョンの場合 Windows 2008 サーバーでファイルダウンロード時

サイズが20KB 超える場合 BinaryWrite エラーが発生する可能性があるし,

このエラーは Windows 2008 設計変更による問題で EnableChunkedEncodingを非活性化(FALSE) しなければならない。

# ImageProc 客体機能追加

- AutoMakeFolder 機能追加

- サムネイル作成時、自動倍率機能追加

- 透かし追加の時透明度調節機能追加

- イメージ回転機能追加

- イメージ処理プロパティ追加

- テキスト透かし追加時、ファイルフォントとスタイル設定機能追加

# サービス拒否(DOS) 攻撃防止機能

# アップロードファイルサイズの制限の時、実際ファイル情報を受ける前に送信可否判断

# アップロードされたファイルの多重 Save 支援

DEXTUploadProfessional v3.2.1
 [バグパッチ]
# イメージ処理時に一部のファイル(8bitのイメージファイル)にThumbnailが適用されない問題を解決。

# [DEXT.ImageProc]オブジェクトの[MDExifFlash]プロパティの変換値を修正。

[機能改善]
 [DEXT.ImageProc]オブジェクトに7つの[Exif]プロパティを追加。

# MDDateTimeOrig - 撮影日時
# MDExifMaximumLensAperture - アイリスの最大値
# MDExifFocalLengthIn35mm - 35mm フィルムの焦点距離
# MDExifExposureBias - 露出補正
# MDExifExifDigitalZoomRatio - デジタルズーム
# MDExifMeteringMode - 測光モード
# MDExifLightSource - 光源

DEXTUploadProfessional v3.2.0
[機能改善]
イメージ処理(WaterMark, Thumbnail, ConvertFormat)時 jpegファイルの鮮明度を調節することができる quality プロパティを追加 。

DEXTUploadProfessional v3.1.9
[バグパッチ]
大量のフォームタグ(Hidden Type)やファイルをアップロードする際に時折発生していた問題を解決。

(エラー内容: 非正常なファイルがアップロードされました。)

ファイルを続けてダウンロードする際、時折正常に続けてダウンロードされなかった問題を解決。

キャッシュファイルをダウンロードする際に正常に動作しない問題を解決。

[機能改善]
これまでのプロパティやメソッドのうち、例題がなかったアイテムに対する例題を追加。(サンプルを参考のこと。)

アップロードしたファイルのサイズがプロパティ(TotalLen)に設定された値よりも大きい場合、これまでは転送を

中断するためにセッションを中断(Response.End)していたが、本バージョンではユーザーにエラーメッセージを送り、

転送が完了されるよう修正された。

DEXTUploadProfessional v3.1.7
[バグパッチ]
DownloadBLOBメソドを使用した後のガービッジメモり問題。

DEXTUploadProfessional v3.1.6
[バグパッチ]
MAC OSでアップロードする時「content typeを発見できませんでしだ。」問題を解決。

DEXTUploadProfessional v3.1.5
[機能改善]
以前の下位バージョンとの互換性問題を修正してソースコードの修正なしでコンポナントアブデート可能
DEXT.ImageProc客体にMDExifWhiteBalanceプロパティ(property)追加

DEXTUploadProfessional v3.1.1
[バグパッチ]
”例外発生、CFileUploadクラス、 _MultiToWideCharmethod。 error'80004005'”メッセージが発生する問題。

[機能改善]
DEXT.ImageProc客体に3個のExifプロパティ(property)追加
追加されたproperty
MDExifISOSpeed - ISO速度
MDExifFocalLength - 焦点距離
MDExifExposureProg - 露出モード

DEXTUpload Professional v3.1.0
[バグパッチ]
FileUploadオブジェクトのフォーム・コレクション・インデックスを変数として割り当てる場合、値のインポートが不可能であったといった不具合を解決しました。
タグ内に指定されたすべてのフォーム・データ・オブジェクトを含む。

[機能改善]
パース・アルゴリズムをさらに最適化しましたので、安定性およびパフォーマンスがアップしました。

DEXTUpload Professional v3.0.5
[バグパッチ]
- 低画質のイメージをサムネイル処理する時の、イメージ黒化の不具合を修正しました。
- HTTP メッセージヘッダのパースを改善しました。 ("multipart/form-data"構文)
- Form コレクションのNameプロパティの不具合を修正しました。

DEXTUpload Professional v3.0.0

DEXTUpload v2.4.8

DEXTUpload v2.4.0

DEXTUpload v2.0.0

DEXTUpload v1.5.0

Copyright © DEVPIA Corporation. All rights reserved.


必要なシステムの動作環境

DEXTUpload Professional

DEXTUpload Professionalのインストール

■ 必要なシステムの動作環境

Windows NT 4.0サーバー系

Windows Server 2000サーバー系

Windows Server 2003サーバー系

Windows Server 2008サーバー系

Windows XP Professional(IISインストール済み)

IIS(Internet Infomation Server) 4.0以上

MS IE 5.0 以上

MAC OS X Safari 2.0.2, Netscape 7.2

Copyright © DEVPIA Corporation. All rights reserved.


インストール方法

DEXTUpload Professional

DEXTUpload Professionalのインストール

■ インストール方法

1.インストールの開始

1.DEXTUpload Professionalインストーラー

2. 最終使用者の使用許諾契約

3. インストールする作業を選ぶ。 - "DEXTUpload Professionalをインストールします。"欄にチェック

[参照]
インターネットが接続された環境以外では、製品の認証は正常に行われません。
オフラインでインストールを行う場合、"2.正規品の登録及び認証"を参照して下さい。

4. 製品登録情報を正確に入力します。

 - 評価版で登録した場合

- 正規品で登録した場合

5. 設置類型及び設置する位置選択

6.既にIISがDEXTUpload.dllを使用している場合、上書きすることができません。IISを再起動してください。

7.インストールの終了－完了ボタンを押すと、プログラムが自動的にサンプルを実行します。

2. 正規品プログラムインストール制限

正規品を設置する過程で下記のようにもう設置された製品キーという画面が表示されて設置が進めないこともあります。

製品キーを入力して設置する場合には一つのサーバーにだけ設置することができるし, 他サーバーに再設置をするためには以前に設置されたサーバーで製品を削除(Uninstall)しなければなりません。

正規品を設置して削除する場合認証サーバーとの通信が可能な状態で進行されると円滑な製品設置が可能です。

既に設置されている正規品を削除しないで再設置ができる方法は下のような方法があります。

1) 提供される “評価版転換プログラム(ConvertToFree.exe)”で正規品を評価版で強制に切り替える。

- この場合は認証サーバーとの通信が可能なオンライン状態ではなければならないし, 転換が完了すれば認証サーバーで正規品の設置情報を削除します。
- このファイルは製品設置経路の “Bin” フォルダに存在します。

2) 販売サイト(http://www.dextsolution.com/jp)の “MY PAGE-設置情報変更”で正規品設置情報を受動で削除できます。

※ ただ,正規品の設置情報と実際サービスされる製品の情報を故意的に変更する場合正常なサービスに差し支えがありえます。

3.正規品の登録及び認証

次に該当する場合、製品の登録及び認証をマニュアルで行ってください。
1. インターネットに接続されていない環境でインストールを行った場合
2. インターネットに接続されているが、何らかの障害により正常に認証が行われなかった場合
3. 評価版から正式版へと切り替える場合

正規品の登録及び認証は、次の手順に従って行って下さい。
1. http://www.dextsolution.com/jp に接続してください。
2."マイページ -> 認証キーの生成(DEXTUpload Pro)"メニューを選びます。("マイページ"にログインするには、"顧客登録"で登録を行う必要があります。)
3.コンピュータ名、製品キー、シリアル番号を入力してから確認ボタンを押すと、"認証番号"が発給されます。(認証番号はこの先のステップ６で必要となります)
4.DEXTUpload ProfessionalがインストールされたPCよりインストールプログラムを実行します。
5.[インストール方法の選択]スクリーンにて、[正規品の登録及び認証をします]を選択します。

6. 認証番号の欄にウェブサイトで発給された認証番号を入力して認証ボタンを押すと、認証が完了します。
終了ボタンをクリックして実行を完了してください。

4. 評価版の有効期限

評価版をインストールした場合の有効期間は30日です。
30日経過後は、プログラムを実行する際に再インストールを促すメッセージが表示されます。

5. サーバーのコンピューター名の変更する場合、再認証方法案内

アップロード コンポーネント中サーバーコンポーネント製品(DEXTUploadX除外)は正規品の設置後該当サーバーのコンピューター名(Hostname)を変更する場合、
正規品の登録をまた進行しなければなりません。
そうではない場合、認証のエラーによってプログラムを正常にご使用になることができません。

正規品の登録をまたする方法は下のような方法があります。

*認証番号を手動で生成する方法- http://www.dextsolution.comの「認証番号生成」メニュで変更されたコンピューター名で新しい認証番号を手動で生成

方法1:　再認証 - 製品が設置された状態で設置ファイルを実行して「作業選択」画面で「正規品登録および認証をします。」を選択して手動で生成した認証番号を入力

方法2:　再インストールする - IIS中止後「プログラム追加/除去」で設置された製品を削除して再インストールする (認証サーバーと通信ができない場合、評価版設置後「方法1」で再認証)

Copyright © DEVPIA Corporation. All rights reserved.


プログラムの削除

DEXTUpload Professional

DEXTUpload Professionalのインストール

■ プログラムの削除

プログラムを削除する場合、コントロールパネルにあるプログラムの追加／除去機能や、インストール時ウィンドウのスタートアップメニューに登録された"UnInstall DEXTUpload Professional"メニューから削除してください。万一、この時IISがDEXTUpload.dllファイルを使用中の場合にはこのファイルを正常に削除できません。
システムを再起動するか、IISを再起動した後で削除してください。

Copyright © DEVPIA Corporation. All rights reserved.


単一ファイルのアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 単一ファイルのアップロード

転送するフォームが存在するページは、次のように作成されます。

入力フォームページ

<HTML>
<BODY>
<FORM NAME= "write_form" METHOD="post" ACTION="SimpleUpload_process.asp" ENCTYPE= "multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

Formタグに指定された ENCTYPE="multipart/form-data"は、ファイルデータ<input type="file" NAME="File1">を含んでいるフォームを転送するために必ず必要な属性であって、省略できません。
次は、実際にファイルのアップロードなどの作業を行うページです。

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject ("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.Save 'uploadform("file1").Saveでも可
Set uploadform = Nothing
%>
</BODY>
</HTML>

ユーザーがアップロードをすると、一応DefaultPathで指定された"C:\Temp"にファイルが保存されます。
uploadform.Saveメソッドは、アップロードされた一時ファイルを所望のフォルダに移動(あるいはコピー)しますが、uploadform("file1").Saveの通りです。
ここで、"file1"は<INPUT TYPE="file" NAME="file1">でのNAME属性に該当する名前と同じでなければなりません。

Copyright © DEVPIA Corporation. All rights reserved.


使用フォルダの自動生成

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 使用フォルダの自動生成

DEXT.FileUploadオブジェクトのAutoMakeFolderプロパティがTrueである場合、フォルダが存在しなければ自動的に生成します。
アップロード時に保存フォルダを動的に定めなければならない場合に便利な機能です。

入力フォームページ

<HTML>
<BODY>
<FORM NAME= "write_form" METHOD="post" ACTION="SimpleUpload_process.asp" ENCTYPE= "multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
'AutoMakeFolderプロパティをtrueに設定すると、DEXT.FileUploadオブジェクトが使用するフォルダが存在しない場合、自動で生成する。
uploadform.AutoMakeFolder = True
uploadform.DefaultPath = "C:\Temp"
uploadform.Save "C:\Temp\TestFolder"
Set uploadform = Nothing
%>
</BODY>
</HTML><% Set uploadform = Server.CreateObject("DEXT.FileUpload") 'AutoMakeFolderプロパティをtrueに設定すると、DEXT.FileUploadオブジェクトが使用するフォルダが存在しない場合、自動で生成する。 uploadform.AutoMakeFolder = True uploadform.DefaultPath = "C:\Temp" uploadform.Save “C:\Temp\TestFolder” Set uploadform = Nothing %>

Copyright © DEVPIA Corporation. All rights reserved.


アップロードしたファイルを唯一のファイル名にして保存

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ アップロードしたファイルを唯一のファイル名で保存

上記のコードのうちSave(strPath, bOverwrite)などの保存メソッドのbOverwriteをfalseに設定すると、アップロード時に同名のファイルが存在する場合、
自動的に一連の数字を含む別のファイル名を生成して保存します。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="SaveAsUnique_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
FileName = uploadform("file").Save( ,false)
Set uploadform = Nothing
%>
</BODY>
</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


多重ファイルのアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 多重ファイルのアップロード

次の例は、多数のファイルを同時にアップロードする方法を示しています。

入力フォームページ#1

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="MultipleUpload_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="file" NAME="file2">
<INPUT TYPE="file" NAME="file3">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ#1

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject ("DEXT.FileUpload")
uploadform.DefaultPath = "c:\Temp"
uploadform ("file1").Save 'uploadform.Save としても可。
uploadform ("file2").Save
uploadform ("file3").Save
Set uploadform = Nothing
%>
</BODY>
</HTML>

アップロードしたファイルの参照は、"file1"、"file2"、"file3"などのNAMEプロパティ値に基づいて行われます。または、いくつかのINPUT項目のNAMEプロパティを同じ値に指定してから反復文を利用し、一括保存することもできます。次は、これを示す例です。

入力フォームページ#2

<HTML>
<BODY>
<FORM NAME="writeform" METHOD="post" ACTION="MultipleUpload_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロードされたファイルのNAME属性値を同値に指定します。

アップロード処理ページ #2

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject ("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
For i = 1 To uploadform("files").Count
uploadform("files")(i).Save
Next
Set uploadform = Nothing
%>
</BODY>
</HTML>

For文を用いて多重ファイルを処理する場合、インデックスは1から始まります。

上記の例でFor文を次のように作成しても同じ結果を得られます。
For Each item In uploadform ("files")
item.Save
Next

Copyright © DEVPIA Corporation. All rights reserved.


다중 파일 업로드

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 多重 Saveアップロード

次の例題はアップロードしたファイルをSave()メソッドを使って同時に多くの所に保存する方法を説明します。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み.)から多重 Save可能.
SaveAs(),SaveVirtual(),SaveAsVirtual(),SaveAsBlob() メソッドも対応できます。

注意事項 : 多重 Save時、用量が大きいファイルをアップロードする場合、全てのSaveが完了するまでアップロードが完了しない。

入力フォームページ

<HTML>

<BODY>

<FORM NAME="write_form" METHOD="post" ACTION="MultiSave_Process.asp" ENCTYPE="multipart/form-data">

<INPUT TYPE="file" NAME="file1">

<INPUT TYPE="submit" VALUE="upload">

</FORM>

</BODY>

</HTML>

アップロード処理ページ

<%

Set uploadform = Server.CreateObject("DEXT.FileUpload")

uploadform.AutoMakeFolder = True

uploadform.DefaultPath = "C:\TEMP"

savepath1 = "C:\Temp1"

savepath2 = "C:\Temp2"

savepath3 = "D:\Temp1"

uploadform("file1").Save savepath1,false

uploadform("file1").Save savepath2,false

uploadform("file1").Save savepath3,false

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


他のフォーム要素も含めてアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 他のフォーム要素も含めてアップロード

Formの他の要素もファイル要素と同様に、NAME属性値を通じて参照します。資料をアップロードする時、<form enctype=”multipart/form-data”…>に設定すれば、 request("element_name")などの方法では値を得られません。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="UploadWithElements_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="text" NAME="title">
<TEXTAREA NAME="content" ROWS="10" COLS="50"></TEXTAREA>
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "c:\temp"
title = uploadform ("title")
content = uploadform ("content")
uploadform ("file1").Save
Set uploadform = Nothing
%>
</BODY>
</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


アップロードファイルのサイズ制限

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ アップロードファイルのサイズ制限

MaxFileLenプロパティーを利用すればアップロード可能な最大ファイルサイズを制限できます。
TotalLen プロパティーは全体アップロード可能なサイズを制限します。
CheckMaxFileLenプロパティーはユーザーが MaxFileLenに設定されたサイズより大きいサイズのファイルをアップロードする場合
サーバー側の負荷を減らすために強制的にユーザーとの連結を切ってしまいます。

下の例題はアップロードファイルのサイズが1MB以上の場合エラーが発生します。
ファイルのサイズが50MB以上の場合はサーバーで連結を切ります。

アップロードしたファイルの大きさと制限された大きさ(1MB)を比べなく、ファイルを保存する時は次のようなエラーが発生します。

DEXTUpload　error’80040200’
指定ファイルサイズ(1048576 Bytes)を超過しました
/Sample/LimitSize/LimitSize_Process.asp, line40)

CheckMaxFileLen プロパティーを設定した場合サーバー側で強制的に連結を終了するから (HTTP/1.1 400 Bad Request 発生)
ブラウザーで連結エラーメッセージが見えるとか白画面の出る場合が発生します。

それでファイルを保存する前にファイルのサイズを確認して処理しなければなりません。

[参照事項]
MaxFileLen : 一つのファイルサイズを制限する屬性
TotalLen : 全体ファイルのサイズを制限する屬性
CheckMaxFileLen : 一つのファイルサイズを制限する屬性で
MaxFileLen プロパティーに設定されたファイルサイズ以上の場合クライアントと連結を強制終了
*最大設定可能値 (2048*1024*1023) : IISが処理できる最大値

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="LimitSize_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"

uploadform.MaxFileLen = 1024*1024 ' 一つのファイルのサイズを1MB以下に制限
uploadform.TotalLen = 50*1024*1024 ' 全体データのサイズを50MB以下に制限
'uploadform.CheckMaxFileLen = True 'MaxFileLenを参考してユーザーとの連結設定制限

if uploadform.FileLen > uploadform.MaxFileLen then
Response.Write "ファイルのサイズが大きすぎます！
' Response.Endを使用する場合、開かれているオブジェクトがあるとそのオブジェクトを閉じる。
set uploadform=nothing
Response.End
else
'アップロードされたファイルのサイズが1MB以下の場合、にファイルを保存する。
FileName = uploadform("file").save()
If Err Then
Response.Write Err.number & "<br>" & Err.source & "<br>" & Err.description
Set uploadform = Nothing
Response.End
End if
end if
%>
<HTML>
<BODY>
Original Path:<%= uploadform.FilePath %> <br>
Upload FilePath:<%= FilePath %> <br>
File Size:<%= uploadform.FileLen %> <br>
Mime Type:<%= uploadform.MimeType %> <br>
Last Saved File Name:<%= uploadform.LastSavedFileName %> <br>
Last Saved File Path:<%= uploadform.LastSavedFilePath %> <br>
</BODY>
</HTML>
<%
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


画像ファイルのサイズを確認

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 画像ファイルのサイズを確認

アップロードされたイメージファイルの幅と高さの情報を表示します。
対応している拡張子は、BMP, EMF, EXIF, GIF, Icon, JPEG, PNG, TIFF, WMFなどです。
下の例では、アップロードファイルに対し、IsImageItem()メソッドによりイメージファイルであるかどうかをチェックします。

[HOT]
DEXTUpload ProfessionalにはDEXT.ImageProcオブジェクトが新しく追加されました。
このオブジェクトを使えば、透かし、サムネイル画像の生成、フォーマット変換などの各種の画像処理が可能になります。
詳細については、使用説明書の"画像処理"を参照下さい。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="GetImageSize_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
FileName = uploadform.Save()
%>
<HTML>
<BODY>
<%
If uploadform("file").IsImageItem() Then
Response.Write uploadform.ImageFormat
Response.Write uploadform.ImageWidth
Response.Write uploadform.ImageHeight
End If
%>
</BODY>
</HTML>
<%
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


データベースBLOBフィールドにアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ データベース BLOB フィールドにアップロード

次のようにSaveAsBlob()メソッドを用いることにより、ファイルをアップロードしてDatabase BLOBフィールドに保存できます。
サンプルの実行時にDEXTUpload.mdbにアクセスできない場合、ファイルのセキュリティタブでUser アカウントに書き込み権限を与えます。

BLOB 処理ページ

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"

filename=uploadform("file").FileName
filesize=uploadform("file").FileLen
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb"

set rs=server.CreateObject("adodb.recordset")
strQuery="select * from DEXTUPLOAD" 'TABLE NAME: DEXTUPLOAD
rs.Open strQuery,Conn,1,3
rs.AddNew
rs("filename")=filename
rs("filesize")=filesize
'ファイルをデータベースに保存
uploadform("file").SaveAsBlob rs("filedata")
rs.Update
rs.Close
set rs=nothing
Set uploadform =nothing
%>

※ Database BLOB 関連Method
FileUploadオブジェクトのSaveAsBlob : ファイルをアップロードしてDatabase BLOBフィールドに保存します。
FileDownloadオブジェクトのDownloadBlob : Database BLOBをユーザーのディスクにダウンロードしてファイルで保存します。
BLOBManagerオブジェクトのSaveFileAsBlob : サーバに存在するフィアルをDatabase BLOBフィールドに保存します。
BLOBManagerオブジェクトのSaveBlobAsFile : Database BLOBをサーバのディスクにファイルとして保存します。

Copyright © DEVPIA Corporation. All rights reserved.


名前をつけて保存

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 名前をつけて保存

アップロードされたファイルをSaveAs( )メソッドを用いて指定された名前で保存する方法を示します。
ファイルの保存先は、"アップロードフォルダ名\新しいファイル名"に指定しなければなりません。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="SaveAs_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<BR>
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
'新しく保存されるファイルの名前をSaveAsで指定
newname = "SaveAs"
oldname = uploadform("file").FileName
'元のファイルの拡張子を得るための部分(ファイル名が変わっても拡張子を保持するためである。)
ext = "." & right(oldname,len(oldname)-instr(oldname,"."))
savefullpath = uploadform.DefaultPath & "\"&newname&ext
FileName = uploadform.SaveAs(savefullpath)
Set uploadform = Nothing
%>
</BODY>
</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


シングルASPページを利用したアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ シングルASPページを利用したアップロード

Post方式を使ってシングルページでのファイルアップロード方法を説明します。
一つのページで処理するために<FORM METHOD="POST"...> により呼び出されなかった場合は入力フォームを表し、

<FORM METHOD="POST" NAME="form1">により呼び出された場合はアップロードを実行します

入力フォームページ

<%
If Request.ServerVariables("Request_Method")<>"POST" Then
%>
</HEAD>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="OnePageUpload.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<BR>
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
<%
ELSE
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
FileName=uploadform.save
%>
</FORM>
</BODY>
</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


ファイルのアップロード／ダウンロード:ネットワークパス

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ネットワーク経路に対するファイルアップロードとダウンロード

ファイルのアップロード(ダウンロード)作業を行うウェブサーバと、アップロードしたファイルが保存される(ダウンロードするファイルが保存されている)ファイルサーバを別のコンピュータに置きたい場合には、次のようなネットワーク経路へのアクセスのための設定が追加として必要となります。

次は、各サーバで設定すべき項目です。

1. ウェブサーバとファイルサーバ（共通）
1). 匿名アクセスのための新しいゲストアカウントを生成し、経路ワードも入力します(両サーバのアカウント及び経路ワードは同じでなければなりません。)
2) " ユーザーはパスワードを変更できない"及び" パスワードを無制限にする"という２つの欄のみをチェックします。
" ユーザーは次回ログオン時にパスワードの変更が必要"、" アカウントを無効にする"、"アカウントがロックされている"という項目にはチェックしないでください。
3) 生成されたアカウントの所属グループの欄から既に基本的に追加されている"Users"グループを削除し、"Guests"グループを追加します。

4) ローカルセキュリティの設定の欄で、このアカウントに"ローカルログオン"権限を与えます。

2. ウェブサーバの設定
1) インターネットサービス マネージャーを実行し、該当ウェブサイトのディレクトリのプロパティ表示ウィンドウを開きます。
2) "ディレクトリセキュリティ"タブで"匿名アクセス及び認証制御"の欄にある"エディット"ボタンをクリックします。
3) "匿名アクセス"の欄にある"エディット"ボタンをクリックし、先ほど生成したアカウント名と経路ワードを「匿名ユーザ名」及び「経路ワード」欄に入力します。ただし、ここで忘れずに"IISによるパスワードの管理を許可する"欄のチェックを外してください。

3. ファイルサーバの設定
1) ファイルサーバのアップロードフォルダのディレクトリのプロパティ表示ウィンドウを開きます。
2) "共有"タブの使用権限と"セキュリティ"タブの使用権限の両方に、先ほど生成したアカウントを追加します。
3) このとき、"共有"タブでの使用権限としては"読み込み"と"変更"を、"セキュリティ"タブでの使用権限としては"読み込み"、"書き込み"、"修正"の権限を指定します。

以上1, 2, 3の手順に従いウェブサーバー及びファイルサーバーを設定してから、物理的な絶対経路値を必要とするプロパティやメソッドに次のような簡単なネットワーク経路を指定すれば、ファイルのアップロードやダウンロードを 行えるようになります。

例1) uploadform.DefaultPath = "\\ファイルサーバ名\共有フォルダ名"
例2) uploadform("file1").SaveAs("\\ファイルサーバ名\共有フォルダ名\Sample.zip")
例3) oDownload.Download("\\ファイルサーバ名\共有フォルダ名\Sample.zip")

Copyright © DEVPIA Corporation. All rights reserved.


アップロードタイムアウトの設定

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ アップロードタイムアウトの設定

大容量ファイルのアップロードや保存は通常長時間を要し、Server.ScriptTimeout(Default: 90sec)やSession.Timeout(Default: 20min)の値を変更しない限り、タイムアウトエラーにより作業を正常に行うことができなくなります。

DEXTUpload Professionalは、UploadTimeoutプロパティを使用し、ファイルをアップロードする際に特にServer.ScriptTimeoutやSession.Timeoutを設定しなくても、タイムアウトエラーを起こすことなく大容量ファイルを正常にアップロードできるよう設計されています。デフォルト値は3600sec(60min)ですが、必要に応じて変更が可能です。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="LimitTimeout_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<BR>
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.UploadTimeout = 1200
FileName = uploadform("file").Save
Set uploadform = Nothing
%>
</BODY>
</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


アップロード可能なファイルの種類を制限

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ アップロード可能なファイルの種類を制限

DEXTUpload Professional付属のMimeTypeプロパティを使えば、アップロード可能なファイルの種類を制限できます。
ここでは、GIFとJPGファイルのみにアップロードを制限する方法を説明します。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="RestrictFileType_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
'アップロードされるファイルのmime_typeを得る。
file_MimeType=uploadform("file").MimeType
'MimeTypeがimage/jpeg ,image/gifではない場合、アップロードを中止
if file_MimeType <> "image/pjpeg" and file_MimeType <> "image/gif" then
%>
<HTML>
<BODY>
アップロードキャンセル!!<br>
MimeTypeが"image/pjpeg"あるいは"image/gif"であるファイルのみ対応しています。<br>
<a href="javascript:history.go(-1)">[ back ]</a>
<%
'Response.Endを使用する場合、開いているオブジェクトがあれば、そのオブジェクトを閉じる。
set uploadform=nothing
Response.End
else
'MimeTypeがimage/jpeg ,image/gifである場合、正常にアップロード
FilePath = uploadform("file").Save
%>
Original Path : <%= uploadform("file").FilePath %>
<br>
Upload Path : <%= FilePath %>
<br>
File Size : <%= uploadform("file").FileLen %> bytes
<br>
MimeType : <%= uploadform("file").MimeType %>
<br>
LastSavedFileName : <%= uploadform("file").LastSavedFileName %>
<br>
LastSavedFilePath : <%= uploadform("file").LastSavedFilePath %>
<%end if%>
</BODY>
</HTML>
<%
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


エラーが生じた時、アップロードされたファイルをすべて削除する

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ エラーが生じた時、アップロードされたファイルをすべて削除する

DeleteAllSavedFiles()メソッドを用いると、ファイルのアップロード中にエラーが発生した場合、アップロードされたファイルをすべて削除します。

入力フォームページ

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="DeleteAllSavedFiles_Process.asp" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="file" NAME="file2">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ Language=VBScript %>
<HTML>
<HEAD>
</HEAD>
<%
ON ERROR RESUME NEXT
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
'最初のファイルを保存
uploadform("file1").save
'最初のファイルの保存後にテストのためのエラーが発生
Err.Raise vbObjectError+1073,"Error Test!!!","Don't worry!! It's simmulation"
uploadform.Form.Item("file2").save
'エラーが発生したためにuploadform.DeleteAllSavedFilesが呼び出され、アップロードされたファイルが削除
If Err Then
Response.Write Err.number & "<br>" & Err.source & "<br> " & Err.description
uploadform.DeleteAllSavedFiles
Set uploadform = Nothing
Response.End
End if
%>
</HTML>
<%
Set uploadform =nothing
%>

DeleteFile()メソッドを用いると、ファイルを選択的に削除することができる。

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
UploadedFile1 = uploadform("file1").Save
UploadedFile2 = uploadform("file2").Save
...
'最初のファイルを削除するには、
uploadform.DeleteFile UploadedFile1
...
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


多国語支援ファイルのアップロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 多国語支援ファイルのアップロード

DEXTUpload Professional付属のCodePageプロパティを使用すれば、外国語やユニコードのフォーム要素値及びファイル名の処理ができます。
外国語やユニコード文字セットを用いるウェブページでは、必ずそのページで使われる文字セットに対応するコードページの値をアップロードコンポーネントのCodePage値として指定する必要があります。
デフォルト値はシステムに設定されたデフォルトのコードページ値となります。
ただし、ASPコードでSession.CodePage値を指定した場合には、その値がデフォルトの値となります。この場合、CodePageプロパティの値を指定する必要はありません。以下は、
ユニコード文字セットを用いるウェブページにDEXTUploadを使用する例です。

入力フォームページ

<%
'UTF-8コードページの宣言
old_codepage = Session.CodePage
Session.CodePage = "65001"
%>
<HTML>
<HEAD>
<META http-equiv="Content-Type" content= "text/html; charset= utf-8">< /FONT>< /FONT>
</HEAD>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="GlobalEnvironment_Process.asp" ENCTYPE="multipart/form-data">
<tr>
<td width="100"><b>TextArea</b></td>
<td width="500">
<textarea name="txtvalue" rows=10 cols=50></textarea>
</td>
</tr>
<INPUT TYPE="file" NAME="file1">
<BR>
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>
<%
Session.CodePage = old_codepage
%>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
old_codepage = Session.CodePage
Session.CodePage = "65001"
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.Codepage = 65001
uploadform.Save
Set uploadform = Nothing
%>
</BODY>
</HTML>
<%
Session.CodePage = old_codepage
%>

Copyright © DEVPIA Corporation. All rights reserved.


サーバに保存せずにアップロード作業をキャンセル

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ サーバに保存せずにアップロード作業をキャンセル

DEXTUpload Professional付属のFlush()メソッドを使用すれば、実際にファイルをサーバーに保存しなくても必要に応じてアップロード作業を完全にキャンセルし、残りのコードを実行し続けられます。次は、アップロードするファイルのサイズが1Mを超える場合の、アップロードをキャンセルしてエラーメッセージを表示する例です。

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
If Request.TotalBytes > 1048576 Then
uploadform.Flush
Response.Write "Warning: File size must be less than 1 MBytes."
Else
uploadform.Save
Response.Write "File-upload completed."
End If
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ユーザ定義型アップロードプログレスバー

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ユーザ定義型アップロードプログレスバー

DEXTUpload Professional付属のアップロード進行情報オブジェクトは、アップロードの進行状態を見やすく、わかりやすく表示します。
ActiveX ControlやJava Appletなどの他のクライアントソフトウェアを使用する必要がまったくありません。また、アップロードの速度やコンテンツ全体のサイズ、現在アップロード中のコンテンツのサイズ、残り時間、現在進行中の作業などの情報をリアルタイムにてモニターすることができます。
プログレスバーの設定を変更する場合には、Progress.aspファイルを編集して下さい。

本機能はProgressオブジェクトにより実現されており、次のようなメソッドやプロパティが与えられています。
[メソッド]
- SetProgressID() : GetProgressIDにより得たIDをこの関数を通じてセットする。
- GetProgressID() : FileUploadやProgressで使用されるIDをゲット。

[プロパティ]
- TotalSize : アップロードする全体のサイズ
- TransferSize : 転送データのサイズ(Byte)
- Percent : アップロードの進行率
- BytesPerSec : アップロードの速度、１秒当たりのByte
- FileName : 現在アップロード中のファイルの名前を表示する。
- Working : trueの場合、アップロード進行中。Falseの場合、作業終了

[参考事項]

ファイルをアップロードする際、不特定にセッションのコードページが変更される問題が生じる場合、

ファイル名が正常に表示されない症状(文字化け)が発生します。

この問題を解決するには、コードページを明示的に指定するようにしてください。

[HOT]
今までのDEXTUploadは、サーバーコンポーネント内にて動的にタグを生成して、プログレスバーのUIを表示していました。このため、サーバー側の負担が比較的大きいことが問題でした。
サーバーの負担を考え、できるだけ新方式を使用されることを推奨します。

入力フォームページ

<%
'ファイルのアップロードの進行状態を表示するための部分
dim ProgressID
set obj = server.CreateObject("DEXT.Progress")
'IDを得る。今後FileUploadとProgressが使用する。
ProgID = obj.GetProgressID()
set obj = nothing
%>
<HTML>
<HEAD>
<SCRIPT language="javascript">
<!--
function ShowProgress() {
strAppVersion = navigator.appVersion;

if (strAppVersion.indexOf('MSIE') != -1 && strAppVersion.substr(strAppVersion.indexOf('MSIE')+5,1) > 4) {
winstyle = "dialogWidth = 385px;dialogHeight:160px;center:yes";
window.showModelessDialog("../Progress/progress.asp?Progressid=<%=ProgID%>",null,winstyle);
}
else{
winpos="left="+((window.screen.width-380)/2)+",top="+((window.screen.height-110)/2);
winstyle="width=380,height=110,status=no,toolbar=no,menubar=no,location=no,resizable=no,scrollbars=no,copyhistory=no," + winpos;
window.open("../Progress/progress.asp?Progressid=<%=ProgID%>",null,winstyle);
}
write_form.submit();
return true;
}
//-->
</SCRIPT>
</HEAD>
<BODY>
<FORMNAME="write_form"METHOD="post"ACTION="SimpleUpload_Process.asp?ProgressID=<%=ProgID=%>"
ENCTYPE="multipart/form-data" onsubmit="return ShowProgress()">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<HTML>
<BODY>
<%
'GetProgressIDにより得られたID
ProgID= request.QueryString("ProgressID")
Set uploadform = Server.CreateObject("DEXT.FileUpload")
'GetProgressIDにより得られたIDをこの関数を通じてセットする。
uploadform.SetProgress(ProgID)
uploadform.DefaultPath = "c:\temp"
uploadform("file1").Save
Set uploadform = Nothing
%>
</BODY>
</HTML>

アップロードの進行表示ページ

<%@ Language=VBScript EnableSessionState="False" %>
<%
Option Explicit
Dim Progress, Percent, TransferBytes, TotalBytes, BytesPer, bWorking, strFileName
Set Progress = Server.CreateObject("DEXT.Progress")
'GET方式により受信された進行状態ＩＤを指定します。
Progress.SetProgressID( Request.QueryString("ProgressID"))
'現在のアップロードの進行状態値を読み込みます。
Percent = Progress.Percent
TransferBytes = Progress.TransferSize
TotalBytes = Progress.TotalSize
BytesPer = Progress.BytesPerSec
bWorking = Progress.Working
strFileName = Progress.FileName
%>
<html>
<Head>
<title>
</title>
<%
'アップロードが進行中である場合、1秒に１回ずつ進行状態を更新します。
Response.Write "<Meta HTTP-EQUIV=""Refresh"" CONTENT=1>"
%>
</head>
<body>
<%
If bWorking = true Then
'アップロードの進行状態を出力します。
Response.Write "進行率: " & TransferBytes & "/" & TotalBytes & " (" & Percent & "%)<br>"
Response.Write "転送速度: " & BytesPer & " bytes/sec <br>"
Response.Write "転送ファイル: " & strFileName & "<br>"
Else
'アップロードが完了しました。
Response.Write "完了しました。."
End If
%>
</Table>
</Body>
</Html>

Copyright © DEVPIA Corporation. All rights reserved.


固定型アップロードのプログレスバー

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 固定型アップロードのプログレスバー

旧バージョンのDEXTUploadで採用していた方式です。できるだけ新バージョンに採用されているユーザー定義型方式のプログレスバーを使用することを推奨します。

この機能は、FileUploadMonitorオブジェクトを通じて実装され、次のようなメソッドが提供されます。
UseMonitor() : Formを作成するページで呼び出され、Progress Barのモニター機能をオンにする。
ShowMonitor() : Progress Barを表示するページ(ウィンドウ)で呼び出され、アップロードの進行状態を視覚的に表示する。

入力フォームページ

<%@ LANGUAGE="VBSCRIPT"%>
<%
'ファイルのアップロードの進行状態を表示するための部分
Set objMon = Server.CreateObject("DEXT.FileUploadMonitor")
objMon.UseMonitor(True)
Set objMon = Nothing
%>
<HTML>
<HEAD>
<SCRIPT LANGUAGE="JavaScript">
<!--
function ShowProgress() {
strAppVersion = navigator.appVersion;

if (strAppVersion.indexOf('MSIE') != -1 && strAppVersion.substr(strAppVersion.indexOf('MSIE')+5,1) > 4) {
winstyle = "dialogWidth = 385px;dialogHeight:160px;center:yes";
window.showModelessDialog("show_progress.asp?nav=ie", null, winstyle);
}
else{
winpos="left="+((window.screen.width-380)/2)+",top="+((window.screen.height-110)/2);
winstyle="width=380,height=110,status=no,toolbar=no,menubar=no,location=no,resizable=no,scrollbars=no,copyhistory=no," + winpos;
window.open("show_progress.asp",null,winstyle);
}
write_form.submit();
return true;
}
//-->
</SCRIPT>
</HEAD>
<BODY>
<FORM NAME="writeform" METHOD="post" ACTION="ProgressBar_Process.asp" ENCTYPE="multipart/form-data" onSubmit="return ShowProgress();">
<INPUT TYPE="file" NAME="file"><BR>
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

Progress Barを使用するには、上記の例のようにForm作成ページの上端でFileUploadMonitorオブジェクトのUseMonitor()メソッドを、Trueをファクタとして呼び出す必要があります。 もし、UserMonitor()メソッドを呼び出さないか、あるいはFalseをファクタとして呼び出すと、Progress Barは動作しません。 以上の例を参照すれば、FormをSubmitする直前にShowProgress()というジャワスクリプト関数を呼び出してProgress Barを視覚的に表示するために、新しいウィンドウ(または、ダイアログ)を表示させるのが見られます。

このとき、新しいウィンドウに表示されるページは、次の通りです。

アップロードの進行表示ページ(show_progress.asp)

<%@ EnableSessionState=False%>
<%
'Netscape Navigatorの場合
If Request("nav") = "ns" Then
%>
<frameset rows="80,1*" border="0" framespacing="0" frameborder="no">
<frame src="show_prog_body.asp" noresize scrolling="NO" frameborder="NO" name="sp_body">
<!-- Netscape NavigatorのようにInline Frameを支援しないウェブブラウザの場合にのみ必要となる -->
<frame src="show_prog_bottom.asp" noresize scrolling="NO" frameborder="NO" name="sp_bottom">
<%
'Internet Explorerの場合
Else
%>
<HTML>
<HEAD>
<TITLE>Uploading Files...</TITLE>
<STYLE type="text/css">
td {font-size: 9pt}
</STYLE>
</HEAD>
<BODY bgcolor="#d4d0c8" leftmargin="8" topmargin="0" scroll="no">
<IFRAME src="show_prog_body.asp" title="Progress Step1" frameborder=0
marginheight=0 marginwidth=0 noresize scrolling=no width=365 height=65>
</IFRAME>
<TABLE border="0" width="365" cellpadding="2" cellspacing="0" bgcolor="#d4d0c8">
<TR><TD>Click the <B>STOP</B> button on your browser to abort uploading.</TD></TR>
</TABLE>
</BODY>
</HTML>
<%
End If
%>

Progress Barを表示するには、上記のshow_progress.aspと共に次にあるshow_prog_body.aspと show_prog_bottom.aspが必要です。
- show_progress.asp: Progress Indicatorを表示するためにウェブページをフレームに分ける。
- show_prog_body.asp: 実際にProgress Indicatorを表示する役割を果たす。
- show_prog_bottom.asp: (Netscape NavigatorのようにInline Frameを支援しないブラウザの場合にのみ必要である。)

アップロードの進行表示ページ(show_prog_body.asp)

<%@ EnableSessionState=False%>
<%
'アップロードの進行状態を表示するページ
Set m_objMon = Server.CreateObject("DEXT.FileUploadMonitor")
m_objMon.ShowMonitor
Set m_objMon = Nothing
%>

アップロードの進行表示ページ (show_prog_bottom.asp)

<%@ EnableSessionState=False%>
<HTML>
<HEAD>
<STYLE type="text/css">
td {font-size: 9pt }
</STYLE>
</HEAD>
<BODY bgcolor="#d4d0c8" leftmargin="8" topmargin="0" scroll="no">
<TABLE border="0" width="365" cellpadding="2" cellspacing="0" bgcolor="#d4d0c8">
<TR><TD>Click the <B>STOP</B> button on your browser to abort uploading.</TD></TR>
</TABLE>
</BODY>
</HTML>

上記のASPページをみると、"EnableSessionState"属性をFalseに指定してセッション状態を解除しています。もし、このページのセッションを解除しないと、FormのSubmit作業、つまり、ファイルのアップロード作業が終了するまではページの実行結果を見ることができなくなるため、必ずページのセッション状態を解除することを推奨します。

ShowMonitor()メソッドは、毎瞬間のアップロードの進行状態を表示し、アップロードが完了すると自動的にウィンドウ(または、ダイアログ)を閉じます。

アップロード処理ページ

<%@ LANGUAGE="VBSCRIPT" %>
<HTML>
<BODY>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform("file1").Save
Set uploadform = Nothing
%>
</BODY>
</HTML>

アップロード作業を処理するページは、Progress Barの使用有無とは無関係に同一に作成すると良いです。

Copyright © DEVPIA Corporation. All rights reserved.


ファイルのダウンロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ファイルのダウンロード

FileDownloadオブジェクトのDownload(),
  DownloadVirtual(), DownloadBlob()メソッドを用いることにより、ユーザはサーバーにあるファイルをウェブブラウザーを通じてダウンロードできます。
- Download() : サーバーの指定パスにあるファイルをダウンロードする。
- DownloadVirtual() : サーバーの指定されたバーチャルパスにあるファイルをダウンロードする。DEXTUploadとの互換性のために存在する。
-
  DownloadBlob() : データベースのBLOBデータをダウンロードする。

ダウンロード処理ページ

<%@ Language=VBScript EnableSessionState="False"%>
<%
filepath = request("filepath")
filename = request("filename")
'ダウンロードオブジェクトの生成
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'objDownload.Download(filepath, ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード))
objDownload.Download(filepath, filename, true, false)
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ファイルの強制保存

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ファイルの強制保存

ダウンロードデータを常にファイルとして保存するため、ウェブブラウザーは保存ダイアログを出力します。

ダウンロード処理ページ

<%@ Language=VBScript EnableSessionState="False"%>
<%
filepath = request("filepath")
filename = request("filename")
'ダウンロードオブジェクトの生成
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'objDownload.Download(filepath, ファイル名、強制保存の有無 (True:強制保存)、続けてダウンロードの有無 (True:続けてダウンロード))
objDownload.Download(filepath, filename, true, false)
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ファイルを続けてダウンロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ファイルを続けてダウンロード

ユーザーがキャンセルまたは、あるいはネットワークトラブルにより一時中断されたダウンロードを再開する場合、ダウンロードが中断された時点のデータに続けてダウンロードを開始します。

ダウンロード処理ページ

<%@ LANGUAGE="VBSCRIPT"%>
<%
filepath = request("filepath")
filename = request("filename")
'ダウンロードオブジェクトの生成
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'objDownload.Download(filepath,ファイル名、強制保存の有無 (True:強制保存)、続けてダウンロードの有無 (True:続けてダウンロード))
objDownload.Download(filepath, filename, false, true)
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


バーチャルパスからのファイルダウンロード

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ バーチャルパスからのファイルダウンロード

いままでのDEXTUploadバージョンでは、DownloadVirtual()メソッドがバーチャルパスへのアップロードに対応していましたが、DEXTUpload
  Professionalでは、Download()メソッドがバーチャルパスに対応しています。
ただし、旧バージョンとの互換性を保つため、DownloadVirtual()メソッドも使用可能となっています。

ダウンロード処理ページ

<%@ Language=VBScript EnableSessionState="False"%>
<%
filepath = request("filepath")
filename = request("filename")
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'DownloadVirtual()メソッドの互換
objDownload.Download "/DEXTUploadProSampels/data/" & filename, filename, true, false
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


データベースBLOBをダウンロードする

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ データベースBLOBをダウンロードする

FileDownloadオブジェクトのDownloadBlob()メソッドを用いることにより、サーバーにあるDatabase BLOBデータをダウンロードできます。
BLOBフィールドをダウンロードするとき、続けてダウンロードには対応していません。

ダウンロード処理ページ

<%@ Language=VBScript EnableSessionState="False"%>
<%
fileid=request("dblist")
Set rs = Server.CreateObject("ADODB.Recordset")
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb"
sql="SELECT * FROM DEXTUPLOAD WHERE fileid ="&fileid
rs.Open sql, Conn, 3, 1
Set objDownload = Server.CreateObject("DEXT.FileDownload")
objDownload.DownloadBlob rs("filedata"), rs("filename"), true
Set objDownload = Nothing
rs.Close
Set rs = Nothing
%>

[参照]
※ Database BLOB関連メソッド
FileUploadオブジェクトのSaveAsBlobファイルをアップロードしてDatabase BLOBフィールドに保存する。
FileDownloadオブジェクトのDownloadBlob : Database BLOBをユーザのディスクにダウンロードしてファイルとして保存する。
BLOBManagerオブジェクトのSaveFileAsBlob : サーバーに存在するファイルをDatabase BLOBフィールドに保存する。
BLOBManagerオブジェクトのSaveBlobAsFile : Database BLOBをサーバーのディスクにファイルとして保存する。

Copyright © DEVPIA Corporation. All rights reserved.


ファイルをメモリにスタックする

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ ファイルをメモリにスタックする

頻繁にダウンロードされるファイルをあらかじめメモリに入れておけば、ディスクからファイルを読み込んでメモリにスタックする時間を短縮することができ、ダウンロード速度がアップされます。
ダウンロードキャッシュ機能は、ファイルをメモリにスタックしておくため、大容量のファイルをダウンロードする場合にメインメモリが不足する恐れがありますので、注意を要します。このため、頻繁にダウンロードされるファイルだけに対してキャッシュ機能を使用することを推奨します。
キャッシュ機能は、DEXT.Manager

オブジェクトにより実装することができます。AddCacheFile() メソッドを用いてファイルをメモリにスタックし、For Each文によりスタックされたファイルリストをインポートします。

下のコードは、ファイルをメモリにスタックし、スタックされたファイルリストを表示するサンプルです。

<%@ Language=VBScript %>
<%
set objManager = server.createobject("DEXT.Manager")
'メモリにファイルを追加
objManager.AddCacheFile Trim(Request("txtFilePath1"))
Response.Write("メモリにスタックされたファイル一覧")
'キャッシュされたファイルリストをインポート
For Each cacheFile in objManager
response.Write(cacheFile & "<br>")
Next
set objManager = nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


指定されたファイルをメモリから除去する

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 指定されたファイルをメモリから除去する

使用しないファイルをメモリから除去してメモリのリソースを管理することができます。RemoveCacheFile()メソッドを用いてファイルをメモリから除去する。
下のコードは、ファイルをメモリから除去し、メモリにスタックされたファイルリストを表示する例である。

<%@ Language=VBScript %>
<%
set objManager = server.createobject("DEXT.Manager")
'メモリからファイルを除去する
objManager.RemoveCacheFile Trim(Request("txtFilePath1"))
Response.Write("メモリにスタックされたファイル一覧")
'キャッシュされたファイルリストをインポート
For Each cacheFile in objManager
response.Write(cacheFile & "<br>")
Next
set objManager = nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


サーバ内のファイルをデータベースのBLOBフィールドに保存

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ サーバー内のファイルをデータベースのBLOBフィールドに保存

下の画像は、サーバーに存在するファイルをデータベースのBLOBフィールドに保存する例です。

アップロードフォームページ

<HTML>
<HEAD>
</HEAD>
<BODY>
<form name="write_form" action="FileToBlob_Process.asp">
<input type="file" name="file"><br>
<input type="submit" name="Upload" value="Upload">
</form>
</BODY>
</HTML>

Formタグで、enctype = "multipart/form-data"プロパティを指定しません。

アップロード処理ページ

<%@ Language=VBScript %>
<%
'サーバーに存在するファイルのパスを得る
filepath=request("file")
set objBlobMan=server.CreateObject("DEXT.BlobManager")
set fso=server.CreateObject("Scripting.FileSystemObject")
'ファイルのパスを用いてファイルの名前とサイズを得る。データベースに単なるデータだけではなく、名前とサイズも一緒に保存するためである。
set file=fso.GetFile(filepath)
filesize=file.size
filename=file.name
set fso=nothing
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb"
set rs=server.CreateObject("ADODB.RECORDSET")
sql="select * from DEXTUPLOAD"
rs.Open sql,conn,3,3
rs.AddNew
'DEXTUPLOAD TABLEの構造
'fileidのシリアル番号
'filenameテキスト
'filesize数字
'filedata OLEオブジェクト
rs("filename")=filename
rs("filesize")=filesize
'サーバー内に存在するファイルをDatabaseに保存
objBlobMan.SaveFileAsBlob filepath,rs("filedata")
rs.Update
rs.Close
set rs=nothing
%>
<HTML>
<BODY>
Upload Name: <%=FileName%> <br>
File Size: <%=filesize%> <br>
</BODY>
</HTML>
<%
set objBlobMan=nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


データベースBLOBをサーバ内のファイルとして保存

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ データベースBLOBをサーバー内のファイルとして保存

下の画像は、データベースBLOBをサーバーにファイルの形式で保存する例です。

アップロードフォームページ

<%@ Language=VBScript %>
<%
sql="select * from DEXTUPLOAD"
set rs=server.CreateObject("adodb.recordset")
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb" rs.Open sql,conn,3,1
%>
<HTML>
<HEAD>
</HEAD>
<BODY>
<form name="write_form" method="post" action="BlobToFile_Process.asp">
<select name="file" size="5">
<%
if rs.EOF and rs.BOF then
%>
<option value="">NO DATA</option>
<%else%>
<%Do Until rs.EOF%>
<br>
<optionvalue="<%=RS("fileid")%>"><%=RS("filename")%></option>
<%
rs.MoveNext
loop
end if
%>
</select><p>
<input type="submit" name="Download" value="Download">
</form>
</BODY>
</HTML>

上の例では、Database BLOBをリストに表示しています。このリストの中から指定のファイルを選んでボタンを押すと、ダウンロードウィンドウが表示されます。

アップロード処理ページ

<%@ Language=VBScript %>
<%
'DEXT.BlobManagerオブジェクトの生成
set objBlobMan = server.CreateObject("DEXT.BlobManager")
fileid = request("file")
sqlstr = "select * from DEXTUPLOAD where fileid="
sql = sqlstr & fileid set rs=server.CreateObject("adodb.recordset")
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb"
rs.Open sql,conn,3,1
filename = rs("filename")
filepath = "C:\TEMP\"&rs("filename")
filesize = rs("filesize")
'Databaseにあるファイルを保存する
objBlobMan.SaveBlobAsFile rs("filedata"),filepath
%>
<HTML>
<BODY>
Save Path: <%= filepath %> <br>
Upload Name: <%= FileName %> <br>
File Size: <%= filesize %> <br>
</BODY>
</HTML>
<%
rs.Close
set rs=nothing
set objBlobMan=nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ウォーターマークイメージを生成

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 透かしイメージ生成

DEXT.ImageProcは、イメージ透かし、ファイルフォーマットの変換、サムネイル機能などを行います。
下のコードは、アップロードされたイメージファイルに対するイメージ透かし処理とテキスト透かし処理を示します。

SetSourceFile()メソッドは、指定されたファイルがイメージファイルであればtrueを返し、イメージオブジェクトを初期化します。

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
'FileNameWithoutExt属性は、アップロードしたファイルの名前を返す(拡張子を除く。)。
SourceFileName = uploadform("file").FileNameWithoutExt
FileName1 = "C:\Temp\" & SourceFileName& "(Image).jpg"
FileName2 = "C:\Temp\" & SourceFileName & "(Text).jpg"
%>
<HTML>
<BODY>
<!-— 透かし処理されたイメージファイルの拡張子は、内部的にjpgフォーマットで保存されます。-->
Save as Watermark Image: <%=objImage.SaveAsWatermarkImage("/DEXTUploadProSamples/Image/WaterMark/watermark.bmp",FileName1,-10,-10,false)%>
Save as Watermark Text: <%=objImage.SaveAsWatermarkText("WaterMark Text",FileName2,15,10,10,false)%>
</BODY>
</HTML>
<%
end if
set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


画像ファイルをサムネイル処理する

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 画像ファイルをサムネイル処理する

下のコードはアップロードしたイメージファイルの横,縦を 1/10 及び 1/5 大きさのサムネｲルイメージを生成します。
生成されたイメージは JPG 形式です。bAutoSizeを TRUEで設定する場合サムネｲルのサイズに合わせて原本イメージの倍率を維持しながらサムネｲル処理して保存します。これにより生成されるイメージ余白は基本値は白に設定されているし
BackGroundColor プローパティを使って余白の色を指定できます。

イメージファイルの処理ページ#1(bAutoSizeを Falseで設定する場合)

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform.TempFilePath) then
'JPGフォーマットで保存されなければならない。
filename = uploadform.FileNameWithoutExt & ".jpg"
%>
<HTML>
<BODY>
Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\TEMP\" & filename, objImage.ImageWidth/10, objImage.ImageHeight/10, false, false)%>
</BODY>
</HTML>
<%
end if

set objImage = nothing
Set uploadform =nothing
%>

bAutoSizeが Falseで設定する場合アップロードしたイメージファイルの横,縦を設定したそのままサムネイル処理して保存します。

これによりイメージが拡大及び縮小される場合が発生してサムネイルイメージの歪む場合が発生したりします。

イメージファイルの処理ページ#2(bAutoSizeを Trueで設定する場合)

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXT.FileUpload")

uploadform.DefaultPath="C:\TEMP"

set objImage =server.CreateObject("DEXT.ImageProc")

objImage.BackGroundColor = "#CC66FF"

if true = objImage.SetSourceFile(uploadform.TempFilePath) then

'JPGフォーマットで保存されなければならない。

filename = uploadform.FileNameWithoutExt & ".jpg"

%>

<HTML>

<BODY>

Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\TEMP\" & filename, objImage.ImageWidth/5, objImage.ImageHeight/5, false, true)%>

</BODY>

</HTML>

<%

end if

set objImage = nothing

Set uploadform =nothing

%>

bAutoSizeが Trueで設定する場合アップロードしたイメージファイルの横,縦を設定したとおりサムネィルの大きさを処理して保存します。

ただ原本イメージの横,縦の割合を維持しながらその割合どおりサムネィルの大きさの中に入るようにすることでイメージが

歪曲されないでサムネィル処理されるが余白空間が発生します。

BackGroundColor プローパティを使って余白の色を指定できます。

Copyright © DEVPIA Corporation. All rights reserved.


画像ファイルのフォーマットを他のフォーマットに変換する

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 画像ファイルのフォーマットを他のフォーマットに変換する

下のコードは、JPGフォーマットをBMPフォーマットに変換して保存します。
BMP, JPG, GIF, TIFF, PNGなど他のフォーマットへの変換も可能です。

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform.TempFilePath) then
'FileNameWithoutExt属性は、アップロードしたファイルの名前を返す(拡張子を除く。)。
SourceFileName = uploadform("file").FileNameWithoutExt
FileName1 = SourceFileName & "(Image).bmp"
%>
<HTML>
<BODY>
Convert Image File Format: <%=objImage.ConvertImageFormat("image/bmp","C:\Temp\" & FileName1 ,false)
%>
</BODY>
</HTML>
<%
end if

set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


画像ファイル情報

DEXTUpload Professional

DEXTUpload Professionalのプログラミング

■ 画像ファイル情報

イメージファイルに対する露出時間、イメージの詳細、解像度など各種のメタデータに対応しています。

<%@ Language=VBScript %>
<%
set uploadform=Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
%>
<HTML>
<BODY>
画像フォーマット: <%=objimage.ImageFormat%> <br>
垂直解像度 : <%=objimage.VerticalResolution%> <br>
水平解像度 : <%=objImage.VerticalResolution%> <br>
イメージの高さ : <%=objimage.ImageHeight%> <br>
イメージの横幅 : <%=objimage.ImageWidth%> <br>
ピクセルフォーマット : <%=objimage.PixelFormat%> <br>
カメラ製造社 : <%=objImage.MDEquipMake%> <br>
カメラモデル名 : <%=objImage.MDEquipModel%> <br>
イメージの説明 : <%=objImage.MDImageDescription%> <br>
イメージの名前 : <%=objImage.MDDocumentName%> <br>
画像ファイルを作成したプログラム : <%=objImage.MDSoftwareUsed%> <br>
撮影子 : <%=objImage.MDArtist%> <br>
撮影日時 : <%=objImage.MDDateTimeOrig%> <br>
修正日時 : <%=objImage.MDDateTime%> <br>
カラーモード : <%=objImage.MDExifColorSpace%> <br>
露出時間(シャッタースピード) : <%=objImage.MDExifExposureTime%> <br>
シャッタースピード : <%=objImage.MDExifShutterSpeed%> <br>
返り値 : <%=objImage.MDExifFlash%> <br>
絞り値 : <%=objImage.MDExifFNumber%> <br>
アイリスの最大値 : <%=objImage.MDExifMaximumLensAperture%> <br>
ISO速度 : <%=objImage.MDExifISOSpeed%> <br>
焦点距離 : <%=objImage.MDExifFocalLength%> <br>
35mmフィルムの焦点距離 : <%=objImage.MDExifFocalLengthIn35mm%> <br>
撮影モード(露出プログラム) : <%=objImage.MDExifExposureProg%> <br>
露出補正 : <%=objImage.MDExifExposureBias%> <br>
デジタルズーム : <%=objImage.MDExifExifDigitalZoomRatio%> <br>
測光モード : <%=objImage.MDExifMeteringMode%> <br>
光源 : <%=objImage.MDExifLightSource%> <br>
White Balance: <%=objImage.MDExifWhiteBalance%> <br>

jpeg ファイルの鮮明度調節 : <%=objImage.Quality%> <br>
</BODY>
</HTML>
<%
else
Response.Write("イメージファイルではありません。")
end if

set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileUploadオブジェクト

実際にファイルをアップロードしてサーバーに保存する機能を担当するコンポネントの一番核心になる客体です。

プロパティ

名前 | 説明
AutoMakeFolder | TRUEに設定しておくと、DefaultPathやSaveAsなどのメソッド実行時に指定したフォルダが存在しない場合、フォルダを自動的に生成してくれる。
CheckMaxFileLen | MaxFileLen に設定した最大ファイルの用量に対する超過可否
CodePage | アップロードコンポーネントの、内部的にデータを処理するときに使用する CodePageを指定する。
DefaultPath | 一時ファイル及びアップロードされたファイルを保存するデフォルトのパス値を指定するために使用する。
FileLen | アップロードされたファイルの長さ値を有する(単一ファイル)。
FileName | アップロードされたファイルの名前(パスを除く)値を有する。
FileNameWithoutExt | アップロードされたファイルの名前(拡張子を除く)値を有する。
FileExtension | アップロードされたファイルの拡張子値を有する。
FilePath | アップロードされたファイルのフルパス値を有する。
Form | Submitされたフォームの各項目情報を保存しているFormItems Collectionオブジェクト
ImageFormat | アップロードされた画像ファイル(BMP,EMF,EXIF,GIF,Icon,JPEG,PNG,TIFF,WMF)のフォーマットをリターン。
ImageWidth | アップロードされた画像ファイルの幅をリターン。画像ファイルでない場合には-1をリターン。
ImageHeight | アップロードされた画像ファイルの高さをリターン。画像ファイルでない場合には-1をリターン。
LastSavedFileName | アップロードされてサーバに保存されたファイルの名前(パスを除く)値を有する。
LastSavedFilePath | アップロードされてサーバに保存されたファイルのフルパス値を有する。
MaxFileLen | アップロード可能な最大のファイルサイズを制限するために使用する(単位: Byte)。指定されたサイズよりも大容量のファイルをアップロードする場合にエラーが生じる。デフォルトの値は、’制限なし’である。
MimeType | アップロードされたファイルのMimeType値を表示。
TotalLen | アップロードされたファイルの全体の長さ値を有する。(例:マルチファイルのアップロード時)
TempFilePath | SaveやSaveAsなどによりファイルが保存される前に存在する一時ファイルの置き場所。DEXT.ImageProcオブジェクトで使用される便利な機能。
UploadTimeout | アップロードのタイムアウト値を指定するために使用する(単位: 秒)。デフォルトの値は3600秒(60分)である。
ResumeFileName | アップロードの中やアップロードされる大容量ファイルの名をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeDirPath | アップロードの中やアップロードされる大容量ファイルの一時保存位置をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeFilePath | アップロードされる大容量ファイルの原本を保存する位置をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeFileSize | アップロードの中やアップロードされる大容量ファイルの全体サイズをリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeMode | DEXTUpload Pro Extensionの現在状態をリターンする。(DEXTUpload Pro Extension 製品に該当)

メソッド

名前 | 説明
DeleteAllSavedFiles | アップロードによりサーバに保存された全てのファイルを削除する。
DeleteFile | サーバに存在するファイルを削除する。
FileExists | 特定のファイルの存否をチェックする。
Flush | どんなファイル(一時ファイルを含む)もサーバーに保存せず、ウェブブラウザから送られてくる全てのデータを無視してフラッシュする。
FolderExists | 特定のフォルダの存否をチェックする。
IsFileItem | 選択されたフォームデータの種類がファイルであるかどうかをチェックする。ファイルであれば、TRUEを返す。
IsImageItem | 選択されたフォームデータの種類がイメージファイルであるかどうかをチェックする。イメージファイルであれば、TRUEを返す。
Save | アップロードされたファイルを元のファイル名と同じ名前でデフォルトのパスまたは指定されたパスに保存する。
SaveVirtual | アップロードされたファイルを元のファイル名と同じ名前で指定したバーチャルパスに保存する。
SaveAs | アップロードされたファイルに名前をつけて指定したパスに保存する。
SaveAsVirtual | アップロードされたファイルに名前をつけて指定したバーチャルパスに保存する。
SaveAsBlob | アップロードされたファイルをDatabaseのBLOBフィールドに保存する。
SetProgress | DEXT.ProgressオブジェクトのGetProgressIDメソッドが渡した値を設定する。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


FileUploadオブジェクトのプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileUploadオブジェクトのプロパティ

プロパティ

名前 | 説明
AutoMakeFolder | TRUEに設定しておくと、DefaultPathやSaveAsなどのメソッド実行時に指定したフォルダが存在しない場合、フォルダを自動的に生成してくれる。
CheckMaxFileLen | MaxFileLen に設定した最大ファイルの用量に対する超過可否
CodePage | アップロードコンポーネントの、内部的にデータを処理するときに使用する CodePageを指定する。
DefaultPath | 一時ファイル及びアップロードされたファイルを保存するデフォルトのパス値を指定するために使用する。
FileLen | アップロードされたファイルの長さ値を有する(単一ファイル)。
FileName | アップロードされたファイルの名前(パスを除く)値を有する。
FileNameWithoutExt | アップロードされたファイルの名前(拡張子を除く)値を有する。
FileExtension | アップロードされたファイルの拡張子値を有する。
FilePath | アップロードされたファイルのフルパス値を有する。
Form | Submitされたフォームの各項目情報を保存しているFormItems Collectionオブジェクト
ImageFormat | アップロードされた画像ファイル(BMP,EMF,EXIF,GIF,Icon,JPEG,PNG,TIFF,WMF)のフォーマットをリターン。
ImageWidth | アップロードされた画像ファイルの幅をリターン。画像ファイルでない場合には-1をリターン。
ImageHeight | アップロードされた画像ファイルの高さをリターン。画像ファイルでない場合には-1をリターン。
LastSavedFileName | アップロードされてサーバに保存されたファイルの名前(パスを除く)値を有する。
LastSavedFilePath | アップロードされてサーバに保存されたファイルのフルパス値を有する。
MaxFileLen | アップロード可能な最大のファイルサイズを制限するために使用する(単位: Byte)。指定されたサイズよりも大容量のファイルをアップロードする場合にエラーが生じる。デフォルトの値は、’制限なし’である。
MimeType | アップロードされたファイルのMimeType値を表示。
TotalLen | アップロードされたファイルの全体の長さ値を有する。(例:マルチファイルのアップロード時)
TempFilePath | SaveやSaveAsなどによりファイルが保存される前に存在する一時ファイルの置き場所。DEXT.ImageProcオブジェクトで使用される便利な機能。
UploadTimeout | アップロードのタイムアウト値を指定するために使用する(単位: 秒)。デフォルトの値は3600秒(60分)である。
ResumeFileName | アップロードの中やアップロードされる大容量ファイルの名をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeDirPath | アップロードの中やアップロードされる大容量ファイルの一時保存位置をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeFilePath | アップロードされる大容量ファイルの原本を保存する位置をリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeFileSize | アップロードの中やアップロードされる大容量ファイルの全体サイズをリターンする。(DEXTUpload Pro Extension 製品に該当)
ResumeMode | DEXTUpload Pro Extensionの現在状態をリターンする。(DEXTUpload Pro Extension 製品に該当)

Copyright ⓒ DEVPIA Corporation. All rights reserved.


AutoMakerFolderプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ AutoMakerFolderプロパティ

形式
[Boolean = ] Object.AutoMakerFolder

型
Boolean – フォルダの自動生成の有無

解説
Trueに設定しておくと、DefaultPathやSave( )などのメソッド実行時に指定したフォルダが存在しない場合、フォルダを自動的に生成する。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.AutoMakerFolder = True
uploadform.DefaultPath = "C:\TEMP"
uploadform.Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ CheckMaxFileLenプロパティ

形式
[Boolean = ] Object.CheckMaxFileLen

戻り値
Boolean - クライアント連結設定の有無

説明
Trueで設定すればアップロードするファイルの大きさが TotalLen プロパティーに設定した最大ファイルのサイズ大きい場合

データ送信を受ける前にクライアントとの連結を強制で切る。( エラーメッセージ : HTTP/1.1 400 Bad Request 発生)

Falseで設定すれば TotalLen プロパティーに設定されたプロパティーをそのまま維持する。

例題

<%

Set uploadform = Server.CreateObject("DEXT.FileUpload")

uploadform.DefaultPath = "D:\Upload"

uploadform.CheckMaxFileLen = True

uploadform.TotalLen = 50*1024*1024 '50MB

uploadform.Save

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


CodePageプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ CodePageプロパティ

形式
[Long = ] Object.CodePage

返り値
Long - コードページ値

解説
アップロードコンポーネントの、内部的にデータを処理するときに使用するCodePageを指定する。
外国語やユニコードセットを用いるウェブページでは、必ずそのページで使われる文字セットに対応するコードページ値をアップロードコンポーネントのCodePage値に指定しなければならない。
デフォルトの値は、システムに設定されたデフォルトのコードページ値となっている。
但し、ASPコードで明示的にSession.CodePage値を指定した場合にはその値がデフォルトの値となるため、この場合にはCodePageのプロパティ値の指定を省略しても良い。

使用例

<%
Session.CodePage = "65001"
%>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.CodePage = 65001
...
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


DefaultPathプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ DefaultPathプロパティ

形式
Object.DefaultPath

解説
一時ファイル及びアップロードされたファイルを保存するデフォルトのパス値を指定するために使用する。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLenプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileLenプロパティ

形式
[Long = ] Object.FileLen

返り値
Long (ReadOnly)

解説
アップロードされたファイルの長さ値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
filelength = uploadform.FileLen ' the same expression
filelength = uploadform("file1").FileLen ' the same expression
filelength2= uploadform("file2").FileLen
Response.Write filelength & " KB"
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileNameプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileNameプロパティ

形式
[String = ] Object.FileName

返り値
String (ReadOnly)

解説
アップロードされたファイル名(パスを除く)の値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
filename = uploadform.FileName 'the same expression
filename = uploadform("file1").FileName 'the same expression
filename2= uploadform("file2").FileName
Response.Write filename '(Ex)Result: sample.zip
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileNameWithoutExtプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileNameWithoutExtプロパティ

形式
[String = ] Object.FileNameWithoutExt

返り値
String (ReadOnly)

解説
アップロードされたファイル名(拡張子を除く)の値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
filename = uploadform.FileNameWithoutExt 'the same expression
filename = uploadform("file1").FileNameWithoutExt 'the same expression
filename2= uploadform("file2").FileNameWithoutExt
Response.Write filename '(Ex)Result: sample
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileExtensionプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileExtensionプロパティ

形式
[String = ] Object.FileExtension

返り値
String (ReadOnly)

解説
アップロードされたファイルの拡張子の値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
filename = uploadform.FileExtension 'the same expression
filename = uploadform("file1").FileExtension 'the same expression
filename2= uploadform("file2"). FileExtension
Response.Write filename '(Ex)Result: zip
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FilePathプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FilePathプロパティ

形式
[String = ] Object.FilePath

返り値
String (ReadOnly)

解説
アップロードされたファイルのフルパスの値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
filepath = uploadform.FilePath 'the same expression
filepath = uploadform("file1").FilePath 'the same expression
filepath2= uploadform("file2").FilePath
Response.Write filepath '(Ex)Result: sample.zip
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


Formプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Formプロパティ

形式
[Object = ] Object.Form

返り値
Object (ReadOnly / Default Property)

解説
Submitされたフォームの各項目の情報が保存されているFormItems Collectionオブジェクト

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\Upload"
title = uploadform.Form.Item("title").Value 'the same expression
title = uploadform.Form("title").Value 'the same expression
title = uploadform("title").Value 'the same expression
title = uploadform("title") 'the same expression
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ImageFormatプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageFormatプロパティ

形式
[String = ] Object.ImageFormat

返り値
String (ReadOnly)

解説
アップロードされた画像ファイル(BMP/EMF/EXIF/GIF/Icon/JPEG/PNG/TIFF/WMF)のフォーマットをリターン。画像ファイルでない場合にはNullをリターン。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
imageformat = uploadform.ImageFormat
imageformat = uploadform("file1").ImageFormat 'the same expression
imageformat2= uploadform("file2").ImageFormat
Response.Write imageformat
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ImageWidthプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageWidthプロパティ

形式
[Long = ] Object.ImageWidth

返り値
Long (ReadOnly)

解説
アップロードされた画像ファイル(BMP/GIF/JPG )の幅をリターン。画像ファイルでない場合には-1をリターンする。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
imagewidth = uploadform.ImageWidth
imagewidth = uploadform("file1").ImageWidth 'the same expression
imagewidth2= uploadform("file2").ImageWidth
Response.Write imagewidth
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ImageHeightプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageHeightプロパティ

形式
[Long = ] Object.ImageHeight

返り値
Long (ReadOnly)

解説
アップロードされた画像ファイル(BMP/GIF/JPG)の高さをリターン。画像ファイルでない場合には-1をリターンする。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
ImageHeight = uploadform.ImageHeight
ImageHeight = uploadform("file1").ImageHeight 'the same expression
imagewidth2= uploadform("file2").ImageHeight
Response.Write ImageHeight
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


LastSavedFileNameプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ LastSavedFileNameプロパティ

形式
[String = ] Object.LastSavedFileName

返り値
String (ReadOnly)

解説
アップロードされてサーバーに保存されたファイルのフルパス値を表示。
アップロードした一つのファイルにSave( )を数回実行し、それぞれ別の名前で保存した場合には、一番最後に保存されたファイル名を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\TEMP"
OrgFileName = uploadform("file1").FileName

uploadform("file1").SaveAs("D:\Upload1\" & OrgFileName , False)
Response.Write "Original FileName: " & uploadform("file1").FileName & "<BR>"
Response.Write "Uploaded FileName1: " & uploadform("file1").LastSavedFileName & "<BR>"

uploadform("file1").SaveAs("F:\Upload2\" & OrgFileName , False)
Response.Write "Original FileName: " & uploadform("file1").FileName & "<BR>"
Response.Write "Uploaded FileName2: " & uploadform("file1").LastSavedFileName & "<BR>"

Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


LastSavedFilePathプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ LastSavedFilePathプロパティ

形式
[String = ] Object.LastSavedFilePath

返り値
String (ReadOnly)

解説
アップロードされてサーバに保存されたファイルのフルパス値を表示。
アップロードした一つのファイルにSave( )を数回実行し、それぞれ別の名前で保存した場合、一番最後に保存したファイル名を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\TEMP"
OrgFileName = uploadform("file1").FileName

uploadform("file1").SaveAs("D:\Upload1\" & OrgFileName , False)
Response.Write "Original FilePath: " & uploadform("file1").FilePath & "<BR>"
Response.Write "Uploaded FilePath1: " & uploadform("file1").LastSavedFilePath & "<BR>"

uploadform("file1").SaveAs("F:\Upload2\" & OrgFileName , False)
Response.Write "Original FilePath: " & uploadform("file1").FilePath & "<BR>"
Response.Write "Uploaded FilePath2: " & uploadform("file1").LastSavedFilePath & "<BR>"

Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


MaxFileLenプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ MaxFileLenプロパティ

形式
[Long = ] Object.MaxFileLen

返り値
Long

解説
アップロード可能な最大のファイルサイズを指定するために使用。(単位: Byte)
指定されたサイズよりも大きなファイルをアップロードしようとするとエラーが発生する。
デフォルト値は'制限なし'である。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\Upload"
uploadform.MaxFileLen = 5242880
uploadform.Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


MimeTypeプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ MimeTypeプロパティ

形式
[String = ] Object.MimeType

返り値
String (ReadOnly)

解説
アップロードされたファイルのMimeType値を表示。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\Upload"
mimetype = uploadform.MimeType ' the same expression
mimetype = uploadform("file1").MimeType ' the same expression
mimetype2= uploadform("file2").MimeType
Response.Write mimetype ' Result: image/pjpeg
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ResumeDirPath プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

形式
[String = ] Object.ResumeDirPath

戻り値
String (ReadOnly)

説明
アップロードの中やアップロードされる大容量ファイルの一時保存位置をリターンする。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXTEx.FileUpload")

uploadform.AutoMakeFolder = TRUE

uploadform.DefaultPath="C:\TEMP"

Dim ResponseData

'------------------------------------------------------------------------------------------------------'

'----------------------------------------- 注意点 ---------------------------------------------------'

' 下のアップロードモードの(uploadform.ResumeMode) 場合は大容量/続けてアップロードのために必ず必要な部分です。

' 修正や削除する場合大容量/続けてアップロード機能にできないかも知れないです。

'

' - uploadform.ResumeMode = "configurefileinfo"

' - uploadform.ResumeMode = "attachfile"

'------------------------------------------------------------------------------------------------------'

if uploadform.ResumeMode = "configurefileinfo" or uploadform.ResumeMode = "attachfile" then

Response.Write "FileSize=" & uploadform.ResumeFileSize & ";"

Response.Write "FileName=" & uploadform.ResumeFileName & ";"

Response.Write "ResumeDirPath=" & uploadform.ResumeDirPath & ";"

'------------------------------------------------------------------------------------------------------'

'----------------------------- 大容量/続けてアップロードモード時のファイル保存 ----------------------------------'

' uploadform.ResumeMode = "done"の場合、大容量/続けてアップロードが完了した状態です。

'(一回の連結に一つのファイル処理)

'

' クライアントでトークンリングができるように必要な情報を適切に構成して送ってください。

' 下の使用例は基本的な情報を構成した一つの使用例です。

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

'------------------------------------------------------------------------------------------------------'

elseif uploadform.ResumeMode = "done" then

uploadform("DextuploadX").Save "C:\TEMP",False

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX").FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFilePath

Response.Write ResponseData

' 大容量/続けてアップロードモードではない一般アップロードの場合、ファイル保存

'(DEXTUploadXEx 製品の "EnableLargeUpload" プロパティーの値段が FALSEの場合)

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

else

For i = 1 To uploadform("DextuploadX").count

uploadform("DextuploadX")(i).save

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFilePath

Next

Response.Write ResponseData

end if

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ResumeFileName プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

形式
[String = ] Object.ResumeFileName

戻り値
String (ReadOnly)

説明
アップロードの中やアップロードする大容量ファイルの名前をリターンする。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXTEx.FileUpload")

uploadform.AutoMakeFolder = TRUE

uploadform.DefaultPath="C:\TEMP"

Dim ResponseData

'------------------------------------------------------------------------------------------------------'

'----------------------------------------- 注意点 ---------------------------------------------------'

' 下のアップロードモードの(uploadform.ResumeMode) 場合は大容量/続けてアップロードのために必ず必要な部分です。

' 修正や削除する場合大容量/続けてアップロード機能にできないかも知れないです。

'

' - uploadform.ResumeMode = "configurefileinfo"

' - uploadform.ResumeMode = "attachfile"

'------------------------------------------------------------------------------------------------------'

if uploadform.ResumeMode = "configurefileinfo" or uploadform.ResumeMode = "attachfile" then

Response.Write "FileSize=" & uploadform.ResumeFileSize & ";"

Response.Write "FileName=" & uploadform.ResumeFileName & ";"

Response.Write "ResumeDirPath=" & uploadform.ResumeDirPath & ";"

'------------------------------------------------------------------------------------------------------'

'----------------------------- 大容量/続けてアップロードモード時のファイル保存 ----------------------------------'

' uploadform.ResumeMode = "done"の場合、大容量/続けてアップロードが完了した状態です。

'(一回の連結に一つのファイル処理)

'

' クライアントでトークンリングができるように必要な情報を適切に構成して送ってください。

' 下の使用例は基本的な情報を構成した一つの使用例です。

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

'------------------------------------------------------------------------------------------------------'

elseif uploadform.ResumeMode = "done" then

uploadform("DextuploadX").Save "C:\TEMP",False

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX").FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFilePath

Response.Write ResponseData

' 大容量/続けてアップロードモードではない一般アップロードの場合、ファイル保存

'(DEXTUploadXEx 製品の "EnableLargeUpload" プロパティーの値段が FALSEの場合)

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

else

For i = 1 To uploadform("DextuploadX").count

uploadform("DextuploadX")(i).save

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFilePath

Next

Response.Write ResponseData

end if

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ResumeFilePath プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

形式
[String = ] Object.ResumeFilePath

戻り値
String (ReadOnly)

説明
アップロードする大容量ファイルの原本保存位置をリターンする。

(ResumeFileSize,ResumeFileName,ResumeDirPath プロパティーとは違うように大容量/続けてアップロード時、省略可能.)

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXTEx.FileUpload")

uploadform.AutoMakeFolder = TRUE

uploadform.DefaultPath="C:\TEMP"

Dim ResponseData

'------------------------------------------------------------------------------------------------------'

'----------------------------------------- 注意点 ---------------------------------------------------'

' 下のアップロードモードの(uploadform.ResumeMode) 場合は大容量/続けてアップロードのために必ず必要な部分です。

' 修正や削除する場合大容量/続けてアップロード機能にできないかも知れないです。

'

' - uploadform.ResumeMode = "configurefileinfo"

' - uploadform.ResumeMode = "attachfile"

'------------------------------------------------------------------------------------------------------'

if uploadform.ResumeMode = "configurefileinfo" or uploadform.ResumeMode = "attachfile" then

Response.Write "FileSize=" & uploadform.ResumeFileSize & ";"

Response.Write "FileName=" & uploadform.ResumeFileName & ";"

Response.Write "ResumeDirPath=" & uploadform.ResumeDirPath & ";"

' Response.Write "ResumeFilePath=" & uploadform.ResumeFilePath & ";"

'------------------------------------------------------------------------------------------------------'

'----------------------------- 大容量/続けてアップロードモード時のファイル保存 ----------------------------------'

' uploadform.ResumeMode = "done"の場合、大容量/続けてアップロードが完了した状態です。

'(一回の連結に一つのファイル処理)

'

' クライアントでトークンリングができるように必要な情報を適切に構成して送ってください。

' 下の使用例は基本的な情報を構成した一つの使用例です。

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

'------------------------------------------------------------------------------------------------------'

elseif uploadform.ResumeMode = "done" then

uploadform("DextuploadX").Save "C:\TEMP",False

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX").FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFilePath

Response.Write ResponseData

' 大容量/続けてアップロードモードではない一般アップロードの場合、ファイル保存

'(DEXTUploadXEx 製品の "EnableLargeUpload" プロパティーの値段が FALSEの場合)

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

else

For i = 1 To uploadform("DextuploadX").count

uploadform("DextuploadX")(i).save

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFilePath

Next

Response.Write ResponseData

end if

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ResumeFileSize プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

形式
[String = ] Object.ResumeFileSize

戻り値
String (ReadOnly)

説明
アップロードの中やアップロードになる大容量ファイルの全体サイズをリターンする。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXTEx.FileUpload")

uploadform.AutoMakeFolder = TRUE

uploadform.DefaultPath="C:\TEMP"

Dim ResponseData

'------------------------------------------------------------------------------------------------------'

'----------------------------------------- 注意点 ---------------------------------------------------'

' 下のアップロードモードの(uploadform.ResumeMode) 場合は大容量/続けてアップロードのために必ず必要な部分です。

' 修正や削除する場合大容量/続けてアップロード機能にできないかも知れないです。

'

' - uploadform.ResumeMode = "configurefileinfo"

' - uploadform.ResumeMode = "attachfile"

'------------------------------------------------------------------------------------------------------'

if uploadform.ResumeMode = "configurefileinfo" or uploadform.ResumeMode = "attachfile" then

Response.Write "FileSize=" & uploadform.ResumeFileSize & ";"

Response.Write "FileName=" & uploadform.ResumeFileName & ";"

Response.Write "ResumeDirPath=" & uploadform.ResumeDirPath & ";"

'------------------------------------------------------------------------------------------------------'

'----------------------------- 大容量/続けてアップロードモード時のファイル保存 ----------------------------------'

' uploadform.ResumeMode = "done"の場合、大容量/続けてアップロードが完了した状態です。

'(一回の連結に一つのファイル処理)

'

' クライアントでトークンリングができるように必要な情報を適切に構成して送ってください。

' 下の使用例は基本的な情報を構成した一つの使用例です。

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

'------------------------------------------------------------------------------------------------------'

elseif uploadform.ResumeMode = "done" then

uploadform("DextuploadX").Save "C:\TEMP",False

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX").FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFilePath

Response.Write ResponseData

' 大容量/続けてアップロードモードではない一般アップロードの場合、ファイル保存

'(DEXTUploadXEx 製品の "EnableLargeUpload" プロパティーの値段が FALSEの場合)

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

else

For i = 1 To uploadform("DextuploadX").count

uploadform("DextuploadX")(i).save

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFilePath

Next

Response.Write ResponseData

end if

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ResumeMode プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

形式
[String = ] Object.ResumeMode

戻り値
String (ReadOnly)

戻り値リスト
configurefileinfo : 実際大容量ファイルを送る前に送るファイルの名前とサイズ,保存経路を受ける。

attachfile : 大容量ファイルを送信受けている中であるという状態を表す。

done : 大容量ファイルの送信完了を表してこの状態の場合、Save 関数を呼び出して大容量ファイルを願う経路で保存する。

説明
DEXTUpload Pro Exの現在状態をリターンする。これを参照でアップロードした大容量ファイルの状態情報や処理可否を決める。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXTEx.FileUpload")

uploadform.AutoMakeFolder = TRUE

uploadform.DefaultPath="C:\TEMP"

Dim ResponseData

'------------------------------------------------------------------------------------------------------'

'----------------------------------------- 注意点 ---------------------------------------------------'

' 下のアップロードモードの(uploadform.ResumeMode) 場合は大容量/続けてアップロードのために必ず必要な部分です。

' 修正や削除する場合大容量/続けてアップロード機能にできないかも知れないです。

'

' - uploadform.ResumeMode = "configurefileinfo"

' - uploadform.ResumeMode = "attachfile"

'------------------------------------------------------------------------------------------------------'

if uploadform.ResumeMode = "configurefileinfo" or uploadform.ResumeMode = "attachfile" then

Response.Write "FileSize=" & uploadform.ResumeFileSize & ";"

Response.Write "FileName=" & uploadform.ResumeFileName & ";"

Response.Write "ResumeDirPath=" & uploadform.ResumeDirPath & ";"

'------------------------------------------------------------------------------------------------------'

'----------------------------- 大容量/続けてアップロードモード時のファイル保存 ----------------------------------'

' uploadform.ResumeMode = "done"の場合、大容量/続けてアップロードが完了した状態です。

'(一回の連結に一つのファイル処理)

'

' クライアントでトークンリングができるように必要な情報を適切に構成して送ってください。

' 下の使用例は基本的な情報を構成した一つの使用例です。

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

'------------------------------------------------------------------------------------------------------'

elseif uploadform.ResumeMode = "done" then

uploadform("DextuploadX").Save "C:\TEMP",False

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX").FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX").LastSavedFilePath

Response.Write ResponseData

' 大容量/続けてアップロードモードではない一般アップロードの場合、ファイル保存

' (DEXTUploadXEx 製品の "EnableLargeUpload" プロパティーの値段が FALSEの場合)

' アップロードされた結果を現在ページで処理する場合、クライアントでデータを送らなくても関係ないです。

else

For i = 1 To uploadform("DextuploadX").count

uploadform("DextuploadX")(i).save

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFileName

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).FileLen

ResponseData = ResponseData & "||" & uploadform("DextuploadX")(i).LastSavedFilePath

Next

Response.Write ResponseData

end if

Set uploadform = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


TempFilePathプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ TempFilePathプロパティ

形式
[Long = ] Object.TempFilePath

返り値
Long (ReadOnly)

解説
Save、SaveAsなどのメソッドによりファイルが保存される前に存在する一時ファイルの置き場所。DEXT.ImageProcオブジェクトで使用される便利な機能。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.Save
Response.Write uploadform.TempFilePath
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


TotalLenプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ TotalLenプロパティ

形式
[Long = ] Object.TotalLen

返り値
Long

解説
アップロード可能なフォームデータの長さを制限する時使います。(単位：Byte)

指定だれたサイズより大きなフォームデータを要求する時、エラーが発生します。

デフォルトが2GBです。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.TotalLen = 50*1024*1024 '50MB
uploadform.Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


UploadTimeoutプロパティ

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ UploadTimeoutプロパティ

形式
[Long = ] Object.UploadTimeout

返り値
Long

解説
アップロードのタイムアウト値を指定するために使用。 (単位: 秒)
指定された時間を超えるとタイムアウトエラーが発生する。
コンポーネントの外部で設定されたServer.ScriptTimeoutやSession.Timeoutの値は無視される。
デフォルト値は、3600秒(60分)である。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.UploadTimeout = 1200
uploadform.Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadオブジェクトメソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileUploadオブジェクトメソッド

メソッド

名前 | 説明
DeleteAllSavedFiles | アップロードによりサーバに保存された全てのファイルを削除する。
DeleteFile | サーバに存在するファイルを削除する。
FileExists | 特定のファイルの存否をチェックする。
Flush | どんなファイル(一時ファイルを含む)もサーバーに保存せず、ウェブブラウザから送られてくる全てのデータを無視してフラッシュする。
FolderExists | 特定のフォルダの存否をチェックする。
IsFileItem | 選択されたフォームデータの種類がファイルであるかどうかをチェックする。ファイルであれば、TRUEを返す。
IsImageItem | 選択されたフォームデータの種類がイメージファイルであるかどうかをチェックする。イメージファイルであれば、TRUEを返す。
Save | アップロードされたファイルを元のファイル名と同じ名前でデフォルトのパスまたは指定されたパスに保存する。
SaveVirtual | アップロードされたファイルを元のファイル名と同じ名前で指定したバーチャルパスに保存する。
SaveAs | アップロードされたファイルに名前をつけて指定したパスに保存する。
SaveAsVirtual | アップロードされたファイルに名前をつけて指定したバーチャルパスに保存する。
SaveAsBlob | アップロードされたファイルをDatabaseのBLOBフィールドに保存する。
SetProgress | DEXT.ProgressオブジェクトのGetProgressIDメソッドが渡した値を設定する。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


DeleteAllSavedFiles( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ DeleteAllSavedFiles( )メソッド

形式
[Long = ] Object.DeleteAllSavedFiles

返り値
Long - 削除されたファイルの数

解説
アップロードによりサーバーに保存された全てのファイルを削除。
主に、コンポーネントの外部でエラーが生じ、アップロード作業を中断してサーバーに残っている不要なファイルを削除したい場合に使用する。
(コンポーネントの内部でエラーが生じた場合には自動的に呼び出される。)

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
...
'コンポーネント外部のASPコードでエラーが生じた場合
uploadform.DeleteAllSavedFiles
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


DeleteFile( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ DeleteFile( )メソッド

形式
[Boolean = ] Object.DeleteFile( strFilename )

返り値
Boolean - 正常にファイルを削除した場合にはTrue、ファイルの不在により削除できなかった場合にはFalseをリターン。

パラメータ
strFilename As String - 削除するファイルのフルパス(物理パスのみ削除可)

解説
サーバーにアップロードされたファイル又はサーバーに存在するファイルを削除。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
UploadedFile1 = uploadform("file1").Save
UploadedFile2 = uploadform("file2").Save
...
'If you want to delete the first file
uploadform.DeleteFile(UploadedFile1)
...
Set uploadform = Nothing
%>
<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
UploadedFile1 = uploadform("file1").Save
UploadedFile2 = uploadform("file2").Save
...
'If you want to delete the first
file uploadform.DeleteFile(UploadedFile1)
...
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileExists( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileExists( )メソッド

形式
[Boolean = ] Object.FileExists( strFilename )

返り値
Boolean – ファイルが存在すればTrue、しなければFalseをリターン。

パラメータ
strFilename As String – ファイルが存在するかどうかをチェックしたいファイルのフルパス (物理パスのみ可能である。)

解説
特定のファイルが存在するかをチェックする。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
If uploadform.FileExists("C:\TEMP\sample.zip") Then
Response.Write "File exists : Sample.zip<br>"
Else
Response.Write "File not exists : Sample.zip<br>"
End If
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


Flush( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Flush( )メソッド

形式
Object.Flush()

解説
どんなファイル(一時ファイルを含む)もサーバーに保存せず、ウェブブラウザーから送られてくるすべてのデータを無視してフラッシュする。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\TEMP"
If Request.TotalBytes > 1048576 Then
uploadform.Flush
Response.Write "Warning: File size must be less than 1 MBytes."
Else
uploadform.Save
Response.Write "File-upload completed."
End If
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FolderExists( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FolderExists( )メソッド

形式
[Boolean = ] Object.FolderExists( strFilename )

返り値
Boolean - フォルダが存在すればTrue、しなければFalseをリターン。

パラメータ
strFilename As String – 存在するかをチェックするフォルダのフルパス (物理パスのみ可能である。)

解説
特定フォルダが存在するかをチェックする。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
If uploadform.FolderExists("C:\TEMP") Then
Response.Write "Folder exists : C:\TEMP<br>"
Else
Response.Write "Folder not exists :C:\TEMP<br>"
End If
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


IsFileItem( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ IsFileItem( )メソッド

形式
[Bool = ] Object.IsFileItem( )

返り値
Bool – ファイルアイテムであればTrue。それ以外はFalse。

解説
指定されたフォームデータの種類がファイルアイテムかどうかを確認するメソッド。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
if uploadform("file1").IsFileItem then
response.Write “これは、ファイルアイテムです。”
End if

Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


IsImageItem( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ IsImageItem( )メソッド

形式
[Bool = ] Object.IsImageItem( )

返り値
Bool – 画像ファイルアイテムであればTrue、それ以外はFalseでリターン

解説
指定されたフォームデータの種類が画像ファイルアイテムであるかどうかを確認するメソッド。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
if uploadform("file1").IsImageItem then
response.Write “これは、イメージファイルアイテムです。”
End if

Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


Save( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Save( )メソッド

形式
[String = ] Object.Save( [strPath], [bOverwrite] )

返り値
String - 実際にサーバに保存されたファイル名

パラメータ
strPath As String (Optional) – アップロードされたファイルを保存する経路。略する場合 DefaultPath Propertyが示す経路に保存される。
bOverwrite As Boolean (Optional) - 同じ名前のファイルが既に存在する場合 Overwrite 有無を指定する。デフォルトTrueで、Falseと指定する場合 filename(2).ext,filename(3).ext などのように唯一のファイル名を求めて保存するようになる。

解説
アップロードされたファイルを元のファイル名と等しい名前でデフォルト経路または指定した経路に保存する。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み。)から多重 Save可能。
DEXTUpload Professional プログラミング - ファイルアップロード基本 - ‘多重 Save アップロード’ 参照.(一つのファイルを多くの経路に保存)
注意事項 : 多重 Save時に大容量のファイルをアップロードする場合、すべての Saveの完了するまでアップロードが完了しない。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.Save
uploadform("file1").Save ' the same expression
uploadform("file2").Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveVirtual( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveVirtual( )メソッド

形式
[String = ] Object.SaveVirtual( [strVirtualPath], [bOverwrite] )

返り値
String - 実際にサーバに保存されたファイル名

パラメータ
strVirtualPath As String – アップロードされたファイルを保存するバーチャルパスのファイル名
bOverwrite As Boolean (Optional) - 同じ名前のファイルが既に存在する場合 Overwrite 有無を指定する。デフォルトTrueで、Falseと指定する場合 filename(2).ext,filename(3).ext などのように唯一のファイル名を求めて保存するようになる。

解説
アップロードされたファイルを元のファイル名と同じ名前で指定したバーチャルパスに保存する。

参照
Save(　)メソッドがバーチャルパスに対応しているためにそれ以上使用しないが、下位の互換性のために存在する。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み。)から多重 Save可能。
DEXTUpload Professional プログラミング - ファイルアップロード基本 - ‘多重 Save アップロード’ 参照.(一つのファイルを多くの経路に保存)
注意事項 : 多重 Save時に大容量のファイルをアップロードする場合、すべての Saveの完了するまでアップロードが完了しない。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.SaveVirtual "/virtualloc/"
uploadform("file1").SaveVirtual "/virtualloc/" ' the same expression
uploadform("file2").SaveVirtual "/virtualloc/"
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAs( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAs( )メソッド

形式
[String = ] Object.SaveAs( [strNewFileName], [bOverwrite] )

返り値
String - 実際にサーバに保存されたファイル名

パラメータ
strNewFilename As String - アップロード後に名前を付けて保存するファイル名(Full Path)
bOverwrite As Boolean (Optional) - 同じ名前のファイルが既に存在する場合 Overwrite 有無を指定する。デフォルトTrueで、Falseと指定する場合 filename(2).ext,filename(3).ext などのように唯一のファイル名を求めて保存するようになる。

解説
アップロードされたファイルに名前を付けて指定パスに保存する。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み。)から多重 Save可能。
DEXTUpload Professional プログラミング - ファイルアップロード基本 - ‘多重 Save アップロード’ 参照.(一つのファイルを多くの経路に保存)
注意事項 : 多重 Save時に大容量のファイルをアップロードする場合、すべての Saveの完了するまでアップロードが完了しない。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.SaveAs "C:\Upload\newfile.zip"
uploadform("file1").SaveAs "C:\Upload\newfile.zip" ' the same expression
uploadform("file2").SaveAs "C:\Upload\newfile2.zip"
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsVirtual( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAsVirtual( )メソッド

形式
[String = ] Object.SaveAsVirtual( strNewFilename, [bOverwrite=TRUE] )

返り値
String - 実際にサーバーに保存されたファイル名

パラメータ
strNewFilename As String – アップロードされたファイルを保存するバーチャルパスのファイル名
bOverwrite As Boolean (Optional) - 同じ名前のファイルが既に存在する場合 Overwrite 有無を指定する。デフォルトTrueで、Falseと指定する場合 filename(2).ext,filename(3).ext などのように唯一のファイル名を求めて保存するようになる。

解説
アップロードされたファイルに名前を付けて、指定したバーチャルパスに保存する。

参照
SaveAs(　)メソッドがバーチャルパスに対応しているためにそれ以上使用しないが、下位の互換性のために存在する。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み。)から多重 Save可能。
DEXTUpload Professional プログラミング - ファイルアップロード基本 - ‘多重 Save アップロード’ 参照.(一つのファイルを多くの経路に保存)
注意事項 : 多重 Save時に大容量のファイルをアップロードする場合、すべての Saveの完了するまでアップロードが完了しない。

使用例

<%
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "C:\TEMP"
uploadform.SaveAsVirtual "/virtualloc/newfile.zip"
uploadform("file1").SaveAsVirtual "/virtualloc/newfile.zip" 'the same expression uploadform("file2").SaveAsVirtual("/virtualloc/newfile.zip")
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsBlob( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAsBlob( )メソッド

形式
Object.SaveAsBlob( dbField )

パラメータ
dbField As ADODB.Field – アップロードされたファイルを保存するDatabaseのBLOBフィールド

解説
アップロードされたファイルをDatabaseのBLOBフィールドに保存する。

*3.3.0 以上のバージョン(DEXTUpload Pro Extension含み。)から多重 Save可能。
DEXTUpload Professional プログラミング - ファイルアップロード基本 - ‘多重 Save アップロード’ 参照.(一つのファイルを多くの経路に保存)
注意事項 : 多重 Save時に大容量のファイルをアップロードする場合、すべての Saveの完了するまでアップロードが完了しない。

使用例

<%
...
Set uploadform = Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath = "D:\TEMP"
Set rs = Server.CreateObject("ADODB.Recordset")
rs.Open strQuery, cn, 3,3
rs.AddNew
uploadform.SaveAsBlob rs("filedata")
uploadform("file1").SaveAsBlob rs("filedata") ' the same expression
uploadform("file2").SaveAsBlob rs("filedata2")
rs.Update
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SetProgress( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SetProgress( )メソッド

形式
Object.SetProgress( ProgressID )

解説
DEXT.ProgressオブジェクトのGetProgressID( )メソッドを使って得たID値を設定し、ユーザー定義型のプログレスバーを実行するメソッド。

使用例

<%
'GetProgressIDで得られたID
ProgID = request.QueryString("ProgressID")
set uploadform=server.CreateObject("DEXT.FileUpload")
'GetProgressIDで得られたIDをこの関数によりセットする
uploadform.SetProgress(ProgID)
uploadform.DefaultPath="C:\Temp"
FileName = uploadform.Save()
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileDownloadオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileDownloadオブジェクト

サーバー上のファイルやデータベースBLOBフィールドに存在するバイナリデータを、ウェブブラウザーを介し、クライアントユーザーのハードディスクにダウンロードする機能を持つオブジェクト

メソッド

名前 | 説明
Download | サーバー上のファイルをウェブブラウザーを通じてクライアントユーザーにダウンロード。
DownloadVirtual | サーバーのバーチャルパスに存在するファイルをウェブブラウザーを通じてクライアントユーザーにダウンロード。
DownloadBlob | Databaseに存在するBLOBデータをウェブブラウザーを通じてクライアントユーザーにダウンロード。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


Download( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Download( )メソッド

形式
Object.Download(bstrFilePath,bstrFileName,bAttach,bResume)

パラメータ
bstrFilePath As String – ダウンロードするフルパス(物理パス、バーチャルパス)
strFileName As String – ダウンロードするファイル名

bAttach As Boolean – ウェブブラウザーがダウンロードを行う際、添付ファイルの処理方法を指定。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するため、ウェブブラウザーは保存ダイアログを出力する。
False | デフォルト値。MIMEフォーマットによりウェブブラウザーの処理方法が異なる。たとえば、MIMEフォーマットがtext/html(HTMLファイル)である場合、ウェブブラウザーが直接ダウンロードの内容を出力して、application/x-zip-compressed(ZIPファイル)である場合には保存ダイアログを出力する。

bResume As Boolean – 続けてダウンロード機能の選択

属性 | 説明
True | ユーザーによるキャンセルまたはネットワーク上の問題により中止されたダウンロードを再開する場合、ダウンロードの切れたデータの続きからダウンロードを開始する。
False | デフォルト値。ダウンロードごとに全てのデータを転送。

解説
サーバー上のファイルをウェブブラウザーを通じてクライアントユーザーにダウンロードする。

使用例

<%@ Language=VBScript %>
<%
filepath = request("filepath")
filename = request("filename")
'ダウンロードオブジェクトの生成
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'ダウンロードobjDownload.Download filepath, ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード)
objDownload.Download filepath, filename, true, false
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


DownloadVirtual( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ DownloadVirtual( )メソッド

形式
Object.DownloadVirtual(bstrFilePath,bstrFileName,bAttach,bResume)

パラメータ
bstrFilePath As String – ダウンロードするフルパス(バーチャルパス)
strFileName As String – ダウンロードするファイル名

bAttach As Boolean – ウェブブラウザーがダウンロードを行う際、添付ファイルの処理方法を指定。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するため、ウェブブラウザーは保存ダイアログを出力する。
False | デフォルト値。MIMEフォーマットによりウェブブラウザーの処理方法が異なる。たとえば、MIMEフォーマットがtext/html(HTMLファイル)である場合、ウェブブラウザーが直接ダウンロードの内容を出力して、application/x-zip-compressed(ZIPファイル)である場合には保存ダイアログを出力する。

bResume As Boolean – 続けてダウンロード機能を支援するか否かを指定する。

属性 | 説明
True | ユーザーによるキャンセルまたはネットワーク上の問題により中止されたダウンロードを再開する場合、ダウンロードの切れたデータの続きからダウンロードを開始する。
False | デフォルト値。ダウンロードごとに全てのデータを転送。

解説
サーバーにあるファイルをウェブブラウザーを通じてクライアントユーザーにダウンロードする。

参考
Download()メソッドがバーチャルパスを支援するためそれ以上使用しないが、下位の互換性のために存在する。

使用例

<%@ Language=VBScript %>
<%
filepath = request("filepath")
filename = request("filename")
'ダウンロードオブジェクトの生成
Set objDownload = Server.CreateObject("DEXT.FileDownload")
'ダウンロードobjDownload.Download filepath, ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード) objDownload.DownloadVirtual filepath, filename, true, false
Set objDownload = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


DownloadBlob( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ DownloadBlob( )メソッド

形式
Object.DownloadBlob(bstrFilePath,bstrFileName,bAttach)

パラメータ
bstrFilePath As String – ダウンロードするフルパス(物理パス)
strFileName As String – ダウンロードするファイル名

bAttach As Boolean – ウェブブラウザーがダウンロードを行う際、添付ファイルの処理方法を指定。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するため、ウェブブラウザーは保存ダイアログを出力する。
False | デフォルト値。MIMEフォーマットによりウェブブラウザーの処理方法が異なる。たとえば、MIMEフォーマットがtext/html(HTMLファイル)である場合、ウェブブラウザーが直接ダウンロードの内容を出力して、application/x-zip-compressed(ZIPファイル)である場合には保存ダイアログを出力する。

bResume As Boolean – 続けてダウンロード機能を支援するか否かを指定する。

属性 | 説明
True | ユーザーによるキャンセルまたはネットワーク上の問題により中止されたダウンロードを再開する場合、ダウンロードの切れたデータの続きからダウンロードを開始する。
False | デフォルト値。ダウンロードごとに全てのデータを転送。

解説
DatabaseにあるBLOBデータをウェブブラウザーを通じてクライアントユーザーにダウンロードする。

参考
BLOBの続けてダウンロードは応対しない。続けてダウンロードはファイル形式で保存されているデータににみ有効。

使用例

<%@ Language=VBScript %>
<%
fileid=request("dblist")
Set rs = Server.CreateObject("ADODB.Recordset")
Conn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("/DEXTUploadProsamples") & "\DEXTUpload.mdb"
sql="SELECT * FROM DEXTUPLOAD WHERE fileid ="&fileid
rs.Open sql, Conn, 3, 1
Set objDownload = Server.CreateObject("DEXT.FileDownload")
objDownload.DownloadBlob rs("filedata"), rs("filename"), true
Set objDownload = Nothing
rs.Close
Set rs = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadMonitorオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FileUploadMonitorオブジェクト

固定型情報表示ウィンドウを介してアップロードの進行状態をチェックできるようにするオブジェクト。

メソッド

名前 | 説明
UseMonitor | アップロードの進行状態のモニターを行うかどうかを指定する。 モニター機能を行いたい場合には必ずSubmitするFormを作成するページ内でUseMonitor(True)を呼び出さなければならない。
ShowMonitor | アップロードの進行状態をプログレスバーに表示。全体のファイル容量、残りのファイル容量、アップロードの速度、残り時間などの情報がリアルタイムで表示される。
SetProgressWindowType | 様々なブラウザに対応しながらアップロードプログレスウィンドウの情報を更新するための関数です。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


UseMonitor( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ UseMonitor()メソッド

形式
Object.UseMonitor( bUse )

パラメータ
bUse As Boolean - True: アップロードの進行状態のモニター機能を使用 / False: 使用しない

解説
アップロードの進行状態のモニターを行うかどうかを指定する。モニター機能を行いたい場合には必ずSubmitするFormを作成するページ内でUseMonitor(True)を呼び出さなければならない。
UseMonitor( )メソッドを呼び出さないか、あるいはUseMonitor(False)を呼び出す場合には、モニター機能を使用しないことと見なされる。

使用例

<%
Set objMon = Server.CreateObject("DEXT.FileUploadMonitor")
objMon.UseMonitor(True)
Set objMon = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ShowMonitor( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ShowMonitor()メソッド

形式
Object.ShowMonitor( )

解説
アップロードの進行状態をプログレスバーで表示。全体のファイル容量、残りのファイル容量、アップロード速度、残り時間などの情報がリアルタイムで表示される。

使用例

<%
Set objMon = Server.CreateObject("DEXT.FileUploadMonitor")
objMon.ShowMonitor
Set objMon = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ShowMonitor( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SetProgressWindowType()メソッド

形式
Object.SetProgressWindowType( [lBrowserType], [lWindowType] )

パラメータ

- lBrowserType As Long : IbrowserType:　ポップアップ関数対応ブラウザ別タイプ情報(デフォルト:0)

0=Only IE([Window.showModelessDialog]、[window.open]関数の同時対応ブラウザ)

1=FireFox、Opera、Chrome、Safariなど([window.open]関数のみ対応のブラウザ)

- lWindowType As Long : スクリプト上でアップロードのプログレス情報ウィンドウをオープンする方式(デフォルト:0)

0 = [window.showModelessDialog]関数の呼び出し時

1 = [window.open]関数の呼び出し時

解説
様々なブラウザに対応しながらアップロードプログレスウィンドウの情報を更新するための関数です。

使用例

<%

Dim BrowserType

BrowserType = Request.ServerVariables("HTTP_USER_AGENT")

Set m_objMon = Server.CreateObject("DEXT.FileUploadMonitor")

If InStr(BrowserType,"MSIE") Then

'クライアントのアップロードプログレス情報ウィンドウをIEで対応するなら最初の因子を0に設定。

'クライアントのアップロードプログレス情報ウィンドウをIE以外のブラウザで対応するなら最初の因子を1に設定。

'クライアントのアップロードプログレス情報ウィンドウをIEブラウザで[window.showModelessDialog]関数で呼び出す場合、二番目の因子は0に設定。

m_objMon.SetProgressWindowType 0, 0

Else

'クライアントのアップロードプログレス情報ウィンドウをIE以外のブラウザで[window.open]関数で呼び出す場合、二番目の因子は1に設定。

m_objMon.SetProgressWindowType 1, 1

End If

m_objMon.ShowMonitor

Set m_objMon = Nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


Progressオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Progressオブジェクト

ユーザー定義型プロセスバーを通じてアップロードの進行状況を表示するオブジェクトである。

プロパティ

名前 | 説明
TotalSize | アップロードするファイルの全体サイズ
TransferSize | 今まで転送したファイルのサイズ
Percent | 今までの転送率
BytesPerSec | 転送速度
FileName | 現在アップロード中のファイル名
Working | TRUEであれば転送中、FALSEであれば転送完了

メソッド

名前 | 説明
SetProgressID | GET方式で伝達された進行状態IDを指定する。
GetProgressID | IDを取得する。今後、FileUploadとProgressで使用。
SetProgressWindowType | 様々なブラウザに対応しながらアップロードプログレスウィンドウの情報を更新するための関数です。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


GetProgressID( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ GetProgressID( )メソッド

形式
[Long = ] Object.GetProgressID()

解説
クライアントを識別できるように割り当てられ、ユーザー定義型のプログレスバーにて使用される固有の定数値をリターン。

使用例

<%
Dim ProgressID
set obj = server.CreateObject("DEXT.Progress")
'今後FileUploadとProgressで使用される。
ProgID = obj.GetProgressID()
set obj = nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SetProgressID( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SetProgressID( )メソッド

形式
Object.SetProgressID( ProgID )

パラメータ
ProgID As Long : アップロードの進行状態のモニター機能を使用するクライアントを識別するための値。
Progress.GetProgressID()で取得する。

解説
GET方式により取得した進行状態ＩＤを指定する。

使用例

<%
'GetProgressIDにより得られたID
ProgID= request.QueryString("ProgressID")
Set uploadform = Server.CreateObject("DEXT.FileUpload")
'GetProgressIDにより得られたIDをこの関数を通じてセットする。
uploadform.SetProgress(ProgID)
uploadform.DefaultPath = "c:\temp"
uploadform("file1").Save
Set uploadform = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


GetProgressID( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SetProgressWindowType( )メソッド

形式
Object.SetProgressWindowType( [lBrowserType], [lWindowType], [lProgressID] )

パラメータ

- lBrowserType As Long : IbrowserType:　ポップアップ関数対応ブラウザ別タイプ情報(デフォルト:0)

0=Only IE([Window.showModelessDialog]、[window.open]関数の同時対応ブラウザ)

1=FireFox、Opera、Chrome、Safariなど([window.open]関数のみ対応のブラウザ)

- lWindowType As Long : スクリプト上でアップロードのプログレス情報ウィンドウをオープンする方式(デフォルト:0)

0 = [window.showModelessDialog]関数の呼び出し時

1 = [window.open]関数の呼び出し時

- lProgressID As Long : アップロードプログレス情報ウィンドウを使用するクライアントを識別するための値。 [Progress.GetProgressID()]で得る。

解説
様々なブラウザに対応しながらアップロードプログレスウィンドウの情報を更新するための関数です。[DEXT.Progress]オブジェクトの[GetProgressID()]関数を使って得たID値を利用して様々なブラウザでアップロードプログレスウィンドウの情報をアップデートしてくれます。([*SetProgressID]の関数との併行使用禁止)

使用例

<%@ Language=VBScript EnableSessionState="False" %>

<%

Option Explicit

Dim Progress, Percent, TransferBytes, TotalBytes, BytesPer, bWorking, strFileName

Dim BrowserType

Dim ProgressID

ProgressID = Request.QueryString("ProgressID")

BrowserType = Request.ServerVariables("HTTP_USER_AGENT")

'DEXT.Progressオブジェクトを生成します。

Set Progress = Server.CreateObject("DEXT.Progress")

If InStr(BrowserType,"MSIE")Then

'GET方式で伝達されたProgressIDでクライアントを識別し

'クライアントのアップロードプログレス情報ウィンドウをIEで対応するなら最初の因子を0に設定。

'クライアントのアップロードプログレス情報ウィンドウをIE以外のブラウザで対応するなら最初の因子を1に設定。

'クライアントのアップロードプログレス情報ウィンドウをIEブラウザで[window.showModelessDialog]関数で呼び出す場合、二番目の因子は0に設定。

Progress.SetProgressWindowType 0, 0, ProgressID

Else

'クライアントのアップロードプログレス情報ウィンドウをIE以外のブラウザで[window.open]関数で呼び出す場合、二番目の因子は1に設定。

Progress.SetProgressWindowType 1, 1, ProgressID

End If

' [SetProgressID]関数の使用時、既存の下位互換性を維持するが

' IE以外のブラウザで正常にアップロードプログレス情報を表示できないため、代わりに、

' [SetProgressWindowType()]関数を使うことを勧奨する。

' Progress.SetProgressID( ProgID )

'現在のアップロードの進行状態値を読み込みます。

Percent = Progress.Percent

TransferBytes = Progress.TransferSize

TotalBytes = Progress.TotalSize

BytesPer = Progress.BytesPerSec

bWorking = Progress.Working

strFileName = Progress.FileName

%>

<HTML>

<HEAD>

<title>ファイルアップロード中です。</title>

<%

Response.Write "<Meta HTTP-EQUIV=""Refresh"" CONTENT=1>"

%>

<style type='text/css'>

td {font-size: 9pt}

</style>

</HEAD>

<BODY bgcolor=#d4d0c8 topmargin=0>

<%

If bWorking = true Then

Response.Write "<table border=0 style='FONT-SIZE: 9pt' width=370 cellpadding=0 cellspacing=0 bgcolor=#d4d0c8>"

Response.Write "<tr>"

Response.Write " <td colspan=2 height=25 valign=bottom><b>ファイルをアップロード中です。</b></td>"

Response.Write "</tr>"

Response.Write "<tr>"

Response.Write " <td colspan=2 width=360>"

Response.Write " <table style='border:solid 1px;' width=370 height=15 cellpadding=0 cellspacing=0 bordercolor=#000000 leftmargin=0 topmargin=0>"

Response.Write " <tr>"

Response.Write " <td width=100% height=100% align=left valign=middle style=padding:1;>"

Response.Write " <table height=100% cellpadding=0 cellspacing=0 width =" & (3.55*Percent) & "></td>"

Response.Write " <tr><td bgcolor='darkblue'></td></tr>"

Response.Write " </table>"

Response.Write " </td>"

Response.Write " </tr>"

Response.Write " </table>"

Response.Write " </td>"

Response.Write "</tr>"

Response.Write "<tr><td>&nbsp;</td></tr>"

Response.Write "<tr>"

Response.Write " <td align=left>転送ファイル : " & strFileName & "</td>"

Response.Write "</tr>"

Response.Write "<tr>"

Response.Write " <td align=left>転送速度 : " & round(BytesPer/(1024*1024),2) & " MB / sec </td>"

Response.Write "</tr>"

Response.Write "<tr>"

Response.Write " <td align=left>進行率 : " & round(TransferBytes/(1024*1024),2) & " MB / " & round(TotalBytes /(1024*1024),2) & " MB (" & Percent & "%)</td>"

Response.Write "</tr>"

Response.Write "</table>"

Response.Write "<tr><td>&nbsp;</td></tr>"

Response.Write "<table border=0 width=360 cellpadding=0 cellspacing=0 bgcolor=#d4d0c8>"

Response.Write "<tr><td>Click the <b>STOP</b> button on your browser to abort uploading.</td></tr>"

Response.Write "</table>"

Else

'アップロードの完了またはIE中止ボタンをクリックした場合

Response.Write("<body onload='javascript: top.window.close();'>")

End If

%>

</BODY>

</HTML>

Copyright © DEVPIA Corporation. All rights reserved.


BlobManagerオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ BlobManagerオブジェクト

Database上でBLOBデータを処理するためのオブジェクト。
BLOBフィールドにファイルを保存したり、BLOBデータをファイルとして保存するなどの機能を有する。

メソッド

名前 | 説明
SaveFileAsBlob | サーバに存在するファイルをDatabase BLOBフィールドに保存する。
SaveBlobAsFile | DatabaseにあるBLOBデータをサーバのディスクファイルとして保存する。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


SaveFileAsBlob( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveFileAsBlob( )メソッド

形式
Object.SaveFileAsBlob( strFilename, dbField )

パラメータ
strFilename As String – BLOBフィールドに保存するファイル名(フルパス)
dbField As ADODB.Field – ファイルを保存するBLOBフィールド

解説
サーバーに存在するファイルをDatabase BLOBフィールドに保存する。

使用例

<%
Set objBlobMan = Server.CreateObject("DEXT.BLOBManager")
Set rs = Server.CreateObject("ADODB.Recordset")
rs.Open strQuery, cn, 3,3
rs.AddNew
objBlobMan.SaveFileAsBlob "C:\file.zip", rs("filedata")
rs.Update
Set objBlobMan = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveFileAsBlob( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveBlobAsFile( )メソッド

形式
[String =] object.SaveBlobAsFile( dbField, strFilename, [bOverwrite] )

戻り値
String –実際に保存されたファイル名

パラメータ
dbField As ADODB.Field – ファイルとして保存するBLOBフィールド
strFilename As String – BLOBデータを保存するファイル名(フルパス)
bOverwrite As Boolean (Optional) – 同じ名前のファイルが既に存在する場合に上書きするかどうかを指定。
デフォルトの値はTrue。Falseに設定するには、filename(2).ext, filename(3).extなど、違うファイル名を使って保存する。

解説
DatabaseにあるBLOBデータをサーバのディスクファイルとして保存する。

使用例

<%
Set objBlobMan = Server.CreateObject("DEXT.BLOBManager")
Set rs = Server.CreateObject("ADODB.Recordset")
rs.Open strQuery, cn, 3,1
objBlobMan.SaveBlobAsFile rs("filedata"), "C:\file.zip"
Set objBlobMan = Nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


Managerオブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ Managerオブジェクト

ダウンロードのキャッシュに必要なオブジェクト。

メソッド

名前 | 説明
AddCacheFile | 指定されたファイルをメモリにスタックする。
RemoveCacheFile | 指定されたファイルをメモリから除去する。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


AddCacheFile( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ AddCacheFile( )メソッド

形式
Object.AddCacheFile( strFilePath )

パラメータ
strFilePath As String - メモリにスタックするファイルのパス (物理的なフルパス)

解説
指定されたファイルをメモリにスタックする
AddCacheFile( )メソッドを用いてファイルをメモリにスタックし、For Each文によりスタックされたファイルリストを求める。

使用例

<%@ Language=VBScript %>
<%
set objManager = server.createobject("DEXT.Manager")

'メモリにファイルを追加
objManager.AddCacheFile Trim(Request("txtFilePath1"))
Response.Write("メモリにスタックされたファイルリスト")
'キャッシュされたファイルリストをインポート
For Each cacheFile in objManager
response.Write(cacheFile & "<br>")
Next

set objManager = nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


RemoveCacheFile( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ RemoveCacheFile( )メソッド

形式
Object.RemoveCacheFile( strFilePath )

パラメータ
strFilePath As String - メモリにスタックするファイルのパス (物理的なフルパス)

解説
指定されたファイルをメモリから除去する。
RemoveCacheFile( )メソッドを用いてファイルをメモリから除去し、For Each文によりスタックされたファイル一覧を求める。

使用例

<%@ Language=VBScript %>
<%
set objManager = server.createobject("DEXT.Manager")

'メモリからファイルを除去
objManager.RemoveCacheFile Trim(Request("txtFilePath1"))
Response.Write("メモリにスタックされたファイルリスト")
'キャッシュされたファイルリストをインポート‘
For Each cacheFile in objManager
response.Write(cacheFile & "<br>")
Next

set objManager = nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ImageProc オブジェクト

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageProc オブジェクト

DEXT.ImageProc オブジェクトは各種の画像フォーマット(BMP、EMF、EXIF、GIF、Icon、JPEG、PNG、TIFF、WMFなど)に対応。
他の画像フォーマットへの変換も可能(BMP、JPG、GIF、TIFF、PNGなど) 画像ファイルのサムネイルイメージも作成できる。生成されたイメージはJPGフォーマットで保存される。
指定された画像や文字などを用いて透かしイメージを作成できる。生成された透かしイメージはJPGフォーマットで保存される。
露出時間、イメージの詳細、解像度などの様々なメタデータを提供。

プロパティ

名前 | 説明
AutoMakeFolder | これをTRUEに設定すればSaveAsThumbnail(),SaveAsWaterMarkImage() などに指定したフォルダが存在しない場合フォルダを自動で生成する。
BackGroundColor | SaveAsThumbnail() メソッドを呼び出し時、自動倍率を選択した場合、バッググラウンド色を決める時に設定する。
FontFamily | SaveAsWatermarkText() メソッドを呼び出し時プリントになるフォントを決める時、設定する。
FontStyle | SaveAsWatermarkText() メソッドを呼び出し時プリントになるフォントのプロパティーを決める時、設定する. 0 : FontStyleRegular(一般テキスト) 1 : FontStyleBold(太いテキスト) 2 : FontStyleItalic 3 : FontStyleBoldItalic 4 : FontStyleUnderline(下線が引かれたテキスト) 5 : FontStyleStrikeout(中間に竝びがあるテキスト)
ImageMirror | イメージの左右反転
ImageRotate | イメージを右側に 90度ずつ回転して表現 (*下の数字だけ可能) 90 : 右側に 90度回転 180 : 右側に 180度回転 270 : 右側に 270度回転
WatermarkTransparency | 透かしイメージの透明度を調節して表現する方式、数字の大きくなるほど透明度が低くなる。
ImageFormat | 画像フォーマット。“BMP”, “EMF”, “EXIF”, “GIF”, “Icon”, ”JPEG”, “PNG”, “TIFF”, “WMF”のうちいずれかをリターン。 これ以外の画像については“Undefined”をリターン。
PixelFormat | ピクセルのフォーマット
ImageWidth | イメージの横幅
ImageHeight | イメージの高さ
HorizontalResolution | 水平解像度
VerticalResolution | 垂直解像度
MDDocumentName | 画像の名前
MDImageDescription | 画像の詳細
MDEquipMake | カメラ製造社
MDEquipModel | カメラの品番
MDSoftwareUsed | 画像ファイルを作成したプログラム
MDDateTimeOrig | 撮影日時
MDDateTime | 修正日時
MDArtist | 撮影者
MDExifShutterSpeed | シャッターのスピード
MDExifExposureTime | 露出時間 (シャッタースピード)
MDExifFNumber | アイリス値。"F/?.?f"のフォーマットを返す。
MDExifMaximumLensAperture | アイリスの最大値
MDExifColorSpace | カラーモード。“sRGB”, “uncalibreated”, “reserved” の中で一つをリターン。
MDExifFlash | フラッシュ使用 0 - flash did not fire 1 - flash fired 2 - flash fired but strobe return light not detected 3 - flash fired and strobe return light detected
MDExifISOSpeed | ISO速度
MDExifFocalLength | 焦点距離
MDExifFocalLengthIn35mm | 35mmフィルムの焦点距離
MDExifExposureProg | 撮影モード (露出プログラム) 0 - Not defined 1 - Manual 2 - Normal program 3 - Aperture priority 4 - Shutter priority 5 - Creative program (biased toward depth of field) 6 - Action program (biased toward fast shutter speed) 7 - Portrait mode (for close-up photos with the background out of focus) 8 - Landscape mode (for landscape photos with the background in focus) 9 to 255 - Reserved
MDExifExposureBias | 露出補正
MDExifExifDigitalZoomRatio | デジタルズーム
MDExifMeteringMode | 測光モード
MDExifLightSource | 光源 0 - Unknown lighting 1 - Daylight 2 - Fluorescent lighting 3 - Tungsten lighting 17 - Standard Light A 18 - Standard Light B 19 - Standard Light C 20 - D55 light 21 - D65 light 22 - D75 light 23 to 254 - Reserved 255 - Other lighting
MDExifWhiteBalance | White Balance ("Auto", "Manual", "Unknown")
Quality | jpeg ファイルの鮮明度調節 (範囲 : 1 ~ 100)

メソッド

名前 | 説明
SetSourceFile | 作業対象のイメージファイルを設定する。このメソッドを成功的に呼び出した 後、次の関数を 呼び出せる。
SaveAsThumbnail | サムネイルイメージを生成する。サムネイルのフォーマットはJPGである。フラッシュ使用は、実際の保存先を含むファイルの名前である。
SaveAsWatermarkImage | イメージを用いた透かしイメージを生成する。透かし処理されたファイルのフォーマットは、JPGである。
SaveAsWatermarkText | テキストを用いた透かしイメージを生成する。透かし処理されたファイルのフォーマットは、JPGである。
ConvertImageFormat | 画像フォーマットを指定されたファイルに変換。 最初のファクタは変換する画像のフォーマットであり、“image/jpeg”、“image/bmp” などのように入力する。

Copyright ⓒ DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ AutoMakeFolder プロパティ

形式
[Boolean = ] Object.AutoMakeFolder

戻り値
Boolean - フォルダ自動生成の有無

説明
Trueで設定すれば SaveAsThumbnail(),SaveAsWaterMarkImage(),SaveAsWaterMarkText(),

ConvertImageFormat() に指定したフォルダが存在しない場合、フォルダを自動で生成する。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXT.FileUpload")

uploadform.DefaultPath="C:\TEMP"

set objImage =Server.CreateObject("DEXT.ImageProc")

objImage.AutoMakeFolder = True

if true = objImage.SetSourceFile(uploadform.TempFilePath) then

'JPG フォーマットで保存しなければならない

filename = uploadform.FileNameWithoutExt & ".jpg"

'基本値 75(範囲 1~100)

objImage.Quality = 90

%>

<HTML>

<BODY>

Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\TEMP\NewMakeFolder\" & filename, objImage.ImageWidth, objImage.ImageHeight, false)%>

</BODY>

</HTML>

<%

end if

set objImage = nothing

Set uploadform =nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ BackGroundColor プロパティ

説明
SaveAsThumbnail() メソッドを呼び出し時自動倍率を選択した場合、バッググラウンド色を決める時設定する。

自動倍率を選択する方法は SaveAsThumbnail() メソッドの 5番目のパラメータを TRUEで設定する。

使用例

<%@ Language=VBScript %>

<%

set objImage =server.CreateObject("DEXT.ImageProc")

if true = objImage.SetSourceFile(uploadform.TempFilePath) then

filename = uploadform.FileNameWithoutExt & ".jpg"

objImage.BackGroundColor = "#009999"

objImage.Quality = 90

%>

<HTML>

<BODY>

Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\Temp\" & filename,objImage.ImageWidth,

objImage.ImageHeight,false, true)%>

</BODY>

</HTML>

<%

end if

set objImage = nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FontFamily プロパティ

説明
SaveAsWatermarkText() メソッドを呼び出し時、プリントするフォントを決める時、設定する。

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXT.FileUpload")

uploadform.DefaultPath="C:\TEMP"

set objImage =Server.CreateObject("DEXT.ImageProc")

if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then

'FileNameNoExt プロパティーはアップロードしたファイルの名前をリターンする。(拡張子除外)

SourceFileName = uploadform("file").FileNameNoExt

FileName1 = "C:\TEMP\" & SourceFileName & "(Image).jpg"

objImage.Quality = 90

' FontFamily プロパティーを使ってウォーターマークテキストの字面を verdanaで設定する。基本字面は arialで設定されている。

objImage.FontFamily = "verdana"

' FontSytle プロパティーを使ってウォーターマークテキストのフォントを太いイテリックテキストで設定する。

objImage.FontStyle = 3

Response.Write "Save as Watermark Image:" & objImage.SaveAsWatermarkText("WaterMark Text",FileName1,15,10,10,false)

end if

set objImage = nothing

Set uploadform =nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ FontStyle プロパティ

説明
SaveAsWatermarkText() メソッドを呼び出し時プリントするフォントのプロパティーを決める時、設定する。

タイプ(0~5)

0 : FontStyleRegular(一般テキスト)

1 : FontStyleBold(太いテキスト)

2 : FontStyleItalic

3 : FontStyleBoldItalic

4 : FontStyleUnderline(下線が引かれたテキスト)

5 : FontStyleStrikeout(中間に竝びがあるテキスト)

使用例

<%@ Language=VBScript %>

<%

set uploadform=server.CreateObject("DEXT.FileUpload")

uploadform.DefaultPath="C:\TEMP"

set objImage =Server.CreateObject("DEXT.ImageProc")

if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then

'FileNameNoExt プロパティーはアップロードしたファイルの名前をリターンする。(拡張子除外)

SourceFileName = uploadform("file").FileNameNoExt

FileName1 = "C:\TEMP\" & SourceFileName & "(Image).jpg"

objImage.Quality = 90

' FontFamily プロパティーを使ってウォーターマークテキストの字面を verdanaで設定する。基本字面は arialで設定されている。

objImage.FontFamily = "verdana"

' FontSytle プロパティーを使ってウォーターマークテキストのフォントを太いイテリックテキストで設定する。

objImage.FontStyle = 3

Response.Write "Save as Watermark Image:" & objImage.SaveAsWatermarkText("WaterMark Text",FileName1,15,10,10,false)

end if

set objImage = nothing

Set uploadform =nothing

%>

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageMirror プロパティ

戻り値
Boolean

説明
イメージの左右反転。

使用例

set objImage =Server.CreateObject("DEXT.ImageProc")

objImage.ImageMirror = True

set objImage = nothing

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ImageRotate プロパティ

タイプ (*下の数字だけ可能)

90 : 右側に 90度回転

180 : 右側に 180度回転

270 : 右側に 270度回転

説明
イメージを右側に 90度ずつ回転。

使用例

set objImage =Server.CreateObject("DEXT.ImageProc")

objImage.ImageRotate = 180

set objImage = nothing

Copyright © DEVPIA Corporation. All rights reserved.


FileLen프로퍼티

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ WatermarkTransparency プロパティ

タイプ

Long - 範囲(0 ~ 10)

説明
透かしイメージの透明度を調節。数字の大きくなるほど透明度が低くなる。

使用例

set objImage =Server.CreateObject("DEXT.ImageProc")

' Watermark イメージの透明度を与えないa.基本設定価格は 8で設定されている。

objImage.WatermarkTransparency = 10

set objImage = nothing

Copyright © DEVPIA Corporation. All rights reserved.


SetSourceFile( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SetSourceFile( )メソッド

形式
[Boolean =] Object.SetSourceFile( strTempFilePath )

戻り値
Boolean – 一時ファイルが存在するかを確認。

パラメータ
strTempFilePath As String – 一時ファイルが生成されたパス

解説
作業対象のイメージファイルを設定する。
このメソッドを呼び出した後、SaveAsThumbnail()やSaveAsWatermarkImage()、SaveAsWatermarkText()のメソッドを呼び出すことができる。

使用例

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
'画像ファイルの処理.....
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsThumbnail( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAsThumbnail( )メソッド

形式
Object.SaveAsThumbnail( bstrFilePath,nWidth,nHeight,bOverwrite )

パラメータ
bstrFilePath- サムネィルイメージの保存経路

nWidth - 広さ

nHeight - 高さ

bOverwrite - 上書き保存有無(Trueなら上書き)

bAutoSize - サムネィルイメージ自動倍率設定有無(基本値:False)

解説
アップロードしたイメージファイルの横,縦を 1/10大きさでサムネィル処理して保存する。生成されたイメージは JPG フォーマットを持つ。

bAutoSizeを TRUEに設定する場合、サムネィルサイズに合わせて原本イメージの倍率を維持しながら切ってす処理して保存する。

これによりイメージ余白が生ずることができて基本余白色相は白に設定されている。

使用例

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform.TempFilePath) then
'JPGフォーマットで保存すること
filename = uploadform.FileNameWithoutExt & ".jpg"
'Default value is 75 (range 1~100)
objImage.Quality = 90
%>
<HTML>
<BODY>
Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\TEMP\" & filename, objImage.ImageWidth/10, objImage.ImageHeight/10, false, false)%>
</BODY>
</HTML>
<%
end if
set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsWaterMarkImage( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAsWaterMarkImage( )メソッド

形式
Object.SaveAsWaterMarkImage( bstrTargetFilePath,bstrSavedPath,PosX,PosY,bOverwrite )

パラメータ
bstrTargetFilePath – ウォーターマーク処理をする画像のパス
bstrSavedPath – ウォーターマーク処理した画像のパス (例:C:\Temp\watermarked.jpg)
PosX – ウォーターマーク処理をする画像のX座標
PosY – ウォーターマーク処理をする画像のY座標
bOverwrite - 上書きするかどうかの指定(Trueの場合に上書きする。)

解説
イメージを用いた透かしテキストを生成する。透かし処理されたファイルのフォーマットはJPGである。
PosXが–10、PosY –10である場合にイメージの右下に位置する。

使用例

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
'FileNameWithoutExt属性は、アップロードしたファイルの名前を返す (拡張子を除く。)
SourceFileName = uploadform("file").FileNameWithoutExt
FileName1 = "C:\TEMP\" & SourceFileName & "(Image).jpg"
'Default value is 75 (range 1~100)
objImage.Quality = 90
Response.Write "Save as Watermark Image:" & objImage.SaveAsWatermarkImage("/DEXTUploadProSamples/Image/WaterMark/watermark.bmp",FileName1,-10,-10,false)
end if

set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsWaterMarkText( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ SaveAsWaterMarkText( )メソッド

形式
Object.SaveAsWaterMarkText( bstrTextForMarking,bstrSavedPath,FontSize,PosX,PosY,bOverwrite )

パラメータ
bstrTextForMarking – ウォーターマーク処理をするテキスト
bstrSavedPath – ウォーターマーク処理した画像のパス (例:C:\TEMP\watermarked.jpg)
FontSize – フォントのサイズ PosX – ウォーターマークテキストのX座標
PosY – ウォーターマークテキストのY座標
bOverwrite – 上書きするかどうかの指定 (Trueの場合に上書きする。)

解説
画像を用いたウォーターマークテキストを作成する。ウォーターマーク処理されたファイルのフォーマットはJPG。
PosXが-10かつPosYが–10である場合にはイメージの右下に挿入される。

使用例

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
'FileNameWithoutExt属性は、アップロードしたファイルの名前を返す (拡張子を除く。)
SourceFileName = uploadform("file").FileNameWithoutExt
FileName1 = "C:\TEMP\" & SourceFileName & "(Image).jpg"
'Default value is 75 (range 1~100)
objImage.Quality = 90
Response.Write "Save as Watermark Image:" & objImage.SaveAsWatermarkText("WaterMark Text",FileName1,15,10,10,false)
end if

set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


ConvertImageFormat( )メソッド

DEXTUpload Professional

DEXTUpload Professionalのオブジェクトリファレンス

■ ConvertImageFormat( )メソッド

形式
Object.ConvertImageFormat( bstrImageFormat,bstrTargetFilePath,bOverwrite )

パラメータ
bstrImageFormat – 変換する画像フォーマット ("image/bmp")
bstrSavedPath – 画像フォーマット変換済みのファイルのパス (例:C:\Temp\watermarked.bmp)
bOverwrite – 上書きするかどうかの指定(Trueの場合に上書きする。)

解説
画像フォーマットを指定されたファイルに変換する。
最初ファクタは変換する画像フォーマットであり、“image/jpeg”、“image/bmp”などのように入力する。

使用例

<%@ Language=VBScript %>
<%
set uploadform=Server.CreateObject("DEXT.FileUpload")
uploadform.DefaultPath="C:\TEMP"
set objImage =Server.CreateObject("DEXT.ImageProc")
if true = objImage.SetSourceFile(uploadform("file").TempFilePath) then
'FileNameWithoutExt属性は、アップロードしたファイルの名前を返す (拡張子を除く。)
SourceFileName = uploadform("file").FileNameWithoutExt
FileName1 = "C:\TEMP\" & SourceFileName & "(Image).jpg"
Response.Write "Convert
Image File Format:" & objImage.ConvertImageFormat("image/bmp","C:\TEMP\" & FileName1 ,false)
end if

set objImage = nothing
Set uploadform =nothing
%>

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload.NET Professionalについて

DEXTUpload.NET Professional

DEXTUpload.NET Professionalについて

■ DEXTUpload.NET Professional とは?

DEXTUpload.NET Professionalは、ウェブブラウザーからIISウェブサーバーへのファイルのアップロード及びダウンロードを支援するコンポーネントです。

インターネット標準であるRFC1867に準拠しており、Microsoft ASP.NETで使用することができます。

 大容量のファイルをアップロードする場合にも、すばやいアップロード速度と低いリソース占有率を実現し、ユーザーがアップロードの進行状態を簡単に確認できるよう開発されています。

 DEXTUpload.NET Professionalには次のような特徴があります。

1. ASP.NETとの完全な統合。

2..NET Framework用ファイルアップロードクラスとの相互運営性を備え、ファイルアップロードにおけるASP.NETの限界(大容量ファイルのアップロードに対する不適合性、サーバー負荷に関する問題や安定性、単純なアップロード機能)を完全に克服。

3. DEXTUpload.NET ProfessionalはDEXTUpload Professionalの.NETバージョンです。C#言語を利用して100％管理されたコードを作成し、既存のコアエンジンを.NETに最適化されたコードに作り変えるため、これまでのASPファイルアップロードコンポーネントよりも優れたアップロード速度と安定性を提供します。

■ DEXTUploadV.NET Professional とは?
DEXTUploadV.NET Professionalは、これまでのDEXTUpload Professionalにアンチウィルス機能を追加した新製品です。

多くのユーザーより安定性が検証されていないファイルがアップロードされる環境で、それらのファイルを管理すること。それはまさに、安定的なウェブビジネスを営むにおいて、常に安全性の確保に注意しなければならないウェブサーバーやファイルサーバーを脅かす問題のひとつといえます。

これからは、 ウェブサーバーよりアップロードされるすべてのファイルの安定性を確保するため、国内有数のセキュリティ業者と協力し、アンチウィルス機能を追加した DEXTUploadV.NET Professionalがこのような問題を一挙に解決いたします。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload.NET Professional の特徴

DEXTUpload.NET Professional

DEXTUpload.NET Professional について

■ DEXTUpload.NET Professional の特徴

1. Windows NT/XP/2000/2003/2008 IIS 5.0 以降のサーバー ASP.NETで利用できる (.NET Framework 1.1 / 2.0 / 4.0)

2. インターネット標準である HTML 4.0, HTTP 1.1, RFC 1867に準拠。

3. 大容量のファイルのアップロードに対応。(2GBのサイズのファイルに対するアップロードテスト済み) すばやいアップロード速度と低いリソース使用が特徴。

(低いCPU利用率－アップロード一件あたりの瞬間メモリー使用量:16~70KB)

4. 多様なイメージフォーマット (JPG, BMP, GIF, PNG, TIFF, ICON, WMF, EMFなど) に対応。

5. イメージファイルに対するさまざまな機能を支援。(サムネイル、ウォーターマーク、フォーマット変換、メタデータ支援など)

6. ユーザーの使いやすさを考慮。(フォルダー自動生成、仮想経路自動変換など)

7. ファイルダウンロード用に「続けてダウンロード」や「強制保存」などの機能を搭載。

8. 外国語やユニコードに完璧に対応。

9. ファイルをアップロードしてサーバーに保存する前に、DEXTUploadV.NET Professionalがウィルスや悪性コードへの感染をチェックし、安全なファイルのみをサーバーに保存。
ウィルスの流布を源泉的にシャットダウンします。
(DEXTUploadV.NET Professional 製品のみ該当)

10. ウィルスや悪性コードに感染したファイルをアップロードした場合、その感染情報とともに、開発者が強制的にそのセッションを希望に沿って処理できるよう開発されています。
(DEXTUploadV.NET Professional 製品のみ該当)

11. 常に最新のエンジン情報を維持できるよう、「DEXTUploadV Smart Update Utility」プログラムを提供。環境設定ファイルを修正すればアップデートの周期や時間を楽に管理することができます。
(DEXTUploadV.NET Professional 製品のみ該当)

12. ウェブサーバーに設置された他のワクチン製品と衝突を起こすことなく、独立的かつ安定的に管理することができます。
(DEXTUploadV.NET Professional 製品のみ該当)

13. 合理的な費用で、アップロードファイルの保存スペースをウィルスや悪性コードから守ることができます。
(DEXTUploadV.NET Professional 製品のみ該当)

Copyright © DEVPIA Corporation. All rights reserved.


ASP.NET 2.0 支援

DEXTUpload.NET Professional

DEXTUpload.NET Professional について

■ ASP.NET 2.0 支援

DEXTUpload.NET Professional は.NET Framework 1.1及び2.0に対応しており、各バージョン別に別途のDEXTUpload.NET.dll が提供されています。

よって、いくつかのバージョンの.NET Framework がインストールされている環境でも、バージョンの異なる製品を同時にご使用いただけます。

ASP.NET 1.1及びASP.NET 2.0を使用の場合に異なる点は次のとおりです。

1. IISに登録されたサンプルのバーチャルディレクトリ
ASP.NETのバージョン別にサンプルがインストールされます。

2. GAC登録
 3.6.1.1は.NET Framework 1.1をサポートするアッセンブリファイルです。また、3.6.2.0は.NET Framework 2.0をサポートするアッセンブリファイルです。

3. コンポーネント　サービス登録
 アプリケーションプログラムのうち、DEXTUpload.NETは.NET Framework 1.1で動作するコンポーネントです。また、DEXTUpload.NET2.0は.NET Framework 2.0で動作するコンポーネントです。

4. Web.configの設定
 ASP.NET 1.1の設定情報のうち、二ヶ所が変更となりました。
    残りの設定情報については以前と同様です。詳しくはサンプルを参考にしてください。

<configSections>
<sectionGroup name="dextupload.net">
<section name="settings" type="System.Configuration.SingleTagSectionHandler, System,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
</sectionGroup>
</configSections>

<httpModules>
<add name="FileUploadMonitorModule" type="DEXTUpload.NET.FileUploadMonitorModule, DEXTUpload.NET,
Version=3.6.2.0, Culture=neutral, PublicKeyToken=d71d611ccd9cc3c0"/>
</httpModules>

 5. 実行環境
Visual Studio 2005では、ASP.NET 2.0ウェブサイトを実行するためのいくつかのタイプを提供しています。代表的な方式は次のとおりです。

IISと作動する方式
 サーバーにIISがインストールされていなければなりません。
バーチャルウェブサーバー(Web Developer Web Server)を利用して作動する方式(New)
 IISをインストールできない環境でASP.NET 2.0プログラムを開発する場合に該当します。
バーチャルウェブサーバーは、ローカルでのみ開発及びテストが可能なよう設定されています。
IISのメカニズムとは異なり、バーチャルウェブサーバーではサポートされていない機能もあります。

 ASP.NET 2.0のサンプルは、上記の違いのため、IISで実行されるタイプとしてインストールされます。バーチャルウェブサーバーで開発を行う場合の注意事項は次のとおりです。

[大容量アップロード処理方式]
 大容量アップロードを処理するためにはhttpModuleを使用します。ASP.NET 2.0のサンプルのWeb.configファイルで次のような設定を行ってください。

<dextupload.net>
<settings enableLargeFileUpload="true" defaultPath="C:\TEMP" uploadTimeout="3600" maxFileLength="1073741824" useIE5BugFix="true"/>
</dextupload.net>

<httpModules>
<add name="FileUploadMonitorModule" type="DEXTUpload.NET.FileUploadMonitorModule, DEXTUpload.NET,
Version=3.6.2.0, Culture=neutral, PublicKeyToken=d71d611ccd9cc3c0"/>
</httpModules>

[enableLargeFileUpload="true"]のプロパティは大容量で処理するという意味を表しています。つまり、httpModuleが処理を行うということです。
バーチャルウェブサーバーはhttpModuleの一部をサポートしていないため、[enableLargeFileUpload]のプロパティを[False]に変更する必要があります。
     ここを[False]に設定した場合、httpModuleを実行せずにASP.NET 2.0のアップロード方式によって処理を行います。
     万一、ここが[True]に設定されている場合はランタイムエラーが発生します。

[ImgProcオブジェクトをサポート]
バーチャルウェブサーバーで実行する場合はイメージ関連の機能が正常に動作しません。
    正常に機能を使用するためにはIISタイプで実行するようにしてください。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload.NET Professional の特徴

DEXTUpload.NET Professional

DEXTUpload.NET Professional について

■ DEXTUpload.NET Professional リリース情報

DEXTUpload.NET Professional v4.0

[改善事項]

Windows 2008 IIS 7.0 Integrated Pipeline Mode 支援

ASP.NET 4.0(.NET Framework 4.0) 支援

イメージサムネイル生成機能

イメージウォーターマーキングの透明度オプションの機能追加

DEXTUpload.NET Professional v3.7

[改善事項]

Windows 2008 IIS 7.0対応 (Integrated Pipe mode 除外)

DEXTUpload.NET Professional v3.6

[改善事項]

ASP.NET 2.0　対応

.NET Framework 1.1及び2.0をサポートし、各バージョン別に別途のDEXTUpload.NET.dllを提供

DEXTUpload.NET Professional v3.5.1

[機能改善]

GDI+で支援するフォーマットでない場合、以前のバージョンでは「Out of Memory」エラーがいたんですけど解決。

Web.configでhttpModuleのバージョン情報を「3.5.1.1」に修正。

DEXTUpload.NET Professional v3.5.0

[機能追加]

アップロードフォル自動生成技能

ユーザ定義型プログレスバー支援

ファイルを続けてダウンロード

ファイルのフォーマットに関系なく強制ダウンロード

イメージファイルウォーターマーク処理

サムネイルイメージ処理技能

イメージファイルフォーマット変換技能

イメージファイルメター情報

各種のイメージファイルのフォーマット、横幅、高さ提供

DEXTUpload.NET v3.0.3

DEXTUpload.NET v3.0.0

Copyright © DEVPIA Corporation. All rights reserved.


システムの要求事項

DEXTUpload.NET Professional

DEXTUpload.NET Professional　インストールについて

■ システムの要求事項

- Microsoft Windows 2000/2003/2008 Server Family

- Microsoft Windows XP Professional (IIS 設置)

- IIS 5.0 以上

- .NET Framework 1.1
- .NET Framework 2.0
- .NET Framework 4.0

- ASP.NET 1.0
- ASP.NET 2.0
- ASP.NET 4.0

- COM+ 1.0 以上

Copyright © DEVPIA Corporation. All rights reserved.


インストール方法

DEXTUpload.NET Professional

DEXTUpload.NET Professional　インストールについて

■ インストール方法

1.インストールの開始

1. DEXTUpload.NET Professional のインストール準備

2. ユーザー契約に同意

3. インストール方法の選択 - 「DEXTUpload.NET Professionalをインストールします。」を選択してください。

4. 製品の登録情報に間違いがあったり、空欄のまま登録を行った場合には、評価版がインストールされます。

[参考] インターネットに接続した状態でなければ正常に製品の認証が行われません。
オフラインの場合には「2．正規登録および認証」を参照してください。

5. インストール先の選択

6. 既存のDEXTUpload.NET.dllをIISが使用中の場合、上書きを実行できないためにIISを再始動する必要があります。

7. インストール完了-　[完了]をクリックすると例が実行されます。

2. 正規登録および認証

次に該当する場合、正規登録および認証を行う必要があります。

1. インターネットに接続されていない状態でインストールを行った場合。

2. インターネットに接続していたが、何らかの障害により正常に認証が行われなかった場合。

3. 評価版より正規バージョンにアップグレードした場合。

正規登録および認証は次のとおりに行ってください。

1. インターネットに接続されたPCで、http://www.dextupload.comにアクセスします。

2. [マイページ→認証キーの生成] メニューを選択します。([マイページ]にログインするにはカスタマー登録を済ませてください。)

3. コンピューター名、製品キー、シリアル番号を入力した後、[確認]をクリックすると認証番号が発給されます。(この認証番号はステップ6で必要となります。)

4. DEXTUpload.NET ProfessionalがインストールされたPCでインストールプログラムを実行します。

5. [インストール方法の選択]スクリーンで[正規登録および認証を行います]を選択してください。

6. [認証キー]にウェブサイトから提供された認証番号を入力し、[認証]をクリックすると認証が完了します。
作業を終了してください。

3. 評価版の使用期限

評価版の使用期限は30日です。30日過ぎた後にプログラムを実行すると、再インストールを促すメッセージが表示されます。

4. サーバーのコンピューター名の変更する場合、再認証方法案内

アップロード コンポーネント中サーバーコンポーネント製品(DEXTUploadX除外)は正規品の設置後該当サーバーのコンピューター名(Hostname)を変更する場合、
正規品の登録をまた進行しなければなりません。
そうではない場合、認証のエラーによってプログラムを正常にご使用になることができません。

正規品の登録をまたする方法は下のような方法があります。

*認証番号を手動で生成する方法- http://www.dextsolution.comの「認証番号生成」メニュで変更されたコンピューター名で新しい認証番号を手動で生成

方法1:　再認証 - 製品が設置された状態で設置ファイルを実行して「作業選択」画面で「正規品登録および認証をします。」を選択して手動で生成した認証番号を入力

方法2:　再インストールする - IIS中止後「プログラム追加/除去」で設置された製品を削除して再インストールする (認証サーバーと通信ができない場合、評価版設置後「方法1」で再認証)

Copyright © DEVPIA Corporation. All rights reserved.


インストール方法

DEXTUpload.NET Professional

DEXTUpload.NET Professional　インストールについて

■ アンインストール

[コントロールパネル]の[プログラムの追加と削除]を利用するか、またはインストールした際に[スタート]メニューに追加された[UnInstall DEXTUpload.NET Professional]

もしくは[UnInstall DEXTUploadV.NET Professional]を開いてコンポーネントをアンインストールしてください。

もしプログラムがDEXTUpload.NET.dllファイルによって使用されている場合は、このファイルを削除することができないためにアンインストールを行うことができません。

このような場合にはIISを再始動してからアンインストールを行うようにしてください。

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUpload.NET Professional の開始

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ DEXTUpload.NET Professional の開始

DEXTUpload.NET Professionalは Windows XP/2000/2003/2008 で IIS 5.0 以降の ASP.NET ページ内で利用することができます。
データベースへのアップロードおよびダウンロードはADO.NETを使って行われます。

1. DEXTUpload.NET.dll インストール
DEXTUpload.NET ProfessionalはCOM+応用プログラムにより動作し、公開HttpModuleを構成しています。よって、次の二つの設定を行わなければなりません。
1) GACのインストール
 コマンドプロンプトで該当のパスに移動し、[gacutil /i DEXTUpload.NET.dll]を実行し、共用アッセンブリに登録します。
システムフォルダーの下の[Assembly]フォルダーで[DEXTUpload.NET]の名前を確認してください。
2) 構成要素サービスの登録
 コマンドプロンプトで該当のパスに移動し、[regsvcs /c DEXTUpload.NET.dll]を実行し、COM+応用プログラムに登録してください。
#DEXTUpload.NET Profressional 4.0.4.0 バージョンは GAC 設置のみ属します

2. 参照の追加
ユーザーのASP.NETウェブアプリケーションでDEXTUpload.NETを使用するには、DEXTUpload.NETおよびSystem.EnterpriseServicesに関する参照を追加しなければなりません。( DEXTUpload.NET Profressional 4.0.4.0 バージョンは除外です)

3. Web.config の設定

参照の追加を終えたら、[Web.config]ファイルを開いて必ず次のような設定を追加してください。(「DEXTUpload.NETサンプル」を参照のこと)

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<configSections>

<sectionGroup name="dextupload.net">

<section name="settings" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

</sectionGroup>

</configSections>

<dextupload.net>

<settings enableLargeFileUpload="true"
defaultPath="c:\temp" uploadTimeout="3600"

maxFileLength="1073741824"
useIE5BugFix="true"/>

</dextupload.net>

<system.web>

<httpRuntime executionTimeout="3600" maxRequestLength="1048576" />

<httpModules>

<add name="FileUploadMonitorModule" type="DEXTUpload.NET.FileUploadMonitorModule, DEXTUpload.NET, Version=4.0.2.0, Culture=neutral,

PublicKeyToken=d71d611ccd9cc3c0" />

</httpModules>

… (중략) …

</system.web>

</configuration>

<dextupload.net><settings></setting></dextupload.net> プロパティの設定
1)enableLargeFileUpload
このプロパティを[true]に指定すれば、DEXTUpload.NETの大容量ファイルアップロード機能が使えるようになります。
反対にこれを[false]に指定すると、ASP.NETがデフォルトで提供するファイルアップロード方式を利用することとなり、DEXTUpload.NETの大容量ファイルアップロード機能は使用できません。

2) defaultPath
アップロードファイルが保存されるデフォルトパスを指定します。また、このパスはファイルのアップロード時に生成される一時ファイルの保存先としても使われます。

3) uploadTimeout
ファイルのアップロード作業に対するタイムアウトの時間を設定します。DEXTUpload.NETは、ASP.NETにおけるServer.ScriptTimeout(90秒)およびSession.Timeout(20分)の設定値の影響を受けません。
ここで設定されたuploadTimeoutの値のみが有効となります。この値は[httpRuntime]の[executionTimeout]のプロパティの値と一致するよう設定してください。

4) maxFileLength
アップロードが可能なファイルの最大サイズを指定します。この値は[httpRuntime]の[maxRequestLength]の値と一致するよう設定してください。
( 注意: [maxFileLength]の単位はByte 、[maxRequestLength]の単位はKByteです。)

5) useIE5BugFix
インターネットエクスプローラー5.0バージョンのバグを自動的に処理できる機能をオンまたはオフにします。

<httpRuntime> プロパティの設定
- [machine.config]のプロパティを再定義します。

1) executionTimeout
HTTP Requestのタイムアウト時間を指定します。

2) maxRequestLength
対応可能なHTTP Requestの最大サイズを指定します。

<httpModules> プロパティの設定
旧バージョンを使用する場合、DEXTUpload.NET Professionalは「Version = 4.0.2.0」に変更されていることに注意してください。
応用プログラム内でHTTPモジュールを構成します。[FileUploadMonitorModule]は大容量ファイルアップロード機能を使用するよう設定してください。

[参考]
実行時、「レジストリーキーHKEY_CLASSES_ROOT\DEXTUpload.NET.Baseへのアクセスが拒否されました」というメッセージが表示された場合。
DEXTUpload.NET ProfessionalはCOM+応用プログラムとして実行されます。COM+構成要素サービスに登録されていない場合にこのようなエラーが発生します。
RegSvcs.exeを使ってマニュアルで登録を行ってください。

Copyright © DEVPIA Corporation. All rights reserved.


単一ファイルのアップロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ 単一ファイルのアップロード

転送するフォームがあるページは次のようなフォーマットで作成されます。

入力フォームページ

<%@ Page ... %>

<HTML>

<BODY>

<FORM NAME="writeform" METHOD="post" ACTION="SimpleUpload_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">

<INPUT TYPE="file" NAME="file1"><BR>

<INPUT TYPE="submit" VALUE="upload">

</FORM>

</BODY>

</HTML>

Formタグに指定された ENCTYPE="multipart/form-data"は、ファイルデータ[input type="file" NAME="File1"]を含むフォームを転送するために必ず必要なプロパティなため、省略することはできません。

DEXTUpload.NET Professionalの大容量ファイルアップロード機能を使用するためには、フォームタグのactionのプロパティで、必ず[ファイル名.aspx]の後ろにQueryStringとして[ProgressID=0]という文字列を付け加えてください。
そうでなければASP.NETのデフォルトのファイルアップロード方式でアップロードを行うこととなります。
例) <form action="xxx.aspx?ProgressID=0" ...>

 次は、実際にファイルのアップロードなどの作業を行うページです。

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

fileUpload.Save();
//同じ構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();

}

}

…

fileUpload.Save()は、アップロードされたファイルをサーバーにディスクファイルの形で保存します。
このとき、ファイルの保存先はWeb.configに指定されたパスです。このデフォルトパスでない他のパスに保存したい場合、fileUpload.Save(“C:\Upload\”)のようにパスを指定してください。

同じくfileUpload[“file1”].Save()のように指定してもかまいません。”file1”は、[INPUT TYPE=”file” NAME=”file1”]でのNAMEのプロパティに該当する名前と同じでなければなりません。

[参考]

<INPUT TYPE="file"...> の項目がいくつかある場合
fileUpload.Save()
fileUpload.SaveAs()
fileUpload.SaveVirtual()
fileUpload.SaveAsVirtual()
fileUpload.SaveAsBlob()
fileUpload.FileLen
fileUpload.FileName
fileUpload.FilePath
fileUpload.MimeType

上記はすべてfileUpload[“file1”].xxxやfileUpload[“file1][0]と同一な表現です。複数の[INPUT TYPE=”file”…]の項目中、一番目のファイルの項目を指します。

Copyright © DEVPIA Corporation. All rights reserved.


アップロードフォルダーの自動生成

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ アップロードフォルダーの自動生成

フォルダーを自動的に生成するための別途のプロパティはありません。該当のパスにフォルダーがない場合、コンポーネント内部にて自動的に生成するようになっています。
 アップロード時、保存先のフォルダーを自動的に生成しなければならない時に便利な機能です。対象となるのはDefaultPathとSave()メソッドの系列です。

入力フォームページ

<%@ Page ... %>

<HTML>

<BODY>

<FORM NAME="writeform" METHOD="post" ACTION="SimpleUpload_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">

<INPUT TYPE="file" NAME="file1"><BR>

<INPUT TYPE="submit" VALUE="upload">

</FORM>

</BODY>

</HTML>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{
fileUpload.DefaultPath = "C:\TEMP";

fileUpload.Save("C:\Upload");
//同じ構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();

}

}

…

DefaultPathとSave()に指定されたパスにフォルダーが存在しない場合、自動的にフォルダーを生成してくれます。

Copyright © DEVPIA Corporation. All rights reserved.


多重ファイルアップロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ 多重ファイルアップロード

次の例題では、複数のファイルを同時にアップロードする方法を示しています。

入力フォームページ#1

<%@ Page ... %>

<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="MultipleUpload_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="file" NAME="file2">
<INPUT TYPE="file" NAME="file3">
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ#1

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

fileUpload[“file1”].Save();

fileUpload[“file2”].Save();
fileUpload[“file3”].Save();

}

}

…

アップロードされたファイルの参照は、”file1”、“file2”、“file3”のようなNAMEの属性値を使って行ってください。
 また、他の方法として、いくつかのINPUT項目のNAME属性を同じ値に指定した後、繰り返し文を利用して一度に保存を行うこともできます。
 次はその例です。

 入力フォームページ#2

<%@ Page ... %>

<HTML>
<BODY>
<FORM NAME="writeform" METHOD="post" ACTION="MultipleUpload_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="file" NAME="files"><BR>
<INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロードされたファイルのNAME属性値を同じに指定します。

 アップロード処理ページ#2

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

for (int i = 0; i < fileUpload["files"].Count; i++)

fileUpload["files"][i].Save();

}

}

…

上の例で、For文を次のように作成しても同じ結果を得ることができます。

foreach (DEXTUpload.NET.FormElement member in fileUpload["files"])
member.Save();

Copyright © DEVPIA Corporation. All rights reserved.


他のフォーム要素も含めてアップロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ 他のフォーム要素も含めてアップロード

フォームの他の要素についても、ファイル要素と同じようにNAME属性値を使って参照します。

入力フォームページ

<%@ Page ... %>
<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="UploadWithElements_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">
<INPUT TYPE="text" NAME="title">
<TEXTAREA NAME="content" ROWS="10" COLS="50"></TEXTAREA>
<INPUT TYPE="file" NAME="file1">
 <INPUT TYPE="submit" VALUE="upload">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

string title = fileUpload[“title”].Value;
string content = fileUpload[“content”].Value;
 fileUpload[“file1”].Save();

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


ファイルアップロードのサイズ制限

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ ファイルアップロードのサイズ制限

 MaxFileLength プロパティを使えば、アップロードが可能なファイルの最大サイズを制限することができます。
 もし指定されたサイズより大きなファイルをアップロードしようとした場合、エラーが発生します。(このプロパティを特に指定していない場合には、Web.configのmaxFileLengthの設定値がデフォルト値として使用されます。)

次の例は、FileLength プロパティを使って、ファイルの最大サイズを超過しない場合にのみSave()メソッドを呼び出す方法を示しています。
この場合、エラーを起こさずにアップロードファイルサイズを制限する処理をカスタマイズできます

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

fileUpload.MaxFileLength = 5242880; //単位は Byte

if (fileUpload["file1"].FileLength > fileUpload.MaxFileLength)

{

Response.Write("File size must be less than 5MBytes.<br>");

Response.Write("Press the back button on your browser...<br>");

}

else

{

fileUpload["file1"].Save();

}

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


イメージファイルのサイズを得る

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ イメージファイルのサイズを得る

 アップロードされたイメージファイルの幅と高さの情報を表示します。
 対応している拡張子は、BMP, EMF, EXIF, GIF, Icon, JPEG, PNG, TIFF, WMFなどとなります。
 下の例ではフォーマットの種類やサイズのみに対応しており、より詳しい情報についてはImageProcオブジェクトを使って確認してください。
[HOT]
ImageProc オブジェクトが新しく追加されました。
 このオブジェクトを使用することにより、イメージのウォーターマークやサムネイルイメージの生成、イメージのフォーマット変換など、各種のイメージ処理が可能になります。
 詳細については使用説明書の 「イメージ処理」を参照ください。

 入力フォームページ

<%@ Page ... %>
<HTML>
<BODY>
<FORM NAME="write_form" METHOD="post" ACTION="GetImageSize_Process.aspx?ProgressID=0" ENCTYPE="multipart/form-data">
<INPUT TYPE="file" NAME="file1">
<INPUT TYPE="submit" VALUE="upload" NAME="Submit1">
</FORM>
</BODY>
</HTML>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{
string UploadedPath = fileUpload.Save();

Response.Write("Original Path (Client) : " + fileUpload.FilePath + "<br>");
Response.Write("Uploaded Path (Server) : " + UploadedPath + "<br>");
Response.Write("File Length : " + fileUpload.FileLength + " byte(s)<br>");
Response.Write("File MimeType : " + fileUpload.MimeType + "<br>");
Response.Write("<b>Image Format : </b>" + fileUpload.ImageFormat + "<br>");
Response.Write("<b>Image Width : </b>" + fileUpload.ImageWidth + "<br>");
Response.Write("<b>Image Height : </b>" + fileUpload.ImageHeight);

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


データベースBLOBフィールドにアップロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ データベースBLOBフィールドにアップロード

次のようにSaveAsBlob()メソッドを用いることにより、ファイルをアップロードしてデータベースBLOBフィールドに保存することができます。
サンプルの実行時にDEXTUpload.mdbにアクセスできない場合には、ファイルのセキュリティタブでUserアカウントに書き込み権限を与えてください。

BLOB処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

string ConnectionString = "…”;

OleDbConnection cn = new OleDbConnection(ConnectionString);

cn.Open();

string strQuery = "SELECT filename, filesize, filedata FROM DEXTUPLOAD";

OleDbDataAdapter adapter = new OleDbDataAdapter(strQuery, cn);

adapter.InsertCommand = new OleDbCommand("INSERT INTO DEXTUPLOAD(filedata, filename, filesize) VALUES (?, ?, ?)", cn);

adapter.InsertCommand.Parameters.Add(…);

adapter.InsertCommand.Parameters.Add(…);

adapter.InsertCommand.Parameters.Add(…);

adapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;

DataSet ds = new DataSet();

adapter.Fill(ds);

DataRow newRow = ds.Tables[0].NewRow();

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

newRow[0] = fileUpload.FileName;

newRow[1] = fileUpload.FileLength;

newRow[2] = fileUpload.SaveAsBlob();

ds.Tables[0].Rows.Add(newRow);

adapter.Update(ds);

}

cn.Close();

}

…

※Database BLOB関連 Methodでは次のようなものなどがあります。
FileUpload オブジェクトの SaveAsBlob : ファイルをアップロードして Database BLOB フィールドに保存します
FileUpload オブジェクトの SaveAsBlobStream : ファイルをアップロードして Database BLOB フィールドに保存する時、FileStream オブジェクトを使うようにします
FileDownload オブジェクトの DownloadBlob : Database BLOBを使用者のディスクでダウンしてファイルで保存します。

Copyright © DEVPIA Corporation. All rights reserved.


ASP.NET方式でアップロードする

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ ASP.NET方式でアップロードする
ASP.NETで、File Fieldコントロールとボタンコントロールをサーバーコントロールとして使用し、ひとつのASPXファイル内(.csファイルを利用)でファイルアップロードをすべて処理する例です。

入力フォームページ(SimpleUploadASPNET.aspx)

<%@ Page ... %>
......
<form id="SimpleUploadASPNET" name="SimpleUploadASPNET" method="post" action="?ProgressID=0" encType="multipart/form-data" runat="server">
<INPUT id="file1" type="file" name="file1" runat="server"><br>
<asp:Button id="Upload" runat="server" Text="Upload"></asp:Button><br><br>
<asp:Label id="Result" runat="server" Width="692px" Height="135px"></asp:Label>
</form>

アップロード処理ページ(SimpleUploadASPNET.aspx.cs)

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

fileUpload.Save();
//同じ構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


ネットワークパスに対するファイルのアップロード･ダウンロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional プログラミング

■ ネットワークパスに対するファイルのアップロード･ダウンロード

ファイルのアップロード(ダウンロード)作業を行うウェブサーバと、アップロードしたファイルが保存される(ダウンロードするファイルが保存されている)ファイルサーバを別のコンピュータに置きたい場合には、次のようなネットワークパスへのアクセスのための設定が追加として必要となります。

 次は、各サーバで設定すべき項目です。

1. ウェブサーバとファイルサーバ（共通）
1). 匿名アクセスのための新しいゲストアカウントを生成し、パスワードも入力します(両サーバのアカウント及びパスワードは同じでなければなりません。)
2) "パスワードの変更不可"及び"パスワードの使用期限を設定しない"という２つの欄のみをチェックします。
"次回のログオン時に必ずパスワードを変更する"、"アカウントを使用しない"、"アカウントがロックされている"という項目にはチェックしないでください。
3) 生成されたアカウントの所属グループの欄から既に基本的に追加されている"Users"グループを削除し、"Guests"グループを追加します。

4) ローカルセキュリティの設定の欄で、このアカウントに"ローカルログオン"権限を与えます。

2. ウェブサーバの設定
1) インターネットサービスマネージャを実行し、該当ウェブサイトのディレクトリのプロパティ表示ウィンドウを開きます。
2) "ディレクトリセキュリティ"タブで"匿名アクセス及び認証制御"の欄にある"エディット"ボタンをクリックします。
3) "匿名アクセス"の欄にある"エディット"ボタンをクリックし、先ほど生成したアカウント名とパスワードを「匿名ユーザ名」及び「パスワード」欄に入力します。ただし、ここで忘れずに"IISでパスワードを制御できる"欄のチェックを外してください。

3. ファイルサーバの設定
1) ファイルサーバのアップロードフォルダのディレクトリのプロパティ表示ウィンドウを開きます。
2) "共有"タブの使用権限と"セキュリティ"タブの使用権限の両方に、先ほど生成したアカウントを追加します。
3) このとき、"共有"タブでの使用権限としては"読み込み"と"変更"を、"セキュリティ"タブでの使用権限としては"読み込み"、"書き込み"、"修正"の権限を指定します。
以上1, 2, 3の手順に従いウェブサーバー及びファイルサーバーを設定してから、物理的な絶対パス値を必要とするプロパティやメソッドに次のような簡単なネットワークパスを指定すれば、ファイルのアップロードやダウンロードを行うことができるようになります。

例1) fileUpload.DefaultPath = "\\ファイルサーバー名\共有フォルダー名";
例2) fileUpload["file1"].SaveAs("\\ファイルサーバー名\共有フォルダー名\Sample.zip");
例3) fileDownload.Download("\\ファイルサーバー名\共有フォルダー名\Sample.zip");

[参考]
 例外: 「System.UnauthorizedAccessException: \\211.240.100.92\Temp\B.txtパスに対するアクセスが拒否されました。」

アップロード時に上記のような例外が発生した場合には次の事項を確認してください。

ASP.NETは基本的にASPNETアカウントで作動するため、次のような設定を行う必要があります。
ASPNETアカウントを使って実行せずに、ウェブサーバーに指定されたアカウントよりアクセスしようとする場合は、web.configを次のように追加設定してください。

[identity impersonate = "true" /]を[system.web]と[/system.web]の間に追加します。
詳しくはMSDNの「identity要素」を参照してください。

Copyright © DEVPIA Corporation. All rights reserved.


アップロードタイムアウトの設定

DEXTUpload.NEt Professional

DEXTUpload.NET Professional　プログラミング

■ アップロードタイムアウトの設定

 通常、ファイルのアップロードまたは保存などといった作業は、大容量ファイルのアップロード時に長時間が必要となり、Server.ScriptTimeout(Default: 90sec)とSession.Timeout(Default: 20min)の値を変えない場合、タイムアウトエラーにより作業を正常に行うことができなくなります。

 DEXTUpload Professionalの場合、UploadTimeout プロパティを用い、ファイルをアップロードする際、別のServer.ScriptTimeout,やSession.Timeoutを設定しなくてもタイムアウトエラーを起こすことなく大容量ファイルのアップロード作業を正常に行うことができます。デフォルトの値は3600sec(60min)ですが、必要に応じて変更することができます。

入力フォームページ

<%@ Page ... %>
......
<form name="LimitTimeout" method="post" action="LimitTimeout.aspx_Process?ProgressID=0" encType="multipart/form-data">
<INPUT type="file" name="file1"><br>
<input type="submit" name="Upload" value="Upload">
</form>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{
// アップロードタイムアウト時間を1200秒に設定
// 1200秒が過ぎるとスクリプトタイムアウトが発生
fileUpload.UploadTimeout = 1200;

fileUpload.Save();
//同じ構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


アップロード可能なファイルの種類を制限

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ アップロード可能なファイルの種類を制限

 MimeType プロパティを用いることにより、アップロード可能なファイルの種類を制限することができます。
次は、GIFとJPGファイルだけアップロードを許容できるようにする例です。

入力フォームページ

<%@ Page ... %>
......
 <form name="RestrictFileTypes" method="post" action="RestrictFileTypes_Process.aspx?ProgressID=0" encType="multipart/form-data">
<INPUT type="file" name="file1"><br>
<input type="submit" name="Upload" value="Upload">
</form>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{
//アップロードされるファイルのmime_typeを得る
string MimeType = fileUpload["file1"].MimeType;

//.JPGか.GIFファイルである場合にのみファイルをアップロード
if (MimeType == "image/pjpeg" || MimeType == "image/jpeg" || MimeType == "image/gif")
{

fileUpload.Save();
//同じ構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();
}

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


エラー発生時、アップロードされたファイルをすべて削除

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ エラー発生時、アップロードされたファイルをすべて削除

 DeleteAllSavedFiles() メソッドを使うと、ファイルのアップロード中にエラーが発生した場合、アップロードされたファイルをすべて削除します。

入力フォームページ

<%@ Page ... %>
......
 <form name="DeleteAllSavedFiles" method="post" action="DeleteAllSavedFiles_Process.aspx?ProgressID=0" encType="multipart/form-data">
<INPUT type="file" name="file1"><br>
<input type="submit" name="Upload" value="Upload">
</form>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

try
{
string UploadedPath = fileUpload.Save();
// 同じ構文
// string UploadedPath = fileUpload["file1"].Save();
// string UploadedPath = fileUpload["file1"][0].Save();

Response.Write("<b>Upload successfully !!</b><br><br>");

// テスト用エラー発生
throw new Exception("Error Test!!! Don't worry!! It's simmulation");

}
catch (Exception ex)
{
// エラー発生時にアップロードされたすべてのファイルを削除
fileUpload.DeleteAllSavedFiles();
}

}

}

…

DeleteFile() メソッドを使うと、ファイルを選択して削除することができます。

.........
catch(Exception ex)
{
fileUpload.DeleteFile();
}
.........

Copyright © DEVPIA Corporation. All rights reserved.


サーバーに保存せずにアップロード作業をキャンセル

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ サーバーに保存せずにアップロード作業をキャンセル

 DEXTUpload.NET Professionalが提供する Flush() メソッドを使うと、ファイルをサーバーに保存せずにアップロード作業をキャンセルし、残りのコードを続けて実行するようにできます。
 次は、アップロードサイズが１MBを超える場合、アップロードをキャンセルしてエラーメッセージを表示する例です。

 アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{
// アップロードファイルのサイズを１MB以下に制限
fileUpload.MaxFileLength = 1024*1024;

 //アップロードされたファイルのサイズと制限サイズ(１MB)を比較せずにファイルを保存しようとすると、次のようなエラーが発生。
//DEXTUpload.NET.DEXTUploadException: Warning: File size must be less than 1048576 Bytes.
//よって、次のような方法でファイルを保存する前にファイルのサイズを確認します。
if (fileUpload.FileLength > fileUpload.MaxFileLength)
{
Response.Write("<b>Upload Aborted !!</b><br><br>");
Response.Write("Sorry !! File size is too large.!!<br><br>");
Response.Write("<a href=\"javascript:history.go(-1)\">[ back ]</a>");
}
else
{
string UploadedPath = fileUpload.Save();
// 同じ構文
// string UploadedPath = fileUpload["file1"].Save();
// string UploadedPath = fileUpload["file1"][0].Save();
}

}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


ユーザー定義型アップロードプログレスバー

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ ユーザー定義型アップロードプログレスバー

 DEXTUpload Professionalが提供するアップロードの進行情報オブジェクトを使用すれば、ActiveX ControlやJava Appletなどの別途のクライアントソフトウェアを使わなくても、ファイルのアップロードの進行状態を視覚的に表示し、アップロードの速度やコンテンツの全体サイズ、さらに現在アップロードが終了したコンテンツのサイズや残り時間、現在進行中の作業などの情報をリアルタイムでモニタリングできます。
アップロードプログレスバーを変更するには、サンプルプログラムより[ShowProgress.aspx]ファイルを編集して下さい。

この機能はProgressオブジェクトにより実装され、次のようなプロパティが提供されます。

TotalSize : アップロードする全体のサイズ
TransferSize : 伝送データのサイズ(Byte)
Percent : アップロードの進行率
BytesPerSec : アップロード速度(Byte/秒)
TimeLeft: 残り時間
TimeElapsed : 経過時間
isUploadClosed: trueであればアップロードが完了。falseであればIEで中止をクリックした場合。

入力フォームページ

<%@Page...%>
......
<HEAD>
<script language="javascript">
<!--
function ShowProgress()
{
strAppVersion = navigator.appVersion;

if(document.write_form.file1.value != "")
{
ProgressID = (new Date()).getTime() % 1000000;
if (ProgressID==0) ProgressID = 1000000;

winstyle = "dialogWidth=385px; dialogHeight:160px; center:yes";
window.showModelessDialog("ShowProgress.aspx?ProgressID="+ProgressID, null, winstyle);

document.write_form.action = "NewProgress_Process.aspx?ProgressID=" + ProgressID;
}

return true;
}
//-->
</script>
</HEAD>
<form name="write_form" enctype="multipart/form-data" method="post" action="NewProgress_Process.aspx?ProgressID=0" onsubmit="return ShowProgress();">
<input type="file" name="file1"><br>
<input type="submit" name="Upload" value="Upload">
</form>

アップロード処理ページ

…

private void Page_Load(object sender, System.EventArgs e)

{
using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

fileUpload.Save();
//同一な構文

// fileUpload["file1"].Save();

// fileUpload["file1"][0].Save();

}

}

…

アップロードの進行表示ページ#1(ShowProgress.aspx)

<%@Page...%>
<%
Response.Write("<meta HTTP-EQUIV='Refresh' CONTENT='1'>");

if(isUploadClosed)
{
//アップロードが完了もしくはIEで中止がクリックされた場合
Response.Write("<body onload='javascript: top.window.close();'>");
}
else
{
Response.Write("<table border=0 style='position:absolute;top:0px;left:0px; FONT-SIZE: 9pt' width=370 cellpadding=0 cellspacing=0 bgcolor=#d4d0c8>");
Response.Write("<tr>");
Response.Write(" <td colspan=2 height=5 valign=bottom><b>ファイルをアップロード中...</b></td>");
Response.Write( "</tr>");
Response.Write("<tr>");
Response.Write( " <td colspan=2 width=370>");
Response.Write( " <table style='left:10px; border:solid 1px;' width=370 height=15 cellpadding=0 cellspacing=0 bordercolor=#000000 leftmargin=0 topmargin=0>");
Response.Write( " <tr>");
Response.Write( " <td width=100% height=100% align=left valign=middle style=padding:1;>");
Response.Write( " <table height=100% cellpadding=0 cellspacing=0 width =" + (3.7*Percent) + "></td>");
Response.Write( " <tr><td bgcolor='darkblue'></td></tr>");
Response.Write( " </table>");
Response.Write( " </td>");
Response.Write( " </tr>");
Response.Write( " </table>");
Response.Write( " </td>");
Response.Write( "</tr>");
Response.Write( "<tr><td>&nbsp;</td></tr>");
Response.Write( "<tr>");
Response.Write( " <td align=left>伝送速度 : " + BytesPerSec + " MB / sec </td>");
Response.Write("&nbsp;");
Response.Write( " <td align=middle>進行率 : " + TransferSize + " MB / " + TotalSize + " MB (" + Percent + "%)</td>");
Response.Write( "</tr>");
Response.Write( "<tr><td colspan=2 height=10>Click the <b>STOP</b> button on your browser to abort uploading.</td></tr>");
Response.Write( "</table>");
Response.Flush();
}
%>

<meta HTTP-EQUIV='Refresh' CONTENT='1'> を使って1秒ごとにRefreshし、アップロードの状態に関する情報をアップデートします。

 アップロードの進行表示ページ#2(ShowProgress.aspx.cs)

public class ShowProgress : System.Web.UI.Page
{
public int TransferSize; //アップロードが終了したサイズ
public int Percent; //アップロードが終了した割合(％)
public int TimeElapsed; //経過時間
 public int TimeLeft; //残り時間
 public int TotalSize; //全体のサイズ
 public int BytesPerSec; //伝送速度(バイト/秒)
public bool isUploadClosed; //trueであればアップロードが完了。FalseであればIEで中止がクリックされた場合。

private void Page_Load(object sender, System.EventArgs e)
{
using (DEXTUpload.NET.Progress progress = new DEXTUpload.NET.Progress())
{
TransferSize = (int)Math.Round((double)progress.TransferSize / (1024*1024));
Percent = progress.Percent;
TimeElapsed = progress.TimeElapsed;
TimeLeft = progress.TimeLeft;
TotalSize = (int)Math.Round((double)progress.TotalSize / (1024*1024));
BytesPerSec = (int)Math.Round((double)progress.BytesPerSec / (1024*1024));
isUploadClosed = progress.IsUploadClosed;
}
}
}

ShowProgress.aspx.csでProgressオブジェクトを生成した後、それぞれのプロパティに関する情報を収集します。
 変数は必ずpublicに設定してください。

Copyright © DEVPIA Corporation. All rights reserved.


固定型アップロードプログレスバー

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ 固定型アップロードプログレスバー

古いバージョンのDEXTUpload.NETで提供していた方式です。

この機能は、FileUploadMonitor オブジェクトを通じて実装され、次のようなメソッドが提供されます。
ShowMonitor() : プログレスバーを表示するページ(ウィンドウ)で呼び出され、アップロードの進行状態を視覚的に表示します。

入力フォームページ (progress.aspx)

<%@ Page language="c#" Inherits="Progress" CodeFile="Progress.aspx.cs" %>

<!--

Previous Progress [ Progress.aspx ]

DEXTUpload.NETがサポートするアップロードプログレスバーを表示する例

Key Point

---------------------------------------------------------------------------------------------------------------

1. ファイルをアップロードするには、<form>タグで必ずencType="multipart/form-dataのプロパティを次のように設定してください。

<form name="write_form" enctype="multipart/form-data" ....>

2. DEXTUpload.NETの大容量ファイルアップロード機能を使用するには、<form>タグのactionのプロパティで、

必ず"ファイル名.aspx"の後ろにQueryStringとして“ProgressID=0”という文字列を加えてください。

これを行わない場合には、ASP.NETのデフォルトのアップロード方式でファイルがアップロードされることとなります。

<form action="xxx.aspx?ProgressID=0" ...>

3. <form>タグに〝onsubmit="return ShowProgress();"を追加します。

4. navigator.appVersionの値によってIEかNetscapeかをチェックし、異なるプログレスバーを表示します。

-->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<title></title>

<meta content="text/html; charset=utf-8" http-equiv="content-Type" />

<link rel="Stylesheet" type="text/css" href="../../../Styles/Default.css"/>

<script type="text/javascript">

<!--

function ShowProgress() {

try {

var progressId = (new Date()).getTime() % 1000000;

if (progressId == 0) progressId = 1000000;

window.open("ShowDefaultProgress.aspx?ProgressID=" + progressId, null, "width=400,height=200,status=no,memubar=no");

var frmObj = document.getElementById("write_form");

frmObj.action = "DefaultProgress_Process.aspx?ProgressID=" + progressId;

return true;

} catch (e) {

alert(e.Message);

return false;

}

}

-->

</script>

</head>

<body>

<form id="write_form" enctype="multipart/form-data" method="post" action="DefaultProgress_Process.aspx?ProgressID=0" onsubmit="return ShowProgress();">

<div class="leftTopIndentOne">

<p><span class="bold">Previous Progress Bar</span></p>

<p><span class="bold">Select the file to upload.</span></p>

<p><input type="file" id="file1" name="file1"/></p>

<ol class="innerList">

<li>アップロードファイルの保存先は<span class="bold">C:\TEMP</span>です。</li>

<li>[参照]に対応していないブラウザーをご使用の場合、最新バージョンのブラウザーにアップデートしてください。</li>

<li>アップロードフォルダーが存在しない場合には自動的に生成されます。<span class="bold">(defaultpath, save())</span></li>

<li>これは、ファイルアップロード中にDEXTUpload.NETコンポーネントがサポートするアップグレードプログレスバーを表示する例です。 </li>

</ol>

<p><input type="submit" name="Upload" value="Upload"/></p>

</div>

</form>

</body>

</html>

プログレスバーを使用するには、上記の例のとおり、ShowProgress()のようなジャバスクリプトを追加する必要があります。
フォームをSubmitする直前にShowProgress()という関数を呼び出し、プログレスバーを視覚的に表示するために新しいウィンドウ(またはダイアログ)を表示させます。

このとき、新しいウィンドウに表示されるページは、次の通りです。

アップロード進行表示ページ (ShowDefaultProgress.aspx)

<%@ Page language="c#" EnableSessionState="false" Inherits="ShowDefaultProgress" CodeFile="ShowDefaultProgress.aspx.cs" %>

上のASPXページをみると、EnableSessionStateのプロパティをFalseに指定してセッション状態を解除しています。もし、このページのセッションを解除しない場合、フォームのSubmit作業、つまり、ファイルのアップロード作業が終了するまではページの実行結果を見ることができなくなるため、必ずページのセッション状態を解除することを推奨します。

ShowMonitor()メソッドは、毎瞬間のアップロードの進行状態を表示し、アップロードが完了すると自動的にウィンドウ(または、ダイアログ)を閉じます。

アップロード処理ページ (DefaultProgress_Process.aspx.cs)

public partial class DefaultProgress_Process : System.Web.UI.Page

{

protected void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

string UploadedPath = fileUpload.Save();

//同じ構文

//UploadedPath = fileUpload.Save(fileUpload.DefaultPath,false);

//UploadedPath = fileUpload["file1"].Save(fileUpload.DefaultPath,false);

//UploadedPath = fileUpload["file1"][0].Save();

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>LastSavedFileName(Server) : {0}</p>

<p>Original Path (Client) : {1}</p>

<p>Uploaded Path (Server) : {2}</p>

<p>File Length : {3}byte(s)</p>

<p>File MimeType : {4}</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.LastSavedFileName,

fileUpload.FilePath,

UploadedPath,

fileUpload.FileLength,

fileUpload.MimeType);

}

}

}

アップロード作業を処理するページは、プログレスバーの使用有無とは関係なく同一に作成してください。

Copyright © DEVPIA Corporation. All rights reserved.


ファイルのダウンロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ ファイルのダウンロード

 FileDownload オブジェクトのDownload()、DownloadVirtual()、DownloadBlob()メソッドを用いることにより、ユーザーはサーバーにあるファイルをウェブブラウザーを通じてダウンロードすることができます。
Download() : サーバーの指定パスにあるファイルをダウンロードします。バーチャルパスをサポートしているため、DownloadVirtual()メソッドを使う必要がありません。
DownloadVirtual() : サーバーの指定されたバーチャルパスにあるファイルをダウンロードします。旧バージョンとの互換性のために残されています。
DownloadBlob() : データベースのBLOBデータをダウンロードします。

ダウンロード処理ページ

private void Page_Load(object sender, System.EventArgs e)
{
string FileName = Request.QueryString["filename"]; //ファイル名
string FilePath = Request.QueryString["filepath"]; //ダウンロード先

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
//objDownload.Download(ファイルのパス、ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード))
fileDownload.Download(FilePath, FileName, false, true);
}
}

Copyright © DEVPIA Corporation. All rights reserved.


ファイルの強制保存

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ ファイルの強制保存

ダウンロードデータを常にファイルとして保存するため、ウェブブラウザーは保存ダイアログを出力します。

 ダウンロード処理ページ

private void Page_Load(object sender, System.EventArgs e)
{
string FileName = Request.QueryString["filename"]; //ファイル名
string FilePath = Request.QueryString["filepath"]; //ダウンロード先

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
//objDownload.Download(ファイルのパス、ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード))
fileDownload.Download(FilePath, FileName, true, false);
}
}

Copyright © DEVPIA Corporation. All rights reserved.


ファイルを続けてダウンロード

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ ファイルを続けてダウンロード

ユーザーによるキャンセル、あるいはネットワークトラブルにより中止されたダウンロードを再開する場合、ダウンロードが中断された時点のデータに続けてダウンロードを開始します。

ダウンロード処理ページ

private void Page_Load(object sender, System.EventArgs e)
{
string FileName = Request.QueryString["filename"]; //ファイル名
string FilePath = Request.QueryString["filepath"]; //ダウンロード先

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
//objDownload.Download(ファイルのパス、ファイル名、強制保存の有無(True:強制保存)、続けてダウンロードの有無(True:続けてダウンロード))
fileDownload.Download(FilePath, FileName, false, true);
}
}

Copyright © DEVPIA Corporation. All rights reserved.


データベースBLOBをダウンロードする

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ データベースBLOBをダウンロードする

FileDownloadオブジェクトのDownloadBlob()メソッドを用いることにより、サーバーにあるデータベースBLOBデータをダウンロードすることができます。
BLOBフィールドをダウンロードする際、続けてダウンロードはお使いいただけません。

ダウンロード処理ページ

private void Page_Load(object sender, System.EventArgs e)
{
OleDbConnection cn = null;
OleDbDataReader dataReader = null;

string FileID = Request.QueryString["fileid"];
string ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Password=\"\";User ID=Admin;Data Source=C:\\Program Files\\Devpia\\DEXTUploadNETProSamples\\DEXTUPLOAD.mdb";
cn = new OleDbConnection(ConnectionString);
cn.Open();

string strQuery = "SELECT filename, filesize, filedata FROM DEXTUPLOAD WHERE fileid = " + FileID;
OleDbCommand cmd = new OleDbCommand(strQuery, cn);
dataReader = cmd.ExecuteReader(CommandBehavior.SequentialAccess);

if (dataReader.Read())
{
string FileName = dataReader.GetString(0);
int FileSize = dataReader.GetInt32(1);

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
fileDownload.DownloadBlob(dataReader, 2, FileName, FileSize, true);
}
}

dataReader.Close();
cn.Close();
}

[参考]
※Database BLOB関連 Methodでは次のようなものなどがあります。
FileUpload オブジェクトの SaveAsBlob : ファイルをアップロードして Database BLOB フィールドに保存します
FileUpload オブジェクトの SaveAsBlobStream : ファイルをアップロードして Database BLOB フィールドに保存する時、FileStream オブジェクトを使うようにします
FileDownload オブジェクトの DownloadBlob : Database BLOBを使用者のディスクでダウンしてファイルで保存します。

Copyright © DEVPIA Corporation. All rights reserved.


ウォーターマークイメージを生成

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ ウォーターマークイメージを生成

ImageProc オブジェクトは、ウォーターマーク処理やファイルフォーマットの変換、サムネイル機能などを行います。
SetSourceFile() メソッドは、指定されたファイルがイメージファイルであればtrueを表示し、イメージオブジェクトを初期化します。

下のコードは、アップロードされたイメージファイルにウォーターマーク処理を行う場合です。

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

// ウォーターマーク処理を行うには、イメージ関連オブジェクトを生成しなければなりません。

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

// 原本イメージファイルのパス

string imgFilePath = fileUpload.TempFilePath;

int positionX = 0;

int positionY = 0;

bool overWrite = false;

float alpha = 0.32f;

// ロゴイメージ

string logoImage = "watermark.bmp";

// イメージウォーターマークファイル名

string watermarked1Path = "../Data/" + filename + "(image).jpg";

// 位置及び上書き保存設定

positionX = -10; //座標 : (+) 左側 (-) 右側

positionY = 10; //座標 : (+) 上端 (-) 下端

overWrite = false; //上書き保存有無

string uploadPath1 = imgProc.SaveAsWaterMarkImage(imgFilePath, logoImage, watermarked1Path ,positionX, positionY, overWrite);

if (fileUpload.Version.StartsWith("4"))

{

// 4.x.x.x 以降のバージョンのみ支援します

watermarked1Path = "../Data/" + filename + "(image_50).jpg";

alpha = 0.5f;

string uploadPath2 = imgProc.SaveAsWaterMarkImage(imgFilePath, logoImage, watermarked1Path, positionX, positionY, alpha, overWrite);

// テキストウォーターマークファイル名

string watermarked2Path = "../Data/" + filename + "(text).jpg";

int fontSize = 20;

string fontStyle = "bold";

string Copyright = "DEVPIA(Developer Utopia!!!)";

// 位置及び上書き保存設定

positionX = 0; //座標 : (+) 左側 (-) 右側

positionY = 0; //座標 : (+) 上端 (-) 下端

overWrite = false; //上書き保存有無

string uploadPath3 = imgProc.SaveAsWaterMarkText(imgFilePath, Copyright, watermarked2Path, positionX, positionY, fontSize, fontStyle, overWrite);

watermarked2Path = "../Data/" + filename + "(text_100).jpg";

alpha = 1.0f;

string uploadPath4 = imgProc.SaveAsWaterMarkText(imgFilePath, Copyright, watermarked2Path, positionX, positionY, alpha, fontSize, fontStyle, overWrite);

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>Original Path (Client) : {0}</p>

<p>File Length : {1}byte(s)</p>

<p>File MimeType : {2}</p>

<p>&nbsp;</p>

<p>Image Watermark Path (Server) : {3}</p>

<p><img src=""../Data/{3}""/></p><p>&nbsp;</p>

<p>Image Watermark Path (Server, 50%) : {4}</p>

<p><img src=""../Data/{4}""/></p><p>&nbsp;</p>

<p>Text Wartermark Path (Server) : {5}</p>

<p><img src=""../Data/{5}""/></p><p>&nbsp;</p>

<p>Text Wartermark Path (Server, 50%) : {6}</p>

<p><img src=""../Data/{6}""/></p><p>&nbsp;</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.FilePath,

fileUpload.FileLength,

fileUpload.MimeType,

Path.GetFileName(uploadPath1),

Path.GetFileName(uploadPath2),

Path.GetFileName(uploadPath3),

Path.GetFileName(uploadPath4));

}

else

{

// 3.x.x.x バージョン用

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>Original Path (Client) : {0}</p>

<p>File Length : {1}byte(s)</p>

<p>File MimeType : {2}</p>

<p>&nbsp;</p>

<p>Image Watermark Path (Server) : {3}</p>

<p><img src=""../Data/{3}""/></p><p>&nbsp;</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.FilePath,

fileUpload.FileLength,

fileUpload.MimeType,

Path.GetFileName(uploadPath1));

}

}

else

{

this.OutputText.Text = @"

<p>Image File Mismatch!!</p>

<p>" + fileUpload.FileName + ": Image File Type is mismatch";

}

}

}

Copyright © DEVPIA Corporation. All rights reserved.


イメージファイルをサムネイル処理する

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ イメージファイルをサムネイル処理する

下のコードは、アップロードしたイメージファイルのサムネイルイメージを生成する例です。
生成されたイメージはJPGフォーマットとなります。

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

// 作業の対象となるイメージファイルを設定します。

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

// 100x100 サムネイル

int nWidth = 100;

int nHeight = 100;

// 原本イメージファイルのパス

string imgFilePath = fileUpload.TempFilePath;

// サムネイル イメージのファイル名

string thumbPath = "../Data/" + filename + "(thumb_100x100).jpg";

string UploadedPath1 = imgProc.SaveAsThumbnail(imgFilePath, thumbPath, nWidth, nHeight, false);

if (fileUpload.Version.StartsWith("4"))

{

// 4.x.x.x 以降のバージョンのみ支援します

nWidth = 50;

nHeight = 25;

thumbPath = "../Data/" + filename + "(thumb_50x25percent).jpg";

string UploadedPath2 = imgProc.SaveAsThumbnail(imgFilePath, thumbPath, nWidth, nHeight, true, true, false, true);

nWidth = 64;

nHeight = 0;

thumbPath = "../Data/" + filename + "(thumb_64_perservedAspectRatio).jpg";

string UploadedPath3 = imgProc.SaveAsThumbnail(imgFilePath, thumbPath, nWidth, nHeight, true, false, true, true);

int frameW = 200;

int frameH = 100;

thumbPath = "../Data/" + filename + "(thumb_200x100_Uniform).jpg";

string UploadedPath4 = imgProc.SaveAsThumbnail(

imgFilePath, thumbPath, frameW, frameH, true,

DEXTUpload.NET.ImageFitOption.Uniform, DEXTUpload.NET.ImageHorizontalAlignment.Center, DEXTUpload.NET.ImageVerticalAlignment.Center, System.Drawing.Color.White, true);

thumbPath = "../Data/" + filename + "(thumb_200x100_UniformToFill).jpg";

string UploadedPath5 = imgProc.SaveAsThumbnail(

imgFilePath, thumbPath, frameW, frameH, true,

DEXTUpload.NET.ImageFitOption.UniformToFill, DEXTUpload.NET.ImageHorizontalAlignment.Center, DEXTUpload.NET.ImageVerticalAlignment.Center, System.Drawing.Color.White, true);

thumbPath = "../Data/" + filename + "(thumb_200x100_UniformToFit).jpg";

string UploadedPath6 = imgProc.SaveAsThumbnail(

imgFilePath, thumbPath, frameW, frameH, true,

DEXTUpload.NET.ImageFitOption.UniformToFit, DEXTUpload.NET.ImageHorizontalAlignment.Center, DEXTUpload.NET.ImageVerticalAlignment.Center, System.Drawing.Color.Green, true);

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>Original Path (Client) : {0}</p>

<p>File Length : {1}byte(s)</p>

<p>File MimeType : {2}</p>

<p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server fixed) : {3}</p>

<p><img src=""../Data/{3}""/></p><p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server percentage) : {4}</p>

<p><img src=""../Data/{4}""/></p><p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server preservedAspectRatio) : {5}</p>

<p><img src=""../Data/{5}""/></p><p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server uniform) : {6}</p>

<p><img src=""../Data/{6}""/></p><p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server uniform_fill) : {7}</p>

<p><img src=""../Data/{7}""/></p><p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server uniform_fit) : {8}</p>

<p><img src=""../Data/{8}""/></p><p>&nbsp;</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.FilePath,

fileUpload.FileLength,

fileUpload.MimeType,

Path.GetFileName(UploadedPath1),

Path.GetFileName(UploadedPath2),

Path.GetFileName(UploadedPath3),

Path.GetFileName(UploadedPath4),

Path.GetFileName(UploadedPath5),

Path.GetFileName(UploadedPath6));

}

else

{

// 3.x.x.x バージョン用

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>Original Path (Client) : {0}</p>

<p>File Length : {1}byte(s)</p>

<p>File MimeType : {2}</p>

<p>&nbsp;</p>

<p>Thumbnail Image Uploaded Path (Server fixed) : {3}</p>

<p><img src=""../Data/{3}""/></p><p>&nbsp;</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.FilePath,

fileUpload.FileLength,

fileUpload.MimeType,

Path.GetFileName(UploadedPath1));

}

}

else

{

this.OutputText.Text = @"

<p>Image File Mismatch!!</p>

<p>" + fileUpload.FileName + ": Image File Type is mismatch";

}

}

}

Copyright © DEVPIA Corporation. All rights reserved.


イメージファイルフォーマットを別のフォーマットに変換する

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ イメージファイルフォーマットを別のフォーマットに変換する

下のコードでは、BMPフォーマットをJPGフォーマットに変換して保存しています。BMPやJPG、GIFなど、他のフォーマットへの変換も可能です。

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

//作業の対象となるイメージファイルを指定します。

//trueの場合はConvertIamgeFormat()メソッドが呼び出されます。

//イメージファイルでない場合にはfalseと表示されます。

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

bool bOverWrite = false;

// 対応している変換フォーマット

// image/jpg,

// image/bmp,

// image/gif

string imgFilePath = fileUpload.TempFilePath;

//アップロードファイルをJPGフォーマットに変換して保存します。

string UploadedPath =imgProc.ConvertImageFormat(imgFilePath, "image/jpg", Path.Combine(fileUpload.DefaultPath, filename + ".jpg"), bOverWrite);

string FileName = imgProc.SavedFileName;

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p>Original Path (Client) : {0}</p>

<p>Uploaded Path (Server) : {1}</p>

<p>File Length : {2}byte(s)</p>

<p>File MimeType : {3}</p>

<p>Saved File Name: {4}</p>";

this.OutputText.Text = string.Format(

outputFormat,

fileUpload.FilePath,

UploadedPath,

fileUpload.FileLength,

fileUpload.MimeType,

imgProc.SavedFileName);

}

else

{

Response.Write("<b>Image File Mismatch!!</b><br><br>");

Response.Write(fileUpload.FileName + ": Image File Type is mismatch");

}

}

}

Copyright © DEVPIA Corporation. All rights reserved.


イメージファイル情報

DEXTUpload.NET Professional

DEXTUpload.NET Professional　プログラミング

■ イメージファイル情報

イメージファイルに関する露出時間、イメージの詳細、解像度など、各種のメタデータに対応しています。

using(DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc();

//作業の対象となるイメージファイルを指定します。

//trueの場合はSave()メソッドが呼び出されます。

//イメージファイルでない場合にはfalseと表示されます。

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

string UploadedPath = fileUpload.Save();

if (fileUpload.Version.StartsWith("4"))

{

// 4.x.x.x 以降のバージョンのみ支援します

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p><span class=""bold"">Image File Information</span></p>

<table style='font-family:맑은고딕;font-size:9pt;'>

<tr><td>ImageWidth</td><td>{0}</td></tr>

<tr><td>ImageHeight</td><td>{1}</td></tr>

<tr><td>HorizontalResolution</td><td>{2}</td></tr>

<tr><td>VerticalResolution</td><td>{3}</td></tr>

<tr><td>PixelFormat</td><td>{4}</td></tr>

<tr><td>MDArtist</td><td>{5}</td></tr>

<tr><td>MDDateTime</td><td>{6}</td></tr>

<tr><td>MDDateTimeOrig</td><td>{7}</td></tr>

<tr><td>MDDocumentName</td><td>{8}</td></tr>

<tr><td>MDEquipMake</td><td>{9}</td></tr>

<tr><td>MDEquipModel</td><td>{10}</td></tr>

<tr><td>MDExifColorSpace</td><td>{11}</td></tr>

<tr><td>MDExifDigitalZoomRatio</td><td>{12}</td></tr>

<tr><td>MDExifExposureBias</td><td>{13}</td></tr>

<tr><td>MDExifExposureMode</td><td>{14}</td></tr>

<tr><td>MDExifExposureProg</td><td>{15}</td></tr>

<tr><td>MDExifExposureTime</td><td>{16}</td></tr>

<tr><td>MDExifFlash</td><td>{17}</td></tr>

<tr><td>MDExifFNumber</td><td>{18}</td></tr>

<tr><td>MDExifFocalLength</td><td>{19}</td></tr>

<tr><td>MDExifFocalLengthIn35mm</td><td>{20}</td></tr>

<tr><td>MDExifISOSpeed</td><td>{21}</td></tr>

<tr><td>MDExifLightSource</td><td>{22}</td></tr>

<tr><td>MDExifMaximumLensApecture</td><td>{23}</td></tr>

<tr><td>MDExifMeteringMode</td><td>{24}</td></tr>

<tr><td>MDExifShutterSpeed</td><td>{25}</td></tr>

<tr><td>MDExifWhiteBalance</td><td>{26}</td></tr>

<tr><td>MDImageDescription</td><td>{27}</td></tr>

<tr><td>MDSoftwareUsed</td><td>{28}</td></tr>

</table>

<p>&nbsp;</p>

<p><span class=""bold"">File Upload Information</span></p>

<p>Original Path (Client) : {29}</p>

<p>Uploaded Path (Server) : {30}</p>

<p>File Length : {31}byte(s)</p>

<p>File MimeType : {32}</p>";

this.OutputText.Text = string.Format(

outputFormat, // format

imgProc.ImageWidth,

imgProc.ImageHeight,

imgProc.HorizontalResolution,

imgProc.VerticalResolution,

imgProc.PixelFormat,

imgProc.MDArtist,

imgProc.MDDateTime,

imgProc.MDDateTimeOrig,

imgProc.MDDocumentName,

imgProc.MDEquipMake,

imgProc.MDEquipModel,

imgProc.MDExifColorSpace,

imgProc.MDExifExifDigitalZoomRatio,

imgProc.MDExifExposureBias,

imgProc.MDExifExposureMode,

imgProc.MDExifExposureProg,

imgProc.MDExifExposureTime,

imgProc.MDExifFlash,

imgProc.MDExifFNumber,

imgProc.MDExifFocalLength,

imgProc.MDExifFocalLengthIn35mm,

imgProc.MDExifISOSpeed,

imgProc.MDExifLightSource,

imgProc.MDExifMaximumLensApecture,

imgProc.MDExifMeteringMode,

imgProc.MDExifShutterSpeed,

imgProc.MDExifWhiteBalance,

imgProc.MDImageDescription,

imgProc.MDSoftwareUsed,

fileUpload.FilePath,

UploadedPath,

fileUpload.FileLength,

fileUpload.MimeType,

imgProc.SavedFileName);

}

else

{

// 3.x.x.x バージョン用

string outputFormat = @"

<p>Upload successfully !!</p>

<p>&nbsp;</p>

<p><span class=""bold"">Image File Information</span></p>

<table style='font-family:맑은고딕;font-size:9pt;'>

<tr><td>ImageWidth</td><td>{0}</td></tr>

<tr><td>ImageHeight</td><td>{1}</td></tr>

<tr><td>HorizontalResolution</td><td>{2}</td></tr>

<tr><td>VerticalResolution</td><td>{3}</td></tr>

<tr><td>PixelFormat</td><td>{4}</td></tr>

<tr><td>MDArtist</td><td>{5}</td></tr>

<tr><td>MDDateTime</td><td>{6}</td></tr>

<tr><td>MDDocumentName</td><td>{7}</td></tr>

<tr><td>MDEquipMake</td><td>{8}</td></tr>

<tr><td>MDEquipModel</td><td>{9}</td></tr>

<tr><td>MDExifExposureTime</td><td>{10}</td></tr>

<tr><td>MDExifFNumber</td><td>{11}</td></tr>

<tr><td>MDExifShutterSpeed</td><td>{12}</td></tr>

<tr><td>MDImageDescription</td><td>{13}</td></tr>

<tr><td>MDSoftwareUsed</td><td>{14}</td></tr>

</table>

<p>&nbsp;</p>

<p><span class=""bold"">File Upload Information</span></p>

<p>Original Path (Client) : {15}</p>

<p>Uploaded Path (Server) : {16}</p>

<p>File Length : {17}byte(s)</p>

<p>File MimeType : {18}</p>";

this.OutputText.Text = string.Format(

outputFormat, // format

imgProc.ImageWidth,

imgProc.ImageHeight,

imgProc.HorizontalResolution,

imgProc.VerticalResolution,

imgProc.PixelFormat,

imgProc.MDArtist,

imgProc.MDDateTime,

imgProc.MDDocumentName,

imgProc.MDEquipMake,

imgProc.MDEquipModel,

imgProc.MDExifExposureTime,

imgProc.MDExifFNumber,

imgProc.MDExifShutterSpeed,

imgProc.MDImageDescription,

imgProc.MDSoftwareUsed,

fileUpload.FilePath,

UploadedPath,

fileUpload.FileLength,

fileUpload.MimeType,

imgProc.SavedFileName);

}

}

else

{

Response.Write("<b>Image File Mismatch!!</b><br><br>");

Response.Write(fileUpload.FileName + ": Image File Type is mismatch");

}

}

各プロパティに関する内容についてはImageProcオブジェクトのリファレンスを参考にしてください。

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadオブジェクト

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FileUploadオブジェクト

実際にファイルをアップロードしてサーバーに保存する機能を担当する、コンポーネントの最も核心となるオブジェクトです。

プロパティ

名前 | 説明
CodePage | アップロードコンポーネントを使って内部的にデータを処理する際に使用するCodePageを指定します。
DefaultPath | 一時ファイルおよびアップロードファイルを保存するデフォルトパスを指定する際に使用します。
ExpirationDate | 評価版の使用期限を表示します。正規版の場合には[Unlimited]という文字列が表示されます。
FileLength | アップロードファイルの長さを表示します。(単一ファイル)
FileName | アップロードファイルの名前(パスを除く)を表示します。
FileExtension | アップロードファイルの拡張子を表示します。
FilePath | アップロードファイルのフルパスを表示します。
Form | Submitされたフォームの各項目に関する情報を保存するFormItems Collectionオブジェクト
ImageFormat | アップロードされたイメージファイル(BMP,EMF,EXIF,GIF,Icon,JPEG,PNG,TIFF,WMF)のフォーマットを表示します。
ImageWidth | アップロードされたイメージファイルの幅を表示します。イメージファイルでない場合には[－1]と表示されます。
ImageHeight | アップロードされたイメージファイルの高さを表示します。イメージファイルでない場合には[－1]と表示されます。
LastSavedFileName | アップロードによりサーバーに保存されたファイルの名前(パスを除く)を表示します。
LastSavedFilePath | アップロードによりサーバーに保存されたファイルのフルパスを表示します。
MaxFileLength | アップロードが可能なファイルの最大サイズを制限する際に使用します。(単位:Byte) ここに指定されたサイズより大きなファイルをアップロードしようとするとエラーが発生します。 デフォルトは[無制限]です。
MimeType | アップロードされたファイルのMimeType値を表示します。
TempFilePath | SaveやSaveAsなどによりファイルが保存される前に存在する一時ファイルの位置です。ImageProcオブジェクトを有効に使用できます。
UploadTimeout | アップロードタイムアウト値を指定する際に使用します。(単位:秒) デフォルトは3600秒(60分)です。
UseIE5BugFix | エンコーディング形式を英語に指定してあるIE5.0で多国語を使用する際に発生するバグに対し、自動的に処理を行う機能を使用するかどうかを指定します。デフォルトはTrue、つまりこの機能を使用するように設定されています。
Version | DEXTUpload.NET Proコンポーネントのバージョン情報を表示します。
IsInfected | ウィルス感染の有無。(DEXTUploadV.NET Professional製品にのみ該当)
VirusName | ウィルス名(DEXTUploadV.NET Professional製品にのみ該当)

メソッド

名前 | 説明
DeleteAllSavedFiles | アップロードによりサーバーに保存したすべてのファイルを削除します。
DeleteFile | サーバーに存在するファイルを削除します。
FileExists | 特定のファイルが存在するかどうかをチェックします。
Flush | サーバーにいかなるファイルも(一時ファイルを含む)保存せず、ウェブブラウザーから送られてくるすべてのデータを無視します。
FolderExists | 特定のフォルダーが存在するかどうかをチェックします。
Save | アップロードファイルを、元来のファイル名と同じ名前で、デフォルトパスもしくは指定のパスに保存します。
SaveVirtual | アップロードファイルを、元来のファイル名と同じ名前で指定のバーチャルパスに保存します。
SaveAs | アップロードフィルを別の名前で指定のパスに保存します。
SaveAsVirtual | アップロードファイルを別の名前で指定のバーチャルパスに保存します。
SaveAsBlob | アップロードファイルをデータベースのBLOBフィールドに保存します。
SaveAsBlobStream | アップロードになったファイルを Databaseの BLOBフィールドに保存するように FileStream オブジェクトを提供します。

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadオブジェクトのプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FileUploadオブジェクトのプロパティ

 プロパティ

名前 | 説明
CodePage | アップロードコンポーネントで、内部的にデータを処理する際に使用するCodePageを指定します。
DefaultPath | 一時ファイル及びアップロードファイルを保存するデフォルトパスを指定する際に使用します。
ExpirationDate | 評価版の使用期限を表示します。正規バージョンの場合、[Unlimited] という文字列が表示されます。
FileLength | アップロードファイルの長さを表示します。(単一ファイル)
FileName | アップロードファイルの名前(パスを除く)を表示します。
FileExtension | アップロードファイルの拡張子を表示します。
FilePath | アップロードファイルのフルパスを表示します。
Form | Submitされたフォームの各項目に関する情報を保存するFormItems Collectionオブジェクト
ImageFormat | アップロードされたイメージファイル(BMP,EMF,EXIF,GIF,Icon,JPEG,PNG,TIFF,WMF)のフォーマットを表示します。
ImageWidth | アップロードされたイメージファイルの幅を表示します。イメージファイルでない場合には[－1]と表示されます。
ImageHeight | アップロードされたイメージファイルの高さを表示します。イメージファイルでない場合には[－1]と表示されます。
LastSavedFileName | アップロードによりサーバーに保存されたファイルの名前(パスを除く)を表示します。
LastSavedFilePath | アップロードによりサーバーに保存されたファイルのフルパスを表示します。
MaxFileLength | アップロードが可能なファイルの最大サイズを制限する際に使用します。(単位:Byte) ここに指定されたサイズより大きなファイルをアップロードしようとするとエラーが発生します。 デフォルトは[無制限]です。
MimeType | アップロードされたファイルのMimeType値を表示します。
TempFilePath | SaveやSaveAsなどによりファイルが保存される前に存在す一時ファイルの位置です。ImageProcオブジェクトを有効に使用することができます。
UploadTimeout | アップロードタイムアウトを指定する際に使用します。(単位:秒) デフォルトは3600秒(60分)です。
UseIE5BugFix | エンコーディング形式を英語に指定してあるIE5.0で多国語を使用する際に発生するバグに対し、自動的に処理を行う機能を使用するかどうかを指定します。デフォルトはTrue、つまりこの機能を使用するように設定されています。
Version | DEXTUpload.NET Proコンポーネントのバージョン情報を表示します。
IsInfected | ウィルス感染の有無。(DEXTUploadV.NET Professional製品にのみ該当)
VirusName | ウィルス名(DEXTUploadV.NET Professional製品にのみ該当)

Copyright © DEVPIA Corporation. All rights reserved.


CodePageプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ CodePageプロパティ

 形式
[Int32 = ] Object.CodePage

説明
 アップロードコンポーネントで、内部的にデータを処理する際に使用するCodePageを指定します。
 外国語やユニコード文字セットを用いるウェブページでは、必ずそのページで使われる文字セットに対応するコードページ値を、アップロードコンポーネントのCodePage値に指定しなければなりません。
 デフォルトの値は、システムに設定されたデフォルトのコードページ値となっています。
 但し、Session.CodePage値を指定した場合にはその値がデフォルトの値となるため、この場合にはCodePageのプロパティ値の指定を省略してもかまいません。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
fileUpload.CodePage = 65001;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


DefaultPathプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ DefaultPathプロパティ

 形式
 [String = ] Object.DefaultPath

説明
 一時ファイル及びアップロードファイルを保存するデフォルトパスを指定する際に使用します。

 Web.Configファイルにて、＜dextupload.net＞＜settings enableLargeFileUpload = "true" defaultPath = "C:\TEMP" .... /＞＜/dextupload.net＞と定義されたものを、次の例のように再定義することができます。
ソースでDefaultPathを指定しなくても、Web.Configで修正することができます。(つまり、ソースページでDefaultPathを省略することができるということです。)

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
fileUpload.DefaultPath = "D:\TEMP";
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


ExpirationDateプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ ExpirationDateプロパティ

形式
[String = ] Object.ExpirationDate

説明
 評価版の使用期限を表示します。(「YYYY-MM-DD」形式)
 正規バージョンの場合には[Unlimited]という文字列が表示されます。
 評価版の使用期限は15日間です。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
Response.Write("Expiration Date :" + fileUpload.ExpirationDate);
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


FileLengthプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ FileLengthプロパティ

形式
[Int32 = ] Object.FileLength

説明
 アップロードファイルの長さの値を表示します。(単位:Byte)

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
int FileLen = fileUpload.FileLength;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


FileNameプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ FileNameプロパティ

 形式
[String = ] Object.FileName

説明
 アップロードファイルの名前(パスを除く)を表示します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string FileName = fileUpload.FileName;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


FileExtensionプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ FileExtensionプロパティ

 形式
[String = ] Object.FileExtension

説明
 アップロードファイルの拡張子名の値を表示します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string FileExt = fileUpload.FileExtension;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


FilePathプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ FilePathプロパティ

形式
[String = ] Object.FilePath

説明
 アップロードファイルのフルパスの値を表示します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string FilePath = fileUpload.FilePath;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


Form 프로퍼티

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ Formプロパティ

形式
[Object = ] Object.Form

返り値
Object (ReadOnly / Default Property)

説明
 Submitされたフォームの各項目に関する情報を保存しているFormItems Collectionオブジェクト

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string title = fileUpload.Form["title"].Value;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


ImageFormatプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ImageFormatプロパティ

形式
[String = ] Object.ImageFormat

説明
 アップロードされたイメージファイル(BMP, EMF, EXIF, GIF, Icon, JPEG, PNG, TIFF, WMF )のフォーマットを表示します。
 イメージファイルでない場合には[Null]と表示されます。

 例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string ImageFormat = fileUpload.ImageFormat;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


ImageWidthプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ImageWidthプロパティ

形式
[Int32 = ] Object.ImageWidth

説明
 アップロードされたイメージファイル(BMP/GIF/JPG)の幅を表示します。
 イメージファイルでない場合には[-1]と表示されます。

 例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
int ImageWidth = fileUpload.ImageWidth;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


ImageHeightプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ImageHeightプロパティ

 形式
[Int32 = ] Object.ImageHeight

説明
 アップロードされたイメージファイル(BMP/GIF/JPG)の高さを表示します。
イメージファイルでない場合には[-1]と表示されます。

 例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
int ImageHeight = fileUpload.ImageHeight;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


LastSavedFileNameプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ LastSavedFileNameプロパティ

形式
[String = ] Object.LastSavedFileName

説明
 アップロードによりサーバーに保存されたファイルの名前(パスを除く)の値を表示します。
 アップロードしたひとつのファイルに対してSave()を何回か呼び出し、それぞれ違う名前で保存した場合、一番最近保存されたファイルの名前が表示されます。
例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string LastSavedFileName= fileUpload.LastSavedFileName;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


LastSavedFilePathプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ LastSavedFilePathプロパティ

形式
[String = ] Object.LastSavedFilePath

説明
 アップロードによりサーバーに保存されたファイルのフルパスの値を表示します。
 アップロードしたひとつのファイルに対してSave()を何回か呼び出し、それぞれ違う名前で保存した場合、一番最近保存されたファイルのフルパスが表示されます。
例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string LastSavedFilePath= fileUpload.LastSavedFilePath;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


MaxFileLengthプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ MaxFileLengthプロパティ

形式
[Int32 = ] Object.MaxFileLength

説明
 アップロードが可能なファイルの最大サイズを制限する際に使用します。(単位:Byte)
 ここで指定されたサイズより大きなファイルをアップロードしようとすると、エラーが発生します。デフォルトは[無制限]です。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
int MaxFileLen = fileUpload.MaxFileLength;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


MimeTypeプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ MimeTypeプロパティ

形式
[String = ] Object.MimeType

説明
 アップロードファイルのMimeType値を表示します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string MimeType = fileUpload.MimeType;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


TempFilePathプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ TempFilePathプロパティ

 形式
[String = ] Object.TempFilePath

説明
 SaveやSaveAsなどによりファイルが保存される前に存在する一時ファイルの位置です。
 ImageProcオブジェクトより有効に使用できます。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
string TempFilePath = fileUpload.TempFilePath;
 .............
}

Copyright © DEVPIA Corporation. All rights reserved.


UploadTimeoutプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ UploadTimeoutプロパティ

 形式
[Int32 = ] Object.UploadTimeout

説明
 アップロードタイムアウト値を指定する際に使用します。(単位:秒)
 指定された時間を超過するとタイムアウトエラーが発生します。
コンポーネントの外部で設定したServer.ScriptTimeoutやSession.Timeout値は無視されます。
 デフォルトは3600秒(60分)です。

 例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
fileUpload.UploadTimeout = 1200;
.............
}

Copyright © DEVPIA Corporation. All rights reserved.


UseIE5BugFixプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ UseIE5BugFixプロパティ

 形式
[boolean = ] Object.UseIE5BugFix

説明
 エンコーディング形式を英語に指定したIE5.0で多国語を使用する際に発生するバグに対し、自動的に処理を行う機能を使用するかど
 うか指定します。デフォルトはTrue、つまりこの機能を使用するよう設定されています。

Copyright © DEVPIA Corporation. All rights reserved.


Versionプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ Versionプロパティ

 形式
[string = ] Object.Version

説明
 DEXTUpload.NET Professionalコンポーネントのバージョン情報を表示します。

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadオブジェクトメソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ FileUploadオブジェクトメソッド

メソッド

名前 | 説明
DeleteAllSavedFiles | アップロードによりサーバーに保存したすべてのファイルを削除します。
DeleteFile | サーバーに存在するファイルを削除します。
FileExists | 特定のファイルが存在するかどうかをチェックします。
Flush | サーバーにいかなるファイル(一時ファイルを含む)も保存せず、ウェブブラウザーから送られてくるすべてのデータを無視します。
FolderExists | 特定のフォルダーが存在するかどうかをチェックします。
Save | アップロードファイルを、元来のファイル名と同じ名前で、デフォルトパスもしくは指定のパスに保存します。
SaveVirtual | アップロードファイルを、元来のファイル名と同じ名前で指定のバーチャルパスに保存します。q
SaveAs | アップロードフィルを別の名前で指定のパスに保存します。
SaveAsVirtual | アップロードファイルを別の名前で指定のバーチャルパスに保存します。
SaveAsBlob | アップロードファイルをデータベースのBLOBフィールドに保存します。
SaveAsBlobStream | アップロードになったファイルを Databaseの BLOBフィールドに保存するように FileStream オブジェクトを提供します。

Copyright © DEVPIA Corporation. All rights reserved.


DeleteAllSavedFiles()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ DeleteAllSavedFiles()メソッド

形式
[Int32 = ] Object.DeleteAllSavedFiles
説明
 アップロードによりサーバーに保存された全てのファイルを削除します。
 主としてコンポーネントの外部でエラーが生じた際に、アップロード作業をキャンセルしてサーバーに残っている不要なファイルを削除したい場合に使用します。
 (コンポーネントの内部でエラーが生じた時には自動的に呼び出されます。)

예제

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
.............
//コンポーネント外部でエラーが発生した場合
fileUpload.DeleteAllSavedFiles();
}

Copyright © DEVPIA Corporation. All rights reserved.


DeleteFile()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ DeleteFile()メソッド

 形式
[Boolean = ] Object.DeleteFile( strFilename )

返り値
 Boolean – 正常にファイルを削除した場合にはTrue、ファイルの不在により削除できなかった場合にはFalseと表示されます。

パラメータ
 strFilename As String - 削除するファイルのフルパス(物理パスのみ可能)

 説明
 サーバーにアップロードされたファイルまたはサーバーに存在するファイルを削除します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string path1 = fileUpload["file1"].Save();
string path2 = fileUpload["file2"].Save();
.................
//ひとつめのファイルを削除しようとする場合
 fileUpload.DeleteFile(path1);
.................
}

Copyright © DEVPIA Corporation. All rights reserved.


FileExists()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FileExists()メソッド

 形式
[Boolean = ] Object.FileExists( strFilename )

返り値
 Boolean - ファイルが存在すればTrue、そうでなければFalseと表示されます。

 パラメータ
 strFilename As String - 存否をチェックするファイルのフルパス(物理パスのみ可能)

説明
 特定のファイルが存在するかどうかをチェックします。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
if (fileUpload.FileExists("C:\TEMP\sample.zip")
Response.Write( "File Exists : sample.zip <br>");
else
Response.Write( "File Not Exists : sample.zip <br>");

}

Copyright © DEVPIA Corporation. All rights reserved.


Flush()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ Flush()メソッド

 形式
Object.Flush()

説明
 サーバーにいかなるファイル(一時ファイルを含む)も保存せず、ウェブブラウザーから送られてくるすべてのデータを無視します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
if ( Request.TotalBytes > 1048576)

fileUpload.Flush();

else

fiUpload.Save();
}

Copyright © DEVPIA Corporation. All rights reserved.


FolderExists()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FolderExists()メソッド

形式
[Boolean = ] Object.FolderExists( strFolderName )

返り値
 Boolean - フォルダが存在すればTrue、そうでなければFalseと表示されます。

 パラメータ
 strFolderName As String - 存否をチェックするフォルダのフルパス(物理パスのみ可能)

説明
 特定のフォルダが存在するかどうかをチェックします。
例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
if (fileUpload.FolderExists("C:\TEMP")
Response.Write( "Folder Exists <br>");
else
Response.Write( "Folder Not Exists <br>");

}

Copyright © DEVPIA Corporation. All rights reserved.


Save()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ Save()メソッド

 形式
[String = ] Object.Save( [strPath], [bOverwrite] )

返り値
 String - 実際にサーバーに保存されたファイル名

パラメータ
 strPath As String (Optional) – アップロードファイルの保存先パス。省略する場合 、DefaultPath Propertyが指定したパスに保存されます。
bOverwrite As Boolean (Optional) - 同じ名前のファイルが既に存在する場合に上書きするかどうかを指定します。
デフォルトの値はTrueです。Falseに指定する場合には、filename(2).extやfilename(3).extなどといった別のファイル名を付けて保存してください。

説明
 アップロードされたファイルを元来のファイル名と同じ名前でデフォルトのパスまたは指定パスに保存します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.Save();
//同じ構文
//UploadedPath = fileUpload.Save(fileUpload.DefaultPath,false);
//UploadedPath = fileUpload["file1"].Save(fileUpload.DefaultPath,false);
//UploadedPath = fileUpload["file1"][0].Save();

}

Copyright © DEVPIA Corporation. All rights reserved.


SaveVirtual()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ SaveVirtual()メソッド

 形式
[String = ] Object.SaveVirtual( strVirtualPath, [bOverwrite] )

返り値
 String - 実際にサーバーに保存されたファイル名

パラメータ
 strVirtualPath As String – アップロードファイルを保存するバーチャルパス
 bOverwrite As Boolean (Optional) – 同じ名前のファイルが既に存在する場合に上書きするかどうかを指定します。
デフォルトの値はTrueです。Falseに指定する場合、filename(2).extやfilename(3).extなどのように別のファイル名を付けて保存してください。

説明
 アップロードファイルを、元来のファイル名と同じ名前で指定のバーチャルパスに保存します。

 参考
 Save()メソッドがバーチャルパスをサポートしているため、もう使う必要はありませんが、下位の互換性のために残されています。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.SaveVirtual("/virtualloc");
............................

}

Copyright © DEVPIA Corporation. All rights reserved.


SaveAs()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ SaveAs()メソッド

 形式
[String = ] Object.SaveAs(strNewFilename, [bOverwrite] )

返り値
 String - 実際にサーバーに保存されたファイル名

 パラメータ
 strNewFilename As String - アップロード後に名前を付けて保存するファイル名(Full Path)
 bOverwrite As Boolean (Optional) – 同じ名前のファイルが既に存在する場合に上書きするかどうかを指定します。
デフォルトの値はTrueです。Falseに指定する場合、filename(2).extやfilename(3).extなどのように別のファイル名を付けて保存してください。

説明
 アップロードファイルに名前を付けて指定のパスに保存します。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.SaveAs("C:Upload\newfile.zip");
............................

}

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsVirtual()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ SaveAsVirtual()メソッド

 形式
[String = ] Object.SaveAsVirtual( strNewFilename, [bOverwrite=TRUE] )

返り値
 String - 実際にサーバーに保存されたファイル名

 パラメータ
 strNewFilename As String - アップロードファイルを保存するバーチャルパスのファイル名
 bOverwrite As Boolean (Optional) – 同じ名前のファイルが既に存在する場合に上書きするかどうかを指定します。
デフォルトの値はTrueです。Falseに指定する場合、filename(2).extやfilename(3).extなどのように別のファイル名を付けて保存してください。

説明
 アップロードファイルに新しい名前で指定したバーチャルパスに保存します。

参考

SaveAs(　)メソッドがバーチャルパスをサポートしているため、もう使用する必要がありませんが、下位の互換性のために残されています。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath = fileUpload.SaveAsVirtual("/virtualloc/newfile.zip");
............................

}

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsBlob()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ SaveAsBlob()メソッド

形式
[byte[] = ] Object.SaveAsBlob()

説明
アップロードファイルをデータベースのBLOBフィールドに保存します。

例

string ConnectionString = ".................";
OleDbConnection cn = new OleDbConnection(ConnectionString);
cn.Open();
.............................................
DataRow newRow = ds.Tables[0].NewRow();

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
newRow[0] = fileUpload.FileName;
newRow[1] = fileUpload.FileLength;
newRow[2] = fileUpload.SaveAsBlob();

ds.Tables[0].Rows.Add(newRow);
adapter.Update(ds);
}

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsBlobStream()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional オブジェクトリファレンス

■ SaveAsBlobStream()メソッド

形式
[FileStream = ] Object.SaveAsBlobStream()

説明
アップロードしたファイルを Databaseの BLOBフィールドに保存する。

例

string ConnectionString = ".................";
OleDbConnection cn = new OleDbConnection(ConnectionString);
cn.Open();
.............................................
DataRow newRow = ds.Tables[0].NewRow();

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
newRow[0] = fileUpload.FileName;
newRow[1] = fileUpload.FileLength;
using (FileStream fs = fileUpload.SaveAsBlobStream())
{
byte[] buffer = new byte[fileUpload.FileLength];
fs.Read(buffer, 0, buffer.Length);
newRow[2] = buffer;
}

ds.Tables[0].Rows.Add(newRow);
adapter.Update(ds);
}

Copyright © DEVPIA Corporation. All rights reserved.


FileDownloadオブジェクト

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FileDownloadオブジェクト

 サーバーにあるファイル、もしくはデータベースBLOBフィールドにある移転データを、ウェブブラウザーを通じ、クライアントユーザーのハードディスクにファイルとしてダウンロードできる機能を持つオブジェクトです。

メソッド

名前 | 説明
Download | サーバーにあるファイルを、ウェブブラウザーを通じてクライアントユーザーにダウンロードする。
DownloadVirtual | サーバーのバーチャルパスにあるファイルを、ウェブブラウザーを通じてクライアントユーザーにダウンロードする。
DownloadBlob | データベースにあるBLOBデータを、ウェブブラウザーを通じてクライアントユーザーにダウンロードする。

Copyright © DEVPIA Corporation. All rights reserved.


Download()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ Download()メソッド

形式
Object.Download(filePath,fileName,bForce,bResume)

パラメータ
 filePath As String - ダウンロードするフルパス
filleName As String – ダウンロードするファイル名

bForce As Boolean - ダウンロードする際、ウェブブラウザーが添付ファイルの処理方法を指定します。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するようにするため、ウェブブラウザーは保存ダイアログを出力します。
False | デフォルトの値。MIMEフォーマットによってウェブブラウザーの処理方法が異なります。 たとえば、text/html(HTMLファイル)の場合にはウェブブラウザーが直接ダウンロードの内容を出力し、application/x-zip-compressed(ZIPファイル)の場合には保存ダイアログを出力します。

bResume As Boolean - 続けてダウンロード機能を使用するかどうかを指定します。

属性 | 説明
True | ユーザによるキャンセル、もしくはネットワーク上の問題により中止されたダウンロードを再開する場合、ダウンロードの切れたデータの続きからダウンロードを開始します。
False | デフォルトの値。ダウンロードのリクエストごとに全体のデータを転送します。

説明
 サーバーにあるファイルを、ウェブブラウザーを通じてクライアントユーザーにダウンロードします。

例

private void Page_Load(object sender, System.EventArgs e)
{
string FileName = Request.QueryString["filename"]; //ファイル名
string FilePath = Request.QueryString["filepath"]; //ダウンロード先のパス

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
 //objDownload.Download(ファイルのパス、ファイル名、強制保存の有無(True:強制保存)、続けてダウンロード(True:続けてダウンロード))
fileDownload.Download(FilePath, FileName, false, true);
}
}

Copyright © DEVPIA Corporation. All rights reserved.


DownloadVirtual()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ DownloadVirtual()メソッド

形式
Object.DownloadVirtual(filePath,fileName,bForce,bResume)

パラメータ
filePath As String - ダウンロードするフルパス
filleName As String – ダウンロードするファイル名

bForce As Boolean - ダウンロード時、ウェブブラウザーが添付ファイルの処理方法を指定します。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するようにするため、ウェブブラウザは保存ダイアログを出力します。
False | デフォルトの値。MIMEフォーマットによってウェブブラウザの処理方法が異なります。 たとえば、text/html(HTMLファイル)の場合にはウェブブラウザが直接ダウンロードの内容を出力し、application/x-zip-compressed(ZIPファイル)の場合には保存ダイアログを出力します。

bResume As Boolean - 続けてダウンロード機能を使用するかどうかを指定します。

属性 | 説明
True | ユーザーによるキャンセル、もしくはネットワーク上の問題により中止されたダウンロードを再開する場合、ダウンロードの切れたデータの続きからダウンロードを開始します。
False | デフォルトの値。ダウンロードのリクエストごとに全体のデータを転送します。

説明
サーバーにあるファイルを、ウェブブラウザーを通じてクライアントユーザーにダウンロードします。

例

private void Page_Load(object sender, System.EventArgs e)
{
string FileName = Request.QueryString["filename"]; //ファイル名
string FilePath = Request.QueryString["filepath"]; //ダウンロード先のパス

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
//objDownload.Download(ファイルのパス、ファイル名、強制保存の有無(True:強制保存)、続けてダウンロード(True:続けてダウンロード))
fileDownload.DownloadVirtual(FilePath, FileName, false, true);
}
}

Copyright © DEVPIA Corporation. All rights reserved.


DownloadBlob()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ DownloadBlob()メソッド

形式
Object.DownloadBlob(filePath,fileName,bForce)

 パラメータ
 filePath As String - ダウンロードするフルパス
 filleName As String – ダウンロードするファイル名

bForce As Boolean - ダウンロード時、ウェブブラウザーが添付ファイルの処理方法を指定します。

属性 | 説明
True | ダウンロードデータを常にファイルとして保存するようにするため、ウェブブラウザは保存ダイアログを出力します。
False | デフォルトの値。MIMEフォーマットによってウェブブラウザの処理方法が異なります。 たとえば、text/html(HTMLファイル)の場合にはウェブブラウザが直接ダウンロードの内容を出力し、application/x-zip-compressed(ZIPファイル)の場合には保存ダイアログを出力します。

説明
 データベースにあるBLOBデータを、ウェブブラウザーを通じてクライアントユーザーにダウンロードします。

参考
 BLOBの続けてダウンロードには対応していません。ファイルのフォーマットで保存されていなければ、続けてダウンロードを行うことはできません。
例

private void Page_Load(object sender, System.EventArgs e)
{
OleDbConnection cn = null;
OleDbDataReader dataReader = null;

string FileID = Request.QueryString["fileid"];
string ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Password=\"\";User ID=Admin;Data Source=C:\\Program Files\\Devpia\\DEXTUploadNETProSamples\\DEXTUPLOAD.mdb";
cn = new OleDbConnection(ConnectionString);
cn.Open();

string strQuery = "SELECT filename, filesize, filedata FROM DEXTUPLOAD WHERE fileid = " + FileID;
OleDbCommand cmd = new OleDbCommand(strQuery, cn);
dataReader = cmd.ExecuteReader(CommandBehavior.SequentialAccess);

if (dataReader.Read())
{
string FileName = dataReader.GetString(0);
int FileSize = dataReader.GetInt32(1);

using (DEXTUpload.NET.FileDownload fileDownload = new DEXTUpload.NET.FileDownload())
{
fileDownload.DownloadBlob(dataReader, 2, FileName, FileSize, true);
}
}

dataReader.Close();
cn.Close();
}

Copyright © DEVPIA Corporation. All rights reserved.


FileUploadMonitor 객체

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ FileUploadMonitorオブジェクト

 固定型情報表示ウィンドウを使い、アップロードの進行状況を把握することができるようにするオブジェクトです。

 メソッド

名前 | 説明
ShowMonitor | アップロードの進行状況をプログレスバーに表示し、全体のファイル容量や残りのファイル容量、アップロード速度や残り時間などの情報を、リアルタイムでわかるようにします。

Copyright © DEVPIA Corporation. All rights reserved.


ShowMonitor()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ShowMonitor()メソッド

形式
Object.ShowMonitor()

説明
 アップロードの進行状況をプログレスバーに表示し、全体のファイル容量や残りのファイル容量、アップロード速度や残り時間などの情報を、リアルタイムでわかるようにします。

 例

private void Page_Load(object sender, System.EventArgs e)
{
using (DEXTUpload.NET.FileUploadMonitor monitor = new DEXTUpload.NET.FileUploadMonitor())
{
monitor.ShowMonitor();
}
}

Copyright © DEVPIA Corporation. All rights reserved.


Progressオブジェクト

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ Progressオブジェクト

 ユーザー定義型プロセスバーを使ってアップロードの進行状況を把握できるようにするオブジェクトです。

プロパティ

名前 | 説明
TotalSize | アップロードするファイル全体のサイズ
TransferSize | 現時点までに転送が終わったファイルのサイズ
Percent | 現時点までの全体の転送率
BytesPerSec | 転送速度
TimeLeft | 残り時間
TimeElapsed | これまでかかった時間
IsUploadClosed | Trueの場合アップロード完了。またはIE中止をクリックするとfalse。

Copyright © DEVPIA Corporation. All rights reserved.


ImageProcオブジェクト

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ImageProcオブジェクト

DEXT.ImageProc オブジェクトは各種の画像フォーマット(BMP、EMF、EXIF、GIF、Icon、JPEG、PNG、TIFF、WMFなど)に対応。
他の画像フォーマットへの変換も可能(BMP、JPG、GIFなど) 画像ファイルのサムネイルイメージも作成できる。生成されたイメージはJPGフォーマットで保存される。
指定された画像や文字などを用いて透かしイメージを作成できる。生成された透かしイメージはJPGフォーマットで保存される。
露出時間、イメージの詳細、解像度などの様々なメタデータを提供。

プロパティ

名前 | 説明
PixelFormat | ピクセルフォーマット
ImageWidth | イメージの横幅
ImageHeight | イメージの高さ
HorizontalResolution | 水平解像度
VerticalResolution | 垂直解像度
MDDocumentName | イメージの名前
MDImageDescription | イメージの説明
MDEquipMake | カメラ製造社
MDEquipModel | カメラモデル名
MDSoftwareUsed | イメージファイルを生成するプログラム
MDArtist | 撮影者
MDExifShutterSpeed | シャッタースピード
MDExifExposureTime | 露出時間
MDExifFNumber | 絞り値
MDDateTime | 修正日付け - 修正対象
MDDateTimeOrig | 撮影日付
MDExifColorSpace | 色相モード
MDExifDigitalZoomRatio | デジタルズーム情報
MDExifExposureBias | 露出情報
MDExifExposureMode | 撮影モード
MDExifExposureProg | 露出プログラム
MDExifFlash | フラッシュ使用可否
MDExifFocalLength | 焦点通り
MDExifFocalLengthIn35mm | 35mm フィルム焦点通り
MDExifISOSpeed | ISO 感度
MDExifLightSource | 光源情報
MDExifMaximumLensApecture | 最大料理ヶ値段
MDExifMeteringMode | 測光モード
MDExifWhiteBalance | ホワイトバランス情報

メソッド

名前 | 説明
SetSourceFile | 作業の対象となるイメージファイルを指定します。このメソッドの呼び出しに成功すれば、次の関数を呼び出すことができます。
SaveAsThumbnail | サムネイルイメージを生成します。サムネイルのフォーマットはJPGです。返り値は、実際の保存先を含むファイル名です。
SaveAsWatermarkImage | イメージを用いたウォーターマークイメージを生成します。ウォーターマーク処理されたファイルのフォーマットはJPGです。
SaveAsWatermarkText | テキストを用いたウォーターマークイメージを生成します。ウォーターマーク処理されたファイルのフォーマットはJPGです。
ConvertImageFormat | イメージのフォーマットを指定どおりに変換します。第１のファクタは変換するイメージのフォーマットで、“image/jpeg”や“image/bmp” などのように入力します。

Copyright © DEVPIA Corporation. All rights reserved.


SetSourceFile()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ SetSourceFile()メソッド

形式
[Boolean =] Object.SetSourceFile( strTempFilePath )

返り値
 Boolean – 一時ファイルの有無

 パラメータ
 strTempFilePath As String – 一時ファイルが生成されたパス

説明
 作業の対象となるイメージファイルを指定します。
このメソッドの呼び出しに成功すると、SaveAsThumbnail()やSaveAsWatermarkImage()、SaveAsWatermarkText()などのメソッドを呼び出すことができるようになります。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
//ウォーターマーク処理を行うためには、イメージ関連オブジェクトを生成しなければなりません。
DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc();

if(imgProc.SetSourceFile(fileUpload.TempFilePath))
{
//イメージファイルの処理...
}
......
}

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsThumbnail()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ SaveAsThumbnail()メソッド

形式
[string = ] Object.SaveAsThumbnail( imgFilePath, strSavedPath,nWidth,nHeight,bOverwrite )

[string = ] SaveAsThumbnail(imgFilePath, strSavedPath, nWidth, nHeight, antialiasing, bOverwrite)

[string = ] SaveAsThumbnail(imgFilePath, strSavedPath, nWidth, nHeight, antialiasing, usePercentages, preserveAspectRatio, bOverwrite)

[string = ] SaveAsThumbnail(imgFilePath, strSavedPath, nWidth, nHeight, antialiasing, fitOption, hAlign, vAlign, backColor, bOverwrite)

パラメータ
imgFilePath As String - 原本イメージファイルパス

strSavedPath As String - サムネイルであるイメージ保存パス

nWidth As Int - 広さ

nHeight As Int - 高さ

antialiasing AS bool - アンチエイリアシング 使用有無

usePercentages As bool - 広さ、高さの値を百分率で計算する可否

preserveAspectRatio As bool - 本来イメージの割合維持可否

fitOption AS ImageFitOption - フレーム基準イメージサイズ調整オプション

hAlign - フレーム基準イメージ横整列オプション

vAlign - フレーム基準イメージ縦整列オプション

backColor - フレーム基準余白色相

bOverwrite As Boolean - 上書き保存有無(trueなら上書き)

説明
アップロード一イメージファイルの横,縦を 100x100サイズでソムネである処理して保存する。生成されたイメージは JPG フォーマットを持つ

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

// 作業の対象となるイメージファイルを設定します。

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

// 100x100 サムネイル

int nWidth = 100;

int nHeight = 100;

// 原本イメージファイルのパス

string imgFilePath = fileUpload.TempFilePath;

// サムネイル イメージのファイル名

string thumbPath = "../Data/" + filename + "(thumb_100x100).jpg";
string UploadedPath1 = imgProc.SaveAsThumbnail(imgFilePath, thumbPath, nWidth, nHeight, false);

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsWaterMarkImage()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ SaveAsWaterMarkImage()メソッド

形式
[string = ] SaveAsWaterMarkImage(imgFilePath, strTargetFilePath, strSavedPath, PosX, PosY, bOverwrite)

[string = ] SaveAsWaterMarkImage(imgFilePath, strTargetFilePath, strSavedPath, PosX, PosY, alpha, bOverwrite)

パラメータ
imgFilePath As string -　原本イメージファイルパス

strTargetFilePath As string - ウォーターマーク加えるイメージパス

strSavedPath AS string - ウォーターマーク処理されたイメージが保存されるパス

PosX As int - ウォーターマーク適用 X座標

PosY As int - ウォーターマーク適用 Y座標

alpha As float - 透明度値(0.0f~1.0fまで)

bOverwrite As bool - 上書き保存有無(trueなら上書き)

説明
イメージを使ってウォーターマークイメージを生成します。ウォーターマーク処理されたファイルのフォーマットはJPGです。
PosXが－10でPosYが10の場合、ウォーターマークはイメージの右上に挿入されます。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

// ウォーターマーク処理を行うには、イメージ関連オブジェクトを生成しなければなりません。

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

// 原本イメージファイルのパス

string imgFilePath = fileUpload.TempFilePath;

int positionX = 0;

int positionY = 0;

bool overWrite = false;

float alpha = 0.32f;

// ロゴイメージ

string logoImage = "watermark.bmp";

// イメージウォーターマークファイル名

string watermarked1Path = "../Data/" + filename + "(image).jpg";

// 位置及び上書き保存設定

positionX = -10; //座標 : (+) 左側 (-) 右側

positionY = 10; //座標 : (+) 上端 (-) 下端

overWrite = false; //上書き保存有無

string uploadPath1 = imgProc.SaveAsWaterMarkImage(imgFilePath, logoImage, watermarked1Path ,positionX, positionY, overWrite);

if (fileUpload.Version.StartsWith("4"))

{

// 4.x.x.x 以降のバージョンのみ支援します

watermarked1Path = "../Data/" + filename + "(image_50).jpg";

alpha = 0.5f;

string uploadPath2 = imgProc.SaveAsWaterMarkImage(imgFilePath, logoImage, watermarked1Path, positionX, positionY, alpha, overWrite);

..........

Copyright © DEVPIA Corporation. All rights reserved.


SaveAsWaterMarkText()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ SaveAsWaterMarkText()メソッド

形式
[string = ] Object.SaveAsWaterMarkText(imgFilePath, strTextForMarking, strSavedPath, PosX, PosY, FontSize, FontStyle, bOverwrite )

[string = ] Object.SaveAsWaterMarkText(imgFilePath, strTextForMarking, strSavedPath, PosX, PosY, alpha, FontSize, FontStyle, bOverwrite )

パラメータ
imgFilePath As String - 原本イメージファイルパス

strTextForMarking As String - ウォーターマーク加えるテキスト

strSavedPath As String - ウォーターマーク処理したイメージが保存されるパス(例:C:TEMPwatermarked.jpg)

PosX As Int - ウォーターマークテキストの X座標

PosY As Int - ウォーターマークテキストの Y座標

alpha As float - 透明度値段(0.0f~1.0fまで)

FontSize As Int - フォント大きさ

FontStyle As String - フォントスタイル ("Bold" ,"italic","Regular","Underline")

bOverwrite As Boolean - 上書き保存有無(trueなら上書き)

説明
イメージを利用したウォーターマークテキストを生成します。ウォーターマーク処理されたファイルのフォーマットはJPGです。

PosXが－10で、PosYが10の場合、ウォーターマークはイメージの右上に挿入されます。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

// ウォーターマーク処理を行うには、イメージ関連オブジェクトを生成しなければなりません。

using (DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc())

{

if(imgProc.SetSourceFile(fileUpload.TempFilePath))

{

// アップロードされたファイル名を検索(拡張子を除く)

string filename = Path.GetFileNameWithoutExtension(fileUpload.FileName);

// 原本イメージファイルのパス

string imgFilePath = fileUpload.TempFilePath;

int positionX = 0;

int positionY = 0;

bool overWrite = false;

float alpha = 0.32f;

// テキストウォーターマークファイル名

string watermarked2Path = "../Data/" + filename + "(text).jpg";

int fontSize = 20;

string fontStyle = "bold";

string Copyright = "DEVPIA(Developer Utopia!!!)";

// 位置及び上書き保存設定

positionX = 0; //座標 : (+) 左側 (-) 右側

positionY = 0; //座標 : (+) 上端 (-) 下端

overWrite = false; //上書き保存有無

string uploadPath3 = imgProc.SaveAsWaterMarkText(imgFilePath, Copyright, watermarked2Path, positionX, positionY, fontSize, fontStyle, overWrite);

watermarked2Path = "../Data/" + filename + "(text_100).jpg";

alpha = 1.0f;

string uploadPath4 = imgProc.SaveAsWaterMarkText(imgFilePath, Copyright, watermarked2Path, positionX, positionY, alpha, fontSize, fontStyle, overWrite);

..........

Copyright © DEVPIA Corporation. All rights reserved.


DEXTUploadXについて

■ DEXTUploadXとは

- DEXTUploadXはウェブブラウザーからウェップサーバーへのファイルアップロード機能を支援する RFC1867 標準の client-side ActiveX コンポーネントです。 HTTP 基盤の環境でウェブブラウザーが支援し難い多様な機能及び UIを支援し、RFC1867 を支援する server-side コンポーネントとの連動を通じて HTTPの制約を越す力強いアップロード及びダウンロード機能を支援します。 また DEXTUploadX コンポーネントは顧客のウェブサイトに最適化になるように開発者のための多様なAPIを提供して、もっと柔軟だし、直観的なUIを製作できるようにします。


DEXTUploadXについて

■ DEXTUploadXの特徴

■HTTPを利用した多様な機能のアップロード/ダウンロード機能提供

  • 2GB まで大容量ファイル送信
    DEXTUploadX     を使う場合、最大 2GBまでのファイル容量安定的に送られます。
    DEXTUpload Pro Extension    を使う場合、無限大のファイル容量安定的に送られます。
  • 掲示板修正モード支援
    掲示板の状態が修正モードの場合もうサーバーにアップロードされたファイルの編集(保存/削除) 及び新しいファイルをアップロードができます。
  • フォルダ構造をアップロード
    ユーザーがフォルダを追加する際、ユーザーが追加したフォルダの構造をそのままアップロードできます。 (ただし、DEXTUpload Proシリーズとのリンクが必要)。
  • フォルダ構造をダウンロード
    ダウンロードを行うそれぞれのファイルに対してダウンロードパスを指定できます。そのためフォルダ構造のダウンロードが可能です。
  • 続けてアップロード機能支援
    インターネット連結切られ, ユーザーによる一時停止などによってアップロードが腰砕けになっても安定的な続けてアップロードが可能です.
    [    ただ,DEXTUpload Pro Extensionだけ対応]
  • 続けてダウンロード機能支援
    インターネット連結切られ, ユーザーによる一時停止などによってダウンロードが腰砕けになっても安定的な続けてダウンロードが可能です。
  • コンテンツセキュリティダウンロード
    サーバーのウェブ上に公開されないファイルをダウンロードできてダウンロードのためにファイルの URLを露出させないです。
    [    ただ,DEXTUpload Pro(or DEXTUpload Pro Ex) シリーズと連動必要]
  • モーダル/モーダルリース方式の送信ウィンドウ支援
    ウェブサイトの環境に適当なモーダル,モーダルリース方式の送信ウィンドウを支援します。
  • 伝送速度の制限支援
    支援される帯域幅の中で伝送速度を制限ができます。
    [    ただ,DEXTUpload Pro Extensionだけ支援]
  • アップロード結果リターン
    POST,PUT     方式アップロード結果をサーバー,クライアントそれぞれのスクリプト環境で確認できます。
  • ファイル整列及び移動支援
    送信の前、ファイル整列及び移動を支援してユーザーが願う順に送信が可能です。
  • 送信の中でファイル追加/削除支援
    送信の中でファイル追加/削除を支援します。
    [    ただ,DEXTUpload Pro Extensionだけ支援]
  • Drag and Dropをサポート
    ファイルやフォルダの「Drag and Drop」機能をサポートしています。
  • ファイルの容量,個数制限及びファイルピルトリングの機能
    送信されるファイルの送信容量と個数を制限ができて,特定拡張子だけ選択,送信されることができるようにピルトリングができます。
  • フォームデータを自動化
    ウェブページに存在するすべてのフォームデータを自動的に認識して転送します。
  • ユーザー任意の付加的なデータアップロード
    それぞれのファイルに対する別称及びユーザー任意の付加的なデータをアップロードができます。

■多様な UI 構成を支援する客体と API 提供

  • ユーザー定義の送信ウィンドウ支援(HTML UI)
    ユーザーが直接ユーザーのウェブサイトに最適化された送信ページを製作するように送信に必要なすべての APIを提供します。
  • 追加送信ウィンドウ UI 支援
    願う形態の送信ウィンドウを選択するように Basic,Simple,ListView 形態のもう作られた送信ウィンドウ UIを支援します。
  • Progress Bar 客体支援
    HTML     及び DEXTUploadXが提供する ListView 客体で直接送信ウィンドウを構成する時、Progress Bar 客体を使って Progress Barの構成が簡単にできます。
  • ダウンロードモニターウィンドウのチェックボックス活性化選択支援
    ダウンロードモニターウィンドウのファイルに対するチェックボックスイメージを選択して活性化できます。

■多様な開発環境支援

  • すべての言語支援
    HTTP     及び RFC 1867 規約を守って ASP,ASP.NET,JSP,PHP などすべての言語を支援
  • 開発者のためのヘルプ,サンプル支援
    すべての APIに対する chmヘルプを提供して,基本機能に対する理解を手伝ってくれるサンプルと共に多様な応用機能具現のためのサンプルを提供します。
  • 送信段階別イベントハンドラー提供
    ファイルを選択する瞬間からファイルをアップロード/ダウンロードと作業が完了する瞬間までの各段階別、豊かなイベントハンドラーを提供します。
  • 例外処理及びエラーメッセージ伝達
    開発及び運営の時問題の原因を手軽く把握するように力強くて多様なメッセージ伝達

■多様な運営環境支援

  • 多様な OSのサーバーで配布可能
    CAB    ファイルの配布を通じて顧客 PCに自動設置されてバージョン管理が容易いだけでなく,Windows, リヌックス,ユニックスなどのすべての運営体制を通じて配布可能
  • ActiveX 機能を制限した最新ウィンドウ環境支援
    Windows Vista / 2008     サポート及び IE 8.0 支援
  • 各種のセキュリティ環境について互換性
    SSL及び Proxy サーバーを支援

■ 完璧な多国語サポート

  • 完璧な多国語サポート
    完璧な多国語サポートを実現するため、ユニコードのファイル名とフォームデータに対応しています。
  • ユーザーの言語にあわせた自動言語選択機能
    ユーザーの基本言語設定が日本語/英語/韓国語の場合、DEXTUploadXから発せられるすべてのメッセージはそれぞれの設定にあわせた言語で表示されます。それ以外の言語が設定されている場合は自動的に英語で表示されるため、多国語サポートがより簡単になりました。


DEXTUploadX リリース情報

DEXTUploadXについて

■ DEXTUploadX リリース情報

  • DEXTUploadX v3.0.1.0

    [    機能改善]
    # Internet Explorer 8    ポリシーの変更によって HTML inputタッグのファイルは転送されないように変更
  • DEXTUploadX v3.0.0.0

    [    バグパッチ]
    #    特定環境の PCで IEのセキュリティ設定画面(Internet Exploreのツール⇒インターネットオプション⇒セキュリティ) 不思議な現象修正
    #ファイルダウンロードの時に2個以上のクギを維持することができない問題修正

    [    機能改善]
    #    ActiveXの動的サイズ変更支援
    #    ListViewのバックグラウンドイメージ設定支援
    #ListViewのコラム名を通じる整列支援
    #Push方式ダウンロードの時にサーバー側で要求に応答したHTTPステータス コード修身支援
  • DEXTUploadX v2.8.2.0

    [    機能改善]
    #     ダウンロードの時、 保存フォルダ生成可否の メッセージボックスで’ 取り消し’ボタンをクリックした場合、 OnTransferCancelイベントが 発生するように機能改善
    #     DEXTUploadX内部の 全ての 動作が 完了されたの を知らせるイベントの 追加 (OnEndProc)
  • DEXTUploadX v2.8.1.0

    [    バグパッチ]
    #    英文 OSで v2.8.0.0を使う場合、Buffer Overrun 発生問題の修正

    [    機能改善]
    #    クライアントに送信されるアップロード結果及びエラーメッセージに対する UTF-8環境支援
    #DEXTUploadXBrokerEx     プロセスの自動削除改善
  • DEXTUploadX v2.8.0.0

    [    機能改善]
    #Windows 2008 & IE 8.0     支援
    #    送信ファイルの整列手順変更及びファイル移動機能支援
    #    モーダル方式モニターウィンドウ支援
    #    追加送信ウィンドウUI 支援 (Basic,Simple,ListView)
    #Progress Bar     客体支援
    #PHP    のためのポームデータ配列処理支援
    #    特定ファイル拡張子をピルトリングができる機能支援(既存 Filter プロパティーの反対される機能)
    #POST     方式アップロード結果リターン支援
    #    ファイルアップロード/ダウンロードの時送信進行情報処理方式改善
    #    ダウンロード速度改善
    #    ダウンロード後実行ファイル連結方法改善(Custom UI)
    #    イベント順序で改善 (OnTransferComplete,OnError)
    #    ダウンロードモニターウィンドウのチェックボックス活性化選択支援
    #    例外及びエラーメッセージ改善
    #    ダウンロードの時保安方案改善
  • DEXTUploadX v2.5.1.0

    [バグパッチ]

    [    機能改善]
    # [Filter]    のプロパティを使用する場合、[ファイル追加]ダイアログボックスのフィルタリング以外にも[フォルダ追加]ダイアログボックスやドラッグ＆ドロップでも同じフィルタリングが可能となるように修正
  • DEXTUploadX v2.5.0.0

    [バグパッチ]
    #     権限のないファイルのダウンロードをリクエストした場合に明示的なエラーが発生するよう修正。
    #     ダウンロード中にネットワークが切れて明示的なエラーが発生した後、ユーザーがダウンロードを再リクエストした場合に続けてダウンロードできるように修正。(ネットワークの接続状態を検査して自動的に続けてダウンロードする機能は今後サポートする予定。)

    [    機能改善]
    #     リストビューに追加されたファイルの表示スタイルを変更できるようサポート。([ListViewFileStyle])
    # Drag&Drop    を活性化又は非活性化できるプロパティを提供。([EnableDragDrop])
    # PHP    が提供する[HTTP_POST_FILES]や[_FILES]と連動して別のサーバコンポーネント(DEXTUpload Proなど)なしでPOST方式のアップロードが可能となるようサポート。([EnablePHPFILES])
    # UseClientRegistry    の値が[TRUE]に設定されていても、ユーザーがユーザー別に設定情報プロパティ(「転送完了後ウィンドウを閉じる」など)を入力すれば、該当のプロパティの値が適用されるように修正。
  • DEXTUploadX v2.4.0.0

    [    バグパッチ]
    # VISTA    支援バージョンからダウンロード時に要請されるファイルでのCookieの維持ができない問題修正

    [機能改善]
    #     アップロードされる個々のファイルについての別称支援
    #     アップロードされる個々のファイル名についてのユーザーデータ転送支援
    #     ユーザーが選択した（ダブルクリック）ファイルの情報閲覧支援
    # FileUploadMonitor    の全体ファイル削除メソッド追加(DeleteAllFile)
  • DEXTUploadX v2.3.3.0

    [    バグパッチ]
    # msvcr71.dll     問題修正

    [    機能改善]
    # FileUploadMonitor    のファイル追加メソッド追加 (AddFile)
  • DEXTUploadX v2.3.2.0

    [バグパッチ]

    [    機能改善]
    # Windows Vista    に対応
    # FileDownloadMonitor    に[ダウンロードするフォルダを選択]メソッドを追加(ChooseDownloadFolder)
    # FileUploadManager    に[全てのファイルを削除]メソッドを追加(DeleteAllFile)
  • DEXTUploadX v2.3.1.0

    [バグパッチ]
    # Windows Vista    において、ユーザー権限の問題により、特定のレジストリー(HKEY_LOCAL_MACHINE)にアクセスできないユーザー別設定情報を維持できない問題点を修正。
    (    ユーザー別設定情報:　ユーザーが最後に選択した[続けてダウンロード]や[転送完了後、ウィンドウを閉じる]などの選択情報)

    [    機能改善]
  • DEXTUploadX v2.3.0.0

    [バグパッチ]
    # FileDownloadManager    にファイルを追加した時に、ファイルサイズを間違えて入力してもダウンロードができるように修正。
    # Put     方式のアップロードで、多重ファイルが正常にアップロードされない問題を修正

    [    機能改善]
    # AES (Advanced Encryption Standard     – Rjindael) 暗号化転送機能を追加
    #     ユーザーGUI用の完璧なAPIを提供
    #     リストビューのスタイル及び色の変更を可能にする多様なプロパティを提供
    # Context Menu    の制御プロパティを提供
    #     ダブルクリックイベントを提供
    # FileUploadManager    とFileDownloadManagerのアウトラインに関する[Visible]のプロパティを提供
    # FileUploadMonitor    の[ファイル追加][フォルダ追加][アイテム削除]ボタンに関する[Enable]プロパティを提供
  • DEXTUploadX v2.1.2.0

    [    バグパッチ]
    #     二つ以上のサイトから同じ名前のファイルをダウンロードする際に発生する問題を修正

    [    機能改善]
    #     フォルダ構造ダウンロード機能の追加
    # FileDownloadMonitor    でダウンロードパスを指定するとき、存在しない下位ディレクトリが二つ以上あってもパスの生成が可能なよう修正
  • DEXTUploadX v2.1.1.0

    [    バグパッチ]
    #     チェックボックス、ラジオボタン及びリストのフォームタグを選択しない状態でも、該当のフォームタグの値が転送されてしまう問題を修正

    [    機能改善]
  • DEXTUploadX v2.1.0.0

    [    バグパッチ]
    # FileUploadManager    で設定したプロパティの値がFileUploadMonitorに反映されない問題を修正
    #     アップロード中にアップロードしようとするファイルが削除された場合に発生する問題を修正
    #     転送中にファイルの追加/削除が出来ないよう修正
    #     ダウンロード中にFileDownloadMonitorでファイルリストのチェックボックスを変更できないよう修正
    # FileDownloadMonitor    でユーザーが間違ったダウンロードパスを入力した場合の例外処理を修正
    # SSL    及びProxy環境でのアップロード及びダウンロードサンプルを修正
    #     ファイルアップロード後にファイルが正常にアップロードされたかを確認する間、プログレスバーは完了を表示しているのに[これまでの時間]や[転送速度]などは継続的に進行されるという問題を修正
    # FileUploadMonitor    において[OBJECT]タグの[PARAM]のプロパティにパラメータ値を伝達できない問題を修正

    [    機能改善]
    #     チェックボックスとラジオボックスの初期チェック状態をクライアントのレジストリに保存された値に設定できるプロパティを提供
    # [    続けてダウンロード]を実行する場合の重複ファイル処理用プロパティを提供
    # [    完了後、ダウンロードしたフォルダを開く]のチェックボックスを活性化し、チェック状態を設定できるプロパティを提供
    #    　[続けてダウンロード]のチェックボックスを可視化/活性化し、チェック状態を設定できるプロパティを提供
    # [    転送完了後、ウィンドウを閉じる]のチェックボックスを可視化/活性化し、チェック状態を設定できるプロパティを提供
    # [    重複ファイル処理]ラジオボックスを活性化し、チェック状態を設定できるプロパティを提供
    # FileDownloadManager    からファイルを実行する場合、[新しいウィンドウを開く]を選択できるプロパティを提供
    #     クライアントレジストリにダウンロードパスが保存されていない場合、システムの一時パスを探して設定する機能を提供
  • DEXTUploadX v2.0.3.0

    [    バグパッチ]
    # Internet Explorer    の設計変更に伴いパッチ適用
    # [input]    タグと同じフォームデータが含まれたウェブページでフォルダ構造アップロードを行う場合、間違ったフォルダ構造が生成される問題を修正

    [    機能改善]
  • DEXTUploadX v2.0.2.0

    [    バグパッチ]
    # FileDownloadMonitor    でプログレスバー進行中に転送完了イベント([OnTransferComplete])が発生するエラーを修正
    # Win98/ME    の環境でFileUploadManagerとFileUploadMonitorにドラッグ＆ドロップを実行した場合に発生するメモリー漏水問題を修正
    # FileDownloadMonitor    で重複ファイル処理のデフォルト値を[別の名前で保存]に設定できるよう修正

    [    機能改善]
    #     フォルダ構造アップロード機能の追加
    #     ドラッグ＆ドロップを実行した場合、ダイアログボックスを使ってファイルやフォルダの追加を行った場合に発生するのと同じイベントを提供
  • DEXTUploadX v2.0.1.0
    [    バグパッチ]
    # [    スキップ]モードを選択した場合、重複ファイルでない場合にもスキップを実行してしまう問題を修正
    # [    上書き]モードを選択した場合、ダウンロード中に一度キャンセルしてから再び[転送]をクリックすると[FileDownloadMonitor]ウィンドウが終了してしまう問題を修正
    #     ファイルをダウンロード中にキャンセルし、ダウンロードしていたファイルを削除しようとしても削除できない問題を修正

    [    機能改善]
    # Upload    及びDownload Listの横スクロールバーの自動調節機能を追加
    # Upload Control    のContext Menu機能を追加
    #     ファイルを続けてダウンロード機能を追加
  • DEXTUploadX v2.0.0


DEXTUploadXのインストール

■ DEXTUploadX システム条件

  • Windows 98SE以上
  • Windows 2000以上
  • ActiveXコントロールをサポートするすべてのブラウザー


DEXTUploadXのインストール

■ DEXTUploadXインストール方法(Windows)

1. DEXTUploadX 設置準備

ウィンドウ基盤の IISが設置された パソコンで DEXTUploadX ダブルクリック。

2. 使用権許諾契約

3. 購入した DEXTUploadXの製品番号(①)とシリアル番号(②)を入力します。

(評価版の場合,ダウンロード時、記録したメールに臨時製品番号と臨時シリアル番号が送信されます。)

IP入力(③) 部分には実際サービスするサーバーの IPを入力します。

製品番号とシリアル番号を正確に入力して ’次へ’ボタンを押せば下のようなメッセージウィンドウが出力されます。

製品番号またはシリアル番号が正確ではない場合は下のようなメッセージウィンドウが 出力し、製品設置が続けません。

4. 設置する位置選択

5. 設置

6. 設置完了 - 完了ボタンを 押せば使用例が実行されます。

[参照]

※ DEXTUploadX 評価版ダウンロードは下の経路で可能です。

http://www.dextsolution.com/jp/Etc/downEval.aspx

※ DEXTUploadXのマニュアルと基本サンプルは DEXTUploadX 基本的に設置した場合,

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX-DEXTUploadX 使用者マニュアル ”

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX- DEXTUploadX 使用例 ”

で確認できます。


DEXTUploadXのインストール

■ プログラムの削除

※ DEXTUploadXの完全な削除のためには下の除去過程を経った後,ウィンドウの再起動をしなければなりません。

再起動を避ける方法で除去以前に IISを消して製品を削除する方法があります。

1. スタート - すべてのプログラム - DEVPIA - DEXTUploadX - UnInstall DEXTUploadX クリック

2. DEXTUploadX 除去のために “はい”ボタンをクリックします。

3. DEXTUploadXの完全な除去のためにコンピューター再起動を選択して “Finish”ボタンをクリックします。

※ DEXTUploadXの完全な削除のためには下の除去過程を経った後,ウィンドウ再起動をしなければなりません(①)。

再起動を避ける方法で除去以前に IISを消して製品を削除する方法があります(②)。


DEXTUploadX 環境設定

■ 使用例を実行するためのバーチャルディレクトリを設定する

DEXTUploadXをインストールすると下図のように「DEXTUploadX」で始まる三つのバーチャルディレクトリが追加されます。[スタートアップメニュー]に追加された[DEXTUploadXの使用例]を実行すれば全ての使用例を実行できます。ただし、「既定ウェブサイト」が存在しない場合などは、使用例を実行するためにマニュアルでバーチャルディレクトリを設定しなければなりません。

1. 「DEXTUploadX」のバーチャルディレクトリを設定する

「DEXTUploadX」のバーチャルディレクトリにはDEXTUploadX.cabというファイルが存在します。このファイルは[C:\Program files\DEVPIA\DEXTUploadX\Bin]にインストールされます。詳しくは下記の説明を参考にしてください。

a. [バーチャルディレクトリ]を選択してから[次へ]をクリックしてください。

b. 下図のように入力した後[次へ]をクリックしてください。

c. [参照]をクリックして下図のように入力してから[次へ]をクリックしてください。

d. アクセス権限の[読み込み]オプションだけにチェックをいれ、[次へ]をクリックしてください。作業を終了するために[終了]をクリックしてください。

2. 「DEXTUploadXSamples」のバーチャルディレクトリを設定する

DEXTUploadXSamplesのバーチャルディレクトリには使用例ファイルが存在します。使用例ファイルはデフォルトでは[C:\Program files\DEVPIA\DEXTUploadX\Samples]にインストールされています。詳しくは下記の説明を参考にしてください。

a. [バーチャルディレクトリ]を選択してから[次へ]をクリックしてください。

b. 下図のように入力してから[次へ]をクリックしてください。

c. [参照]をクリックして下図のように入力した後[次へ]をクリックしてください。

d. アクセス権限をデフォルト値に設定した後[次へ]をクリックしてください。作業を終了するために[終了]をクリックしてください。

3. 「DEXTUploadXSamplesData」のバーチャルディレクトリを設定する

「DEXTUploadXSamplesData」は「Simple Put Upload」の使用例を実行するためのバーチャルディレクトリです。「Simple Put Upload」を使ってアップロードされたファイルがこのバーチャルディレクトリに保存されます。

a. [バーチャルディレクトリ]を選択してから[次へ]をクリックしてください。

b. 下図のように入力してから[次へ]をクリックしてください。

c. [参照]をクリックして下図のように入力した後に[次へ]をクリックしてください。

d. アクセス権限では[読み込み]と[書き込み]にチェックをいれ、[次へ]をクリックしてください。作業を終了するために[終了]をクリックしてください。これでユーザーがアップロードしたファイルがこのバーチャルディレクトリに書き込めるようになりました。


DEXTUploadX 環境設定

■ クライアントでDEXTUploadX を削除する

一般的な環境でクライアントにインストールされた DEXTUploadXを 削除する必要はないです。ただDEXTUploadXが画面に正常に表示されない場合、DEXTUploadXと係わる項目を全て削除して、再インストールする場合があります。その場合は次のように作業すれば良いです。

｢注意」 DEXTUploadXが挿入されていたブラウザーを終了しない場合は正常にDEXTUploadXの削除ができません。

1. Windows XP IE6で DEXTUploadX ファイル削除する

1) ブラウザーでツール --> インターネットオプションをクリックする後、
2) インタネット一時ファイルの領域で " 設定 " ボタンをクリックして, 設定画面で "オブジェクッとの表示" ボタンをクリックしてください.
3) "Downloaded Program File" エクスプローラが表示されます。
4) エクスプローラに " DEXTUploadX… " または " DEXTUploadXEx… "で始める Classを探してそれぞれの Control の上にマウス右クリックすると、削除をクリックして全てファイルを削除します。

2. Windows Server 2003 IE7で DEXTUploadX ファイルを削除する

1) ブラウザーでツール --> インターネットオプションをクリックする後、
2) 全段タブで閲覧の意暦 " 設定 " ボタン押して, インターネット一ファイル領域で " オブジェクトの表示 " ボタンをクリックしてください.
3)"Downloaded Program File" エクスプローラが表示されます。
4) エクスプローラに " DEXTUploadX… " または " DEXTUploadXEx… "で始める Classを 探してそれぞれの Control の上にマウス右クリックすると、 削除をクリックして全てファイルを削除します。

3. Windows Server 2008 IE8.xで DEXTUploadX ファイルを削除する

1) ブラウザーで “ ツール ” --> “ 追加機能管理” クリックする後、
2) 左側の中間に‘フィルター’という名の Select Boxで “ ダウンロードしたコントロール “ 選択します.
3) 掲示者が “ Devpia Corp ” と表示された部分で " DEXTUploadX… " または " DEXTUploadXEx… "と表示された部分をクリックします。
4) 画面の下部にある ActiveXの情報の中で “ 属性 “ と言う部分をクリック表示されたページで “削除 “というボタンを確認できます。
5) この部分で “削除 “ ボタンを押して DEXTUploadXを削除します。

4. その他の環境で DEXTUplaodX ファイルを削除する

その他の環境では上の項目を参考して削除してください.


DEXTUploadX 環境設定

■ DEXTUploadXが画面に表示されない場合

DEXTUploadXがInternet Explorerに正しく表示されない場合、次のファイルが存在しているかどうか、また損傷していないかどうかを確認してください。下記のファイルが一つでも不足している場合はDEXTUploadXがきちんと作動しません。

1. C:\Windows\System32\ADVAPI32.DLL

2. C:\Windows\System32\COMCTL32.DLL

3. C:\Windows\System32\CRYPT32.DLL

4. C:\Windows\System32\DEXTUPLOADX.DLL

5. C:\Windows\System32\GDI32.DLL

6. C:\Windows\System32\KERNEL32.DLL

7. C:\Windows\System32\MSASN1.DLL

8. C:\Windows\System32\MSVCRT.DLL

9. C:\Windows\System32\NTDLL.DLL

10. C:\Windows\System32\OLE32.DLL

11. C:\Windows\System32\OLEAUT32.DLL

12. C:\Windows\System32\RPCRT4.DLL

13. C:\Windows\System32\SHELL32.DLL

14. C:\Windows\System32\SHLWAPI.DLL

15. C:\Windows\System32\USER32.DLL

16. C:\Windows\System32\WININET.DLL

17. C:\Windows\System32\WS2HELP.DLL

18. C:\Windows\System32\WS2_32.DLL

19. C:\Windows\System32\UnicoWs.dll

Copyright ⓒ DEVPIA Corporation. All rights reserved


DEXTUploadX 環境設定

■ DEXTUploadXのActiveXがインストールできない場合の解決方法。

1. OSのバージョンを確認する

‘マイコンピュータ’を右クリックして 'プロパティ'メニューを選択してOSのバージョンを確認します。

ウィンドウアップデート情報を確認する後、最新バージョンにアップデートします。

もう最新バージョンの場合,

基本的にウェブブラウザーの上部に黄色バーの案内ボタンを押して 'ActiveX コントロール設置’を選択。

2. 黄色バーの案内ボタンが現われない場合 - 'インターネットオプション' 設定を変更する

(環境によって該当するオプションの名称や位置などの差がある可能性があります。)

a. ウェブブラウザー(Internet Explorer)で 'ツール' メニューの'インターネットオプション' を選択します.

b. 'インターネットオプション'で ’セキュリティ’ タブをクリックします.

c. 下にある 'インターネット' アイコンを選択します.

d. ウィンドウ下部の 'レベルのカスタマイズ' ボタンをクリックします.

e. ‘ActiveX コントロールとプラグイン' 項目グループがあります.

次のように設定を変更します.

バイナリービヘイビアとスクリプトビヘイビア -> 有効にする

署名済み ActiveX コントロールのダウンロード -> 有効にする

スクリプトを実行しても安全だとマークされているActiveXコントロールの初期化とスクリプトの実行 ->　有効にする

ActiveX コントロールとプラグインの実行 -> 有効にする

ActiveX コントロールに対して自動的にダイアログを表示 -> 有効にする

- 上のように設定を変更した後には必ず下部の 'OK'ボタンを押してください。

f. 今度は 'インターネットオプション' ウィンドウで '詳細設定' タブを押します.
g. 下の 'セキュリティ' 項目で次のように設定を変更します.

[マイコンピュータのファイルでのアクティブコンテンツの実行を許可する] -> チェック

- 上のように設定を変更した後には必ず下部の 'OK'ボタンを押してください。

またウェブブラウザーを実行して ActiveX 設置が表示されるかを確認します。


DEXTUploadX プログラミング

■ DEXTUploadX エラー処理方法

エラー処理のための基本コードは次のとおりです。

<SCRIPT For = "FileUploadManager" Event = "OnError(nCode, sMsg, sDetailMsg)" LANGUAGE = "javascript">
OnFileManagerError(nCode, sMsg, sDetailMsg);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnFileManagerError(nCode, sMsg, sDetailMsg)
{
// ここでエラーを処理する。
}
</SCRIPT>

DEXTUploadXは、[OnError]イベントが発生した場合、3種類の情報(nCode、sMsg、sDetailMsg)を提供してくれます。

1. nCodeはエラーコードです。その種類は下記のとおりです。

20000000 ~
アップロードしようとするファイルが指定のサイズを超えたりした場合に起こる一方的なエラーです。このコードに該当するエラーメッセージは、大部分が一般ユーザーに知らされなければならない内容です。

30000000 ~
ウィンドウズのシステム関数エラーです。ファイルが現在使用中だったり、インターネットを使用できないなどの問題があった場合に発生します。一部は一般ユーザーに知らされなければならない内容です。

40000000 ~
サーバーから発せられるエラーメッセージです。クライアント側には問題がないが、サーバー側になんらかの問題がある場合に発生します。40000以降の数字はサーバーのエラーコードです。(例：40000404は「接近エラー」)。

50000000 ~
ブローカープロセスと通信中に発生するエラーです。ブローカープロセスが削除されたり正常に動作しない場合に発生します。この種類のエラーの中には一般のユーザーにも知らせなければならないものもあります。

60000000 ~
ブローカープロセスで発生するウィンドウズのシステム関数に関するエラーです。ファイルが使用中だったり、インターネットが使用できないなどの問題がある場合に発生します。この種類のエラーの中には一般のユーザーにも知らせなければならないものもあります。

2. sMsgは簡単なエラーメッセージです。

sMsgはユーザーにどんなエラーが発生したかを知らせる単純なメッセージです。このエラーの正確な原因はsDetailMsgが知らせてくれます。40000000のエラーの場合、サーバーから送られるページのタイトルが表示されます。サーバーに問題がある場合、「サーバーとの接続が非正常的に終了しました」というエラーメッセージが表示されます。その場合、アップロードしようとしていたファイルのサイズが16KB以上の可能性があります。HTTPの構造上、サーバーから送られるエラーメッセージを正常に受信するためには、16KB以下のファイルをアップロードしなければなりません。そうすることによりsDetailMsgにサーバー側からの正確なメッセージが伝えられ、問題点が何なのかを詳しく判断する事ができるようになります。

3. sDetailMsgはエラーの原因を知らせるメッセージです。

sDetailMsgはsMsgが発生した原因を知らせるメッセージです。 sDetailMsgはエラーの種類によっては表示されない場合もあります。40000000のエラーの場合、サーバーから送られるページの実質的な内容が表示されます。


DEXTUploadX プログラミング

■ DEXTUploadX 基本的なファイルのアップロード

DEXTUploadXのファイルアップロードは下図のようにFileUploadManagerオブジェクトとFileUploadMonitorオブジェクトによって実現されます。

図1>FileUploadManager

図2> FileUploadMonitor

FileUploadManagerオブジェクトにファイルを追加して転送するとFileUploadMonitorオブジェクトが呼び出されます。FileUploadMonitorオブジェクトで再び転送を実行すると、FileUploadManagerから転送されたすべてのファイルとフォームアイテムは指定されたサーバーへと転送されます。FileUploadManagerを使わずにFileUploadMonitorだけを使用することも可能です。ただし、その場合、フォームアイテムは自動的に転送されないため、ユーザーがそれぞれのフォームアイテムを追加しなければなりません。

1. FileUploadManagerの基本的なコード

エラー処理コードを除いた最も基本的なFileUploadManagerのコードは下記のとおりです。

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=Shift-JIS">
<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">
winstyle="height=355,width=445, status=no,toolbar=no,menubar=no,location=no"
window.open "./FileUploadMonitor.htm",null,winstyle
</SCRIPT>
</HEAD>

<BODY>
<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0"
height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
</OBJECT>
</BODY>
</HTML>

ブルーで表示された部分は、各サーバー及びDEXTUploadXのバージョンにあわせて必ず修正しなければなりません。この値が正しくない場合、DEXTUploadXはIEに表示されません。

FileUploadManagerの[転送]ボタンをクリックすると、[OnTransfere_Click()]というイベントが発生します。ユーザーは、このイベントからFileUplodaMonitorオブジェクトが存在するページを呼び出すようにしてください。

2. FileUploadMonitorの基本的なコード

エラー処理コードを除いた最も基本的なFileUploadMonitorのコードは下記のとおりです。

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=Shift-JIS">
<SCRIPT LANGUAGE="VBS">
Sub OnLoading()
document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/PostScript.asp"
document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items
document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties
End Sub
</SCRIPT>
</HEAD>

<BODY onload="OnLoading()" bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0>
<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5
CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
</OBJECT>
</BODY>
</HTML>

FileUploadMonitorまたはブルーで表示された部分は、各サーバー及びDEXTUploadXのバージョンにあわせて必ず修正してください。この値が正しくない場合、DEXTUploadXはIEに表示されません。

UploadURL は、DEXTUploadXが転送したファイルを処理するスクリプトの位置です。DEXTUpload Professionalを基準にすると、ファイルが転送される場所はIEでもDEXTUploadXでも違いはありません。DEXTUploadXはIEの代わりにファイルやフォームデータを転送する役割をすると理解いただければ、サーバースクリプトファイルを作成する際の手助けになるでしょう。スクリプトファイルについては、該当サーバーアップロードコンポーネント(DEXTUpload ProfessionalやDEXTUpload.NET Professionalなど)のマニュアルを参考にしてください。

Items は、FileUploadManagerが伝達するファイル及びフォームアイテムを渡し受けます。このプロパティを設定しなかった場合、FileUploadMonitorはアイテムをひとつも持たずに実行されることになります。

Properties では、FileUploadManagerで設定されたいくつかのプロパティ(ファイルサイズ制限や個数制限、最後に選択されたフォルダの位置など)を指定してください。このプロパティを設定しなくても作業に大きな支障はありませんが、できるだけ設定を行うようお勧めいたします。

DEXTUploadXの初期化は、一部の類似アップロードコンポーネントが別途の初期化イベントを持つのと違い、上記の使用例のようにページがローディングされるときに実行されます。UploadURLのようなプロパティは<PARAM>形式で指定する事も可能です。


DEXTUploadX プログラミング

■ DEXTUploadX PUT ファイルアップロード

サーバーに別途のスクリプト(ASP,ASP.NET みたいな)でアップロードされたファイルを処理する POST 方式と違い PUT 方式は単純にファイルをアップロードすること以上の作業には多くの不便さがよります。それで DEVPIAはユーザーができるだけ POST 方式を使うことを勧奨します。

PUT 方式ファイルアップロードは POST 方式で下二つの部分だけ変更すれば良いです。

Sub OnLoading()
document.all("FileUploadMonitor").EnablePutMode = TRUE
document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamplesData"

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items
document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties
End Sub

EnablePutMode を TRUEに設定して PUT モードを宣言します。

UploadURL にはスクリプトファイルの位置代わりにアップロードするサーバーの仮想ディレクトリーの位置を入力します。送信が完了すれば明示した所にファイルがアップロードされます。

※ PUT方式アップロード時、基本環境設定
PUT方式のアップロード時、該当のサーバーの IISに WebDAV が許容されてなければならなくて (IIS6の場合にだけ当たります。IIS5は当たらないです.),アップロードされたファイルが保存されるフォルダ(基本設置時経路 C:Program FilesDEVPIADEXTUploadXsamplesData)に Everyone勘定の ‘すべての権限’が設定されていなければなりません。


DEXTUploadX プログラミング

■ DEXTUploadX POST ファイルアップロード

DEXTUploadX で POST方式でアップロード時,基本的に DEXTUpload Proと連動されています。

DEXTUploadXだけ使おうとする場合,POST方式アップロード及びその他機能具現に制約があります。

下記のようにUploadURLには POST方式でアップロードするサーバーページの経路及びサーバーページ名を明示します。 外部で使うためにLocalhostに表示された部分にサーバーのアドレスに変更します。

<SCRIPT LANGUAGE="VBS">

sub OnLoading()

' Post 方式の場合下記のように UploadURL プロパティーに Post Script ファイルを明示をしなければなりません。

' 標準ポート以外の他のポートを使おうとすれば

' http://Localhost:8080/DEXTUploadX/Upload/PostScript.asp

' と一緒に一般的なアドレス指定方法と等しく使えば良いです。

document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/PostScript.asp"

' このページの 上位ページファイルマネージャーコントロールのすべての ファイル及びフォームアイテムを ファイルモニターコントロールにコピーします。

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items

' ファイルマネージャーの何種類の プロパティーたち(DefaultPath,Filter 等々)の 値をファイルモニターにコピーします。

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties

end sub

</SCRIPT>

DEXTUploadXはアップロードするファイルを ‘DEXTUploadX’という名前で送ります。

下のコードは POST方式アップロード時 DEXTUploadXでアップロードになるいくつかのファイルを DEXTUpload Proで保存する部分です。

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.AutoMakeFolder = TRUE
uploadform.DefaultPath="C:\TEMP"

For i = 1 To uploadform("DEXTUploadX").count
uploadform("DEXTUploadX")(i).save
Next

Set uploadform = Nothing
%>


DEXTUploadX プログラミング

■ DEXTUploadX フォルダ構造のアップロード

フォルダ構造のファイルアップロードを実行する場合、POST方式から下記のように一ヶ所だけ変更してください。

Sub OnLoading()
document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/StructureFolderPostUpload.asp"

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items
document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties
End Sub

UploadURLのStructurFolderPostUpload.aspは、DEXTUploadXからフォームデータを受けてフォルダを生成するスクリプトです。


DEXTUploadX プログラミング

■ DEXTUploadX フォームアイテムを転送する

DEXTUploadXは、FileUploadManagerが存在するページにあるすべてのINPUT/SELECT/TEXTAREAタイプのフォームアイテムを自動的に転送します。万一、ユーザーがこのフォームアイテム以外のアイテムを追加したい場合は下記のような作業を行ってください。

FileUploadManager.AddFormItem "UserAddText", "これはテスト用テキストです。"

AddFormItem の最初のファクターはフォームアイテムの名前です。二番目はフォームアイテムの値です。


DEXTUploadX プログラミング

■ DEXTUploadX ファイル及びフォームアイテムを使用する

DEXTUploadXに追加されたファイル及びフォームアイテムにアクセスする方法はいくつかあります。これはすべてのオブジェクトに同様です。
アップロードオブジェクトは(FileUploadManager, FileUploadMonitor) Name, Size, Alias, UserDataA, UserDataB 属性を支援し、
ダウンロードオブジェクトは(FileDownloadManager, FileDownloadMonitor) Name, Size 属性を支援します。

1. コレクションスタイル

For Each FileItem In document.all("FileUploadManager")
MsgBox "ファイル名: " & FileItem.Name
MsgBox "ファイルサイズ: ” & FileItem.Size
 MsgBox “別称: “ & FileItem.Alias
MsgBox “ユーザーデータ A: “ & FileItem.UserDataA
 MsgBox “ユーザーデータ B: “ & FileItem.UserDataB
Next

ファイルアイテムには二つのプロパティ(Name、Size)があります。コレクションスタイルでは上記のように使用できます。コレクションスタイルではファイルアイテムへのアクセスのみが可能です。フォームアイテムを使用するためにはインデックススタイルを使用してください。

2. インデックススタイル

For i = 1 to document.all("FileUploadMonitor").Count
MsgBox "ファイル名: " & document.all("FileUploadMonitor")(i)
 MsgBox "ファイルサイズ: " & document.all("FileUploadMonitor")(i).Size
 MsgBox “別称: “ & document.all("FileUploadMonitor")(i).Alias
MsgBox “ユーザーデータ A: “ & document.all("FileUploadMonitor")(i).UserDataA
 MsgBox “ユーザーデータ B: “ & document.all("FileUploadMonitor")(i).UserDataB
Next

上記の使用例もファイルアイテムにアクセスし、ファイルのサイズや名前を取得しています。[Count]プロパティは全体のファイル数を表しています。ファイルではなくフォームアイテムを求めたい場合、ブルーで表示された「i」に、該当のフォームアイテム名を入力してください。

MsgBox "フォームアイテム名" + document.all("FileUploadMonitor")(“フォームアイテム名”)

ブルーで表示された部分に数字を入力すると、リストコントロールボックスに見えるファイルの位置が表示され、上記のように文字列を入力すると、フォームアイテムが表示されます。


DEXTUploadX プログラミング

■ BBS修正(編集)機能を使用する

DEXTUploadXは、掲示物が修正されるときにアップロードされたファイルも一緒に修正されるよう、編集機能もサポートしています。主なコードは次のとおりです。

1. FileUploadManagerで

// アイテムの固有値、表示されるファイル名、ファイルサイズの順に表示されます。
FileUploadManager.AddUploadedFile "SN0001", "FileTest1.txt", 11111
FileUploadManager.AddUploadedFile "SN0002", "FileTest2.txt", 22222
FileUploadManager.AddUploadedFile "SN0003", "FileTest3.txt", 33333

AddUploadedFile は、サーバーにアップロードされているファイルをFileUploadManagerに仮想的に追加するメソッドです。最初のファクターは該当ファイルを区分できる唯一のキーです。このキーは、サーバーに存在するファイルの物理的なパス、もしくはDBに保存されたファイルのPrimary Keyです。サーバースクリプトでは、このキーを使用してファイルが区分されます。二番目のファクターはFileUploadManagerに表示されるファイル名です。三番目のファクターばFileUploadManagerに表示されるファイルサイズです。

2. FileUploadMonitorで

[AddUploadedFile]を使って追加された仮想ファイルは、FileUploadMonitorのリストコントロールには表示されません。仮想ファイルは実際にアップロードされることがないため、FileUploadMonitorから排除されます。万一、ユーザーが仮想ファイルのみを修正し、実際にアップロードするファイルがない場合、DEXTUploadXは転送するファイルがないというエラーメッセージを表示します。これを避けるために[EnableEmptyFileUpload]のプロパティを使用できます。[EnableEmptyFileUpload]を使用すると、アップロードする実際のファイルがなくても仮想ファイルやフォームアイテムの転送が許されるようになります。

<SCRIPT LANGUAGE="VBS">
sub OnLoading()
document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/AddUploadedFile/PostScript_AddUploadedFile.asp"
document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items
document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties

'実際に転送するファイルがなく、フォームアイテムのみを転送しなければならない場合、ユーザーの同意を求めずにすぐに転送を行います。
If 0 = document.all("FileUploadMonitor").Count then
document.all("FileUploadMonitor").EnableEmptyFileUpload = TRUE
document.all("FileUploadMonitor").Transfer
End If
end sub
</SCRIPT>

3. PostScript.ASPで

ユーザーがFileUploadMonitorから転送を行うと、サーバーでは下記のような形でファイルを処理できます。

For each UserFile in uploadform("DextuploadX")
Response.Write UserFile.FileName
Next

For each UploadedItem in uploadform("DEXTUploadX_Uploaded")
Response.Write UploadedItem
Next

For each DeleteItem in uploadform("DEXTUploadX_Deleted_Uploaded")
Response.Write DeleteItem
Next

一番目の[For Each]構文は、一般的にアップロードされたファイルを処理する場合と同様です。二番目と三番目の[For Each]構文を見ると、フォーム名がそれぞれ「DextUploadX_Uploaded」と「DextUploadX_Deleted_Uploaded」と表示されています。この二つのフォームは、ファイルアイテムではない一般的なテキストフォームです。つまり、[Save]などの機能がなく、単に[AddUploadedFile]メソッドによって指定された固有キーの値だけを保有しています。

「DEXTUploadX_Uploaded」は、[AddUploadedFile]を使ってFileUploadManagerに追加された仮想ファイルが削除されずにそのまま存在しているファイルの固有キーリストです。

「DEXTUploadX_Deleted_Uploaded」は、[AddUploadedFile]を使ってFileUploadManagerに追加された仮想ファイルが削除されたファイルの固有キーリストです。つまり、一般的には、ユーザーは「DEXTUploadX_Deleted_Uploaded」に存在する固有キーに該当するファイルを削除すれば良いです。


DEXTUploadX プログラミング

■ 多国語環境で使用する

DEXTUploadXは、Windows NT系とWindows 98でも完璧なユニコードをサポートしています。また、ひとつのCABファイルで二つのOSをすべて対応しているため、バージョン管理にもメリットがあります。下記はユニコードをサポートするために追加されたコードに関する説明です。

1. FileUploadMonitorで

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
.
.
.
document.all("FileUploadMonitor").CodePage = 65001

基本的にFileUploadMonitorの[CodePage]プロパティの設定だけを行えばOKです。ウェブページ上で文字化けしないように[charset]も修正しなければなりません。上記の使用例ではユニコードで指定されています。中国語や日本語なども指定できます。

1. PostScriptで

set uploadform=server.CreateObject("DEXT.FileUpload")
uploadform.CodePage = 65001

サーバースクリプトでは使用するコンポーネントによって方式が異なります。DEXTUpload Professionalの場合は上記のように[CodePage]に該当する値を設定してください。


DEXTUploadX プログラミング

■ 基本的なファイルのダウンロード

DEXTUploadXのファイルダウンロードは、ファイルアップロードと同じく[FileDownloadManager]オブジェクトと[FileDownloadMonitor]オブジェクトにより実現されます。

図 1> FileDownloadManager

図 2> FileDownloadMonitor

[FileDownloadManager]オブジェクトにファイルを追加すると、チェックボックスがチェックされた状態でファイルが追加されます。詳しいコードについては下記のとおりです。

1. FileDownloadManagerの基本的なコード

エラー処理コードを除く基本的なFileDownloadManagerのコードは下記のとおりです。

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=Shift-JIS">
<script language="vbs">
Sub OnLoading()
// ファイルのURL/サイズ/名前(ファイル名は省略可能)
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile1.tst", 10000000
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile2.tst", 20000000
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile3.tst", 30000000, "DevpiaTest3.tst"
 End Sub

Sub OpenDownloadMonitor()
winstyle= "height=445,width=445, status=no,toolbar=no,menubar=no,location=no"
window.open "FileDownloadMonitor.htm",null,winstyle
End Sub
</script>
</HEAD>

<BODY onload="OnLoading()">
<OBJECT ID="FileDownloadManager" height="200" width="450"
CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0"
CLASSID="CLSID:535AE497-8E85-45F8-AF36-2DFCBCA8B68A"></OBJECT>

<INPUT type="button" value="ダウンロードモニターウィンドウを表示" onclick="OpenDownloadMonitor()">
</BODY>
</HTML>

ブルーで表示された部分は、各サーバーにあわせて設定しなければなりません。

FileDownloadManagerの[AddFile]メソッドを使用してダウンロードするファイルを追加できます。

最初のファクターはファイルの住所です。この住所は絶対に一つのサーバーである必要はありません。つまり、いくつかのファイルサーバーからダウンロードできるよう指定することも可能です。

２番目のファクターはファイルのサイズです。これは必ずユーザーが指定しなければなりません。ファイルのサイズはバイト単位で正確に入力してください。

3番目のファクターはFileDownloadManagerに表示されるファイル名です。これはオプションで、入力しなかった場合は最初のファクターに指定されたファイル名を使用します。


DEXTUploadX プログラミング

■ ダウンロードファイルアイテムを使用する

ダウンロードオブジェクトは、アップロードオブジェクトと同様の方法でファイルアイテムに接近できます。ただし、ダウンロードの特性上、フォームアイテムに関連する部分は例外となります。

1. コレクションスタイル

For Each FileItem In document.all("FileDownloadManager")
MsgBox "ファイル名" + FileItem.Name + "ファイルサイズ" & FileItem.Size & " URL " + FileItem.URL
Next

ファイルアイテムには三つのプロパティ(Name、Size、URL)があります。コレクションスタイルでは上記のように使用できます。

2. インデックススタイル

For I = 1 to document.all("FileDownloadManager").TotalCount
MsgBox "ファイル名" + document.all("FileDownloadManager")(i) + “ファイルサイズ" & document.all("FileDownloadManager")(i).Size & " URL " + document.all("FileDownloadManager")(i).URL
Next

上記の使用例もファイルアイテムにアクセスし、ファイルのサイズと名前を取得しています。[TotalCount]のプロパティは全体のファイル数を表示しています。


DEXTUploadX オブジェクトリファレンス

■ [DefaultPath]プロパティ

属性
Read/Write

タイプ
String

説明
ユーザーがファイル選択ダイアログを開くときのダイアログの初期位置。指定がない場合はユーザーが最後にアクセスしたフォルダがデフォルトになります。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="DefaultPath" VALUE="C:\Temp">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Filter]プロパティ

属性
Read/Write

タイプ
String

説明
全てのファイル及びフォルダの追加に適用されるフィルタストリングです。

デフォルトは[全てのファイル|*.*|]です。

使用例

<PARAM NAME="Filter" VALUE="All Files|*.*|Image Files|*.jpg;*.jpeg;*.gif;*.bmp|">


■ [RFilter]プロパティ

属性
Read/Write

タイプ
String

説明
Filter プロパティーの反対機能で,登録された拡張子にあたるファイルは追加されません。

使用例

<PARAM NAME="RFilter" VALUE="*.jpg;*.jpeg;*.bmp">


■ [Items]プロパティ

属性
Read

タイプ
Variant

説明
FileUploadManagerがFileUploadMonitorにフォームデータ及びファイルを伝達するために使用します。

使用例

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items


■ [Properties]プロパティ

属性
Read

タイプ
Variant

説明
FileUploadManagerの 6種プロパティー(DefaultPath,Filter,RFilter,MaxCount,MaxFileSize,MaxTotalSize)を FileUploadMonitorに伝達する。
DEXTUpload Pro Extension バージョンの場合 “EnableLargeUpload” プロパティーの値も同時に伝達する。

使用例

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties


■ [ButtonVisible]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの右側にある四つのボタンを表示するかを決定します。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ButtonVisible" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [StatusBarVisible]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの下段に位置するステータスバーを表示するかを決定します。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="StatusBarVisible" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableAddFileButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの右側にある[ファイルを追加]ボタンを活性化もしくは非活性化します。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableAddFileButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableAddFolderButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの右側にある[フォルダを追加]ボタンを活性化または非活性化します。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableAddFolderButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableAutoIncludeFormItems]プロパティ

属性
Write

タイプ
BOOL

説明
FileUploadManagerが挿入されているページ全ての input typeのポームデータ情報を自動で送らないように設定する。デフォルトは TRUE だ。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableAutoIncludeFormItems" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableDeleteButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの右側にある[アイテムを削除]ボタンを活性化または非活性化します。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableDeleteButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableLargeUpload]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
大容量アップロード支援(2GB 以上)。デフォルトはFALSEだ。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" height="200" width="450" classid="CLSID:4FCFCDC8-346B-4d35-A001-C92AA3775BBB" VIEWASTEXT>
<PARAM NAME="EnableLargeUpload" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableTransferButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadManagerの右側にある[転送する]ボタンを活性化または非活性化する。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableTransferButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


DEXTUploadX_EnableDragDrop

■ [EnableDragDrop]プロパティ

属性
Write

タイプ
BOOL

説明
FileUploadManagerリストビューのファイル及びフォルダをDrag&Dropできる機能を活性化または非活性化します。デフォルトは[TRUE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableDragDrop" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnablePHPFILES]プロパティ

属性
Write

タイプ
BOOL

説明
PHPが提供する[HTTP_POST_FILES]や[_FILES]と連動して別のサーバーコンポーネント(DEXTUpload Proなど)なしでPOST方式のアップロードが可能できるようにサポートします。デフォルトは[FALSE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnablePHPFILES" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableSortByColumn]プロパティ

属性
Write

タイプ
BOOL

説明
ListViewのコラム名を通じる整列を支援します。
デフォルトは[FALSE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="EnableSortByColumn" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ImageURL]プロパティ

属性
Write

タイプ
String

説明
ListViewに設定するバックグラウンドイメージの URLです。

使用例

document.all("FileUploadManager").ImageURL = "http://Localhost/DEXTUploadXSamples/img/ListViewBkImage.bmp"


■ [XOffsetPercentOfImage]プロパティ

属性
Write

タイプ
Long

説明
ListViewバックグラウンドイメージの縦の位置値です。(Offset Percentage)
デフォルトは[50%]です。

使用例

document.all("FileUploadManager").XOffsetPercentOfImage = 50


■ [YOffsetPercentOfImage]プロパティ

属性
Write

タイプ
Long

説明
ListViewバックグラウンドイメージの横の位置値です。(Offset Percentage)
デフォルトは[50%]です。

使用例

document.all("FileUploadManager").YOffsetPercentOfImage = 50


■ [ListViewStyle]プロパティ

属性
Read/Write

タイプ
String

説明
リストビューのスタイルを変更します。デフォルトは[LVS_REPORT]です。

スタイル

LVS_REPORT | - ファイルに関する詳しい情報を表示するレポートスタイルです。
LVS_LIST | - ファイルに関する簡単な情報を表示するリストスタイルです。
LVS_ICON | - ファイルに関する簡単な情報を表示するアイコンスタイルです。
LVS_SMALLICON | - ファイルに関する簡単な情報を表示する小さなアイコンスタイルです。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewStyle" VALUE="LVS_LIST">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewSortStyle]プロパティ

属性
Read

タイプ
String

説明
ファイルが追加される時リストビューの 整列モードを指定します。 指定ファイル追加手順によって 順次にリストビューにファイルが追加される。.

スタイル

ASC – ファイルに対する昇順整列をしてくれるスタイル

DESC – ファイルに対する降順整列をしてくれるスタイル

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewSortStyle" VALUE="ASC">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewLineStyle]プロパティ

属性
Read/Write

タイプ
BOOL

説明
リストビューのラインに関する[Visible]のプロパティを設定します。リストビューのスタイルが[LVS_REPORT]の場合だけ使用できます。デフォルトは[TRUE] です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewLineStyle" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewFileStyle]プロパティ

属性
Read/Write

タイプ
String

説明
リストビューに追加されたファイルの表示スタイルを変更します。デフォルトは[LVFS_FILEPATH]です。

スタイル

LVFS_FILEPATH | - リストビューにファイルの全体パスを表示するスタイルです。
LVFS_FILENAME | - リストビューにファイル名だけを表示するスタイルです。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewFileStyle" VALUE="LVFS_FILENAME">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューの背景色を変更します。入力値はRGBの色コードです。デフォルトは、背景色が設定されていない[CLR_NONE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキストの色を変更します。入力値はRGBの色コードです。デフォルトは、テキストの色が設定されていない[CLR_NONE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewTextColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキスト背景色を変更します。入力値はRGBの色コードです。デフォルトはテキスト背景色が設定されていない[CLR_NONE] です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="ListViewTextBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [VisibleListViewFrame]プロパティ

属性
Read/Write

タイプ
BOOL

説明
リストビューのアウトラインに関する[Visible]のプロパティを設定します。デフォルトは[TRUE] です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="VisibleListViewFrame" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [VisibleContextMenu]プロパティ

属性
Read/Write

タイプ
BOOL

説明
リストビューの[Context Menu]に関する[Visible]のプロパティを設定します。デフォルトは[TRUE]です。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="VisibleContextMenu" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Count]プロパティ

属性
Read

タイプ
LONG

説明
FileUploadManagerオブジェクトにユーザーが追加したファイルの個数

使用例

alert("全体のファイル数:" + document.all("FileUploadManager").Count);


■ [CheckResume]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read/Write

タイプ
BOOL

説明
大容量アップロードが活性化になっている時、続けてアップロードを選択できる。
デフォルトは FALSEだ。

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" height="200" width="450" classid="CLSID:4FCFCDC8-346B-4d35-A001-C92AA3775BBB" VIEWASTEXT>
<PARAM NAME="CheckResume" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxCount]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadManagerに追加できるファイルの最大個数

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="MaxCount" VALUE="10">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxTotalSize]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadManagerに追加できる全体ファイルの最大サイズ

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="MaxTotalSize" VALUE="10000">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxFileSize]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadManagerに追加できる個別ファイルの最大サイズ

使用例

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>
<PARAM NAME="MaxFileSize" VALUE="10000">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Size]プロパティ

属性
Read

タイプ
LONG

説明
FileUploadManagerオブジェクトに追加した全てのファイルのサイズ

使用例

alert("全体のファイルサイズ:" + document.all("FileUploadManager").Size);


■ [AddFile]メソッド

形式

AddFile(FilePath, Alias, UserDataA, UserDataB, ResumeDirPath, TransferedFileSize)

FilePath – クライアントに存在するファイルの物理的な経路
Alias – FilePathに対する別称
UserDataA – FilePathに対するサーバーに送ろうとするユーザー任意の付加的なデータ
UserDataB - FilePathに対するサーバーに送ろうとするユーザー任意の付加的なデータ
ResumeDirPath – 続けてアップロードをする時、生成されたディレクトリーを指定
TransferedFileSize – 続けてアップロード時、サーバーに生成された臨時ファイルの大きさ(BYTE 単位)

戻り値

説明
クライアントにいるファイルを FileUploadManagerに追加します。一般的にユーザーが選択してファイルを追加するからこのメソッドを使う仕事は珍しいです。

使用例

document.all("FileUploadManager").AddFile("C:\Temp\Test.zip");
document.all("FileUploadManager").AddFile("C:\Temp\Test.zip", "Alias.htm");
document.all("FileUploadManager").AddFile("C:\Temp\Test.zip", "Alias.htm", "これはユーザーが入力した任意のデータです");
document.all("FileUploadManager").AddFile("C:\Temp\Test.zip", "Alias.htm", "これはユーザーが入力した任意のデータです", "これはユーザーが入力した任意のデータです");
document.all("FileUploadManager").AddFile("C:\Temp\Test.zip", "", "", "これはユーザーが入力した任意のデータです");

// ブラウザーが閉まった時などの 状況でまた続けてアップロードをする時、 続けてアップロードしてるファイルの 情報を入力します。
// 必須入力パラメーターは FilePath,ResumeDirPath,TransferedFileSize です。
document.all("FileUploadManager").AddFile("C:\Temp\Test.zip", "", "", "", "C:\Temp\DXT59071198331196", 30000000);


■ [AddFolder]メソッド

形式

AddFolder(FolderPath)

FolderPath - クライアントに存在するフォルダの物理的なパス

戻り値

説明
クライアントのフォルダに保存されたファイルをFileUploadManagerに追加します。一般的に、ユーザーが選択したフォルダを追加するためにこのメソッドを使用することはあまりありません。

使用例

document.all("FileUploadManager").AddFolder(“C:\Temp”);


■ [AddFormItem]メソッド

形式

AddFormItem(FormName, FormValue);

FormName – フォームアイテムの名前です。
FormValue – フォームアイテムの値です。

戻り値

説明
DEXTUploadXはFileUploadManagerが存在するページのすべてのINPUT/ SELECT/ TEXTAREAタイプのフォームアイテムを自動的に転送します。ユーザーがその他のフォームアイテムを必要とする場合にこのメソッドをお使いください。

使用例

FileUploadManager.AddFormItem "UserAddText", "これはテスト用テキストです。"


■ [AddUploadedFile]メソッド

形式

AddUploadedFile(Index, FilePath, Size)

Index – 追加されたバーチャルファイルアイテムを区分する唯一のキー
FilePath – FileUploadManagerに表示されるファイル名
Size – FileUploadManagerに表示されるファイルのサイズ

戻り値

説明

バーチャルファイルをFileUploadManagerに追加するメソッドです。このメソッドを使用するとBBS修正モードの具現が可能になります。詳しくはDEXTUploadXプログラムの「BBS修正(編集)機能の使い方」を参考にしてください。

使用例

FileUploadManager.AddUploadedFile "SN0001", "FileTest1.txt", 11111
FileUploadManager.AddUploadedFile "SN0002", "FileTest2.txt", 22222
FileUploadManager.AddUploadedFile "SN0003", "FileTest3.txt", 33333

///////////////////////////////////////////////////////////////////////

For each UserFile in uploadform("DextuploadX")
Response.Write UserFile.FileName
Next

For each UploadedItem in uploadform("DEXTUploadX_Uploaded")
Response.Write UploadedItem
Next

For each DeleteItem in uploadform("DEXTUploadX_Deleted_Uploaded")
Response.Write DeleteItem
Next

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [DeleteFile]メソッド

形式

DeleteFile(FilePath)

FilePath - クライアントに存在するファイルの物理的なパス

戻り値

説明
[AddFile]メソッドを使用して追加したファイルアイテムを削除できます。

使用例

document.all("FileUploadManager").DeleteFile(“C:\Temp\Test.htm”);


■ [DeleteAllFile]メソッド

形式

DeleteAllFile()

戻り値

説明
FileUploadManagerのすべてのファイルを削除します。

使用例

document.all(“FileUploadManager”).DeleteAllFile();


■ [DeleteFolder]メソッド

形式

DeleteFolder(FolderPath)

FolderPath - クライアントに存在するフォルダの物理的パス

戻り値

説明
クライアントに保存されたフォルダを削除します。一般的に、ユーザーがフォルダを削除するのはリスクが伴います。このメソッドの使用は慎重に行ってください。

使用例

document.all("FileUploadManager").DeleteFolder (“C:\Temp”);


■ [DeleteFormItem]メソッド

形式

DeleteFormItem(FormName)

FormName – 削除しようとするフォームアイテムの名前

戻り値

説明
[AddFormItem]を使って追加されたフォームアイテムを削除します。

使用例

FileUploadManager.DeleteFormItem "UserAddText"


■ [DeleteSelectedFile]メソッド

形式

DeleteSelectedFile(Index)

Index - 削除したいファイルのインデックス

戻り値

説明

Indexに値が入力されていない場合、FileUploadManagerに選択されているファイルが削除されます。FileUploadManagerの右側にある[削除]ボタンと同じ働きをします。
Indexに0以上の正しい値が入力されている場合、FileUploadManagerに追加されているファイルの中でインデックスに該当するファイルが削除されます。

使用例

document.all("FileUploadManager").DeleteSelectedFile(); // FileUploadManagerの右側にある[削除]ボタンと同じ働きをします。
document.all("FileUploadManager").DeleteSelectedFile( 3 ); // FileUploadManagerに追加されているファイルの中から3番目に該当するファイルが削除されます。


■ [DeleteUploadedFile]メソッド

形式

DeleteUploadedFile(Index)

Index – 削除する仮想ファイルアイテムを区分する唯一のキー

戻り値

説明
[AddUploadedFile]を使ってFileUploadManagerに追加されたバーチャルアイテムを削除するメソッドです。

使用例

FileUploadManager.DeleteUploadedFile "SN0003"


■ [OpenFileDialog]メソッド

形式

OpenFileDialog()

戻り値

説明
ファイル選択ダイアログの画面を表示します。FileUploadManagerの右側にある[ファイルを追加]ボタンと同じ機能です。

使用例

document.all("FileUploadManager").OpenFileDialog();


■ [OpenFolderDialog]メソッド

形式

OpenFolderDialog()

戻り値

説明
フォルダ選択ダイアログの画面を表示します。FileUploadManagerの右側にある[フォルダを追加]ボタンと同じ機能です。

使用例

document.all("FileUploadManager").OpenFolderDialog();


■ [Transfer]メソッド

形式

Transfer()

戻り値

説明
転送イベントを発生させます。FileUploadManagerの右側にある[転送する]と同じ機能です。

使用例

<HTML>
<HEAD>
<SCRIPT LANGUAGE="javascript">
function btnTransfer_onclick()
{
document.all("FileUploadManager").Transfer();
}
</SCRIPT>

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">
winstyle="height=355,width=445, status=no,toolbar=no,menubar=no,location=no"
window.open "./FileUploadMonitor.htm",null,winstyle
</SCRIPT>
</HEAD>

<BODY>
<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT></OBJECT>
<P><INPUT type="button" value="転送イベント発生" onclick="btnTransfer_onclick()"></P>
</BODY>
</HTML>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MoveFileUp]メソッド

形式

MoveFileUp(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、上に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileUploadManager"].MoveFileUp(3);


■ [MoveFileDown] メソッド

形式

MoveFileDown(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、下に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileUploadManager"]. MoveFileDown(3);


■ [OnAddFile_Click]イベント

形式

OnAddFile_Click()

説明
ユーザーが[ファイルを追加]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnAddFile_Click()">
Msgbox "[OnAddFile_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnAddFolder_Click]イベント

形式

OnAddFolder_Click()

説明
ユーザーが[フォルダを追加]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnAddFolder_Click()">
Msgbox "[OnAddFolder_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnChangedStatus]イベント

形式

OnChangedStatus(LONG nFileCount, LONG nFileSize)

nFileCount – 全体のファイル個数
nFileSize – 全体のファイルサイズ

説明
ファイルが追加されたり削除されたときに発生します。ユーザーはこのイベントからFileUploadManagerの現在のファイルの追加状態を知ることができます。

使用例

<SCRIPT FOR="FileUploadManager" Event="OnChangedStatus(nFileCount, nFileSize)" LANGUAGE="javascript">
OnChangedStatus(nFileCount, nFileSize);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnChangedStatus(nFileCount, nFileSize)
{
alert("現在のファイル数:" + nFileCount);
alert("現在のファイルサイズ:" + nFileSize);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDelete_Click]イベント

形式

OnDelete_Click()

説明
ユーザーが[ファイルを削除]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnDelete_Click()">
Msgbox "[OnDelete_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnError]イベント

形式

OnError(ErrorCode, sMsg, sDetailMsg)

Code - エラーコード。種類は次のとおりです。

20000000 ~
アップロードしようとするファイルが指定のサイズを超えたりした場合に起こる一方的なエラーです。このコードに該当するエラーメッセージは、大部分が一般ユーザーに知らされなければならない内容です。

30000000 ~
ウィンドウズのシステム関数エラーです。ファイルが現在使用中だったり、インターネットを使用できないなどの問題があった場合に発生します。一部は一般ユーザーに知らされなければならない内容です。.

40000000 ~
サーバーから発せられるエラーメッセージです。クライアント側には問題がないが、サーバー側になんらかの問題がある場合に発生します。40000以降の数字はサーバーのエラーコードです。(例：40000404は「接近エラー」)

sMsg – ユーザーにどんなエラーが発生したかを知らせる単純なメッセージです。このエラーの正確な原因はsDetailMsgが知らせてくれます。40000000のエラーの場合、サーバーから送られるページのタイトルが表示されます。サーバーに問題がある場合、「サーバーとの接続が非正常的に終了しました」というエラーメッセージが表示されます。その場合、アップロードしようとしていたファイルのサイズが16KB以上の可能性があります。HTTPの構造上、サーバーから送られるエラーメッセージを正常に受信するためには、16KB以下のファイルをアップロードしなければなりません。そうすることによりsDetailMsgにサーバー側からの正確なメッセージが伝えられ、問題点が何なのかを詳しく判断する事ができるようになります。

sDetailMsg – sMsgが発生した原因を知らせるメッセージです。 sDetailMsgはエラーの種類によっては表示されない場合もあります。40000000のエラーの場合、サーバーから送られるページの実質的な内容が表示されます。

使用例

<SCRIPT For = "FileUploadManager" Event = "OnError(nCode, sMsg, sDetailMsg)" LANGUAGE = "javascript">
OnFileManagerError(nCode, sMsg, sDetailMsg);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnFileManagerError(nCode, sMsg, sDetailMsg)
{
// ここにエラー処理が表示されます。
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransfer_Click]イベント

形式

OnTransfer_Click()

説明
ユーザーが[転送する]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">
Msgbox "[OnTransfer_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDouble_Click]イベント

形式

OnDouble_Click()

説明
ユーザーが[リストビュー]をダブルクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnDouble_Click()">
Msgbox "OnDouble_Click イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnFile_DoubleClick]イベント

形式

OnFile_DoubleClick()

説明
ユーザーがリストコントロール内のファイルアイテムをダブルクリックしたとき発生します。nItemIndexはダブルクリックしたファイルアイテムのindexです。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnFile_DoubleClick(nItemIndex)">
Msgbox document.all("FileUploadManager")(nItemIndex).Name
Msgbox document.all("FileUploadManager")(nItemIndex).Size
Msgbox document.all("FileUploadManager")(nItemIndex).Alias
Msgbox document.all("FileUploadManager")(nItemIndex).UserDataA
MsgBox document.all("FileUploadManager")(nItemIndex).UserDataB
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [CodePage]プロパティ

属性
Read/Write

タイプ
LONG

説明
多国語をサポートするためのコードページです。該当の言語コードを入力してください。

使用例

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
.
.
.
document.all("FileUploadMonitor").CodePage = 65001


\DEXTUploadX

■ [DefaultPath]プロパティ

属性
Read/Write

タイプ
String

説明

ユーザーがファイル選択ダイアログを開くときのダイアログの初期位置。指定しなかった場合はユーザーが最後にアクセスしたフォルダがデフォルトになります。

使用例

<OBJECT id="FileUploadMonitor" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID: 96A93E40-E5F8-497A-B029-8D8156DE09C5" VIEWASTEXT>
<PARAM NAME="DefaultPath" VALUE="C:\Temp">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [UploadURL]プロパティ

属性
Read/Write

タイプ
String

説明
POST方式の場合はサーバーのスクリプトファイルの位置。PUT方式の場合はファイルが保存されるサーバー側のバーチャルパスの位置。

使用例

document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/PostScript.asp"


■ [UseClientRegistry]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[完了後、ダウンロードしたフォルダを開く]や[続けてダウンロード]、[転送完了後、ウィンドウを閉じる]、[重複ファイル処理]のチェック状態を、クライアントのレジストリに保存された値に設定するかどうかを決定します。
デフォルトは[FALSE]です。

使用例

document.all("FileUploadMonitor").UseClientRegistry = TRUE


■ [Filter]プロパティ

属性
Read/Write

タイプ
String

説明
すべてのファイル及びフォルダの追加に適用されるフィルタストリングです。

デフォルトは[すべてのファイル|*.*|]です。

使用例

<PARAM NAME="Filter" VALUE="All Files|*.*|Image Files|*.jpg;*.jpeg;*.gif;*.bmp|">


■ [RFilter]プロパティ

属性
Read/Write

タイプ
String

説明
Filter プロパティーの反対機能で,登録された拡張子にあたるファイルはファイルが追加されない。

使用例

<PARAM NAME="RFilter" VALUE="*.jpg;*.jpeg;*.bmp">


■ [Items]プロパティ

属性
Write

タイプ
Variant

説明
FileUploadMonitorがFileUploadManagerでフォームデータやファイルを伝達するために使用します。
FileUploadMonitor中の[OBJECT]タグにある[PARAM]というプロパティには[Items]のプロパティを入力することができません。

使用例

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items


■ [Properties]プロパティ

属性
Write

タイプ
Variant

説明
FileUploadManagerの 6種速成(DefaultPath,Filter,RFilter,MaxCount,MaxFileSize,MaxTotalSize)を FileUploadMonitorから受ける。
FileUploadMonitor “OBJECT” タッグの “PARAM” プロパティーで Properties プロパティーを入力できない。

DEXTUpload Pro Extension バージョンの場合 “EnableLargeUpload” プロパティーの値も同時に伝達する。

使用例

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties


■ [EnableEmptyFileUpload]プロパティ

属性
Read/Write

タイプ
BOOL

説明
ユーザー側に実際に転送するファイルがない場合、つまりフォームアイテムだけが存在する場合にはDEXTUploadXはファイルをアップロードしてくれません。ただし[EnableEmptyFileUpload]を[TRUE]に設定するとフォームアイテムだけでも転送できるように設定できます。

使用例

document.all("FileUploadMonitor").EnableEmptyFileUpload = TRUE


■ [EnablePutMode]プロパティ

属性
Read/Write

タイプ
BOOL

説明
PUT方式のアップロードモードを使用するかどうかを決定します。デフォルトは[FALSE]でPOST方式のアップロードを使用するよう設定されています。

使用例

document.all("FileUploadMonitor").EnablePutMode = TRUE
document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamplesData"


■ [EnableOverwriteModeForPutUpload]プロパティ

属性
Read/Write

タイプ
BOOL

説明
PUT方式のアップロードを行う場合でサーバーに同一名のファイルが存在する場合に[上書き]モードを使用するか選択します。デフォルトは[FALSE]です。

使用例

<OBJECT id="FileUploadMonitor" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID: 96A93E40-E5F8-497A-B029-8D8156DE09C5" VIEWASTEXT>
<PARAM NAME="EnableOverwriteModeForPutUpload" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableLargeUpload]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
大容量アップロードを支援(2GB 以上). デフォルトは FALSEだ。

使用例

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" VIEWASTEXT>
<PARAM NAME="EnableLargeUpload" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableDragDrop]プロパティ

属性
Write

タイプ
BOOL

説明
FileUploadMonitorのリストビューにファイル及びフォルダをDrag&Dropできる機能を活性化または非活性化します。デフォルトは[TRUE]です。

使用例

<OBJECT id="FileUploadMonitor" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID: 96A93E40-E5F8-497A-B029-8D8156DE09C5" VIEWASTEXT>
<PARAM NAME="EnableDragDrop" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnablePHPFILES]プロパティ

属性
Write

タイプ
BOOL

説明
PHPが提供する[HTTP_POST_FILES]や[_FILES]と連動して別のサーバコンポーネント(DEXTUpload Proなど)なしでPOST方式のアップロードが可能となるようサポートします。デフォルトは[FALSE]です。

使用例

<OBJECT id="FileUploadMonitor" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID: 96A93E40-E5F8-497A-B029-8D8156DE09C5" VIEWASTEXT>
<PARAM NAME="EnablePHPFILES" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableSortByColumn]プロパティ

属性
Write

タイプ
BOOL

説明
ListViewのコラム名を通じる整列を支援します。
デフォルトは[FALSE]です。

使用例

<OBJECT id="FileUploadMonitor" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version= 3,0,1,0" height="200" width="450" classid="CLSID: 96A93E40-E5F8-497A-B029-8D8156DE09C5" VIEWASTEXT>
<PARAM NAME="EnableSortByColumn" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [LastSaveFileName]プロパティ

属性
Read

タイプ
String

説明
PUT方式のアップロードを行って転送を完了した後でサーバーに保存された実際のファイル名に関する情報です。

使用例

Dim UploadedFileName
Dim UploadedFileSize
Dim UploadedFileCount
Dim i

UploadedFileName = Split(document.all("FileUploadMonitor").LastSaveFileName, "||")
UploadedFileSize = Split(document.all("FileUploadMonitor").LastSaveFileSize, "||")
UploadedFileCount = document.all("FileUploadMonitor").LastSaveFileCount

For i=0 to UploadedFileCount
Msgbox i+1 & "番目のファイル名: " & UploadedFileName(i)
Msgbox i+1 & "番目のファイルのサイズ: " & UploadedFileSize(i)
Next

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [LastSaveFileSize]プロパティ

属性
Read

タイプ
String

説明
PUT方式のアップロードを行って転送を完了した後でサーバーに保存された実際のファイルのサイズに関する情報です。

使用例

Dim UploadedFileName
Dim UploadedFileSize
Dim UploadedFileCount
Dim i

UploadedFileName = Split(document.all("FileUploadMonitor").LastSaveFileName, "||")
UploadedFileSize = Split(document.all("FileUploadMonitor").LastSaveFileSize, "||")
UploadedFileCount = document.all("FileUploadMonitor").LastSaveFileCount

For i=0 to UploadedFileCount
Msgbox i+1 & "番目のファイル名: " & UploadedFileName(i)
Msgbox i+1 & "番目のファイルのサイズ: " & UploadedFileSize(i)
Next

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [LastSaveFileCount]プロパティ

属性
Read

タイプ
LONG

説明
PUT方式のアップロードを行って転送を完了した後に保存された実際のファイルの個数です。[EnableOverwriteModeForPutUpload]のプロパティが[TRUE]の場合はこの値は有効ではありません。

使用例

Dim UploadedFileName
Dim UploadedFileSize
Dim UploadedFileCount
Dim i

UploadedFileName = Split(document.all("FileUploadMonitor").LastSaveFileName, "||")
UploadedFileSize = Split(document.all("FileUploadMonitor").LastSaveFileSize, "||")
UploadedFileCount = document.all("FileUploadMonitor").LastSaveFileCount

For i=0 to UploadedFileCount
Msgbox i+1 & "番目のファイル名: " & UploadedFileName(i)
Msgbox i+1 & "番目のファイルのサイズ: " & UploadedFileSize(i)
Next

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableProxy]プロパティ

属性
Read/Write

タイプ
BOOL

説明
プロキシサーバーを使用するかどうかを決定します。このとき[ProxyName]や[UserID]、[UserPassword]などの設定も一緒に設定しなければなりません。

使用例

document.all("FileUploadMonitor").EnableProxy = TRUE
document.all("FileUploadMonitor").ProxyName = "ProxyServerName"
document.all("FileUploadMonitor").UserID = "UserID"
document.all("FileUploadMonitor").UserPassword = "UserPassword"


■ [ProxyName]プロパティ

属性
Read/Write

タイプ
String

説明
プロキシサーバーの名前を設定します。

使用例

document.all("FileUploadMonitor").EnableProxy = TRUE
document.all("FileUploadMonitor").ProxyName = "ProxyServerName"
document.all("FileUploadMonitor").UserID = "UserID"
document.all("FileUploadMonitor").UserPassword = "UserPassword"


■ [EnableSSL]プロパティ

属性
Read/Write

タイプ
BOOL

説明
SSLを使用するかどうかを決定します。デフォルトは[FALSE]です。

使用例

document.all("FileUploadMonitor").EnableSSL = TRUE


■ [UserID]プロパティ

属性
Read/Write

タイプ
String

説明
ゲストアカウントでなく、ログインが必要な場合にユーザーのIDを入力します。

使用例

document.all("FileUploadMonitor").UserID = "UserID"
document.all("FileUploadMonitor").UserPassword = "UserPassword"


■ [UserPassword]プロパティ

属性
Read/Write

タイプ
String

説明
ゲストアカウントでなく、ログインが必要な場合にユーザーのパスワードを入力します。

使用例

document.all("FileUploadMonitor").UserID = "UserID"
document.all("FileUploadMonitor").UserPassword = "UserPassword"


■ [EnableAddFileButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadMonitorの右側にある[ファイルを追加]ボタンを活性化･非活性化します。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="EnableAddFileButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableAddFolderButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadMonitorの右側にある[フォルダを追加]ボタンを活性化･非活性化します。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="EnableAddFolderButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableDeleteButton]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileUploadMonitorの右側にある[アイテムを削除]ボタンを活性化･非活性化します。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="EnableDeleteButton" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [VisibleAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]のチェックボックスの可視化の状態を決定します。
[VisibleAutoCloseWindow]のプロパティに明示的に入力しない状態で[EnableAutoCloseWindow]のプロパティを設定すると、[VisibleAutoCloseWindow]のプロパティに[TRUE]と設定したのと同様になります。
デフォルトは[TRUE]です。

使用例

document.all("FileUploadMonitor").VisibleAutoCloseWindow = TRUE


■ [EnableAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]のチェックボックスの活性化の状態を決定します。
[VisibleAutoCloseWindow]のプロパティに明示的に入力しない状態で[EnableAutoCloseWindow]のプロパティを設定すると、[VisibleAutoCloseWindow]のプロパティに[TRUE]と設定したのと同様になります。
デフォルトは[TRUE]です。

使用例

document.all("FileUploadMonitor").EnableAutoCloseWindow = TRUE


■ [CheckAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]のチェックボックスのチェック状態を決定します。
[VisibleAutoCloseWindow]や[EnableAutoCloseWindow]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileUploadMonitor").CheckAutoCloseWindow = TRUE


■ [ListViewStyle]プロパティ

属性
Read/Write

タイプ
String

説明
リストビューのスタイルを変更します。デフォルトは[LVS_REPORT]です。

スタイル

LVS_REPORT | - ファイルに関する詳しい情報を表示するレポートスタイルです。
LVS_LIST | - ファイルに関する簡単な情報を表示するリストスタイルです。
LVS_ICON | - ファイルに関する簡単な情報を表示するアイコンスタイルです。
LVS_SMALLICON | - ファイルに関する簡単な情報を表示する小さなアイコンスタイルです。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewStyle" VALUE="LVS_LIST">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewSortStyle]プロパティ

属性
Read

タイプ
String

説明
ファイルが追加される時リストビューの 整列モードを指定する。
指定しなければファイル追加の 手順によって順次にリストビューにファイルが追加される。

スタイル

ASC – ファイルに対する昇順整列をしてくれるスタイル

DESC – ファイルに対する降順整列をしてくれるスタイル

使用例

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewSortStyle" VALUE="ASC">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewLineStyle]プロパティ

属性
Read/Write

タイプ
BOOL

説明
リストビューのラインに関する[Visible]のプロパティを設定します。リストビューのスタイルが[LVS_REPORT]の場合にだけ使用できます。デフォルトは[TRUE]です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewLineStyle" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewFileStyle]プロパティ

属性
Read/Write

タイプ
String

説明
リストビューに追加されたファイルの表示スタイルを変更します。デフォルトは[LVFS_FILEPATH]です。

スタイル

LVFS_FILEPATH | - リストビューにファイルの全体パスを表示するスタイルです。
LVFS_FILENAME | - リストビューにファイル名だけを表示するスタイルです。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewFileStyle" VALUE="LVFS_FILENAME">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューの背景色を変更します。入力値はRGBの色コード値です。デフォルトは、背景色が設定されていない[CLR_NONE]です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキストの色を変更します。入力値はRGBの色コード値です。デフォルトは、テキストの色が設定されていない[CLR_NONE]です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewTextColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキスト背景色を変更します。入力値はRGBの色コード値です。デフォルトは、テキスト背景色が設定されていない[CLR_NONE]です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ListViewTextBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableEncryption]プロパティ

属性
Read/Write

タイプ
BOOL

説明
暗号化に関する[Enable]のプロパティを設定します。デフォルトは[FALSE]です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="EnableEncryption" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [PrefixForEncryption]プロパティ

属性
Write

タイプ
String

説明
暗号化されたファイルを区別するための接頭子です。ここに入力がない場合は原本のファイル名で暗号化されます。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="PrefixForEncryption" VALUE="DEXTENC_">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxLengthForEncryptionPassword]プロパティ

属性
Write

タイプ
LONG

説明
暗号化用パスワードの最大文字数を指定します。指定しない場合は32文字まで入力可能です。

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="MaxLengthForEncryptionPassword" VALUE="12">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [PercentOfTotalEncryptionFile]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関する暗号化の進行度を百分率で表します。プログレスバーなどに表示するために使用されます。

使用例

alert("全体のファイルに関する暗号化の進行度: " + document.all("FileUploadMonitor").PercentOfTotalEncryptionFile);


■ [MaxCount]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadMonitor追加することができるファイルの最大個数

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="MaxCount" VALUE="10">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxTotalSize]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadMonitorに追加することができる全体ファイルの最大サイズ

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME=" MaxTotalSize " VALUE="100000">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxFileSize]プロパティ

属性
Read/Write

タイプ
LONG

説明
FileUploadMonitorに追加することができる個別ファイルの最大サイズ

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="MaxFileSize" VALUE="10000">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Count]プロパティ

属性
Read

タイプ
LONG

説明
FileUploadMonitorオブジェクトにユーザーが追加したファイルの個数

使用例

alert("全体のファイル数:" + document.all("FileUploadMonitor ").Count);


■ [CurrentCount]プロパティ

属性
Read

タイプ
LONG

説明
アップロードを進行中のファイルの数。

使用例

alert("アップロード進行中のファイル数: " + document.all("FileUploadMonitor").CurrentCount);


■ [Size]プロパティ

属性
Read

タイプ
LONG

説明
FileUploadMonitorオブジェクトに追加されたすべてのファイルのサイズ

使用例

alert("全体のファイルサイズ:" + document.all("FileUploadMonitor").Size);


■ [CurrentSize]プロパティ

属性
Read

タイプ
LONG

説明
アップロード中のファイルサイズ。

使用例

alert("アップロード中のファイルサイズ: " + document.all("FileUploadMonitor").CurrentSize);


■ [TransferedSizeOfTotalFile]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関するこれまでにアップロードが完了したサイズ。

使用例

alert("全体のファイルに関するこれまでにアップロードが完了したサイズ: " + document.all("FileUploadMonitor").TransferedSizeOfTotalFile);


■ [TransferedSizeOfCurrentFile]プロパティ

属性
Read

タイプ
LONG

説明
アップロード中のファイルに関するこれまでにアップロードが完了したサイズ。

使用例

alert("アップロード中のファイルに関するこれまでにアップロードが完了したサイズ: " + document.all("FileUploadMonitor").TransferedSizeOfCurrentFile);


■ [PercentOfTotalFile]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関するアップロードの進行度を百分率であらわします。プログレスバーなどに表示するために使用されます。

使用例

alert("全体のファイルに関するアップロードの進行度: " + document.all("FileUploadMonitor").PercentOfTotalFile);


■ [PercentOfCurrentFile]プロパティ

属性
Read

タイプ
LONG

説明
アップロード中のファイルに関するアップロード進行度を百分率で表します。プログレスバーなどに表示するために使用されます。

使用例

alert("アップロード中のファイルに関するアップロード進行度: " + document.all("FileUploadMonitor").PercentOfCurrentlFile);


■ [ElapsedTime]プロパティ

属性
Read

タイプ
String

説明
これまでの時間を時･分･秒で表示します。(例:01:22:15)

使用例

alert("これまでの時間: " + document.all("FileUploadMonitor").ElapsedTime);


■ [RemainingTime]プロパティ

属性
Read

タイプ
String

説明
アップロードが完了するまでの残り時間を時･分･秒で表示します。(例:01:22:15)

使用例

alert("残り時間: " + document.all("FileUploadMonitor").RemainingTime);


■ [BytesPerSec]プロパティ

属性
Read

タイプ
String

説明
秒あたりに転送されたバイト数。転送速度を表します。

使用例

var CurrentSpeed = document.all["FileUploadMonitor"].BytesPerSec;

if(1 < CurrentSpeed/1000.0/1000.0/1000.0) {

CurrentSpeed = CurrentSpeed / (1024*1024*1024);

alert("転送速度: " + CurrentSpeed + GB);
}

else if(1 < CurrentSpeed/1000.0/1000.0) {

CurrentSpeed = CurrentSpeed / (1024*1024);

alert("転送速度: " + CurrentSpeed + MB); ";

}

else if(1 < CurrentSpeed/1000.0) {

CurrentSpeed = CurrentSpeed / 1024;

alert("転送速度: " + CurrentSpeed + KB);
}

else {
alert("転送速度: " + CurrentSpeed + Bytes);

}


■ [CurrentFileName]プロパティ

属性
Read

タイプ
String

説明
アップロード中のファイル名。

使用例

alert("アップロード中のファイル名: " + document.all("FileUploadMonitor").CurrentFileName);


■ [CheckResume]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read/Write

タイプ
BOOL

説明
大容量アップロードが活性化になっている時に続けてアップロードを選択できる。
基本値は FALSEだ。

使用例

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" VIEWASTEXT>
<PARAM NAME="CheckResume" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [CheckTransSpeed]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
支援される帯域幅の内で伝送速度を制限する。
デフォルトは FALSEだ。

使用例

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" VIEWASTEXT>
<PARAM NAME="CheckTransSpeed" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxTransSpeed]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
CheckTransSpeedプロパティーが TRUEに設定されている場合 MaxTransSpeed プロパティーを利用して秒当たり最大送ることができるファイルの大きさを設定する。
デフォルトは FALSEで,入力単位は BYTEである。

使用例

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:5C935DF7-976A-47f6-B148-20FD62F1C988 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" VIEWASTEXT>
<PARAM NAME="MaxTransSpeed" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [DialogBoxMode]プロパティ

属性
Read

タイプ
String

説明
FileUploadMonitorが生成される時 FileUploadMonitorの多様な UI形態を支援

スタイル

DLG_LISTVIEW – リストビュー形態の UIを支援

DLG_SIMPLE – 既存 FileUploadMonitor よりシンプルな形態の UIを支援

使用例

<OBJECT id=FileUploadMonitor height=355 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="DialogBoxMode" VALUE=" DLG_LISTVIEW">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ResponseData] プロパティ

属性
Read

タイプ
String

説明
アップロード完了後サーバーページで渡す結果 Dataを受けて来られる。

使用例

alert(document.all("FileUploadMonitor").ResponseData);


■ [EnableTransFormItems]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Write

タイプ
BOOL

説明
大容量アップロードモードの場合、ユーザーが追加したフォームデーターや FileUploadManagerで読み込んだブラウザー内のinput タイプポムデーターを送信する時に(中止, 一時停止など) よってユーザーが送信可否を決められます。

デフォルトは TRUE

使用例

document.all("FileUploadMonitor").EnableTransFormItems = FALSE


■ [AddFile]メソッド

形式

AddFile(FilePath)

FilePath – クライアントに存在するファイルの物理的なパス
Alias - FilePathについての別称
UserDataA - FilePathについてのサーバに転送しようとするユーザー任意の付加的なデータ
UserDataB - FilePathについてのサーバに転送しようとするユーザー任意の付加的なデータ

戻り値

説明
クライアントに保存されたファイルをFileUploadMonitorに追加します。一般的に、ユーザーが選択したファイルを追加するためにこのメソッドを使用することはあまりありません。

使用例

document.all("FileUploadMonitor").AddFile(“C:\Temp\Test.htm”);
document.all("FileUploadMonitor").AddFile(“C:\Temp\Test.htm”, “Alias.htm”);
document.all("FileUploadMonitor").AddFile(“C:\Temp\Test.htm”, “Alias.htm”, “これはユーザーが入力した任意のデータです”);
document.all("FileUploadMonitor").AddFile(“C:\Temp\Test.htm”, “Alias.htm”, “これはユーザーが入力した任意のデータです”, “これはユーザーが入力した任意のデータです” );
document.all("FileUploadMonitor").AddFile(“C:\Temp\Test.htm”, , , “これはユーザーが入力した任意のデータです” );


■ [AddFormItem]メソッド

形式

AddFormItem(FormName, FormValue);

FormName – フォームアイテムの名前です。

FormValue – フォームアイテムの値です。

戻り値

説明
ユーザーがさらにフォームアイテムを必要とする場合にこのメソッドを使用します。

使用例

FileUploadMonitor.AddFormItem "UserAddText", "これはテスト用テキストです。"


■ [CloseWindow]メソッド

形式

CloseWindow()

戻り値

説明
FileUploadMonitorがあるウェブブラウザーを終了します。ただし、終了するときにメッセージボックスなどが表示されている場合、終了は失敗に終わります。

使用例

FileUploadMonitor.CloseWindow

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [DeleteSelectedFile] メソッド

形式

DeleteSelectedFile(Index)

Index – 削除しようとするファイルのインデックス

戻り値

説明
Indexに値を入力しなければ FileUploadMonitor に選択されているファイルを削除します。FileUploadMonitor の右側にある削除’ボタンと等しい機能をします。

Indexに 0 以上の正しい値を入力すれば FileUploadMonitor に追加されているファイルたちの中で indexにあたるファイルを削除します。

使用例

document.all("FileUploadMonitor").DeleteSelectedFile(); // FileUploadMonitor の右側にある‘削除’ ボタンと等しい機能をします。
document.all("FileUploadMonitor ").DeleteSelectedFile( 3 ); // FileUploadMonitor に追加されられているファイルたちの中で 3番目にあたるファイルを削除します。


■ [OpenFileDialog] メソッド

形式

OpenFileDialog()

戻り値

説明
ファイル選択ダイアローグ画面を見せてくれます。FileUploadMonitorの右側にある ‘ファイル追加’ ボタンと同じ機能をします。

使用例

document.all("FileUploadMonitor").OpenFileDialog();


■ [OpenFolderDialog] メソッド

形式

OpenFolderDialog()

戻り値

説明
フォルダ選択ダイアローグ画面を見せてくれます。 FileUploadMonitorの 右側にある ‘フォルダ追加’ ボタンと同じ機能をします。

使用例

document.all("FileUploadMonitor").OpenFolderDialog();


■ [DeleteFormItem]メソッド

形式

DeleteFormItem(FormName)

FormName – 削除しようとするフォームアイテムの名前

戻り値

説明
[AddFormItem]を使って追加したフォームアイテムを削除します。

使用例

FileUploadMonitor.DeleteFormItem "UserAddText"


■ [DeleteAllFile]メソッド

形式

DeleteAllFile()

戻り値

説明
FileUploadMonitorのすべてのファイルを削除します。

使用例

document.all(“FileUploadMonitor”).DeleteAllFile();


■ [Transfer]メソッド

形式

Transfer()

戻り値

説明
ファイル及びフォームアイテムの転送を開始します。ユーザーが[転送]ボタンをクリックするのと同様の機能です。

使用例

document.all("FileUploadMonitor").Transfer();


■ [Cancel]メソッド

形式

Cancel()

戻り値

説明
転送をキャンセルします。すでにキャンセルされている場合には転送ウィンドウを閉じます。ユーザーが[キャンセルして閉じる]ボタンをクリックした場合と同じ働きをします。

使用例

document.all("FileUploadMonitor").Cancel();


■ [MoveFileUp]メソッド

形式

MoveFileUp(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、上に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileUploadMonitor"].MoveFileUp(3);


■ [MoveFileDown] メソッド

形式

MoveFileDown(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、下に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileUploadMonitor"]. MoveFileDown(3);


■ [OnAddFile_Click]イベント

形式

OnAddFile_Click()

説明
ユーザーが[ファイルを追加]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnAddFile_Click()">
Msgbox "[OnAddFile_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnAddFolder_Click]イベント

形式

OnAddFolder_Click()

説明

ユーザーが[フォルダを追加]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnAddFolder_Click()">
Msgbox "[OnAddFolder_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnChangedStatus]イベント

形式

OnChangedStatus(LONG nFileCount, LONG nFileSize)

nFileCount – 全体のファイル個数
nFileSize – 全体のファイルのサイズ

説明
ファイルが追加されたり削除されたときに発生します。ユーザーは、このイベントを使ってFileUploadMonitorの現在のファイルの追加状態を知ることができます。

使用例

<SCRIPT FOR="FileUploadMonitor" Event="OnChangedStatus(nFileCount, nFileSize)" LANGUAGE="javascript">
OnChangedStatus(nFileCount, nFileSize);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnChangedStatus(nFileCount, nFileSize)
{
alert("現在のファイル数:" + nFileCount);
alert("現在のファイルサイズ:" + nFileSize);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCloseWIndow]イベント

形式

OnCloseWIndow()

説明
FileUploadMonitorを終了することを知らせます。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnCloseWIndow()">
Msgbox "ウィンドウを閉じます。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDelete_Click]イベント

形式

OnDelete_Click()

説明
ユーザーが[ファイルを削除]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnDelete_Click()">
Msgbox "[OnDelete_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnEndProc]イベント

形式

OnEndProc()

説明
DEXTUploadX内部の全ての動作が完了されたのを知らせます。
OnEndProcイベントはOnTransferCompleteイベントより後に発生します。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnEndProc()">
Msgbox "DEXTUploadXの全ての動作が完了されました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnEndTransferringItem]イベント

形式

OnEndTransferringItem(LONG nItemIndex, BOOL bSuccess)

nItemIndex – 転送が始まるファイルアイテムのインデックス番号
bSuccess – 転送に成功したかどうか

説明

一つのファイルアイテムの転送が終了したことを知らせます。nItemIndexは該当するファイルのインデックスで、[FileUploadMonitor(nItemIndex).Name]のようにそのファイルの情報を取得できます。

使用例

<SCRIPT FOR="FileUploadMonitor" Event="OnEndTransferringItem(nItemIndex, bSuccess)" LANGUAGE="javascript">
OnEndTransferringItem(nItemIndex, bSuccess);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnEndTransferringItem(nItemIndex, bSuccess)
{
alert("転送終了アイテムのインデックス:" + nItemIndex);
alert("転送に成功したかどうか:" + bSuccess);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnError]イベント

形式

OnError(ErrorCode, sMsg, sDetailMsg)

Code - エラーコード。種類は次のとおりです。

20000000 ~
アップロードしようとするファイルが指定のサイズを超えたりした場合に起こる一方的なエラーです。このコードに該当するエラーメッセージは、大部分が一般ユーザーに知らされなければならない内容です。

30000000 ~
ウィンドウズのシステム関数エラーです。ファイルが現在使用中だったり、インターネットを使用できないなどの問題があった場合に発生します。一部は一般ユーザーに知らされなければならない内容です。.

40000000 ~
サーバーから発せられるエラーメッセージです。クライアント側には問題がないが、サーバー側になんらかの問題がある場合に発生します。40000以降の数字はサーバーのエラーコードです。(例：40000404は「接近エラー」)

sMsg - ユーザーにどんなエラーが発生したかを知らせる単純なメッセージです。このエラーの正確な原因はsDetailMsgが知らせてくれます。40000000のエラーの場合、サーバーから送られるページのタイトルが表示されます。サーバーに問題がある場合、「サーバーとの接続が非正常的に終了しました」というエラーメッセージが表示されます。その場合、アップロードしようとしていたファイルのサイズが16KB以上の可能性があります。HTTPの構造上、サーバーから送られるエラーメッセージを正常に受信するためには、16KB以下のファイルをアップロードしなければなりません。そうすることによりsDetailMsgにサーバー側からの正確なメッセージが伝えられ、問題点が何なのかを詳しく判断する事ができるようになります。

sDetailMsg - sMsgが発生した原因を知らせるメッセージです。 sDetailMsgはエラーの種類によっては表示されない場合もあります。40000000のエラーの場合、サーバーから送られるページの実質的な内容が表示されます。

使用例

<SCRIPT For = "FileUploadMonitor" Event = "OnError(nCode, sMsg, sDetailMsg)" LANGUAGE = "javascript">
OnFileUploadMonitorError(nCode, sMsg, sDetailMsg);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnFileUploadMonitorError(nCode, sMsg, sDetailMsg)
{
// ここでエラーを処理します。
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnStartTransferringItem]イベント

形式

OnStartTransferringItem(LONG nItemIndex)

nItemIndex – 転送が始まるファイルアイテムのインデックス番号

説明
一つのファイルアイテムの転送が始まることを知らせます。nItemIndexは該当するファイルのインデックスで、[FileUploadMonitor(nItemIndex).Name]のようにそのファイルの情報を取得できます。

使用例

<SCRIPT FOR="FileUploadMonitor" Event="OnStartTransferringItem(nItemIndex)" LANGUAGE="javascript">
OnStartTransferringItem(nItemIndex);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnStartTransferringItem(nItemIndex)
{
alert("転送開始アイテムのインデックス:" + nItemIndex);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransfer_Click]イベント

形式

OnTransfer_Click()

説明
ユーザーが[転送する]ボタンをクリックしました。.

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnTransfer_Click()">
Msgbox "[OnTransfer_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferCancel]イベント

形式

OnTransferCancel()

説明
ユーザーが[中止]ボタンをクリックしたり、サーバー側のエラーにより転送が中止されたことを知らせます。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnTransferCancel()">
Msgbox "転送が中止されました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferComplete]イベント

形式

OnTransferComplete()

説明
転送が完了されました。これはエラーなく転送に成功したことを示しています。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnTransferComplete()">
Msgbox "転送を完了しました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferPause]イベント (DEXTUpload Pro Extension 製品だけ当たります。)

属性

OnTransferPause()

説明
大容量アップロード,続けてアップロードが活性化になっている時、またはが日時止まりを選択すれば発生する。

使用例

<SCRIPT LANGUAGE="Java Script" for="FileUploadMonitor" event="OnTransferPause()">
Alert("アップロードが日時中止されました.");
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnStartEncryption]イベント

形式

OnStartEncryption()

説明
暗号化を開始しました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event=" OnStartEncryption()">
Msgbox "OnStartEncryption イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCancelEncryption]イベント

形式

OnCancelEncryption()

説明

ユーザーが[キャンセル]ボタンをクリックした、もしくはエラーにより暗号化がキャンセルされたことをお知らせします。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnCancelEncryption()">
Msgbox "暗号化がキャンセルされました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCompleteEncryption]イベント

形式

OnCompleteEncryption()

説明
暗号化を完了しました。これは、エラーなく暗号化に成功したことを表しています。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnCompleteEncryption()">
Msgbox "暗号化を完了しました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDouble_Click]イベント

形式

OnDouble_Click()

説明
ユーザーが[リストビュー]をダブルクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnDouble_Click()">
Msgbox "OnDouble_Click イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnFile_DoubleClick]イベント

形式

OnFile_DoubleClick()

説明
ユーザーがリストコントロール内のファイルアイテムをダブルクリックしたとき発生します。nItemIndexはダブルクリックしたファイルアイテムのindexです。

使用例

<SCRIPT LANGUAGE="VBS" for="FileUploadMonitor" event="OnFile_DoubleClick(nItemIndex)">
Msgbox document.all("FileUploadMonitor")(nItemIndex).Name
Msgbox document.all("FileUploadMonitor")(nItemIndex).Size
Msgbox document.all("FileUploadMonitor")(nItemIndex).Alias
Msgbox document.all("FileUploadMonitor")(nItemIndex).UserDataA
MsgBox document.all("FileUploadMonitor")(nItemIndex).UserDataB
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Items]プロパティ

属性
Read

タイプ
Variant

説明
FileDownloadManagerがFileDownloadMonitorにフォームデータやファイルを伝達するために使用される。

使用例

document.all("FileDownloadMonitor").Items = opener.document.all("FileDownloadManager").Items


■ [OpenWindow]プロパティ

属性
Write

タイプ
BOOL

説明
FileDownloadManagerのポップアップメニューから[実行]をクリックした場合、新しいウィンドウを開いて実行するかどうかを決定します。デフォルトは[FALSE]です(現在のウィンドウで実行)。

使用例

document.all("FileDownloadManager").OpenWindow = TRUE


■ [StatusBarVisible]プロパティ

属性
Read/Write

タイプ
BOOL

説明
FileDownloadManager下段にあるステータスバーの表示有無を決定する。

使用例

document.all("FileDownloadManager").StatusBarVisible = TRUE


■ [SelectedCount]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadManagerに追加され、選択されたファイル個数

使用例

document.all("FileDownloadManager").SelectedCount


■ [SelectedSize]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadManagerに追加され、選択されたファイルのサイズ

使用例

document.all("FileDownloadManager").SelectedSize


■ [TotalCount]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadManagerに追加されたすべてのファイル個数

使用例

document.all("FileDownloadManager").TotalCount


■ [TotalSize]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadManagerに追加されたすべてのファイルのサイズ

使用例

document.all("FileDownloadManager").TotalSize


■ [VisibleDownloadCheckbox]プロパティ

属性
Read

タイプ
BOOL

説明
FileDownloadManagerが生成される時、リストビューのチェックボックス活性化状態を設定する。デフォルトは TRUE である。

使用例

<OBJECT ID="FileDownloadManager" height="200" width="450" CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:535AE497-8E85-45F8-AF36-2DFCBCA8B68A">
<PARAM NAME="VisibleDownloadCheckbox" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [CustomExecute]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
FileDownloadManagerのポップアップメニューで “実行” メニューを選択した場合、クライアントパソコンの 一時フォルダでファイルをダダウンロードして, 該当のファイルの 拡張子に繋がれた実行ファイルを通じてファイルを実行します。
デフォルトは FALSE であり,CustomExecute プロパティーは OpenWindow プロパティーの設定より優先です。

使用例

<OBJECT ID="FileDownloadManager" height="200" width="450" CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" CLASSID="CLSID:B0250CBD-2F67-45b1-9AC1-E846CF0A12C5">
<PARAM NAME="CustomExecute" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ImageURL]プロパティ

属性
Write

タイプ
String

説明
ListViewに設定するバックグラウンドイメージの URLです。

使用例

document.all("FileDownloadManager").ImageURL = "http://Localhost/DEXTUploadXSamples/img/ListViewBkImage.bmp"


■ [XOffsetPercentOfImage]プロパティ

属性
Write

タイプ
Long

説明
ListViewバックグラウンドイメージの縦の位置値です。(Offset Percentage)
デフォルトは[50%]です。

使用例

document.all("FileDownloadManager").XOffsetPercentOfImage = 50


■ [YOffsetPercentOfImage]プロパティ

属性
Write

タイプ
Long

説明
ListViewバックグラウンドイメージの横の位置値です。(Offset Percentage)
デフォルトは[50%]です。

使用例

document.all("FileDownloadManager").YOffsetPercentOfImage = 50


■ [EnableSortByColumn]プロパティ

属性
Write

タイプ
BOOL

説明
ListViewのコラム名を通じる整列を支援します。
デフォルトは[FALSE]です。

使用例

<OBJECT ID="FileDownloadManager" height="200" width="450" CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:535AE497-8E85-45F8-AF36-2DFCBCA8B68A">
<PARAM NAME="EnableSortByColumn" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [AddFile]メソッド

形式

AddFile(BSTR FileURL, LONG nFileSize, BSTR FileName, BSTR DirectoryName)

FileURL –　ファイルのアドレス。このアドレスは必ずしも一つのサーバーである必要はありません。つまり、いくつかのファイルサーバーからダウンロードを実行できるよう指定もできます。
nFileSize –　ファイルサイズ。ユーザーが必ず指定してください。ファイルサイズはバイト単位で正確に入力するようにしてください。
FileName – FileDownloadManagerに表示されるファイル名。オプションです。入力しなければ最初のファクターで指定されたファイル名が使用されます。
DirectoryName　－ フォルダ構造ダウンロードのためのフォルダパスなのでオプションです。入力しなければフォルダの構造は生成されません。

戻り値

説明
FileDownloadManagerの[AddFile]メソッドを使用してダウンロードするファイルを追加ができます。

使用例

document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile1.tst", 10000000
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile2.tst", 20000000, "DevpiaTest3.tst"
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile3.tst", 30000000, "UserDirectory.tst", "\Temp\Temp1\"
document.all("FileDownloadManager").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile4.tst", 10000000, "", "\Temp\Temp1\Temp2\"


■ [DeleteFile]メソッド

形式

DeleteFile(BSTR FileURL)

FileURL – [AddFile]で使用した削除するURL

戻り値

説明
[AddFile]メソッドを使用して追加したファイルアイテムを削除できます。

使用例

document.all("FileDownloadManager").DeleteFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile1.tst"


■ [DeleteAllFile] メソッド

形式

DeleteAllFile()

戻り値

説明
FileDownloadManagerのすべてのファイルを削除します。

使用例

document.all("FileDownloadManager").DeleteAllFile();


■ [DeleteSelectedFile] メソッド

形式

DeleteSelectedFile(Index)

Index – 削除しようとするファイルのインデックス

戻り値

説明
Indexに値を入力しなければ FileDownloadManagerに 選択されているファイルを削除します。 FileDownloadManagerの 右側にある‘削除’ ボタンと等しい機能です。
Indexに 0 以上の正しい値を入力すれば FileDownloadManagerに 追加されているファイルの中で indexにあたるファイルを削除します。

使用例

document.all("FileDownloadManager").DeleteSelectedFile(); // FileDownloadManagerの右側に位した ‘削除’ ボタンと等しい機能をします。
document.all("FileDownloadManager").DeleteSelectedFile( 3 ); // FileDownloadManagerに 追加されているファイルたちの中で 3番目にあたるファイルを 削除します。


■ [SelectAll]メソッド

形式

SelectAll()

戻り値

説明
FileDownloadManagerに追加されたすべてのファイルを選択します。

使用例

document.all("FileDownloadManager").SelectAll


■ [UnselectAll]メソッド

形式

UnselectAll()

戻り値

説明
FileDownloadManagerに追加されたすべてのファイルの選択を解除します。

使用例

document.all("FileDownloadManager").UnselectAll


■ [MoveFileUp]メソッド

形式

MoveFileUp(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、上に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileDownloadManager"].MoveFileUp(3);


■ [MoveFileDown] メソッド

形式

MoveFileDown(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、下に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileDownloadManager"]. MoveFileDown(3);


■ [OnChangedStatus]イベント

形式

OnChangedStatus(LONG nFileCount, LONG nFileSize, LONG nSelectedFileCount, LONG nSelectedFileSize)

nFileCount – 全体ファイルの個数
nFileSize – 全体ファイルのサイズ
nSelectedFileCount – 選択されたファイルの個数
nSelectedFileSize – 選択されたファイルのサイズ

説明
ファイルが追加/選択/解除/削除される時に発生します。
ユーザーこのイベントを通じて FileUploadMonitorの現在ファイル追加状態が分かります。

使用例

<SCRIPT FOR="FileDownloadManager" Event="OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize)" language="javascript">
OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize)
{
alert("全体のファイル数: " + nFileCount);
alert("全体のファイルサイズ: " + nFileSize);
alert("選択されたファイル数: " + nSelectedFileCount);
alert("選択されたファイルのサイズ: " + nSelectedFileSize);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDownload_Click]イベント

形式

OnDownload_Click()

説明
ポップアップメニューで[ダウンロード]をクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadManager" event="OnDownload_Click()">
Msgbox "[OnDownload_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnError]イベント

形式

OnError(ErrorCode, sMsg, sDetailMsg)

Code –エラーコード。種類は下記のとおりです。

20000000 ~
アップロードしようとするファイルが指定のサイズを超えたりした場合に起こる一方的なエラーです。このコードに該当するエラーメッセージは、大部分が一般ユーザーに知らされなければならない内容です。

30000000 ~
ウィンドウズのシステム関数エラーです。ファイルが現在使用中だったり、インターネットを使用できないなどの問題があった場合に発生します。一部は一般ユーザーに知らされなければならない内容です。

40000000 ~
サーバーから発せられるエラーメッセージです。クライアント側には問題がないが、サーバー側になんらかの問題がある場合に発生します。40000以降の数字はサーバーのエラーコードです。(例：40000404は「アクセスエラー」)

sMsg – ユーザーにどんなエラーが発生したかを知らせる単純なメッセージです。このエラーの正確な原因はsDetailMsgが知らせてくれます。40000000のエラーの場合、サーバーから送られるページのタイトルが表示されます。サーバーに問題がある場合、「サーバーとの接続が非正常的に終了しました」というエラーメッセージが表示されます。その場合、アップロードしようとしていたファイルのサイズが16KB以上の可能性があります。HTTPの構造上、サーバーから送られるエラーメッセージを正常に受信するためには、16KB以下のファイルをアップロードしなければなりません。そうすることによりsDetailMsgにサーバー側からの正確なメッセージが伝えられ、問題点が何なのかを詳しく判断できるようになります。

sDetailMsg – 　sMsgが発生した原因を知らせるメッセージです。 sDetailMsgはエラーの種類によっては表示されない場合もあります。40000000のエラーの場合、サーバーから送られるページの実質的な内容が表示されます。

使用例

<SCRIPT For = "FileDownoadManager" Event = "OnError(nCode, sMsg, sDetailMsg)" LANGUAGE = "javascript">
OnFileManagerError(nCode, sMsg, sDetailMsg);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnFileManagerError(nCode, sMsg, sDetailMsg)
{
// ここでエラーを処理します。
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnExcute_Click]イベント

形式

OnExcute_Click(LONG nItemIndex, BSTR FileURL)

nItemIndex – 実行するアイテムのインデックス
FileURL – 実行するファイルのアドレス

説明
ポップアップメニューで[実行]をクリックしました。

使用例

<SCRIPT FOR="FileDownloadManager" Event=" OnExcute_Click (nItemIndex, FileURL)" language="javascript">
OnExcute_Click (nItemIndex, FileURL);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnExcute_Click (nItemIndex, FileURL)
{
alert("実行するアイテムのインデックス: " & nItemIndex);
alert("実行するファイルのURL: " + FileURL);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnSelectAll_Click]イベント

形式

OnSelectAll_Click()

説明
ポップアップメニューで[すべて選択]をクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadManager" event="OnSelectAll_Click()">
Msgbox "[OnSelectAll_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnUnselectAll_Click]イベント

形式

OnUnselectAll_Click()

説明
ポップアップメニューで[選択を解除]をクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadManager" event="OnUnselectAll_Click()">
Msgbox "[OnUnselectAll_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDouble_Click]イベント

形式

OnDouble_Click()

説明
ユーザーが[リストビュー]をダブルクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadManager" event="OnDouble_Click()">
Msgbox "OnDouble_Click イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnFile_DoubleClick]イベント

形式

OnFile_DoubleClick()

説明
ユーザーがリストコントロール内のファイルアイテムをダブルクリックしたとき発生します。nItemIndexはダブルクリックしたファイルアイテムのindexです。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadManager" event="OnFile_DoubleClick(nItemIndex)">
Msgbox document.all("FileDownloadManager")(nItemIndex).Name
Msgbox document.all("FileDownloadManager")(nItemIndex).Size
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [Items]プロパティ

属性
Write

タイプ
Variant

説明
FileDownloadManagerからフォームデータ及びファイルをダウンロードするために使用します。
FileDownloadMonitorの[OBJECT]タグにある[PARAM]というプロパティで[Items]のプロパティを入力できません。

使用例

document.all("FileDownloadMonitor").Items = opener.document.all("FileDownloadManager").Items


■ [DownloadFolder]プロパティ

属性
Read/Write

タイプ
String

説明
ユーザーがファイルをダウンロードするフォルダを指定します。指定しなかった場合は最後に選択されたフォルダをデフォルトとします。

使用例

document.all("FileDownloadMonitor").DownloadFolder = “C:\Temp”


■ [UseClientRegistry]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[完了後、ダウンロードしたフォルダを開く]や[続けてダウンロード]、[転送完了後、ウィンドウを閉じる]、[重複ファイル処理]のチェック状態を、クライアントのレジストリに保存された値に設定するかどうかを決定します。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").UseClientRegistry = TRUE


■ [EnableSSL]プロパティ

属性
Read/Write

タイプ
BOOL

説明
SSLの使用有無を決定します。デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").EnableSSL = TRUE


■ [UserPassword]プロパティ

属性
Read/Write

タイプ
String

説明
ゲストアカウントでない場合で、明示的にログインが必要な場合にユーザーのパスワードを入力します。

使用例

document.all("FileDownloadMonitor").UserID = "UserID"
document.all("FileDownloadMonitor").UserPassword = "UserPassword"


■ [UserID]プロパティ

属性
Read/Write

タイプ
String

説明
ゲストアカウントではない場合で、明示的にログインが必要な場合にユーザーのIDを入力します。

使用例

document.all("FileDownloadMonitor").UserID = "UserID"
document.all("FileDownloadMonitor").UserPassword = "UserPassword"


■ [EnableProxy]プロパティ

属性
Read/Write

タイプ
BOOL

説明
プロキシサーバーの使用有無を決定します。[ProxyName]や[UserID]、[UserPassword]なども一緒に設定するようにしてください。

使用例

document.all("FileDownloadMonitor").EnableProxy = TRUE
document.all("FileDownloadMonitor ").ProxyName = "ProxyServerName"
document.all("FileDownloadMonitor ").UserID = "UserID"
document.all("FileDownloadMonitor ").UserPassword = "UserPassword"


■ [ProxyName]プロパティ

属性
Read/Write

タイプ
String

説明
プロキシサーバーの名前を設定します。

使用例

document.all("FileDownloadMonitor").EnableProxy = TRUE
document.all("FileDownloadMonitor").ProxyName = "ProxyServerName"
document.all("FileDownloadMonitor").UserID = "UserID"
document.all("FileDownloadMonitor").UserPassword = "UserPassword"


■ [EnableDownloadFolder]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[完了後、ダウンロードしたフォルダを開く]の活性化の状態を決定します。デフォルトは[TRUE]です。

使用例

document.all("FileDownloadMonitor").EnableDownloadFolder = TRUE


■ [CheckDownloadFolder]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[完了後、フォルダを開く]のチェックボックスのチェック状態を決定します。.
[VisibleDownloadFolder]や[EnableDownloadFolder]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").CheckDownloadFolder = TRUE


■ [VisibleResume]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[続けてダウンロード]のチェックボックスの可視化の状態を決定します。
[VisibleResume]のプロパティを明示的に入力しない状態で[EnableResume]のプロパティを設定すると、[VisibleResume]のプロパティに[TRUE]と設定したのと同様になります。デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").VisibleResume = TRUE


■ [EnableResume]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[続けてダウンロード]のチェックボックスの活性化の状態を決定します。
[VisibleResume]プロパティを明示的に入力しない状態で[EnableResume]プロパティを設定すると、[VisibleResume]プロパティを[TRUE]に設定したのと同様になります。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").EnableResume = TRUE


■ [CheckResume]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[続けてダウンロード]のチェックボックスのチェック状態を決定します。
[VisibleResume]や[EnableResume]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").CheckResume = TRUE


■ [VisibleAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]のチェックボックスの可視化の状態を決定します。
[VisibleAutoCloseWindow]のプロパティを明示的に入力しない状態で[EnableAutoCloseWindow]のプロパティを設定すると、[VisibleAutoCloseWindow]のプロパティに[TRUE]と設定したのと同様になります。デフォルトは[TRUE] です。

使用例

document.all("FileDownloadMonitor").VisibleAutoCloseWindow = TRUE


■ [EnableAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]の活性化の状態を決定します。
[VisibleAutoCloseWindow]のプロパティを明示的に入力しない状態で[EnableAutoCloseWindow]のプロパティを設定すると、[VisibleAutoCloseWindow]のプロパティを[TRUE]に設定したのと同様になります。
デフォルトは[TRUE]です。

使用例

document.all("FileDownloadMonitor").EnableAutoCloseWindow = TRUE


■ [CheckAutoCloseWindow]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[転送完了後、ウィンドウを閉じる]のチェックボックスのチェック状態を決定します。
[VisibleAutoCloseWindow]や[EnableAutoCloseWindow]のプロパティの設定に関係なくチェック状態を決定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").CheckAutoCloseWindow = TRUE


■ [EnableOverlappedMode]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[重複ファイル処理]のラジオボックスの活性化の状態を決定します。デフォルトは[TRUE]です。

使用例

document.all("FileDownloadMonitor").EnableOverlappedMode = TRUE


■ [CheckRename]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[重複ファイル処理]のラジオボックスの[別の名前で保存]に関するチェック状態を決定します。
[VisibleOverlappedMode]や[EnableOverlappedMode]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[TRUE]です。

使用例

document.all("FileDownloadMonitor").CheckRename = TRUE


■ [CheckOverwrite]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[重複ファイル処理]のラジオボックスの[上書き]に関するチェック状態を決定します。
[VisibleOverlappedMode]や[EnableOverlappedMode]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").CheckOverwrite = TRUE


■ [CheckSkip]プロパティ

属性
Read/Write

タイプ
BOOL

説明
[重複ファイル処理]のラジオボックスの[スキップ]に関するチェック状態を決定します。
[VisibleOverlappedMode]や[EnableOverlappedMode]のプロパティの設定に関係なくチェック状態を設定できます。
デフォルトは[FALSE]です。

使用例

document.all("FileDownloadMonitor").CheckSkip = TRUE


■ [EnableSortByColumn]プロパティ

属性
Write

タイプ
BOOL

説明
ListViewのコラム名を通じる整列を支援します。
デフォルトは[FALSE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="EnableSortByColumn" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewStyle]プロパティ

属性
Read/Write

タイプ
String

説明
リストビューのスタイルを変更します。デフォルトは[LVS_REPORT]です。

スタイル

LVS_REPORT | - ファイルに関する詳しい情報を表示するレポートスタイルです。
LVS_LIST | - ファイルに関する簡単な情報を表示するリストスタイルです。
LVS_ICON | - ファイルに関する簡単な情報を表示するアイコンスタイルです。
LVS_SMALLICON | - ファイルに関する簡単な情報を表示する小さなアイコンスタイルです。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="ListViewStyle" VALUE="LVS_LIST">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewLineStyle]プロパティ

属性
Read/Write

タイプ
BOOL

説明
リストビューのラインに関する[Visible]のプロパティを設定します。リストビューのスタイルが[LVS_REPORT]の場合にだけ使用できます。デフォルトは[TRUE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="ListViewLineStyle" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューの背景色を変更します。入力値はRGBの色コード値です。デフォルトは、背景色が設定されていない[CLR_NONE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="ListViewBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキストの色を変更します。入力値はRGBの色コード値です。デフォルトは、テキストの色が設定されていない[CLR_NONE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="ListViewTextColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ListViewTextBkColor]プロパティ

属性
Write

タイプ
String

説明
リストビューのテキスト背景色を変更します。入力値はRGBの色コード値です。デフォルトは、テキスト背景色が設定されていない[CLR_NONE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="ListViewTextBkColor" VALUE="#4169E1">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableDecryption]プロパティ

属性
Read/Write

タイプ
BOOL

説明
複合化に関する[Enable]のプロパティを設定します。デフォルトは[FALSE]です。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="EnableDecryption" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [PercentOfTotalDecryptionFile　]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関する複合化の進行度を百分率で表します。プログレスバーなどに表示するために使用されます。

使用例

alert("全体のファイルに関する複合化の進行度: " + document.all("FileDownloadMonitor").PercentOfTotalDecryptionFile);


■ [TransferedSizeOfTotalFile]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関するこれまでにダウンロードが完了したサイズ。

使用例

alert("全体のファイルに関するこれまでにダウンロードが完了したサイズ: " + document.all("FileDownloadMonitor").TransferedSizeOfTotalFile);


■ [TransferedSizeOfCurrentFile]プロパティ

属性
Read

タイプ
LONG

説明
ダウンロード中のファイルに関するこれまでにダウンロードが完了したサイズ。

使用例

alert("ダウンロード中のファイルに関するこれまでにダウンロードが完了したサイズ: " + document.all("FileDownloadMonitor").TransferedSizeOfCurrentFile);


■ [TotalCount]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadMonitorに追加されたすべてのファイル個数

使用例

document.all("FileDownloadMonitor").TotalCount


■ [CurrentCount]プロパティ

属性
Read

タイプ
LONG

説明
ダウンロードを進行中のファイルの個数。

使用例

alert("ダウンロード進行中のファイル個数: " + document.all("FileDownloadMonitor").CurrentCount);


■ [SelectedCount]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadMonitorに追加され、選択されたファイル個数

使用例

document.all("FileDownloadMonitor").SelectedCount


■ [TotalSize]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadMonitorに追加されたすべてのファイルのサイズ

使用例

document.all("FileDownloadMonitor").TotalSize


■ [CurrentSize]プロパティ

属性
Read

タイプ
LONG

説明
ダウンロード中のファイルサイズ。

使用例

alert("ダウンロード中のファイルサイズ: " + document.all("FileDownloadMonitor").CurrentSize);


■ [SelectedSize]プロパティ

属性
Read

タイプ
LONG

説明
FileDownloadMonitorに追加され、選択されたファイルのサイズ

使用例

document.all("FileDownloadMonitor").SelectedSize


■ [PercentOfTotalFile]プロパティ

属性
Read

タイプ
LONG

説明
全体のファイルに関するダウンロードの進行度を百分率であらわします。プログレスバーなどに表示するために使用されます。

使用例

alert("全体のファイルに関するダウンロードの進行度: " + document.all("FileDownloadMonitor").PercentOfTotalFile);


■ [PercentOfCurrentFile]プロパティ

属性
Read

タイプ
LONG

説明
ダウンロード中のファイルに関するダウンロード進行度を百分率で表します。プログレスバーなどに表示するために使用されます。

使用例

alert("ダウンロード中のファイルに関するダウンロード進行度: " + document.all("FileUploadMonitor").PercentOfCurrentlFile);


■ [ElapsedTime]プロパティ

属性
Read

タイプ
String

説明
これまでの時間を時･分･秒で表示します。(例:01:22:15)

使用例

alert("これまでの時間: " + document.all("FileDownloadMonitor").ElapsedTime);


■ [RemainingTime]プロパティ

属性
Read

タイプ
String

説明
ダウンロードが完了するまでの残り時間を時･分･秒で表示します。(例:01:22:15)

使用例

alert("残り時間: " + document.all("FileDownloadMonitor").RemainingTime);


■ [BytesPerSec]プロパティ

属性
Read

タイプ
String

説明
秒あたりに転送されたバイト個数。転送速度を表します。

使用例

var CurrentSpeed = document.all["FileDownloadMonitor"].BytesPerSec;

if(1 < CurrentSpeed/1000.0/1000.0/1000.0) {

CurrentSpeed = CurrentSpeed / (1024*1024*1024);

alert("転送速度: " + CurrentSpeed + GB);
}

else if(1 < CurrentSpeed/1000.0/1000.0) {

CurrentSpeed = CurrentSpeed / (1024*1024);

alert("転送速度: " + CurrentSpeed + MB); ";

}

else if(1 < CurrentSpeed/1000.0) {

CurrentSpeed = CurrentSpeed / 1024;

alert("転送速度: " + CurrentSpeed + KB);
}

else {
alert("転送速度: " + CurrentSpeed + Bytes);

}


■ [CurrentFileName]プロパティ

属性
Read

タイプ
String

説明
ダウンロード中のファイル名。

使用例

alert("ダウンロード中のファイル名: " + document.all("FileUploadMonitor").CurrentFileName);


■ [EnableLargeDownload]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
大容量ダウンロードを支援(2GB 以上) デフォルトは FALSE である。

使用例

<OBJECT ID="FileDownloadMonitor" height=380 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" CLASSID="CLSID:64F53B6B-C2A8-4e46-89E0-8ADD2F2AA861">
<PARAM NAME="EnableLargeDownload" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [VisibleDownloadCheckbox] プロパティ

属性
Read

タイプ
BOOL

説明
FileDownloadMonitorが生成される時リストビューのチェックボックス活性化状態を設定する。基本値は TRUE である。

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="VisibleDownloadCheckbox" VALUE="FALSE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [DialogBoxMode]プロパティ

属性
Read

タイプ
String

説明
FileDownloadMonitorが生成される時 FileDownloadMonitorの多様な UI形態を支援

スタイル

DLG_LISTVIEW – リストビュー形態の UIを支援

DLG_SIMPLE – 既存 FileDownloadMonitor よりシンプルな形態の UIを支援

使用例

<OBJECT id=FileDownloadMonitor height=355 width=445 classid=CLSID: 471678BB-F992-4BE6-9761-7767883E8619 CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="DialogBoxMode" VALUE=" DLG_LISTVIEW">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [CheckTransSpeed]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
支援される帯域幅内で伝送速度を制限する。
基本値は FALSE である。

使用例

<OBJECT ID="FileDownloadMonitor" height=380 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" CLASSID="CLSID:64F53B6B-C2A8-4e46-89E0-8ADD2F2AA861">
<PARAM NAME="CheckTransSpeed" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [MaxTransSpeed]プロパティ (DEXTUpload Pro Extension 製品だけ当たります。)

属性
Read

タイプ
BOOL

説明
CheckTransSpeed プロパティーが TRUEに設定されている場合,MaxTransSpeed プロパティーを利用して秒当たり最大に送られるファイルのサイズを設定する。
デフォルトは FALSEで,入力単位は BYTE である。

使用例

<OBJECT ID="FileDownloadMonitor" height=380 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadXEx.cab#version=1,5,1,0" CLASSID="CLSID:64F53B6B-C2A8-4e46-89E0-8ADD2F2AA861">
<PARAM NAME="MaxTransSpeed" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [EnableBehindDownload]プロパティ

属性
Read

タイプ
BOOL

説明
サーバーのウェブ上に公開されないファイルをダウンロードできて,ダウンロードのためにファイルの URLを露出させない。
デフォルトは FALSE である。
(ただ,EnableBehindDownload プロパティーが TRUEの場合、続けてダウンロード,2GB 以上の大容量ダウンロード(Ex バージョン) 及び暗号化ダウンロードは支援されない。(今後のサポート予定))

使用例

<OBJECT ID="FileDownloadMonitor" height=445 width=445 CodeBase = "http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" CLASSID="CLSID:471678BB-F992-4BE6-9761-7767883E8619">
<PARAM NAME="EnableBehindDownload" VALUE="TRUE">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [AddFile]メソッド

形式

AddFile(BSTR FileURL, LONG nFileSize, BSTR FileName, BSTR DirectoryName)

FileURL – ファイルのアドレス。このアドレスは必ずしも一つのサーバーである必要はありません。つまり、いくつかのファイルサーバーからダウンロードを実行できるよう指定もできます。
nFileSize – ファイルサイズ。ユーザーが必ず指定してください。ファイルサイズが間違っていてもダウンロードに失敗することはありません。
FileName – FileDownloadManagerに表示されるファイル名。オプションです。入力しなければ最初のファクターで指定されたファイル名が使用されます。
DirectoryName　－フォルダ構造ダウンロードのためのフォルダパスなのでオプションです。入力しなければフォルダの構造は生成されません。

戻り値

説明
FileDownloadMonitorの[AddFile]メソッドを使用してダウンロードしたファイルを追加できます。

使用例

document.all("FileDownloadMonitor ").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile1.tst", 10000000
document.all("FileDownloadMonitor ").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile2.tst", 20000000, "DevpiaTest3.tst"
document.all("FileDownloadMonitor ").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile3.tst", 30000000, "UserDirectory.tst", "\Temp\Temp1\"
document.all("FileDownloadMonitor ").AddFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile4.tst", 10000000, "", "\Temp\Temp1\Temp2\"


■ [DeleteFile]メソッド
形式

DeleteFile(BSTR FileURL)

FileURL – [AddFile]で使用した削除するURL

戻り値

説明
[AddFile]メソッドを使用して追加したファイルアイテムを削除できます。

使用例

document.all("FileDownloadMonitor").DeleteFile "http://Localhost/DEXTUploadXSamples/Download/DEXTUploadXTestFile1.tst"


■ [SelectAll]メソッド

形式

SelectAll()

戻り値

説明
FileDownloadMonitorに追加されたすべてのファイルを選択します。

使用例

document.all("FileDownloadMonitor").SelectAll


■ [UnselectAll]メソッド

形式

UnselectAll()

戻り値

説明
FileDownloadMonitorに追加されたすべてのファイルの選択を解除します。

使用例

document.all("FileDownloadMonitor").UnselectAll


■ [ChooseDownloadFolder]メソッド

形式

ChooseDownloadFolder()

戻り値

説明
ダウンロードフォルダ選択のためのダイアローグを見せます。FileDownloadMonitorの中にある‘検索’　ボタンと同じ機能を持ちます。

使用例

document.all("FileDownloadMonitor").ChooseDownloadFolder();


■ [Transfer]メソッド

形式

Transfer()

戻り値

説明
ファイルやフォームアイテムの転送を始めます。ユーザーが[転送]ボタンをクリックする場合と同じ効果です。

使用例

document.all("FileDownloadMonitor").Transfer();


■ [Cancel]メソッド

形式

Cancel()

戻り値

説明
転送をキャンセルします。すでにキャンセルされた状態の場合は転送ウィンドウを閉じます。ユーザーが[キャンセルして閉じる]ボタンをクリックした場合と同じ働きです。

使用例

document.all("FileDownloadMonitor").Cancel();


■ [MoveFileUp]メソッド

形式

MoveFileUp(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、上に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileDownloadMonitor"].MoveFileUp(3);


■ [MoveFileDown] メソッド

形式

MoveFileDown(nIndex)

nIndex – 移動しようとする範囲

戻り値

説明
リストビューにあるファイルを nIndexに指定した個数ほど、下に移動する。
Indexに値を入力しなければ限り間ずつ移動する。

使用例

document.all["FileDownloadMonitor"]. MoveFileDown(3);


■ [DeleteAllFile] メソッド

形式

DeleteAllFile()

戻り値

説明
FileDownloadMonitorのすべてのファイルを削除します。

使用例

document.all("FileDownloadMonitor").DeleteAllFile();


■ DeleteSelectedFile メソッド

形式

DeleteSelectedFile(Index)

Index – 削除しようとするファイルのインデックス

戻り値

説明
Indexに値段を入力しなければ FileDownloadMonitorに 選択されているファイルを削除します。 FileDownloadMonitorの 右側にある ‘削除’ ボタンと等しい機能です。
Indexに 0 以上の正しい値を入力すれば FileDownloadMonitorに追加されているファイルの中で indexにあたるファイルを 削除します。

使用例

document.all("FileDownloadMonitor").DeleteSelectedFile(); // FileDownloadMonitorの右側に位した ‘削除’ ボタンと等しい機能をします。
document.all("FileDownloadMonitor").DeleteSelectedFile( 3 ); // FileDownloadMonitorに追加されられているファイルたちの中で 3番目にあたるファイルを削除します。


■ [OnChangedStatus]イベント

形式

OnChangedStatus(LONG nFileCount, LONG nFileSize, LONG nSelectedFileCount, LONG nSelectedFileSize)

nFileCount – 全体のファイル個数
nFileSize – 全体のファイルサイズ
nSelectedFileCount – 選択されたファイル個数
nSelectedFileSize – 選択されたファイルのサイズ

説明
ファイルが追加されたり、選択/解除されたときに[OnChangedStatus]イベントが発生します。

使用例

<SCRIPT FOR="FileDownloadMonitor" Event="OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize)" language="javascript">
OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnChangedStatus(nFileCount, nFileSize, nSelectedFileCount, nSelectedFileSize)
{
alert("全体のファイル数: " + nFileCount);
alert("全体のファイルサイズ: " + nFileSize);
alert("選択されたファイル数: " + nSelectedFileCount);
alert("選択されたファイルのサイズ: " + nSelectedFileSize);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCloseWIndow]イベント

形式

OnCloseWIndow()

説明
FileDownloadMonitorが終了されたことを知らせます。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnCloseWIndow()">
Msgbox "ウィンドウを閉じます。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnEndTransferringItem]イベント

形式

OnEndTransferringItem(LONG nItemIndex, BOOL bSuccess)

nItemIndex – 転送が始まったファイルアイテムのインデックス番号
bSuccess – 転送が成功したかどうか

説明
一つのファイルアイテムの転送が終了したことを知らせます。nItemIndexは該当ファイルのインデックスで、 FileDownloadMonitor(nItemIndex).Nameのような形で該当ファイルの情報を得ることができます。

使用例

<SCRIPT FOR="FileDownloadMonitor " Event="OnEndTransferringItem(nItemIndex, bSuccess)" LANGUAGE="javascript">
OnEndTransferringItem(nItemIndex, bSuccess);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnEndTransferringItem(nItemIndex, bSuccess)
{
alert("転送が終わったアイテムのインデックス:" + nItemIndex);
alert("転送が成功したかどうか:" + bSuccess);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnEndProc]イベント

形式

OnEndProc()

説明
DEXTUploadX内部の全ての動作が完了されたのを知らせます。
OnEndProcイベントはOnTransferCompleteイベントより後に発生します。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnEndProc()">
Msgbox "DEXTUploadXの全ての動作が完了されました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnError]イベント

形式

OnError(ErrorCode, sMsg, sDetailMsg)

Code - エラーコード。種類は下記のとおりです。

20000000 ~
アップロードしようとするファイルが指定のサイズを超えたりした場合に起こる一方的なエラーです。このコードに該当するエラーメッセージは、大部分が一般ユーザーに知らされなければならない内容です。

30000000 ~
ウィンドウズのシステム関数エラーです。ファイルが現在使用中だったり、インターネットを使用できないなどの問題があった場合に発生します。一部は一般ユーザーに知らされなければならない内容です。.

40000000 ~
サーバーから発せられるエラーメッセージです。クライアント側には問題がないが、サーバー側になんらかの問題がある場合に発生します。40000以降の数字はサーバーのエラーコードです。(例：40000404は「アクセスエラー」)

sMsg - ユーザーにどんなエラーが発生したかを知らせる単純なメッセージです。このエラーの正確な原因はsDetailMsgが知らせてくれます。40000000のエラーの場合、サーバーから送られるページのタイトルが表示されます。サーバーに問題がある場合、「サーバーとの接続が非正常的に終了しました」というエラーメッセージが表示されます。その場合、アップロードしようとしていたファイルのサイズが16KB以上の可能性があります。HTTPの構造上、サーバーから送られるエラーメッセージを正常に受信するためには、16KB以下のファイルをアップロードしなければなりません。そうすることによりsDetailMsgにサーバー側からの正確なメッセージが伝えられ、問題点が何なのかを詳しく判断できるようになります。

sDetailMsg - sMsgが発生した原因を知らせるメッセージです。 sDetailMsgはエラーの種類によっては表示されない場合もあります。40000000のエラーの場合、サーバーから送られるページの実質的な内容が表示されます。

使用例

<SCRIPT For = "FileDownoadMonitor" Event = "OnError(nCode, sMsg, sDetailMsg)" LANGUAGE = "javascript">
OnFileMonitorError(nCode, sMsg, sDetailMsg);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnFileMonitorError(nCode, sMsg, sDetailMsg)
{
// ここでエラーを処理します。
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnStartTransferringItem]イベント

形式

OnStartTransferringItem(LONG nItemIndex)

nItemIndex – 転送が始まったファイルアイテムのインデックス番号

説明
一つのファイルアイテムの転送が始まったことを知らせます。nItemIndexは該当ファイルのインデックスで、 FileDownloadMonitor(nItemIndex).Nameのような形で該当ファイルの情報を得ることができます。

使用例

<SCRIPT FOR="FileDownloadMonitor" Event="OnStartTransferringItem(nItemIndex)" LANGUAGE="javascript">
OnStartTransferringItem(nItemIndex);
</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">
function OnStartTransferringItem(nItemIndex)
{
alert("転送が始まったアイテムのインデックス:" + nItemIndex);
}
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransfer_Click]イベント

形式

OnTransfer_Click()

説明
ユーザーが[転送する]ボタンをクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnTransfer_Click()">
Msgbox "[OnTransfer_Click]イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferCancel]イベント

形式

OnTransferCancel()

説明

ユーザーが[中止]ボタンをクリックしたり、サーバー側のエラーにより転送がキャンセルされた場合に知らせます。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnTransferCancel()">
Msgbox "転送がキャンセルされました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferComplete]イベント

形式

OnTransferComplete()

説明
転送を完了しました。これはエラーなく転送に成功したことを表しています。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnTransferComplete()">
Msgbox "転送を完了しました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnTransferPause]イベント(DEXTUpload Pro Extension 製品だけ当たります。)

形式

OnTransferPause()

説明
大容量ダウンロード,続けてダウンロードが活性化になっている時、ユーザーが日時止まりを選択すれば発生する。

使用例

<SCRIPT LANGUAGE="Java Script" for="FileDownloadMonitor" event="OnTransferPause()">
Alert("アップロードが日時中止されました。");
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnStartDecryption]イベント

形式

OnStartDecryption()

説明
複合化が始まりました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event=" OnStartDecryption()">
Msgbox "OnStartDecryption イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCancelDecryption]イベント

形式

OnCancelDecryption()

説明
ユーザーが[キャンセル]ボタンをクリックしたか、または何らかのエラーによって複合化がキャンセルされたことを知らせます。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnCancelDecryption()">
Msgbox "複合化がキャンセルされました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnCompleteDecryption]イベント

形式

OnCompleteDecryption()

説明
複合化を完了しました。これは、エラーなく複合化に成功したことを表しています。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnCompleteDecryption()">
Msgbox "複合化を完了しました。"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnDouble_Click]イベント

形式

OnDouble_Click()

説明
ユーザーが[リストビュー]をダブルクリックしました。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnDouble_Click()">
Msgbox "OnDouble_Click イベント発生"
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [OnFile_DoubleClick]イベント

形式

OnFile_DoubleClick()

説明
ユーザーがリストコントロール内のファイルアイテムをダブルクリックしたとき発生します。nItemIndexはダブルクリックしたファイルアイテムのindexです。

使用例

<SCRIPT LANGUAGE="VBS" for="FileDownloadMonitor" event="OnFile_DoubleClick(nItemIndex)">
Msgbox document.all("FileDownloadMonitor")(nItemIndex).Name
Msgbox document.all("FileDownloadMonitor")(nItemIndex).Size
</SCRIPT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ProgressBarColor]プロパティ

属性
Read

タイプ
String

説明
Progress Barの色を指定する。デフォルトは"CLS_DEFAULT"です。

使用例

<OBJECT id="Progress" height="30" width="600" classid="CLSID:253B8695-AFE6-4918-AE1C-003FCF070D08" codebase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME="ProgressBarColor" VALUE="#FF2288">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [ProgressBarBkColor]プロパティ

属性
Read

タイプ
String

説明
Progress Barの背景色を指定する。デフォルトは"CLS_DEFAULT"です。

使用例

<OBJECT id="Progress" height="30" width="600" classid="CLSID:253B8695-AFE6-4918-AE1C-003FCF070D08" codebase="http://Localhost/DEXTUploadX/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>
<PARAM NAME=" ProgressBarBkColor " VALUE="#FF2288">
</OBJECT>

Copyright ⓒ DEVPIA Corporation. All rights reserved


■ [CurrentPos]プロパティ

属性
Read/Write

タイプ
LONG

説明
CurrentPosプロパティーはプログレスバーの 現在状態値を持って来る。 CurrentPosプロパティーは一ページで何回も 宣言できます。

使用例

alert(document.all["Progress_total"].CurrentPos);


■ [SetRange] メソッド

形式

SetRange(nMinRange, nMaxRange)

nMinRange - 最小範囲値

nMaxRange – 最大範囲値

戻り値

説明
Progress Barの範囲を指定する。デフォルトは 0 ~ 100 である。

使用例

document.all["Progress"]. SetRange(0,50);


■ [AddPos] メソッド

形式

AddPos(nPos)

nPos – 加わる Progress Bar 位置値

戻り値

説明
現在 Progress Barの位置に nPosの値を加えて新しい位置を指定する。

使用例

document.all["Progress"]. AddPos(30);


DEXTUploadJ

DEXTUploadJ 製品紹介

■ DEXTUploadJ 製品紹介

DEXTUploadJはウェブブラウザーからウェブサーバーへファイル・アップロード機能を支援するHTTPプロトコル基盤のサーバー側Componentでリナクス/ユニックスプラットフォームのウェブサーバーへホスティングされる全てのサーブレット(Servlet)環境で使用できます。国内外アップロード製品の中で最高の性能と安定性で10,000余個以上のサイトでサービスされており、 DEXTUpload製品のJAVAバージョンです JSPなどでサービスされている様々なウェーブビジネス環境に適用し、優れた性能のファイル・アップロードやダウンロードサービスを提供してください。

■ DEXTUploadJの重要機能

1.　抜群のファイル・アップロード機能の支援

- 2GBまで大容量ファイル・アップロード可能

- 最適のパシングアルゴリズム適用で早いアップロード速度及び低いシステムリソース使用

- 多重ファイル・アップロードの時、エラーが発生した場合全体作業をキャンセルするトランジャクション処理支援

- アップロードされたファイルに対して上書き、 新しい名前で保存、フォルダ自動生成機能支援

- Database BLOBへファイル・アップロード支援

- アップロード可能なファイル・フィルタリング機能、容量制限,Timeout設定機能支援

- ユニコードで作成されたフォームデータ及びファイル名の完璧な処理支援

2.　ファイル・アップロード ウィンドウ 提供

- ウィンドウ 表示のための別のクライアント・ソフトウェア不必要

- アップロード速度、アップロードファイルの容量、伝送したファイルの容量、残り時間などの進行状態を実時間表示

- ユーザー定義形 ウィンドウ 構成支援

3. ファイル・ダウンロード支援

- 抜群の「続けてダウンロード」機能支援

- ファイル・ダウンロードの時ブラウザーで開かず、いつでもダウンロードできるように設定可能- Database BLOBからのファイル・ダウンロード機能

4. イメージプロセッシング機能支援

- アップロードされたイメージファイルにウォーターマーキング処理して、イメージファイルの藷作権表示など必要によってイメージまた文字列を表示できます。

- アップロードされたイメージファイルをサムネイル処理して、イメージファイルを求めるサイズに合わせて見せる。

- 多様なファイルフォーマット変換機能支援

: JDK 1.4 - 形式変換のサポート(JPG、PNGなど)

: JDK 1.5 - 形式変換のサポート(JPG、PNG、BMP、WBMPなど)

: JDK 1.6 - 形式変換のサポート(JPG、PNG、BMP、WBMP、GIFなど)

- 多様なイメージファイルのフォーマット、広さ、高さ提供 (JPG、BMP、PNG、GIF、WBMPなど)

■ DEXTUploadJのシステム要件

- Linux, Unix, FreeBSDなどでJava Servletを支援する環境

- JRE 1.4.2以上

- テストされた環境情報は ウェブサイト(http://www.dextsolution.com/jp)を参考してください。

DEXTUploadJ製品に関する詳しく情報は http://www.dextsolution.com/jpの ‘PRODUCTS’メニューでDEXTUploadJ製品のコードサンプル及びライブデモなどを確認できます。


DEXTWebEditor

DEXTWebEditor製品紹介

■ DEXTWebEditor製品紹介

DEXTWebEditorは、掲示板などのような対話型ウェブサイトの構築時に必要なコンポーネント型ウェブエディターでとして、様々な形態の文書作成とワードレベル表の作成機能、そしてオフィス製品を含む全てのHTML文書との互換性と多国語を対応することで、よりよい業務システムの開発を可能にしてくれます。

特に、DEXTUpload製品群と一緒に貴社のソルーションやサービスに使用する場合、最適なインタラクティブシステムを構築することで顧客満足度を最大限に拡大することができるHTMLウェーブエディターとして、ウェブブラウザから自動的にダウンロードして使用する形で提供され、活用したいウェブ運営プログラムに自動的に配布して使用します。

■ DEXTWebEditorの重要機能

-Windows　Vista、IE7.0完璧支援

-全てのHTML文書及びCSS(Cascading　Style　Sheet)互換性維持

-MSオフィス文書の互換性（読み込み、コピーなど）

-様々な式のフォム作成ができる専門家レベル表の機能搭載

-メールや掲示板などとのアクセス時必要なアップロード、通信 モジュール支援

-ユニコード基盤で開発され、完璧な多国語支援

-様々な言語環境で使用できるように韓国語、英語バージョン提供（今後拡張予定）

-ブラウザー基盤のコンポーネントで簡単に自動配布とアップグレード

-最小/最適のクライアント資源を使用し、ネットワーク負荷を最小にする強力な機能

-様々な詳細機能に対する開発者API提供

–デザイン/ソースビュー/プレビューの３段階編集ウィンドウ提供

-HTTPアップロード機能が搭載され、独立な使用可能

–DEXTUpload製品群との統合サンプル提供

■ DEXTWebEditorのシステム要件

1.クライアントの要求仕様(一般ユーザー)

- Windows 98 SE/ Me/ 2000/ XP/ 20003/ Vistaなどの全てのバージョンのWindowsに対応しています。

- Internet Explorer 5.5以上

2.サーバーの要求仕様 (開発者)

- 自動配布ファイル(Cab)をインストールできる全てのOS(Windows、Linux、Unixなど)

DEXTWebEditor製品に関する詳しく情報は http://www.dextsolution.com/jpの ‘PRODUCTS’メニューでDEXTWebEditor製品のコードサンプル及びライブデモなどを確認できます。


DEXTVideo

DEXTVideo製品紹介

■ DEXTVideo製品紹介

DEXTVideoは、動画を登録し照会できる動画ソリューションです。動画情報を簡単にウェブ上で共有できることによって、社内や外部で簡単にウェブ2･0サービス構築ができます。

DEXTVideoは、ファイル変換及びアップロード機能をするActiveX Controlと、動画プレイヤーで構成されています。

既存に構築されているウェブシステム（全社グループウェア、ポータルなど）に動画パートを簡単に追加でき、外部顧客の為に安定的な動画サービスが可能です。世界最大動画ポータルであるgoogleのYOUTUBE及び、韓国有数のポータル業者で使用しているオープンソース基盤のFFMPEG技術で具現され、後、持続的な機能改善が可能であると言うメリットがあります。

DEXTVideoは、多様なビデオフォーマトを一つの標準ファイルフォーマトであるFLVファイルで変換することによって、クライアントで追加ソフトウェア（コーデック）を設置する必要が無く、Viewingが可能であり、またファイル変換がクライアントPCから実行され、サーバーの負荷を減らすことによって、ソリューション構築及び、運営費用を最小限にできます。

■ DEXTVideoの重要機能

1. ファイル変換がユーザーのＰＣで処理されます。

- ActiveX 技術を利用したクライアントでインコーデイングを支援することによって、サーバーの負荷を減少し、インコーデイング後、POST方式でサーバーにアップロードすることによって、他製品よりも保安性が優れています。

2. 改善されたActiveXのアップグレードを提供します。

- DEXT VIDEOの機能改善などで、クライアントに自動で配布されるActiveX Controlのダウンロード時に進行状況を表示することによって、改善されたUIを提供します。

3. 多様なビデオフォーマットの変換を支援します。

- wmv, avi, asf, mpg, mpeg, mov, mpeg, k3g, skm, wma, mp3, mp4など、多様なオーデイオ、ビデオフｵーマットを支援します。

4. DEXT製品達との100%互換性

- DEXTUPLOAD, DEXT WEBEDITOR などの製品と100%互換し、 DEXT COMPONENTと照合できるサンプルコードも持続的に提供されます。

■ DEXTVideo Player の重要機能

1. 画面サイズ調整（管理者設定）

- 画面の比率別オプションを選択

(800*600, 720*480, 352*240, 320*240)

2.　便利な場面移動

- サムネイルイメージがプレイヤーの下段に表示され中間に移動する機能。下段ボタンで区間移動も可能（微細移動／区間移動）

3.　ロゴ挿入

- プレイヤー上段にサービス業者のロゴを挿入

4.　広告機能（動画）

- 動画プレイヤー以前区間に広告映像挿入

5.　広告機能（テキスト／行広告）

- 管理者設定で、簡単にプレイヤー下段にテキストを挿入できる機能

6.　映像キャプチャー機能

- 動画の中で、必要な場面をキャプチャーし、JPGで生成する機能

■ DEXTVideo Player のシステム要件

1. サーバーの要求仕様

-自動配布ファイル(.Cab)を設置できる全てのOS (Windows, Linux, Unix etc.)

2. クライアントの要求仕様

- Windows 98 SE / Me / 2000 / XP / 20003 / Vista など、すべてのWindowsバージョンを支援します。

- Internet Explorer 5.5 以上

■ DEXTVideoの適用分野

1. 製品/サービス/コンテンツ広報

- オンラインショッピングモール

：オープンマーケット事業者など

- 一般企業広報映像

- 団体

- 地方自治団体広報

- 広報企画社

- 芸能プロダクション

- 映画社

- 公演企画社

2. 資料保存/行事広報

- 学院、学校

- 幼稚園、保育院

- 教会：説教の動画

- 各種研究団体

- 企業イントラネット

3. UCCサイト構築

- 動画専門サイト

- スポーツ動画サイト

- 親睦コミュニティ

DEXTVideo製品に関する詳しく情報は http://www.dextsolution.com/jpの ‘PRODUCTS’メニューでDEXTVideo製品のコードサンプル及びライブデモなどを確認できます。


DEXT Products

DEXTUploadXと DEXTUpload Pro 連動活用

■ DEXTUploadXと DEXTUpload Pro 連動時 DEXTUpload Proの機能活用する

二つの製品を連動して POST 方式でアップロード時 DEXTUploadXは下のポームネームでファイル及び付加情報をサーバーに伝逹します。

ファイルを一つ以上アップロードする場合は等しいポームネームで配列のようにアクセスできます。

[DEXTUploadX ポームネーム]

DEXTUploadX - ファイルデータ

DEXTUploadX_FolderPath - 各ファイルに対するディレクトリーパス

DEXTUploadX_Alias - 各ファイルに対する別称

DEXTUploadX_UserDataA - 各ファイルに対する使用者定義データ

DEXTUploadX_UserDataB - 各ファイルに対する使用者定義データ

DEXTUploadX_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを表示する時)

DEXTUploadX_Deleted_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを削除した時)

下のコードは POST方式アップロード(DEXTUploadXと DEXTUpload Pro 連動) 時 DEXTUploadXでアップロードするいくつかのファイルを DEXTUpload Proで保存する部分と DEXTUpload Proだけ使うサンプルの中でいくつかのファイルを保存する部分のコードです。

1-1. FileUploadManager ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>一番簡単な POST 方式の例題.</TITLE>

<SCRIPT FOR="FileUploadManager" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileManagerError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

// sMsgは手短に要約されたエラーメッセージです。

// sDetailMsgはもっと詳しい情報が含まれたエラーメッセージです。

// sDetailMsgはエラーメッセージによって空白の場合もあります。

// 必ず上のように宣言を言ってくれなければなりません。

// このエラー処理方式は DEXTUploadXのすべてのコントロールが等しいです。

function OnFileManagerError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">

'ファイルアップロードマネージャーの送るボタンを押せば上の 'OnTransfer_Click' イベントが発生します。

' ここで下記のようにファイルアップロードモニター画面を開けば良いです。

winstyle="height=335,width=445, status=no,toolbar=no,menubar=no,location=no"

window.open "./FileUploadMonitor.htm",null,winstyle

</SCRIPT>

</HEAD>

<BODY>

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab #version=3,0,1,0"

height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>

</OBJECT>

<P>一番簡単な POST 方式のアップロードです。<BR>

上に見えるコントロールを "ファイルアップロードマネージャー (FileUploadManager)"と言います。<BR>

ドラッグ&ドロップを支援します。ファイルやフォルダをひいておいて見てください。<BR>

</P>

</BODY>

</HTML>

1-2. FileUploadMonitor ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>DEXTUploadX アップロード</TITLE>

<SCRIPT FOR="FileUploadMonitor" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileMonitorError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

function OnFileMonitorError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS">

sub OnLoading()

' Post 方式の場合下記のように UploadURL 属性に Post Script ファイルを明示しなければなりません。

' 標準ポート以外の他のポートを使おうとすれば

' http://Localhost:8080/DEXTUploadX/Upload/PostScript.asp

' と一緒に一般的なアドレス指定方法と等しく使えば良いです。

document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/PostScript.asp"

'このページの親ページにいるファイルマネージャーコントロールのすべてのファイル及びフォームアイテムをファイルモニターコントロールにコピーします。

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items

' ファイルマネージャーの何種類のプロパティ (DefaultPath,Filter 等々)の値をファイルモニターにコピーします。

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties

end sub

</SCRIPT>

</HEAD>

<BODY onload="OnLoading()" bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0>

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5

CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab #version=3,0,1,0" VIEWASTEXT>

</OBJECT>

</BODY>

</HTML>

1-3. PostScript.asp (DEXTUploadX,DEXTUpload Pro 連動時)

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXTEx.FileUpload")
uploadform.AutoMakeFolder = TRUE
uploadform.DefaultPath="C:\TEMP".

' コレクションスタイルでいくつかのファイルを処理します。
For i = 1 To uploadform("DEXTUploadX").Count
uploadform("DEXTUploadX")(i).Save
Next

' DEXTUploadXが使われているページのフォームデータが自動に送信されます。
' response.Write "ユーザーフォームデータ (単一) : " & uploadform("form") & vbCrLf

'等しいフォームはいなのを持ったフォームデータがいくつかの場合下記のように処理します。
'aspで使う一般的にフォームデータ処理方式でも可能です。
'For i = 1 To uploadform("form_multi").Count
' response.Write “ユーザーフォームデータ (多重) : “& uploadform("form_multi")(i) & vbCrLf
'Next

set uploadform = Nothing
%>

2-1. ファイルアップロードページ(DEXTUpload Proの MultiUpload サンプル : MultiUpload.asp)

<HTML>
<HEAD>
</HEAD>
<BODY>
<form name="write_form" enctype="multipart/form-data" method="post" action="MultiUpload_Process.asp">
Multiple Upload<br><br>
Select the file to upload<br>

<input type="file" name="files"><br>
<input type="file" name="files"><br>
<input type="file" name="files"><br><br>

1. アップロードファイル保存経路は C:TEMP です。<br>
2. '参考' ボタンを支援しないブラウザーの場合最新バージョンのブラウザーでアップデートなさってください。<br><br>

<input type="submit" name="Upload" value="Upload">
</form>
</BODY>
</HTML>

2-2. DEXTUpload Proでファイルを保存するページ (DEXTUpload Proの MultiUpload サンプル : MultiUpload_Process.asp)

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXTEx.FileUpload")
uploadform.AutoMakeFolder = TRUE
uploadform.DefaultPath="C:\TEMP"

For i = 1 To uploadform("files").Count
uploadform("files")(i).Save
Next

set uploadform =nothing
%>

POST方式アップロード時基本的なファイル保存以外に DEXTUpload Proの機能である ‘サムネィル生成’のような機能も簡単に具現が可能です。

下のコードは POST方式アップロード時 DEXTUploadXでアップロードするいくつかのイメージファイルを DEXTUpload Proで保存する部分と DEXTUpload Proのサンプルの中でサムネィルを保存する部分のコードです。

3-1. DEXTUploadX + DEXTUpload Pro サムネィル保存(比較のために製作されたコードサンプルです。)

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXTEx.FileUpload")
uploadform.AutoMakeFolder = TRUE
uploadform.DefaultPath="C:\TEMP\"
set objImage =server.CreateObject("DEXTEx.ImageProc")

For i = 1 To uploadform("DEXTUploadX ").count
if true = objImage.SetSourceFile(uploadform("DEXTUploadX ")(i).TempFilePath) then
' JPG フォーマットで保存しなければならない
filename = uploadform("DEXTUploadX ")(i).FileNameWithoutExt & ".jpg"
objImage.Quality = 90 'default value is 75 (range 1~100)

objImage.SaveasThumbnail "C:\Temp\" & filename,objImage.ImageWidth/10,objImage.ImageHeight/10,false
end if
Next

set objImage = nothing
set uploadform = Nothing
%>

3-2. DEXTUpload Pro (Thumbnail サンプル)

<%@ Language=VBScript %>
<%
set uploadform=server.CreateObject("DEXTEx.FileUpload")
uploadform.DefaultPath="C:\Temp\"
set objImage =server.CreateObject("DEXTEx.ImageProc")

if true = objImage.SetSourceFile(uploadform.TempFilePath) then
' JPG フォーマットで保存しなければならない
filename = uploadform.FileNameWithoutExt & ".jpg"
objImage.Quality = 90 'default value is 75 (range 1~100)

%>
<HTML>
<BODY>
Save as Image Thumbnail: <%=objImage.SaveasThumbnail("C:\Temp\" & filename,objImage.ImageWidth/10,objImage.ImageHeight/10,false)%>
</BODY>
</HTML>
<%
end if

set objImage = nothing
set uploadform =nothing
%>

4. その他参照事項

※ DEXTUploadX,DEXTUpload Pro 評価版ダウンロードは下の経路で可能です.

http://www.dextsolution.com/jp/Etc/downEval.aspx

※ DEXTUploadXのマニュアルと基本サンプルは基本設置した場合,

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX-DEXTUploadX 使用者マニュアル ”

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX- DEXTUploadX 例題 ”

で確認できます。

※ DEXTUpload Proのマニュアルと基本サンプルは基本設置した場合,

“スタート-すべてのプログラム-DEVPIA-DEXTUpload Professional-DEXTUpload Professional 使用者ヘルプ ”

“スタート-すべてのプログラム-DEVPIA-DEXTUpload Professional-DEXTUpload Professional 使用者例題 ”

で確認できます。


DEXT Products

DEXTUploadXと DEXTUpload.NET Pro 連動活用

■ DEXTUploadXと DEXTUpload.NET Pro 連動時 DEXTUpload.NET Proの機能活用する

二つの製品を連動して POST 方式でアップロード時 DEXTUploadXは下のポームネームでファイル及び付加情報をサーバーで伝逹します。

ファイルを一つ以上アップロードする場合は等しいポームネームで配列のように近付くことができます。

[DEXTUploadX ポームネーム]

DEXTUploadX - ファイルデータ

DEXTUploadX_FolderPath - 各ファイルに対するディレクトリーパス

DEXTUploadX_Alias - 各ファイルに対する別称

DEXTUploadX_UserDataA - 各ファイルに対する使用者定義データ

DEXTUploadX_UserDataB - 各ファイルに対する使用者定義データ

DEXTUploadX_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを表示する時)

DEXTUploadX_Deleted_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを削除した時)

下のコードは POST方式アップロード時 DEXTUploadXでアップロードするいくつかのファイルを DEXTUpload.NET Proで保存する部分と DEXTUpload.NET Proのサンプルの中でいくつかのファイルを保存する部分のコードです。

1-1. FileUploadManager ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>一番簡単な POST 方式の例題.</TITLE>

<SCRIPT FOR="FileUploadManager" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileManagerError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

// sMsgは手短に要約されたエラーメッセージです。

// sDetailMsgはもっと詳しい情報が含まれたエラーメッセージです。

// sDetailMsgはエラーメッセージによって空白の場合もあります。

// 必ず上のように宣言を言ってくれなければなりません。

// このエラー処理方式は DEXTUploadXのすべてのコントロールが等しいです。

function OnFileManagerError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">

'ファイルアップロードマネージャーの送るボタンを押せば上の 'OnTransfer_Click' イベントが発生します。

' ここで下記のようにファイルアップロードモニター画面を開けば良いです。

winstyle="height=335,width=445, status=no,toolbar=no,menubar=no,location=no"

window.open "./FileUploadMonitor.htm",null,winstyle

</SCRIPT>

</HEAD>

<BODY>

<OBJECT id="FileUploadManager" codeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab #version=3,0,1,0"

height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>

</OBJECT>

<P>一番簡単な POST 方式のアップロードです。<BR>

上に見えるコントロールを "ファイルアップロードマネージャー(FileUploadManager)"と言います。<BR>

ドラッグ&ドロップを支援します。ファイルやフォルダをひいておいて見てください。<BR>

</P>

</BODY>

</HTML>

1-2. FileUploadMonitor ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>DEXTUploadX アップロード</TITLE>

<SCRIPT FOR="FileUploadMonitor" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileMonitorError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

function OnFileMonitorError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS">

sub OnLoading()

' Post 方式の場合下記のように UploadURL 属性に Post Script ファイルを明示しなければなりません。

' 標準ポート以外の他のポートを使おうとすれば

' http://Localhost:8080/DEXTUploadX/Upload/PostScript.asp

' と一緒に一般的なアドレス指定方法と等しく使えば良いです。

document.all("FileUploadMonitor").UploadURL = "http://Localhost/DEXTUploadXSamples/Upload/PostScript.asp"

'このページの親ページにいるファイルマネージャーコントロールのすべてのファイル及びフォームアイテムをファイルモニターコントロールにコピーします。

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items

' ファイルマネージャーの何種類のプロパティ(DefaultPath,Filter 等々)の値をファイルモニターにコピーします。

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties

end sub

</SCRIPT>

</HEAD>

<BODY onload="OnLoading()" bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0>

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5

CodeBase="http://Localhost/DEXTUploadX/DEXTUploadX.cab #version=3,0,1,0" VIEWASTEXT>

</OBJECT>

</BODY>

</HTML>

1-3. PostScript.aspx (DEXTUploadXと DEXTUpload.NET Pro 連動時)

using(DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
string UploadedPath;

for (int i=0; i<fileUpload["DEXTUploadX"].Count; i++)
{
//input type="file" ...ポーム要素でアップロードするファイルを指定した場合だけ画面に見せてくれる。
 if (fileUpload["DEXTUploadX"][i].IsFileElement && fileUpload["DEXTUploadX"][i].Value != "")
{
UploadedPath = fileUpload["DEXTUploadX"][i].Save(false);
}
}
// DEXTUploadXが使われているページのフォームデータが自動に送信されます。
//Response.Write("Text1 : " + fileUpload["form"].Value + "\r\n");

// 等しいフォームはいなのを持ったフォームデータがいくつかの場合下記のように処理します。
// asp.netで使う一般的にフォームデータ処理方式でも可能です。
//for (int j=0; j<fileUpload["multiform "].Count; j++)
//{
// Response.Write("Text1 : " + fileUpload["multiform"][j].Value + "\r\n");
//}}

2-1. ファイルアップロードページ(DEXTUpload.NET Proの MultiUpload サンプル : MultiUpload.aspx)

<html>
<head>
<title>MultipleUpload</title>
<meta name="GENERATOR" Content="Microsoft Visual Studio 7.0">
<meta name="CODE_LANGUAGE" Content="C#">
<meta name="vs_defaultClientScript" content="JavaScript">
<meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie5">
</head>
<body MS_POSITIONING="GridLayout">
<form name="write_form" enctype="multipart/form-data" method="post" action="MultipleUpload_Process.aspx?ProgressID=0">
Multiple Upload<br><br>
Select the file to upload <br>
<input type="file" name="files"><br>
<input type="file" name="files"><br>
<input type="file" name="files"><br>
1. アップロードされたファイルの保存経路は STRONGC:TEMP/STRONGです。<br>
2. '参考' ボタンを支援しないブラウザーの場合最新バージョンのブラウザーでアップデートしてください。<br>
3. アップロードフォルダが存在しなければ自動で生成してくれます。<STRONG>(defaultpath, save())<br></STRONG>
4. この例題ではファイルアップロードの中に進行率を現わすグラフが現われないです。<br>
<br>
<input type="submit" name="Upload" value="Upload">
</form>
</body>
</html>

2-2. DEXTUpload.NET Proでファイルを保存するページ (DEXTUpload.NET Proの MultiUpload サンプル : MultiUpload_Process.aspx.cs)

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
Response.Write("<b>Upload successfully !!</b><br><br>");
string UploadedPath;

for (int i=0; i<fileUpload["files"].Count; i++)
{
//input type="file" ...ポーム要素でアップロードするファイルを指定した場合だけ画面に見せてくれる。
 if (fileUpload["files"][i].IsFileElement && fileUpload["files"][i].Value != "")
{
UploadedPath = fileUpload["files"][i].Save(false);

Response.Write("LastSavedFileName(Server) :" + fileUpload["files"][i].LastSavedFileName + "<br>");
Response.Write("Original Path (Client) :" + fileUpload["files"][i].FilePath + "<br>");
Response.Write("Uploaded Path (Server) :" + UploadedPath + "<br>");
Response.Write("File Length :" + fileUpload["files"][i].FileLength + " byte(s)<br>");
Response.Write("File MimeType : </td><td>" + fileUpload["files"][i].MimeType + "<br><br>");
}
}
}

POST方式アップロード時基本的なファイル保存以外に DEXTUpload.NET Proの機能である ‘サムネィル生成’のような機能も簡単に具現が可能です。

下のコードは POST方式アップロード時 DEXTUploadXでアップロードになるいくつかのイメージファイルを DEXTUpload.NET Proで保存する部分と DEXTUpload.NET Proのサンプルの中でサムネィルを保存する部分のコードです。

3-1. DEXTUploadX + DEXTUpload.NET Pro サムネィル保存(比較のために製作されたコードサンプルです。)

using(DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc();

for (int i=0; i<fileUpload["DEXTUploadX"].Count; i++)
{
if(imgProc.SetSourceFile(fileUpload["DEXTUploadX"][i].TempFilePath))
{
string NewFileName;

int index = fileUpload["DEXTUploadX"][i].FileName.LastIndexOf(".");

if(index > 0)
NewFileName = fileUpload["DEXTUploadX"][i].FileName.Substring(0,index);
else
NewFileName = fileUpload["DEXTUploadX"][i].FileName;

int nWidth = imgProc.ImageWidth / 10;
int nHeight = imgProc.ImageHeight / 10;

string imgFilePath = fileUpload["DEXTUploadX"][i].TempFilePath;

string strPath = @"C:\temp\" + NewFileName + ".jpg";

string UploadedPath = imgProc.SaveAsThumbnail(imgFilePath,strPath, nWidth, nHeight, false);
string FileName = imgProc.SavedFileName;
}
}
}

3-2. DEXTUpload.NET Pro ( Thumbnail サンプル )

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc();

if(imgProc.SetSourceFile(fileUpload["Image"].TempFilePath))
{
string NewFileName;

int index = fileUpload["Image"].FileName.LastIndexOf(".");

if(index > 0)
NewFileName = fileUpload["Image"].FileName.Substring(0,index);
else
NewFileName = fileUpload["Image"].FileName;

int nWidth = fileUpload["Image"].ImageWidth / 10;
int nHeight = fileUpload["Image"].ImageHeight / 10;

string imgFilePath = fileUpload["Image"].TempFilePath;

string strPath = @"C:\temp\" + NewFileName + ".jpg";

string UploadedPath = imgProc.SaveAsThumbnail(imgFilePath,strPath, nWidth, nHeight, false);
string FileName = imgProc.SavedFileName;

Response.Write("<b>Upload successfully !!</b><br><br>");
Response.Write("Original Path (Client) :" + fileUpload["Image"].FilePath + "<br>");
Response.Write("Uploaded Path (Server) :" + UploadedPath + "<br>");
Response.Write("File Length :" + fileUpload["Image"].FileLength + " byte(s)<br>");
Response.Write("File MimeType :" + fileUpload["Image"].MimeType + "<br>");
Response.Write("Saved File Name :" + FileName);

}
else
{
Response.Write("<b>Image File Mismatch!!</b><br><br>");
Response.Write(fileUpload["Image"].FileName + ": Image File Type is mismatch");
}
}

4. その他参照事項

※ DEXTUploadX,DEXTUpload.NET Pro 評価版ダウンロードは下の経路で可能です.

http://www.dextsolution.com/jp/Etc/downEval.aspx

※ DEXTUploadXのマニュアルと基本サンプルは基本設置した場合,

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX-DEXTUploadX 使用者マニュアル ”

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX- DEXTUploadX 例題 ”

で確認できます。

※ DEXTUpload Proのマニュアルと基本サンプルは基本設置した場合,

“スタート-すべてのプログラム-DEVPIA-DEXTUpload.NET Professional->DEXTUpload.NET Professional 使用者ヘルプ”

“スタート-すべてのプログラム-DEVPIA-DEXTUpload.NET Professional->ASP.NET 1.X 使用者例題 ”

“スタート-すべてのプログラム-DEVPIA-DEXTUpload.NET Professional->ASP.NET 2.X 使用者例題 ”

で確認できます。


DEXT Products

DEXTUploadXと DEXTUploadJ 連動活用

■ DEXTUploadXと DEXTUpload Pro 連動時 DEXTUploadJの機能活用する

例題は Localhost基準,Tomcat 基盤に作成されました。

サーバーによって Localhost 部分をサーバーのアドレスに変えてくださらなければならないし,ポート番号も変更される可能性があることをお知らせいたします。

二つの製品を連動して POST 方式でアップロード時 DEXTUploadXは下のポームネームでファイル及び付加情報をサーバーで伝逹します。

ファイルを一つ以上アップロードする場合は等しいポームネームで配列のように近付くことができます。

[DEXTUploadX ポームネーム]

DEXTUploadX - ファイルデータ

DEXTUploadX_FolderPath - 各ファイルに対するディレクトリーパス

DEXTUploadX_Alias - 各ファイルに対する別称

DEXTUploadX_UserDataA - 各ファイルに対する使用者定義データ

DEXTUploadX_UserDataB - 各ファイルに対する使用者定義データ

DEXTUploadX_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを表示する時)

DEXTUploadX_Deleted_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを削除した時)

1. FileUploadManager ページ (SimplePostUpload.htm)

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE> 一番簡単な POST 方式の例題.</TITLE>

<SCRIPT FOR="FileUploadManager" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileManagerError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

// sMsgは手短に要約されたエラーメッセージです。

// sDetailMsgはもっと詳しい情報が含まれたエラーメッセージです。

// sDetailMsgはエラーメッセージによって空白の場合もあります。

// 必ず上のように宣言を言ってくれなければなりません。

// このエラー処理方式は DEXTUploadXのすべてのコントロールが等しいです。

function OnFileManagerError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">

' ファイルアップロードマネージャーの送るボタンを押せば上の 'OnTransfer_Click' イベントが発生します。

' ここで下記のようにファイルアップロードモニター画面を開けば良いです。

winstyle="height=335,width=445, status=no,toolbar=no,menubar=no,location=no"

window.open "./FileUploadMonitor.htm",null,winstyle

</SCRIPT>

</HEAD>

<BODY>

<OBJECT id="FileUploadManager" codeBase="http://Localhost:8080/DEXTUploadJ/DEXTUploadX.cab#version=3,0,1,0"

height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>

</OBJECT>

<P>一番簡単な POST 方式のアップロードです。<BR>

上に見えるコントロールを "ファイルアップロードマネージャー(FileUploadManager)"と言います。<BR>

ドラッグ&ドロップを支援します。ファイルやフォルダをひいておいて見てください。<BR>

</P>

</BODY>

</HTML>

2. FileUploadMonitor ページ (FileUploadMonitor.htm)

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>DEXTUploadX Upload </TITLE>

<SCRIPT FOR="FileUploadMonitor" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileMonitorError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

function OnFileMonitorError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS">

sub OnLoading()

' Post 方式の場合下記のように UploadURL 属性に Post Script ファイルを明示しなければなりません。

' 標準ポート以外の他のポートを使おうとすれば

' http://Localhost:8080/DEXTUploadX/Upload/PostScript.asp

' と一緒に一般的なアドレス指定方法と等しく使えば良いです。

document.all("FileUploadMonitor").UploadURL = "http://Localhost:8080/DEXTUploadJ/Upload/PostScript.jsp"

'このページの親ページにいるファイルマネージャーコントロールのすべてのファイル及びフォームアイテムをファイルモニターコントロールにコピーします。

document.all("FileUploadMonitor").Items = opener.document.all("FileUploadManager").Items

' ファイルマネージャーの何種類のプロパティ(DefaultPath,Filter 等々)の値をファイルモニターにコピーします。

document.all("FileUploadMonitor").Properties = opener.document.all("FileUploadManager").Properties

end sub

</SCRIPT>

</HEAD>

<BODY onload="OnLoading()" bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0>

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5

CodeBase="http://Localhost:8080/DEXTUploadJ/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>

</OBJECT>

</BODY>

</HTML>

3. JSP ページ (PostScript.jsp)

<%@page language="java" contentType="text/html; charset=euc-kr"%>

<%@page import="java.io.*"%>

<%@page import="devpia.dextupload.*"%>

<%

PrintWriter w = response.getWriter();

FileUpload fileUpload = new FileUpload(request, response);

try {

String strPath = request.getRealPath("/");

// 正規品や評価版の満了日を判断するためのライセンスファイルの位置を指定する。

fileUpload.setLicenseFilePath(strPath + File.separator + "dextuploadj.config");

fileUpload.setCharacterEncoding("euc-kr");

fileUpload.UploadStart(strPath);

// getFileItemValues("DEXTUploadX") を使って重複されたすべてのファイルアイテムを持って来る。

// DEXTUploadXを連動する場合ファイルアイテムは皆 "DEXTUploadX" 名前に送信される。

FileItem[] value = fileUpload.getFileItemValues("DEXTUploadX");

for (int i = 0; i < value.length; i++)

{

if(value[i] != null)

{

if(value[i].IsUploaded())

{

value[i].Save(strPath, true);

// Save() メソッドなどによって最後に保存されたファイルの名前を求めることができる。

// value[i].getLastSavedFilePath();

System.out.println("LastSavedFilePath : "+value[i].getLastSavedFilePath());

}

else

{

// ファイルがアップロードしてない時の処理をする。

}

}

}

}

catch (DEXTUploadException ex) {

// 例外に対する処理を進行する。

System.out.println("DEXTUploadException : "+ex.getMessage());

}

catch (Exception ex) {

// 例外に対する処理を進行する。

System.out.println("Exception : "+ ex.getMessage());

}

finally {

// 終了時に必ず資源を解除しなければならない。

// そうではなければ臨時ファイルが削除されないで残る可能性がある。

fileUpload.dispose();

}

%>

4. その他参照事項

※ DEXTUploadX,DEXTUploadJ 評価版ダウンロードは下の経路で可能です.

http://www.dextsolution.com/jp/Etc/downEval.aspx

※ DEXTUploadXのマニュアルと基本サンプルは基本設置した場合,

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX-DEXTUploadX 使用者マニュアル ”

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX- DEXTUploadX 例題 ”

で確認できます。。

※ DEXTUploadJのメニュアールや気本サンプル（機能別サンプル）はダウンロード圧縮ファイルを解凍すると、

“ DEXTUploadJ_X.X.X.X_Manual_Kor.zip -> DEXTUploadJ API”

“ DEXTUploadJ_ X.X.X.X _Samples_Kor.zip -> DEXTUploadJ 機能別サンプル”

で確認できます。


DEXT Products

DEXTUploadXと PHP 連動活用

■ DEXTUploadXと PHP 連動

PHPは自体ライブラリを使います。

二つの製品を連動して POST 方式でアップロード時 DEXTUploadXは下のポームネームでファイル及び付加情報をサーバーで伝逹します。

ファイルを一つ以上アップロードする場合は等しいポームネームで配列のように近付くことができます。

[DEXTUploadX ポームネーム]

DEXTUploadX - ファイルデータ

DEXTUploadX_FolderPath - 各ファイルに対するディレクトリーパス

DEXTUploadX_Alias - 各ファイルに対する別称

DEXTUploadX_UserDataA - 各ファイルに対する使用者定義データ

DEXTUploadX_UserDataB - 各ファイルに対する使用者定義データ

DEXTUploadX_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを表示する時)

DEXTUploadX_Deleted_Uploaded - 仮想ファイルデータ(サーバーにもうアップロードされているファイルを削除した時)

1. FileUploadManager ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>一番簡単な POST 方式の例題.</TITLE>

<SCRIPT FOR="FileUploadManager" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileManagerError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

// sMsgは手短に要約されたエラーメッセージです。

// sDetailMsgはもっと詳しい情報が含まれたエラーメッセージです。

// sDetailMsgはエラーメッセージによって空白の場合もあります。

// 必ず上のように宣言を言ってくれなければなりません。

// このエラー処理方式は DEXTUploadXのすべてのコントロールが等しいです。

function OnFileManagerError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="VBS" for="FileUploadManager" event="OnTransfer_Click()">

'ファイルアップロードマネージャーの送るボタンを押せば上の 'OnTransfer_Click' イベントが発生します。

' ここで下記のようにファイルアップロードモニター画面を開けば良いです。

winstyle="height=335,width=445, status=no,toolbar=no,menubar=no,location=no"

window.open "./FileUploadMonitor.htm",null,winstyle

</SCRIPT>

</HEAD>

<BODY>

<OBJECT id="FileUploadManager" codeBase="http://localhost/DEXTUploadX_PHP/DEXTUploadX.cab#version=3,0,1,0"

height="200" width="450" classid="CLSID:DF75BAFF-7DD5-4B83-AF5E-692067C90316" VIEWASTEXT>

<!-- PHPと連動するための "EnablePHPFILES" プロパティー設定 -->

<param name="EnablePHPFILES" value="TRUE">

</OBJECT>

<P> すべてのサンプルファイルの "localhost" 部分をお客様のサーバー環境に合わせて修正してください。 </P>

<P> php.ini 設定を含めた環境設定はサンプルとともに含まれた "PHP_アップロード_環境設定.txt" 文書を参考してください。 </P>

</BODY>

</HTML>

2. FileUploadMonitor ページ

<HTML>

<HEAD>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ks_c_5601-1987">

<TITLE>$HTTP_POST_FILES process</TITLE>

<SCRIPT FOR="FileUploadMonitor" Event="OnError(nCode, sMsg, sDetailMsg)" LANGUAGE="javascript">

OnFileMonitorError(nCode, sMsg, sDetailMsg);

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

function OnFileMonitorError(nCode, sMsg, sDetailMsg)

{

alert(nCode);

alert(sMsg);

alert(sDetailMsg);

}

</SCRIPT>

<SCRIPT LANGUAGE="JavaScript">

function OnLoading()

{

// Post 方式の場合下記のように UploadURL 属性に Post Script ファイルを明示しなければなりません

// 標準ポート以外の他のポートを使おうとすれば,

// http://localhost/DEXTUploadX_PHP/Upload/upload_process_for_httppostfiles.php

// と一緒に一般的なアドレス指定方法と等しく使えば良いです。

document.all["FileUploadMonitor"].UploadURL = "http://localhost/DEXTUploadX_PHP/Upload/upload_process_for_httppostfiles.php";

//このページの親ページにいるファイルマネージャーコントロールのすべてのファイル及びフォームアイテムをファイルモニターコントロールにコピーします。

document.all["FileUploadMonitor"].Items = opener.document.all["FileUploadManager"].Items;

//ファイルマネージャーの何種類のプロパティ(DefaultPath,Filter 等々)の値をファイルモニターにコピーします。

document.all["FileUploadMonitor"].Properties = opener.document.all["FileUploadManager"].Properties;

}

</SCRIPT>

</HEAD>

<BODY onload="OnLoading()" bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0>

<OBJECT id=FileUploadMonitor height=335 width=445 classid=CLSID:96A93E40-E5F8-497A-B029-8D8156DE09C5

CodeBase="http://localhost/DEXTUploadX_PHP/DEXTUploadX.cab#version=3,0,1,0" VIEWASTEXT>

<!-- PHPと連動するための "EnablePHPFILES" プロパティー設定-->

<param name="EnablePHPFILES" value="TRUE">

</OBJECT>

</BODY>

</HTML>

3. PHP page (upload_process_for_httppostfiles.php)

<?

//-----------------------------------------------------------------------------

//----------------[ ファイル保存方法 ]------------------------

//-----------------------------------------------------------------------------

// ファイル保存方法

$upload_dir = "./";

// アップロードされたファイルの個数位ファイルを保存

for ($i=0; $i < sizeof($HTTP_POST_FILES["DEXTUploadX"]["tmp_name"]); $i++)

{

// HTTP POSTを通じてアップロードされたファイルの場合だけ保存

if (is_uploaded_file($HTTP_POST_FILES["DEXTUploadX"]["tmp_name"][$i]))

{

$file_name = $HTTP_POST_FILES["DEXTUploadX"]["name"][$i]; // 実際ファイル名

$file_tmp_name = $HTTP_POST_FILES["DEXTUploadX"]["tmp_name"][$i]; // 臨時ファイル名

$last_saved_filename = $file_name; // 終わりに保存されるファイル名

// 重複ファイル処理 (拡張子がないファイル,許容されない拡張子に対する例外処理必要)

$index = 1;

$filename_without_ext = substr($file_name, 0, strrpos($file_name, "."));

$filename_ext = substr(strrchr($file_name, "."), 1);

while(true)

{

if(file_exists($upload_dir.$last_saved_filename))

{

$last_saved_filename = $filename_without_ext."[".$index."].".$filename_ext;

$index++;

}

else

{

break;

}

}

// アップロードされたファイルを指定された経路に移動

if (move_uploaded_file($file_tmp_name, $upload_dir . $last_saved_filename))

{

// ファイルのモードに変更

@chmod($upload_dir . $last_saved_filename, 0775); // 8bitモード値使用明示

}

}

}

/*

$HTTP_POST_FILES の配列インデックス

- $HTTP_POST_FILES["userfile"]["tmp_name"] -> Temporary file name uploaded at server

- $HTTP_POST_FILES["userfile"]["name"] -> Actual file name

- $HTTP_POST_FILES["userfile"]["size"] -> File size

- $HTTP_POST_FILES["userfile"]["type"] -> File mime type

*/

//--------------------------------------------------------------------------------

//----------------------------------------[フォームデータ使用方法 ]--------------------

//--------------------------------------------------------------------------------

/*

DEXTUploadXは DEXTUploadXが挿入されているウェプページのポームデータを自動で認識して送ります。

それで DEXTUploadXが挿入されているウェプページのポームデータ使用は既存に PHPで使った方式と等しく使うことができます。

また DEXTUploadXは使用者が追加的なポームアイテムを動的に追加することができる AddFormItem メソッドを支援します。

ポームデータの使用方法は等しくて AddFormItem メソッドの詳しい使用方法はマニュアルを参考してください。
*/

?>

4. その他参照事項

※ DEXTUploadX 評価版ダウンロードは下の経路で可能です.

http://www.dextsolution.com/jp/Etc/downEval.aspx

※ DEXTUploadXのマニュアルと基本サンプルは基本設置した場合,

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX-DEXTUploadX 使用者マニュアル ”

“ スタート-すべてのプログラム-DEVPIA-DEXTUploadX- DEXTUploadX 例題 ”

で確認できます。


DEXT Products

DEXT製品顧客支援

■ DEXT 製品顧客サポートガイド

1. オンラインテクニカルサポート

正式テクニカルサポートお問い合わせは http://www.dextsolution.com/jpの ‘ オンラインテクニカルサポート ’ で受け付けてください。

- DEXT 製品を購入した顧客は購買時点から 1年間 Maintenanceをサポートもらうようになります。

- Maintenanceにはアップグレード,パッチアップデート,オンラインテクニカルサポートが含まれます。

-受付された技術お問い合わせを順次にお返事を申し上げるためにオンラインテクニカルサポートメニューを通じる正式要請に

限って返事を申し上げているから,電話ではお問い合わせることができない点を了解してください。

- オンラインテクニカルサポートサービス時間 : 月~金 09:00~17:00

(サービス時間以後に受付されたお問い合わせは休日を除いた後、業務日に処理されます。)

1年が経った後には 1 Year Maintenance Onlyを購買してオンラインテクニカルサポートを 1年間追加利用することができます。

※ テクニカルサポートの制限

下の事項によるテクニカルサポート要請は支援して上げることができないです。

-アップロード製品と関連がないページの Programming Source Code エラー解決を要請する場合。

-アップロード製品の使用と無関係なビジネスロジッグに対する要請の場合。

-アップロード製品使用の時に Network Settingと係わったサポート要請の場合。

-アップロード製品使用の時に機能による文法的な質問ではなく,開発言語(ASP,Html 等々)の文法的なお問い合わせ及びエラー解決要請の場合。

2. FAQ

http://www.dextsolution.com/jpの ‘FAQ’メニューで過去,頻繁に受付された

お問い合わせ事項に対する返事を確認することができます。

DEVPIA アップロードコンポネント販売サイト (http://www.dextsolution.com/jp)


IsInfectedプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ IsInfectedプロパティ

 形式
[Boolean = ] Object.IsInfected
返り値
Boolean

説明
 ファイルがウィルスに感染しているかどうかを知らせてくれます。

 例

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

// 0: チェックを行わない、1: チェックを行う、2: チェック後、自動的に治療を行う
fileUpload.VirusInfo.ScanMode = 1;

// ウィルス感染ファイルを削除するかどうかを設定
// true: ファイルを自動的に削除する
// false: ファイルを削除しない
fileUpload.VirusInfo.AutoRemovingInfectedFile = false;

//ウィルス感染の有無
//true: 感染
//false: 感染していない
if(! fileUpload.IsInfected )
// チェックの結果

......................................
}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


VirusNameプロパティ

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ VirusNameプロパティ

 形式
[String = ] Object.VirusName

返り値
String

説明
 ウィルス名

 例

…

private void Page_Load(object sender, System.EventArgs e)

{

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())

{

// 0: チェックを行わない、1: チェックを行う、2: チェック後、自動的に治療を行う
fileUpload.VirusInfo.ScanMode = 1;

 // ウィルス感染ファイルを削除するかどうかを設定
// true: ファイルを自動的に削除する
// false: ファイルを削除しない
fileUpload.VirusInfo.AutoRemovingInfectedFile = false;

 //ウィルス感染の有無
//true: 感染
//false: 感染していない
if(! fileUpload.IsInfected )
// チェックの結果
else
//ウィルス名
Respons.Write("Virus Name : " + fileUpload.VirusName);

......................................
}

}

…

Copyright © DEVPIA Corporation. All rights reserved.


ConvertImageFormat()メソッド

DEXTUpload.NET Professional

DEXTUpload.NET Professional　オブジェクトリファレンス

■ ConvertImageFormat()メソッド

形式
Object.ConvertImageFormat( imgFilePath, strImageFormat,strSavedPath,bOverwrite )

パラメータ
 imgFilePath As String – 原本イメージファイルのパス
strImageFormat – 変換するイメージフォーマット("image/bmp")
strSavedPath – 変換したファイルの保存先(例:C:\Temp\watermarked.bmp)
bOverwrite – 上書きの有無(Trueの場合、上書きを実行します。)

 説明
 イメージフォーマットを指定したファイルに変換します。

一番目のファクターは変換するイメージフォーマットです。”image/jpeg”、”image/bmp“のように入力してください。

例

using (DEXTUpload.NET.FileUpload fileUpload = new DEXTUpload.NET.FileUpload())
{
//ウォーターマーク処理を行うためには、イメージ関連オブジェクトを生成しなければなりません。
 DEXTUpload.NET.ImageProc imgProc = new DEXTUpload.NET.ImageProc();

//作業の対象となるイメージファイルを設定します。
//trueの場合、SaveAsWaterMarkImageやSaveAsWaterMarkImageメソッドが呼び出されます。
//イメージファイルでない場合にはfalseと表示されます。
if(imgProc.SetSourceFile(fileUpload.TempFilePath))
{
//############# アップロードされたファイル名を検索(拡張子を除く) ############
string NewFileName;

int index = fileUpload.FileName.LastIndexOf(".");
if(index > 0)
NewFileName = fileUpload.FileName.Substring(0,index);
else
NewFileName = fileUpload.FileName;
//#####################################################################

bool bOverWrite = false;

//###################### 対応しているイメージフォーマット #######################
//"image/jpg", image/bmp", image/gif"
//#####################################################################

//原本イメージファイルのパス
string imgFilePath = fileUpload.TempFilePath;
//アップロードするファイルをJPGフォーマットに変換して保存します。
string UploadedPath =imgProc.ConvertIamgeFormat(imgFilePath, "image/jpg",fileUpload.DefaultPath + NewFileName + ".jpg", bOverWrite);
string FileName = imgProc.SavedFileName;

Response.Write("<b>Upload successfully !!</b><br><br>");
Response.Write("Original Path (Client) :" + fileUpload.FilePath + "<br>");
Response.Write("Uploaded Path (Server) :" + UploadedPath + "<br>");
Response.Write("File Length :" + fileUpload.FileLength + " byte(s)<br>");
Response.Write("File MimeType :" + fileUpload.MimeType + "<br>");
Response.Write("Saved File Name :" + FileName);
}
else
{
Response.Write("<b>Image File Mismatch!!</b><br><br>");
Response.Write(fileUpload.FileName + ": Image File Type is mismatch");
}
}

Copyright © DEVPIA Corporation. All rights reserved.